
Object Linking and Embedding (OLE)
{button Tell me

how . . .,PI(`',`IDH_HT_Object_Linking_and_Embedding')}

This program offers object linking and embedding (OLE) capabilities. In addition to placing charts in 
other documents, you can link and embed objects from other programs into your charts.
Object linking and embedding lets you combine information created by different programs in a 
single document. With OLE, your focus is on the document rather than the program. Documents that
contain information from two or more OLE-compatible programs are called compound documents.
With OLE, you do not have to worry about having the right file filter or translator. You can share 
charts, worksheets, text, drawings, sounds, video, and animation among any OLE-compatible 
programs.

Linking
You can link a chart created in FlowCharter to a document in another OLE-compatible program. The 
chart becomes the object, and the document becomes a compound document.
You also can link an object from a source file (in the object program) to a chart. When an object is 
linked, any changes you make to the object in the source file are reflected in the chart.

Embedding
You can embed a chart created in FlowCharter in a document in another OLE-compatible program. 
The chart becomes the object, and the document becomes a compound document.

Inserting a New Object in a Chart
You can select an object type from a list of OLE-compatible programs on your system. A new, empty 
object is inserted in the the program window, and the object program opens for you to fill in the 
empty object. The object appears in both the object program and FlowCharter at the same time.

Inserting an Object from a File
You can open an existing OLE-compatible file that contains the object you want to insert in 
FlowCharter. The object is embedded unless you select the Link to File option.

{button Related Topics,PI(`',`IDH_RT_OLE')}
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Moving Linked Files

You can move a set of linked files and still maintain the links between the files. For example, you 
may want to move a set of linked files from a hard disk to a floppy disk for transporting them. When 
you open the files from the floppy disk, the links are intact.

Note
You must move all the linked files together to the same location.

{button Related Topics,PI(`',`IDH_RT_MOVELINKFILE')}



Object linking and embedding



Placing Charts in Other Programs

Using OLE, you can include a FlowCharter chart in any document created in an OLE-compatible 
program. For example, you can include a chart in a word-processing document. The chart then 
appears in the document each time you open it. The chart is the object. The program in which it was
created (FlowCharter) is the object program. The word-processing program is the container program
because it contains the object.
You can change the chart directly from the word-processing program just by double-clicking the 
chart. FlowCharter opens automatically, with the chart already open and waiting to be changed. If 
the chart is linked, you can make changes to it in FlowCharter, and the changes appear 
automatically in the word-processing document.

{button Related Topics,PI(`',`IDH_RT_PLACINGFLOW')}
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Placing Objects in Charts

In addition to being an object program, FlowCharter also acts as a container program. This means 
you can include information from other OLE object programs in your charts. This information can be 
data cells from a spreadsheet, text from a word-processing document, charts from a presentation 
package, drawings from an illustration program, sounds, video, or animation.
For example, you can link spreadsheet data to a chart. Each time you update the data in the 
spreadsheet program, the new data appears in the chart. You can even place the entire spreadsheet
in the chart, but have it appear only as an icon. If you double-click the icon, the spreadsheet opens.
You also can have “talking shapes” or animated objects in a chart by embedding sounds, video, or 
animation in an icon. Then, for example, you just double-click a sound icon to hear the sound or 
double-click a video icon to play the video.

{button Related Topics,PI(`',`IDH_RT_PLACINGOBJ')}
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Using Drag and Drop to Place an Object in a Chart

You can use drag and drop to embed an object in a chart. You also can link the object to the chart by
dragging. (This feature is available only with OLE 2.0-compatible programs that act as object 
programs.)

To Do this

Move and 
embed

Drag the object from the object program window into 
FlowCharter. (This is the default function.)

Copy and 
embed

Press Ctrl and drag the object into FlowCharter.

Copy and link Press Ctrl +Shift and drag the object into 
FlowCharter.

{button Related Topics,PI(`',`IDH_RT_DRAGOBJECT')}
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To link a chart to a document
1 Create a chart in FlowCharter.
2 On the File menu, click Save As.
3 Type a file name and press enter.
4 On the Edit menu, click Select , and then click All to select the chart (object).
5 On the Edit menu, click Copy.
6 Minimize FlowCharter.
7 Open an OLE-compatible container program, such as Microsoft Word for Windows.
8 Open the document to which you want to link the object.
9 Click Paste Link in the container program. (It probably will appear in the Paste Special dialog 

box.) The object is linked from FlowCharter (the object program) to the document.

Tip
Press Ctrl+A to select the chart in one easy step.

Notes
You must save the object in a source file before the object can be linked to a document.
The link may be broken if the source file is deleted or moved to another directory. If a link is 

broken, the chart still can be produced in the container program. It will appear similar to the last time it
was updated, however, it can no longer be updated. You must reestablish the link to the source file 
from the container program.

{button Related Topics,PI(`',`IDH_RT_To_link_an_ABC_FlowCharter_chart_to_a_document')}
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To change a linked FlowCharter object
1 Double-click the FlowCharter object in the container program. FlowCharter opens and displays 

the object.
2 Change the attribute of the shapes in the chart.
3 On the File menu, click Exit. A FlowCharter dialog box prompts you to save the changes.
4 Click Yes. FlowCharter closes, and the compound document displays the changes to the object.

{button Related Topics,PI(`',`IDH_RT_To_change_a_linked_ABC_FlowCharter_object')}
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To link an object to a chart
1 Create an object in an OLE-compatible object program.
2 Save the object in a file.
3 Copy the object to the Clipboard.
4 Minimize the object program and open FlowCharter. FlowCharter acts as the container program.
5 Open the FlowCharter file to which you want to link the object.
6 On the Edit menu, click Paste Link. The linked object appears in the chart.

Note
You must save the object in a source file before the object can be linked to a chart.

{button Related Topics,PI(`',`IDH_RT_LINKINGOBJ')}
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To change an object linked to a chart
1 Double-click the object in the chart or open the Edit menu, and then click Edit Linked <Name> 

Object. The object program opens.
2 Make changes to the object in the program.
3 Minimize the object program. FlowCharter displays the changes to the object.

Note
If you try to exit the object program, it displays a message asking whether you want to save 

the changes to the object. Click Yes to save the changes in the source file. The program then reminds 
you that remote links to a document currently exist and asks whether you want to close the program 
anyway. Click Cancel to keep the object program open and maintain the link to FlowCharter. Click OK to
close the program and break the link to the chart.

{button Related Topics,PI(`',`IDH_RT_EDITOBJLINK')}
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To view the links to a chart
1 Open the FlowCharter file that contains the links.
2 On the Edit menu, click Links. The Links dialog box opens. The dialog box displays the name and 

location of the source file, the item (such as the cell range in a spreadsheet), the object type 
(such as Excel Worksheet), and the update method (automatic or manual).

3 Click Cancel to close the dialog box without making any changes.

{button Related Topics,PI(`',`IDH_RT_VIEWINGLINKS')}
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To change a link
1 Open the FlowCharter file that contains the link you want to change.
2 On the Edit menu, click Links.
3 Click a link in the box to select it for changing.
4 Click a link option button.

Click Update Now to update the object with changes that have been made in the source file.
Click Open Source to open the source file in which the object was created.
Click Change Source to choose a new source file or item for the object.
Click Break Link to disconnect the link between the object and the source file. The link

is removed from the list.
5 Click the Automatic or Manual option if you want to change the update method.
6 Click Cancel to close the Links dialog box.

Notes
In step 4, if you select Change Source and choose a new source that is invalid, a message 

displays asking whether you want to correct it. Click Yes to choose a different source. Click No to keep 
the source you selected. If you click No, the link is broken.

With the Automatic option, the object is updated automatically in the chart if changes are 
made to the object in the source file.

With the Manual option, changes are not made to the object in the chart until you click Update 
Now in the Links dialog box.

{button Related Topics,PI(`',`IDH_RT_EDITINGLINKS')}
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To embed a chart in a document
1 Create a chart in FlowCharter.
2 On the Edit menu, click Select.
3 Click All to select the chart (object).
4 On the Edit menu, click Copy.
5 Minimize FlowCharter.
6 Open an OLE-compatible container program, such as Microsoft Word for Windows.
7 Open the document in which you want to embed the object.
8 Paste the object into the document. The object is embedded in the document.

Tip
Press Ctrl+A to select the chart in one easy step.
It is not necessary to save an object in a source file before it can be embedded in a document.

{button Related Topics,PI(`',`IDH_RT_EMBEDDINGFLOW')}
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To change an embedded FlowCharter object
1 Double-click the FlowCharter object in the container program. FlowCharter opens and displays 

the object.
2 Change the color, fill pattern, border, or other attribute of the shapes in the chart.
3 On the File menu, click Exit, and Return To <Compound Document Name>. A FlowCharter dialog 

box warns that the object has been changed and prompts you to update the compound 
document before proceeding.

4 Click Yes. FlowCharter closes, and the compound document displays the changes to the object.

{button Related Topics,PI(`',`IDH_RT_EDITEMBABCOBJ')}
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To embed an object in a chart
1 Create an object in an OLE-compatible object program.
2 Copy the object to the Clipboard.
3 Minimize the object program and open FlowCharter. FlowCharter will act as the container 

program.
4 Open the FlowCharter file in which you want to embed the object.
5 On the Edit menu, click Paste, or press Ctrl+V. The embedded object appears in the chart.

Notes
It is not necessary to save an object in a source file before it can be embedded in a chart.
When an object is embedded, changes you make to the object in the source file are not 

automatically reflected in the chart.

{button Related Topics,PI(`',`IDH_RT_EMBOBJINFLOW')}
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To change an object embedded in a chart
1 Double-click the object in the chart or open the Edit menu, and then click Edit <Name> Object. 

The object program opens.
2 Make changes to the object in the program.
3 On the File menu, click Update in the object program.
4 Minimize the object program. Changes to the object display.

Note
If you try to exit the object program without choosing Update, it displays a message asking 

whether you want to update the object. Click Yes to update the object in FlowCharter. The object 
program closes.

{button Related Topics,PI(`',`IDH_RT_EDITOBJEMBED')}
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To paste OLE and non-OLE information into a chart
1 Create a piece of information in an OLE-compatible program, such as a table of data in a 

spreadsheet program or a paragraph in a word-processing program.
2 Copy the information to the Clipboard.
3 Minimize the program and open FlowCharter.
4 Open the FlowCharter file in which you want to paste the information.
5 On the Edit menu, click Paste Special.
6 Select a paste format in the box. (Note that the Paste option is selected by default.)
7 If you selected the Object format in the box and if you want the object to appear as an icon 

rather than as a full graphic, click to check the Display as Icon option.

{button Related Topics,PI(`',`IDH_RT_PASTEOLENON')}
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To change the icon while pasting an object
1 On the Edit menu, click Paste Special.
2 Select the Object format in the box and click to check the Display as Icon option.
3 Click Change Icon.
4 Click one of the icons shown or click Browse to choose another program and display its icons. 

(Click Standard to return to the default icon for the object program.)
5 Type new text in the Caption text box if you want to specify what object the icon represents.
6 Click OK to close the Change Icon dialog box.
7 Click OK to close the Paste Special dialog box. The new icon and caption appear in the chart.

Tip
To change the icon or caption after the object is pasted, select the current icon and cut it to the

Clipboard. Click Paste Special and repeat the steps above.

{button Related Topics,PI(`',`IDH_RT_CHANGEICON')}
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To insert a new object in a chart
1 Open the FlowCharter file in which you want to insert the object.
2 On the Insert menu, click Object. The Insert Object dialog box opens. (Note that the Create New 

option is selected by default.)
3 Click to select an object type in the box.
4 Click to check the Display as Icon option if you want the object to appear as an icon rather than 

as a full graphic.
5 Click OK. The OLE-compatible program you selected opens.
6 Create an object in the program.
7 On the File menu, click Update in the program.
8 On the File menu, click Exit, and Return To <Chart Name>. The program closes and the new 

object appears in the chart.

Note
If you exit the program without choosing Update, the program displays a message prompting 

you to update the embedded object. Click Yes to update the object in FlowCharter.

{button Related Topics,PI(`',`IDH_RT_INSERTNEWOBJ')}
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To insert an object from a file
1 Open the FlowCharter file in which you want to insert the object.
2 On the Insert menu, click Object.
3 Click to select the Create from File option.
4 Click Browse.
5 Select the file that contains the object you want to insert in FlowCharter.
6 Click OK.
7 Click to check the Link to File option if you want to create a link between the object and the 

source file.
8 Click to check the Display as Icon option if you want the object to appear as an icon rather than 

as a full graphic.
9 Click OK. The object appears in the chart.

{button Related Topics,PI(`',`IDH_RT_INSERTOBJFILE')}
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To drag and drop an object into a chart
1 Open the FlowCharter file in which you want to embed or link the object.
2 Open the file in the OLE 2.0-compatible program that contains the object.
3 Arrange both programs so that they are visible on your screen.
4 Select the object in the object program window. For example, highlight the text in a word-

processing document.
5 Drag the object into the FlowCharter window while pressing the keyboard controls you want. The 

object is now embedded or linked in the chart.
6 Repeat steps 4 and 5 to drag more objects into the chart.

Note
FlowCharter does not support drag and drop source. Therefore, you cannot drag an object from

FlowCharter into another OLE-compatible program in order to create a link. FlowCharter also does not 
support OLE 2.0 in-place activation.
Tip

Drag any OLE object program file from Explorer into the FlowCharter window to embed the 
objects in the file in a chart. Press CTRL+Shift while you drag to create a link.

{button Related Topics,PI(`',`IDH_RT_To_drag_and_drop_an_object_into_a_chart')}
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Change Icon dialog box
Icon box
The Icon box displays the icons available with the program file shown at the bottom of the dialog 
box. The default program icon is selected; click another icon in the box to select it.

Browse button
Click Browse to open the Browse dialog box. You then can choose another program file and display 
its icons.

Caption text box
Type new text in the Caption text box if you want to specify what object the icon represents.

{button Related Topics,PI(`',`IDH_RT_CHANGEICONDB')}
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To update an embedded object
1 Select the embedded object within FlowCharter.
2 On the File men, click Update. The current version of the object is updated in the container 

program.

{button Related Topics,PI(`',`IDH_RT_UPDATEP')}



Update command



To exit and return to the container program
1 Double-click the embedded object within the container program. FlowCharter opens and displays 

the object.
2 Select the object and make your changes.
3 On the File menu, click Exit and Return To. The Exit and Return To dialog box opens to inform you 

that this command will close the connection between the open embedded object and the 
container program. It prompts you to update the open embedded object before proceeding.

4 Click Yes. FlowCharter closes, and the container program displays the changed embedded object.

{button Related Topics,PI(`',`IDH_RT_EXITOLEP')}
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Exit and Return To dialog box

Choosing the Exit and Return To command on the File menu opens the Exit and Return To dialog box.
The Exit and Return To dialog box informs you that the command you have chosen will close the 
connection between the open embedded object and the container program file. It then prompts you 
to select one of three choices: Yes, No, or Cancel.

Yes updates (saves) changes made to the embedded object in the object program 
(FlowCharter), then restores the window of the container program.

No does not update (save) changes to the embedded object, and it restores the window of the 
container program.

Cancel cancels the Exit and Return To command and returns you to the current object in the 
object program (FlowCharter).

{button Related Topics,PI(`',`IDH_RT_EXITOLEDB')}
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Tools menu

Click a command below to learn more about it.
Spelling Spell checks the chart.
Protect Chart Sets or removes password protection to 

protect your chart from unauthorized 
changes.

Run 
Flowchart

Runs a Living FlowChart script.

Shape Action
Wizard

Creates a Living FlowChart action for 
the selected shape.

Edit Object 
Script

Adds to or changes script that controls 
the actions of a specific object or shape.

Edit Chart 
Script

Runs the Script Editor.

Import Data Lets you import data to your active 
worksheet.

Report Runs a report.
Add-Ons Lets you access other applications
Customize Lets you customize the program 

toolbars and the Toolbox.
Options Lets you set options for shape spacing 

and alignment, line spacing, spell 
checking, displaying Finished button, 
displaying Welcome dialog, and setting 
number of Undos and Redos.

{button Related Topics,PI(`',`IDH_RT_TOOLSMENU')}



Spelling command
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Spelling command
{button OLE Automation,PI(`',`IDH_OA_Spelling_Method')}

The Spelling command on the Tools menu lets you check the spelling of any text included in the 
charts you created.
You can check the spelling of all the text in the document, or just the selected text. For example, if 
you want to check one word, highlight the word, and then choose the Spelling command.
The Options command on the Tools menu lets you choose a dictionary for spell checking.

{button Related Topics,PI(`',`IDH_RT_Spelling_Command')}
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Spelling method



Checks the spelling of any text included in charts you created.
You can check the spelling of all the text in the document, or just the selected text. For example, if 
you want to check one word, highlight the word, and then choose Spelling.



Protect Chart command
The Protect Chart command on the Tools menu lets you set or remove password protection to 
protect your chart from unauthorized changes.
When you choose this command, the Protect Chart dialog box opens.

{button Related Topics,PI(`',`IDH_RT_ProtectChart_Command')}



Tools menu
To protect a chart



Sets or removes password protection.
When you choose this command, the Protect Chart dialog box opens.



Import Data command
The Import Data command on the Tools menu lets you import data to your active worksheet. The 
data can be from a database in a number of other formats.
When you choose this command, the Data Import Wizard opens. Use the list of database types to 
choose which you want to export to.

{button Related Topics,PI(`',`IDH_RT_Get_External_Data_Command')}



Worksheet command
View Menu
Tools Menu



Lets you import data to your active worksheet.



Customize command
The Customize command lets you customize the program toolbars and the Toolbox.

{button Related Topics,PI(`',`IDH_RT_Customize_Command')}



Tools menu
Toolbars command



Lets you customize the program toolbars and the Toolbox.



Options command (Tools menu)
The Options command on the Tools menu lets you set options for shape spacing and alignment, line 
spacing, spell checking, displaying Finished button, displaying Welcome dialog, and setting number 
of Undos and Redos.
When you choose this command, the Options dialog box opens.

{button Related Topics,PI(`',`IDH_RT_Options_Command')}



Tools menu
Working with objects



Lets you set options for shape spacing and alignment, line spacing, and spell checking.



Spelling dialog box

This dialog box is used to enter the correct spelling or add words to the dictionary.

{button Related Topics,PI(`',`IDH_RT_DB_Spelling')}



Spell Checking
Spelling command
Options command (Tools menu)
To check spelling
To choose spelling options



Displays words not found in the dictionary. If no suggested correct spellings are displayed, you can 
click this area to copy its contents to the Change To box.



Displays the first suggested correct spelling, if suggestions are made. If no suggested spellings are 
listed, displays the text insertion point. You can type the correct spelling of the word or you can click
the Not In Dictionary box to copy the misspelled word into this area. You can change the word in this
box.



Displays a list of words similar to the misspelled word from the currently used dictionary. The first 
word listed also appears in the Change To box. Click another suggested word to copy it to the 
Change To box. If there are no suggestions for the correct spelling of the word, “No Suggestions” 
appears in the list.



Skips the word in the Not in Dictionary box without changing it.



Ignores the current word and all other occurrences of the word in this chart without prompting you.



Changes the Not In Dictionary word to the word in the Change To box.



Makes the same change to all subsequent occurrences of the word in the chart without prompting 
you.



Adds the word to the current dictionary.



Displays additional information.



Displays the Spelling tab of the Options dialog box so you can change the dictionary or specify to 
ignore words that contain numbers.



Protect/Unprotect Chart dialog box

To create a password for a chart, you must enter the password twice.
Type a password in the Password text box. The password is not case-sensitive. This means that 
uppercase and lowercase letters are considered to be the same. For example, flowchrt is 
recognized as the same password as FlowChrt. The password appears as a series of asterisks (****)
as you type. This prevents unauthorized persons from viewing the password as you enter it.
Type the password in the Verify text box exactly as you typed it in the Password text box. This 
verifies that the password you typed was not typed incorrectly.

Note
If you want to remove password protection so that you can make changes to a chart, the 

Unprotect Chart dialog box opens when you choose the Unprotect Chart command on the Tools menu. 
You then must enter the password to unprotect the chart.

{button Related Topics,PI(`',`IDH_RT_DB_Protect_Chart')}



Tools menu
Protect Chart command
To protect a chart
To unprotect a chart



Lets you type a password in the Password text box. 
The password is not case-sensitive. This means that uppercase and lowercase letters are considered
to be the same. For example, flowchrt is recognized as the same password as FlowChrt.
The password appears as a series of asterisks (****) as you type. This prevents unauthorized 
persons from viewing the password as you enter it.



Lets you type the password again exactly as you typed it in the Password text box. This verifies that 
the password you typed was not typed incorrectly.



Lets you tyep the password again exactly as you typed it in the Password text box. This verifies that 
the password you typed was not typed incorrectly.



Customize dialog box

This dialog box lets you add and remove buttons to the toolbars and the Toolbox by dragging 
buttons between the toolbar and Toolbox. You also can create a new toolbar by dragging a button 
onto the chart.

{button Related Topics,PI(`',`IDH_RT_DB_Customize')}



Customizing Toolbars 
Tools menu



Lists the categories. Select the one for which you want to view buttons.



Shows the buttons for the selected category.



Describes the button that you click on.



Saves all open charts, prompting for each one separately.



Sends the active chart through electronic mail.



Selects all items in the chart.



Displays the Help Topics dialog.



Inserts a drawing, image, or other object.



Changes the OLE links in the active chart.



Saves the active chart or template.



Shows or hides the numbers for the selected shapes.



Lets you change the properties of the selected shape type.



Lets you change the properties of the selected lines.



Adds a horizontal guideline to the chart and adjusts it.



Adds a vertical guideline to the chart and adjusts it.



Changes the units of measurement to inches.



Changes the units of measurement to centimeters.



Changes the selected text to strikethrough. This button swithces between strikethrough and not 
strikethrough.



Aligns the selected text to the left.



Aligns the selected text to the right.



Aligns the selected text to the center, horizontally.



Aligns the selected text to the top.



Aligns the selected text to the bottom.



Aligns the selected text to the middle.



Makes the selected text opaque.



Shows or hides nodes on lines.



Shows view of the entire chart.



Removes the data from all fields.



Sets the arrowhead at the beginning of the line.



Sets the arrowhead at the end of the line.



Options dialog box - Alignment tab

This dialog box sets Snap to Grid and Channel Alignment options.

{button Related Topics,PI(`',`IDH_RT_DB_Options_Alignment')}



Understanding Channel Alignment
To align a shape using channel alignment 
To automatically snap to grids

Tools menu
Options command (Tools menu)



To automatically snap to grids
1 On the Tools menu, click Options.
2 Click the Alignment tab.
3 Click Snap To Grid. 
4 Click OK.

Notes
You should turn off the grid to completely disable snapping. To do so, on the View menu, click 

Grid to remove the check mark from the Grid option. 
Tip

Use the Apply button to make your changes and view the results without closing the dialog 
box.

{button Related Topics,PI(`',`IDH_RT_To_automatically_snap_to_grids')}



Alignment and snapping
Options command (Tools menu)
Grid command
Tools menu



Options dialog box - Line Spacing tab

This dialog box sets the line offset for right-angle lines.
The Horizontal text box contains the distance between the shape and the first right angle of a 
horizontal line.
The Vertical text box contains the distance between the shape and the first right angle of a vertical 
line.

{button Related Topics,PI(`',`IDH_RT_DB_Options_LineSpacing')}



Tools menu
Options command (Tools menu)
Line Options



Options dialog box - Spelling tab

This dialog box lets you specify your own dictionary for use during spell checking.
Sets the spelling options such as specifying a user dictionary or ignoring words with numbers.

{button Related Topics,PI(`',`IDH_RT_DB_Options_Spelling')}



Tools menu
Options command (Tools menu)
To check spelling
To choose spelling options



Options dialog box - General tab
This dialog box lets you hide or display the "Finished" button or welcome dialog. You can also select 
the number of times you want to undo or redo changes.

{button Related Topics,PI(`',`IDH_RT_DB_Options_General')}



To hide or display "Finished" button
To hide or display Welcome dialog
To select number of undos and redos for chart changes
Tools menu

Options command (Tools menu)



To hide or display "Finished" button
1 On the Tools menu, click Options.
2 Click the General tab.
3 If you want to hide the Finished button, clear the Display "Finished" Button check box. To display 

the Finished button, make sure the Display "Finished" Button check box is selected.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_HideDisplay_Finished_button')}



To hide or display Welcome dialog
To select number of undos and redos for chart changes
Tools menu
Options command (Tools menu)



To hide or display Welcome dialog
1 On the Tools menu, click Options.
2 Click the General tab.
3 If you want to hide the Welcome dialog box, clear the Display Welcome Dialog check box. To 

display the Welcome dialog box, make sure the Display Welcome Dialog check box is selected.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_HideDisplay_Welcome_dialog')}



To hide or display "Finished" button
To select number of undos and redos for chart changes
Tools menu
Options command (Tools menu)



To select number of undos and redos for chart changes
1 On the Tools menu, click Options.
2 Click the General tab.
3 If you want to hide the Finished button, clear the Display "Finished" Button check box. To display 

the Finished button, make sure the Display "Finished" Button check box is selected.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_Chart_Undos_Redos')}



To hide or display "Finished" button
To hide or display Welcome dialog
Tools menu
Options command (Tools menu)



Lets you select whether to display the Finished button for your active chart. Clearing the Display 
"Finished" Button check box will hide the Finished button.



Lets you select whether to display the dialog box that displays when you first open FlowCharter. 
Clearing the Display Welcome Dialog check box will hide the Welcome dialog box.



Lets you indicate the number of redos or undos you want to reverse.



Lets you define how far shapes snap from each other when placed in a chart. For example, if you set
0.5" horizontal spacing and drag a new shape out of an existing shape, the new shape snaps half an
inch away if you release the mouse button near that location.



Lets you define how far shapes snap from each other horizontally when placed in a chart. For 
example, if you set 0.5" horizontal spacing and drag a new shape out of an existing shape 
horizontally, the new shape snaps half an inch away if you release the mouse button near that 
location.



Lets you define how far shapes snap from each other vertically when placed in a chart. For example,
if you set 0.5" horizontal spacing and drag a new shape out of an existing shape vertically, the new 
shape snaps half an inch away if you release the mouse button near that location.



Lets you place a new shape that is aligned to a reference shape already in the chart. To define the 
reference shape, you press the mouse button and drag a new shape over an existing shape as you 
are about to place the new shape. Reference marks appear on the existing shape. You can change 
the reference shape simply by dragging the new shape over a different shape already in the chart.



Aligns shapes horizontally and vertically (in a channel) when you drag to place connected shapes. 
Channel alignment also works when you click to place shapes if you click near the center of the 
channel.



Lets you snap objects and guidelines to ruler positions. Coarse alignment makes the pointer snap at 
1/8" increments; fine alignment makes it snap at 1/16" increments (when inches is selected as the 
unit of measure).



Lets you snap objects and guidelines to ruler positions. Coarse alignment makes the pointer snap at 
1/8" increments; fine alignment makes it snap at 1/16" increments (when inches is selected as the 
unit of measure).



Lets you snap objects and guidelines to ruler positions. Coarse alignment makes the pointer snap at 
1/8" increments; fine alignment makes it snap at 1/16" increments (when inches is selected as the 
unit of measure).



Lets you set the amount of horizontal space between lines and shapes.



Lets you set the amount of vertical space between lines and shapes.



Type the path and file name of the dictionary to be used for spell checking.



Ignores words with numbers during spell checking.



Creates a Living FlowChart action for the selected shape.



Add-Ons command
{button OLE 
Automation,PI(`',`I
DH_OA_OLE_Auto
mation')}

The Add-ons command is an advanced feature that requires the use of OLE Automation. On the 
Tools menu, this command displays a menu of other applications that can be accessed. If none are 
available, the command is "(Empty)." 

{button Related Topics,PI(`',`IDH_RT_Addons_Command')}



OLE Automation 
Tools menu 



An advanced feature that requires the use of OLE Automation. On the Tools menu, this command 
displays a menu of other applications that can be accessed. If none are available, the command is 
"(Empty)." 



Runs a Living FlowChart script.



Runs the Script Editor.



Welcome to FlowCharter 7 dialog box
The Welcome to FlowCharter 7 dialog box displays when the program opens unless you selected the 
"Don't display this startup screen again" check box at the bottom of this dialog box.
The Welcome to FlowCharter 7 dialog box lets you choose how you want the program to open. You 
can open by:

Creating a new chart starting with a blank page
Selecting from a list of recently used files
Selecting a file using the Open dialog box
Creating a new chart based on a template

The Welcome to FlowCharter 7 dialog box also displays tips about using FlowCharter.

{button Related Topics,PI(`',`IDH_RT_Welcome_dialog_box')}



To create a chart from a template 
To open a file 
To create a new chart 
To create a new template 
To save your default template in another view state 

Options command (Tools menu) 
Tools menu 



Lets you open the program with a new chart starting with a blank page.



Lets you open the program with a file you choose from a list of files you recently used.



List of recently used files. Click drop-down arrow to display list.



Lets you open the program with a file you choose from the Open dialog box.



Lets you open the program with a new chart starting with an existing template.



Displays or hides this dialog box when the program starts up again.



Displays the Tip Of The Day.



Displays the next Tip Of The Day.



Adds to or changes script that controls the actions of a specific object or shape.



Shape Numbers Overview
{button Tell me how . . .,PI(`',`IDH_HT_Shape_Numbering')}

Automatic numbering
You can number shapes as you draw them. You can use various numbering systems (including 1, 2, 
3, and so on; 1.1, 1.2, 1.3, and so on; 1.1.1, 1.1.2, 1.1.3, and so on).
The number you define is used as the shape number for the next shape you place in a chart and 
subsequent shapes are numbered in consecutive order. For example, if you define 50 as the next 
number, the shape number for the first shape you place in the chart is 50, the next shape you place 
is numbered 51, and so on. 

Text labels for numbers
If you enter text before the number, the text appears along with the number. For example, if you 
enter Step before the number, the word "Step" appears in front of each shape you place or 
renumber from that point. Numbers can include numeric and nonnumeric labels. For example, the 
label First 1.2.34 is an acceptable label, but only 34 is called a "number." You can use numbers up to
999,999,999 in a label.
Use the Next Number box in the Set Next Shape Number dialog box to define the number for the 
next shape you place in a chart and for the shapes you renumber. If the entry is a decimal number, 
the portion to the right of the decimal is incremented. If you enter text without a number, the same 
text label is applied to each new shape.
You can enter up to 20 characters in a shape number.

Showing and hiding numbers
The Display Numbers command in the Shape Numbering submenu in the Format menu lets you 
display and hide shape numbers. When Display Numbers is selected, the shape numbers in selected
shapes are displayed. When it is not selected, the shape numbers in selected shapes are hidden.

Note
Numbering is turned off by default. You must turn it on to number shapes automatically.

{button 
Related 
Topics,PI(`',`I
DH_RT_Shap
e_Numbers_
Overview')}

{button OLE 
Automation,
PI(`',`IDH_O
A_NumberSh
own_Propert
y')}

To number shapes
To show or hide shape numbers
To renumber shapes automatically
To renumber shapes manually



Renumbering existing shapes
To change the next number for new shapes
To hide and display shape numbers
To renumber shapes automatically
To renumber shapes manually



NumberShown Property



Renumbering Existing Shapes
{button Tell me 
how . . .,PI(`',`IDH
_HT_Renumberin
g_Existing_Shape
s')}
{button OLE 
Automation,PI(`',
`IDH_OA_Renumb
er_Method')}

You can renumber specific shapes. You can manually renumber shapes one at a time by clicking the 
shapes to choose the numbering order, or automatically renumber a group of selected shapes at the
same time.

Manually Renumbering Shapes
When you manually renumber shapes, the number displayed in the Set Next Shape Number box 
increases by one so the next shape you click is renumbered in consecutive order. For example, if 
you define 100 as the next number, the first shape you click is renumbered 100, and the next 
number increases to 101.

Automatically Renumbering Shapes
With the Auto Renumber command in the Shape Numbering submenu, you can automatically 
renumber a group of shapes at one time. When you do this, the selected shapes are renumbered in 
consecutive order. The selected shape with the lowest number is renumbered with the number you 
choose, and the other selected shapes are renumbered in consecutive order, based on their current 
sequence. For example, suppose you select three shapes numbered 12, 15, and 25 and define 1 as 
the next number. When you automatically renumber the shapes, shape 12 is renumbered 1, shape 
15 is renumbered 2, and shape 25 is renumbered 3.
When you renumber existing shapes, the next number is applied to the first shape you renumber, 
and all other shapes you designate are renumbered in consecutive order. For example, if you define 
1.1.12 as the next number, the first shape you designate is renumbered 1.1.12, the next designated
shape is renumbered 1.1.13, and so on.

{button Related Topics,PI(`',`IDH_RT_RENUMBERP')}



Shape Numbers Overview



To renumber shapes manually
To renumber shapes automatically



Renumber Method



To renumber shapes manually
1 Click the Renumber tool. The pointer changes to the Number pointer when you move it into the 

drawing area.

Renumber tool
2 On the Format menu, click Shape Numbering.
3 Click Set Next Shape Number.
4 In the Set Next Shape Number dialog box, type the next number you want displayed.
5 Click the first shape in the chart you want to renumber. The shape number is changed to the next

number you defined.
6 Click the other shapes in the order you want them renumbered.

Tips
If you want to renumber an existing shape with the next number, you may omit steps 2 and 3.
The number in the Set Next Shape Number dialog box is used as the shape number for the 

next shape you place in the chart.
This feature only affects shapes that are numbered with the Shape Numbering command. If 

you typed a number in the shape itself, the shape cannot be renumbered via this method.

{button Related Topics,PI(`',`IDH_RT_To_renumber_shapes_manually')}



Renumbering Existing Shapes
To renumber shapes automatically
Shape Numbering command 
Format menu 



To renumber shapes automatically
1 Select the shapes you want to renumber.
2 On the Format menu, click Shape Numbering.
3 Click Auto Renumber.

Note
This feature only affects shapes that are numbered with the Shape Numbering feature. If you 

type a number in the shape, the number cannot be renumbered via this method.

{button Related Topics,PI(`',`IDH_RT_To_renumber_shapes_automatically')}



Renumbering Existing Shapes
To renumber shapes manually
Shape Numbering command 
Format menu 



To show or hide shape numbers
1 Select the shapes whose numbers you want to show or hide.
2 On the Format menu, click Shape Numbering.
3 Deselect Display Shape Numbers.

Tip
This feature only affects shapes that are numbered with the Shape Numbering feature. If you 

type a number in the shape, the number cannot be shown or hidden via this method.

{button Related Topics,PI(`',`IDH_RT_To_hide_shape_numbers')}



Shape Numbers Overview
Shape Numbering command 
Format menu 



To change the next number for new shapes
1 On the Format menu, click Shape Numbering.
2 Type the next number and any text you want to appear beside the number in the Next Number 

box.
3 Click OK.

Notes
The number and text you define appear in the next shape you place in the chart. The number 

automatically increases with each new shape.
This feature only affects shapes that are numbered with the Shape Numbering feature. If you 

type a number in the shape, the number cannot be changed with this method.

{button Related Topics,PI(`',`IDH_RT_To_change_the_next_number_for_new_shapes')}



Shape Numbers Overview
To renumber shapes automatically
To renumber shapes manually
Shape Numbering command 
Format menu 



To number shapes

{button Show me how . . .,PI(`',`IDH_AVI_tonumbershapes16')}
1 Select the shape or shapes to number.
2 On the Format menu, click Display Shape Numbers.

{button Related Topics,PI(`',`IDH_RT_To_number_shapes')}



Shape Numbers Overview
To renumber shapes automatically
To renumber shapes manually



{mci PLAY NOMENU NOPLAYBAR,CAP0016.AVI}



Set Next Shape Number dialog box

The Set Next Shape Number dialog box uses the Next Number box to define the number for the next
shape you place in a chart and for the shapes you renumber. If the entry is a decimal number, the 
portion to the right of the decimal is incremented. If you enter text without a number, the same text 
label is applied to each new shape.
You can enter up to 20 characters in a shape number.

{button Related Topics,PI(`',`IDH_RT_Set_Next_Shape_Number_DB')}



Shape Numbers Overview
To renumber shapes automatically
To renumber shapes manually
Shape Numbering command 
Format menu 



To use ToolTips
1 On the View menu, click Toolbars.
2 Make sure the Show ToolTips box is checked.
3 Point to a tool or button in the window, and hold the mouse still for a short time. A short message

(bubble) appears, explaining the tool or button.

To turn off ToolTips
1 On the View menu, click Toolbars.
2 Make sure the Show ToolTips box is cleared.

{button Related Topics,PI(`',`IDH_RT_Using_Tool_Tips')}



View menu
Toolbars - Overview



Toolbars - Overview
{button Tell me how. . .,PI(`',`IDH_HT_Toolbars')}

Toolbars contain a set of related tools. For example, the Formatting toolbar contains tools that allow 
you to format elements of the chart or graph.
Toolbars can display as palettes that you drag to a preferred place on the screen, or you can attach 
(“dock”) them to the side of the window. Toolbars can also be hidden and/or customized.
You can display the following toolbar:

Standard
Formatting
Arrange
Arrange+
Toolbox
Preset Styles
Data
Living FlowCharts

The following toolbars display when you use the DataAnalyzer feature:
Standard
Formatting

Tips
You can resize your Font box, or any other drop-down box, on the toolbar while the Customize 

dialog box is open.    To open the Customize dialog box, on the Tools menu, click Customize.
You can give custom toolbars any name you want. Also, you can rename the custom toolbars.
You can add over 20 custom toolbars that will show up in the shortcut menu (displayed when 

you right-click on the toolbars area).    You must use the View menu’s Toolbars command to see them. 
(The number of toolbars you can view on the shortcut menu varies depending on your screen 
resolution.)

You can return the Micrografx-supplied toolbars to the way they were when you installed the 
program. To do this, on the View menu, click Toolbars. Click the toolbar to reset, and click Reset. Any 
buttons you have added will be removed. Any buttons you have deleted will be replaced.

You can drag buttons off a toolbar. To do this, hold down the Alt key, click on the button to 
remove and drag it off the toolbar. Note that you cannot undo this action.

{button Related Topics,PI(`',`IDH_RT_Toolbars')}



To hide toolbars
To dock toolbars
To choose color buttons 
To choose toolbar button sizes 

To create new toolbars 
To delete toolbars 
To rename toolbars 
To reset toolbars 



Standard toolbar
Formatting toolbar
Toolbox
Arrange toolbar
Arrange+ toolbar

Preset Styles toolbar
Data toolbar
Living FlowCharts toolbar



To dock toolbars
1 Click and drag the toolbar to a side of the chart window (top, bottom, left, or right).
2 When the outline of the toolbar conforms to the side, release the mouse button.

{button Related Topics,PI(`',`IDH_RT_Docking_Toolbars')}



Toolbars - Overview



To hide toolbars
1 On the View menu, click Toolbars.
2 Clear the check box of the toolbar you want to hide.



ToolTips display the name of a tool or button. They display when you rest the cursor over the tool or 
button. 



FlowCharter 7 menus
FlowCharter provides the following commands for the program menus:

Menus Commands
File menu New - Opens a new, blank chart window.

Open - Opens a previously saved chart, template, or workspace. 
Close - Closes the active chart.
Close All - Closes all of the windows of all charts.
Save - Saves the file on which you are working, using the current filename.
Save As - Makes a copy of the file under a new name or in another location.
Save Workspace - Saves the names of open charts and their window 
arrangement in a file.
Import - Imports a shape from another file.
Export    - Exports a chart to another file.
Page Setup - Sets up the page dimensions and orientation.
Print Preview - Previews how a page will look.
Print - Selects a print range and other options before printing a chart.
Print Setup - Selects a printer and printer options.
Send - Creates an e-mail message with the current chart as an attachment.
Recent File List - Lists the last four charts you opened or saved.
Exit - Closes open chart files and the program.

Edit menu Undo - Reverses the last action or change on a chart.
Redo - Reverses the last undo you made.
Cut - Cuts the selected objects to the Clipboard.
Copy - Copies the selected objects to the Clipboard.
Paste - Pastes the cut or copied objects into the active chart.
Paste Special - Pastes information from the Clipboard in various formats.
Clear - Deletes the selected objects from a chart.
Duplicate -Duplicates the selected objects.
Select All - Selects all objects in a chart.
Select - Selects the specified shapes, lines, text blocks, or OLE objects in a 
chart.
Find - Finds text in shapes.
Replace - Replaces the text in shapes.
Links - Opens a list of the objects linked to the active chart.
Object - Opens an object application for you to change the linked or 
embedded object.

View menu Normal - Displays a page at its actual sizes.
Page - Displays the entire page.
Full Screen - Shows all of the elements of your chart on the screen without 
menus or buttons.
Toolbars - Hides or shows any of the toolbars.
Status Bar - Hides or shows the status bar.
Rulers - Hides or shows the rulers.
Shape Palettes - Hides or shows the Shape palette.
Worksheet - Hides or shows the data fields worksheet.
Entity Manager - Hides or shows the Entity Manager.
Field Viewer - Opens the Field Viewer dialog box for entering data into 
selected shapes’ fields.
Note - Hides or shows a Note window.
CoolSheets - Hides or shows a CoolSheet.
Guidelines - Hides or shows guidelines.
Grid - Hides or shows a grid.
QuickZoom - Hides or shows the QuickZoom window.



Zoom -    Changes the magnification of a chart.
Insert 
menu

Link - Changes a link for selected objects.

Data Field - Creates or arranges a data field.
Legend - Hides or shows a chart legend.
Starting Point - Selects a starting shape for a Living FlowChart.
CoolSheet - Inserts a CoolSheet into a chart.
Guideline - Adds a guideline to the chart and adjusts them.
SPC Chart - Inserts a Statistical Process Control chart into a flowchart.
Object - Inserts a drawing, image, or other object into a chart.

Format 
menu

Fill - Specifies a shape's background color, fill pattern, and pattern color.

Line - Changes a line's color, weight, and style.
Ends - Changes a line's color, size, and arrowhead type.
Effects - Changes an object's color, style, and depth of the effect.
Font - Defines the font, size, style (bold, italic, underline, strikethrough), 
color of text, and whether or not it can be opaque.
Text Alignment - Defines the horizontal or vertical alignment and the text-
to-page orientation (horizontal or vertical).
Object Properties - Displays and defines object information and connect 
point properties of shapes.
Shape Numbering - Hides or displays shape numbers, sets the next shape 
number, automatically renumber the shapes, or makes the Renumber tool 
active.

Tools menu Spelling - Spell checks the chart.
Protect Chart - Sets or removes password protection to protect your chart 
from unauthorized changes.
Run Flowchart - Runs a Living FlowChart script.
Shape Action Wizard - Creates a Living FlowChart action for the selected 
shape.
Edit Chart Script - Runs the Script Editor.
Import Data - Lets you import data to your active worksheet.
Report - Runs a report.
Add-Ons - Lets you access other applications.
Customize - Lets you customize the program toolbars and the Toolbox.
Options - Lets you set options for shape spacing and alignment, line 
spacing, spell checking, displaying Finished button, displaying Welcome 
dialog, and setting number of Undos and Redos

Arrange 
menu

Order - Changes the order of selected objects.

Layers - Provides a submenu of commands that opens the Layer Manager, 
edits all layers, adds layers, lets you select a layer to move to, moves the 
layer back one layer, and moves the layer forward one layer.
Align - Aligns shapes vertically and horizontally.
Make Same Size - Makes selected shapes same size.
Space Evenly - Spaces selected shapes evenly.
Center - Centers selected objects or the entire chart on a page.
Group - Groups the selected objects.
Ungroup - Ungroups the selected group of objects.
Make New Shape - Makes the selected objects into a new shape.
Break Apart - Breaks apart a new shape that was formed with the Make 
New Shape command.
Combine - Connects and disconnects closed and open objects. Also, forms 
new shapes from different combinations of operations that you can do with 
shapes.



Rotate/Flip - Rotates or flips the selected object.
Replace Shape - Replaces the selected shape(s) with the shape in the 
Shape palette.
Reverse Ends - Reverse the ends of the selected line.
Fit to Text - Fits the object to the text.

Window 
menu

New Window - Creates a new chart window.

Arrange All - Arranges all the chart windows so that they can be viewed 
simultaneously.
Split - Divides the current chart into separate, active sections.
Chart List - Lists the names of open charts.

Help menu FlowCharter 7 Help - Displays an index that lets you find specific 
information to help you use the program.
Micrografx Home Page - Displays Micrografx internet home page.
Micrografx Tech Support - Displays Micrografx technical support 
information.
Office Compatible - Displays information about the program and its 
compatibility with Microsoft Office.
Tip of the Day - Displays program tips.
About FlowCharter - Displays the program’s version number, copyright, and
licensing information.

{button Related Topics,PI(`',`IDH_RT_FlowCharter_menus')}



File menu 
Edit menu 
View menu 
Insert menu 
Format menu 
Tools menu 
Arrange menu 
Window menu 
Help menu 



Help menu
FlowCharter 7 Help Displays an index that lets you find 

specific information to help you use the 
program.

Micrografx Home Page Displays Micrografx internet home page.
Micrografx Tech Support Displays Micrografx technical support 

information.
Office Compatible Displays information about the program 

and its compatibility with Microsoft Office.
Tip of the Day Displays program tips.
About FlowCharter Displays the program’s version number, 

copyright, and licensing information.

FlowCharter Help command
The FlowCharter Help command displays an index that lets you find specific information to help you 
use the program.



Displays an index that lets you find specific information to help you use the program.



Micrografx Home Page command
The Micrografx Home Page command displays Micrografx internet home page.



Displays Micrografx internet home page.



Micrografx Tech Support command
The Micrografx Tech Support command displays Micrografx technical support information.



Displays Micrografx technical support information.



Office Compatible command
The Office Compatible command displays information about the program and its compatibility with 
Microsoft Office.



Displays information about the program and its compatibility with Microsoft Office.



Tip of the Day command
The Tip of the Day command displays program tips for working with FlowCharter.



Displays program tips for working with the program.



About FlowCharter command
The About FlowCharter command displays the program’s version number, copyright, and licensing 
information.



Displays the program’s version number, copyright, and licensing information.



About FlowCharter dialog box

The top portion of the About FlowCharter 7 dialog box contains the program version number and 
copyright date for your copy of the program.
Click the telephone icon for information about how to contact Micrografx Technical Support. Click the
other icons for information about additional Micrografx products.

{button Related Topics,PI(`',`IDH_RT_About_ABC_FlowCharter')}



About FlowCharter command



Edit menu 

Click a command below to learn more about it.
Undo Reverses the last action or change on a

chart.
Redo Reverses the last undo you made.
Cut Cuts the selected objects to the 

Clipboard.
Copy Copies the selected objects to the 

Clipboard.
Paste Pastes cut or copied objects into the 

active chart.
Paste 
Special

Pastes information from the Clipboard 
in various formats.

Clear Deletes selected objects from a chart.
Duplicate Duplicates the selected objects.
Select All Selects all objects in a chart.
Select Selects specified shapes, lines, text 

blocks, or OLE objects in a chart.
Find Finds text in shapes.
Replace Replaces text in shapes.
Links Opens a list of the objects linked to the 

active chart.
Object Opens the object application for you to 

change the linked or embedded object.

{button Related Topics,PI(`',`IDH_RT_Editmenu')}



Undo command 
Redo command
Cut command
Copy command

Paste command
Paste Special command
Clear command
Duplicate command

Select All command
Select command
Find command
Replace command

Links command
Object command (Edit menu)



Undo command
{button OLE Automation,PI(`',`IDH_OA_Undo_Method')}

The Undo command reverses the last action or change on a chart. If an action cannot be reversed, 
Can't Undo appears in the menu.

{button Related Topics,PI(`',`IDH_RT_Undo_Command')}



To undo an action
Redo Command
Edit menu



Undo Method



Reverses the last action or change you made to a chart. If an action cannot be reversed, Can't Undo 
appears in the menu.



To undo an action
Click Undo on the Edit menu.

Tips
You can also undo an action by clicking 

 on the Standard toolbar.
You can also press Ctrl+Z to undo an action.

{button Related Topics,PI(`',`IDH_RT_Reversing_changes')}



Undo command
To redo (reverse) your last undo
Edit menu



Redo command
The Redo command on the Edit menu reverses the last undo you made.
A description of the action to be redone follows the Redo command. For example, Redo Move 
indicates that Redo will redo a move action.
Redo is not available if the program cannot reverse the most recent undo.

{button Related Topics,PI(`',`IDH_RT_Redo_Command')}



To redo (reverse) your last undo
Undo command
Edit menu



Reverses the last undo you made. If an undo cannot be reversed, Can't Redo appears in the menu.



To redo (reverse) your last undo
Click Redo on the Edit menu.

Tips
You can also reverse an undo by clicking 

 on the Standard toolbar.
You can also press Ctrl+Y to reverse an undo.
To reverse a redo, use Undo.

{button Related Topics,PI(`',`IDH_RT_To_reverse_your_last_undo')}



Redo Command
To undo an action
Undo command
Edit menu



Cut command
{button OLE Automation,PI(`',`IDH_OA_Cut_Method')}

The Cut command removes the selected objects from a chart and places them on the Clipboard.

{button Related Topics,PI(`',`IDH_RT_Cut_Command')}



Paste command
Copy command
Clear command
Edit menu



Cut Method



Removes the selected objects from a chart and places them on the Clipboard.



To cut objects
1 Select the object or objects to cut.
2 On the Edit menu, click Cut.

Tips
Shapes or text cut or copied from the chart window cannot be pasted into the Note window.
The keyboard shortcut for cutting an object is Ctrl+X.

{button Related Topics,PI(`',`IDH_RT_Cutting_an_Object')}



Cut command
Paste command
Copy command
Clear command

Edit menu



Copy command
{button OLE Automation,PI(`',`IDH_OA_Copy_Method')}

The Copy command copies the selected objects in a chart and places the copy on the Clipboard.

{button Related Topics,PI(`',`IDH_RT_Copy_Command')}



Copies the selected objects in a chart and places the copy on the Clipboard.



To copy objects
Paste command
Edit menu



Copy Method



Copies the selected objects in a chart and places the copy on the Clipboard.



To copy objects
1 Select the object or objects you want to copy.
2 On the Edit menu, click Copy.

Tip
You can also press Ctrl+C to copy a selected object.
Shapes or text copied or cut from the chart window cannot be pasted into the Note window.

{button Related Topics,PI(`',`IDH_RT_Copying_an_object')}



Copy command
Paste command
Edit menu



Paste command
{button OLE Automation,PI(`',`IDH_OA_Paste_Method')}

The Paste command places the contents of the Clipboard in the active chart.

{button Related Topics,PI(`',`IDH_RT_Paste_Command')}



To paste objects
To add a picture to a chart
Cut command
Copy command

Paste Special command
Paste Link command
Edit menu



Paste Method



Places the contents of the Clipboard in the active chart.



To paste objects
On the Edit menu, click Paste.

Tips
You can also press Ctrl+V to paste the object.
You can paste notes into the active chart window using the Paste command in the main 

program window. Before you can paste something from the Note window, you must select a shape or 
click the left mouse button on the active chart.

{button Related Topics,PI(`',`IDH_RT_Pasting_an_object')}



Cut command
Copy command
Paste Special command
Paste Link command

Paste command
Edit menu



To add a picture to a chart
1 Select the picture you want in the other program.
2 Copy the picture to the Clipboard.
3 Open the chart into which you want to paste the picture.
4 On the Edit menu, click Paste. 

Tip
After you paste a picture into your chart, you can resize it and position it anywhere in the 

chart.

{button Related Topics,PI(`',`IDH_RT_To_add_a_picture')}



Cut command
Copy command
Paste Special command
Paste Link command

Paste command
Edit menu



Clear command
{button OLE Automation,PI(`',`IDH_OA_Clear_Method')}

The Clear command deletes the selected objects from a chart.

Note
Objects are deleted permanently when you choose the Clear command. They are not placed on

the Clipboard. You can use the Undo command to recover a cleared object.



Deletes the selected objects from a chart.

Note
Objects are deleted permanently when you choose the Clear command or press the Delete 

button. They are not placed on the Clipboard. You can use the Undo command to recover a cleared 
object.



To delete objects
Cut command
Edit menu



Clear Method



To delete objects
1 Select the object you want to delete.
2 On the Edit menu, click Clear.

Tip
You can also press Del to delete the selected object.
Objects are deleted permanently when you choose the Clear command. They are not placed on

the Clipboard. 
You can use the Undo command to recover a cleared object.

{button Related Topics,PI(`',`IDH_RT_Deleting_an_object')}



Clear command
Cut command
Edit menu



Select command
{button OLE Automation,PI(`',`IDH_OA_Select_Method')}

The Select command lets you specify the shapes, lines, text blocks, or OLE objects that you want 
selected in a chart.

{button Related Topics,PI(`',`IDH_RT_Select_Command')}



To select all objects of one type
Select All command
Edit menu



Select Method



Select All command
The Select All command selects all objects, shapes, and lines in the chart.

{button Related Topics,PI(`',`IDH_RT_Select_All')}



Selects all objects, shapes, and lines in the chart.



To select all objects of one type
Select command
Edit menu



Selects specific types of objects.



Select dialog box

Use the Select dialog box to select items in a chart. 
This dialog is useful when you want to standardize the style of lines, text, or shapes.    For example, 
when you click Text Blocks and click OK, every action you take affects all the text in your chart until 
you click in your chart again.

{button Related Topics,PI(`',`IDH_RT_Select_dialog_box')}



To select all objects of one type
Select command
Select All Command



Selects only shapes in your chart. Next, click the shape type to select from the Name    box, or click 
<all types> in the    box.



Selects all shapes of a certain type. You may also select all shapes regardless of type by clicking 
<all types>. 



Selects all lines in your chart.



Selects all text blocks in your chart.



Selects all the OLE objects in your chart.



Selects all items in your chart.



Clears all items in your chart.



To select all objects of one type
1 On the Edit menu, click Select.
2 Click one or more of the check boxes to select all objects of that type.

Tips
In the Name    box, you can click a shape name to select all shapes of that kind.
You can also select all objects using the Select All command on the Edit menu.
You can select multiple objects. Press and hold Shift as you click each object.
You can select an object beneath other objects. Click the Selector tool, press and hold Ctrl, and

click the top object. As you continue to click, each object below the top object is selected.

{button Related Topics,PI(`',`IDH_RT_Selecting_stuff')}



To select an object 
Select command



Understanding Object Linking and Embedding 
(OLE)

{button OLE 
Automation,PI(`',`I
DH_AT_Linking_an
d_Embedding')}
{button Tell me 
how. . .,PI(`',`IDH_
HT_Linking_and_E
mbedding')}

Object linking and embedding (OLE) is a way to exchange, or share information between files. The 
files can be made with the same program or different programs. For example, you can bring a 
Micrografx Designer picture into a flowchart made with FlowCharter, or insert your flowchart into a 
Word document. 

What Is an Object?
An object is simply information. It can be a file or a part of a file that you can use in another file.

Linking
You can link a chart to another program. (The other program must also be OLE-compatible.) The 
chart becomes the object, and the document becomes a compound document.
You also can link an object from a file from another program to a chart. When an object is linked, any
changes you make to the object in the source file are reflected in the chart.

Inserting Objects (Embedding)
You can embed a chart in a document in another program. The chart becomes the object, and the 
document becomes a compound document.

Inserting a New Object in a Chart
You can select an object type from a list of programs on your system. A new, empty object is 
inserted in the window, and the object application opens for you to fill in the empty object. The 
object appears in both the object application and FlowCharter at the same time.

Inserting an Object from a File
You can open an existing OLE-compatible file that contains the object you want to insert in your 
chart. The object is embedded unless you select the Link to File option.

Do You Want to Link or Embed Your Information?
Linking Embedding 

Linked
Embedding Not 
Linked

Result of 
using

Shows pasted
information in
chart.

Shows entire 
file in chart or 
shows it as an 
icon. Changes 
you make will 
appear in the 
original file, 
and changes to
original file 
show in the 

Shows entire file in 
chart or shows it as
an icon. Changes 
you make will NOT 
appear in the 
original file, and 
changes to the 
original file do not 
show in the chart.



chart.
Advantage of 
using

You can paste
only a portion
of an existing
file, instead 
of the entire 
file.

You can change
it within your 
chart without 
leaving the 
program.

You can change it 
within your chart 
without leaving the 
program.

Changing 
information

Double-click 
on it to open 
it in its 
program.

Click once on it 
and change it 
within the 
chart.

Click once on it and
change it within the
chart.

Command Paste Special 
command, 
Paste Link 
option

Insert Object, 
Create from file

Insert Object, 
Create New

{button Related Topics,PI(`',`IDH_RT_Objects_and_linking')}



Object Linking and Embedding (OLE)
Paste Special command
Object command (Edit menu)



AT Linking and Embedding



To change an embedded FlowCharter object
To change an object embedded in a chart
To change an object linked to a chart

To change a link
To embed a chart in a document
To embed an object in a chart
To change an embedded FlowCharter object

To insert a new object in a chart
To insert an object from a file
To link a chart to a document
To link an object to a chart

To paste OLE and non-OLE information in a chart
To save files in ABC FlowCharter version 3.0/4.0 format
To view the links to a chart



InsertObjectFromFile Method
PasteLink Method
Paste Special Method
ClipboardFormatAvailable_Property (Paste Option)



Paste Special command
{button OLE Automation,PI(`',`IDH_OA_Paste_Special_command')}

The Paste Special command lets you paste information from the Clipboard into your chart in various 
formats. You use this command to link information to the active chart.
Depending upon the information in the Clipboard, your paste format options may include an 
embedded OLE object, Rich Text Format (RTF), unformatted text, a metafile (which will act as a chart
shape), and a bitmap. (Format options vary; additional formats may be available.)
After you link an object to a chart, any changes made to the object in its source file in the original 
program (the object application) are reflected in the chart.

Note
The difference between the Paste Special command’s Paste Link option and the Insert Object 

command is that when you insert an object, the entire object is included in your chart. With the Paste 
Link option, you can select a portion of a document, spreadsheet, or bitmap and paste it into your 
chart. When something is Paste Linked, you cannot change it right in your chart, as you can an 
inserted object.

{button Related Topics,PI(`',`IDH_RT_Paste_Special_Command')}



To paste OLE and non-OLE information into a chart
Paste command
Edit menu



PasteSpecial Method
PasteLink Method



Selects a type of data to paste.



Paste Link command
{button OLE Automation,PI(`',`IDH_OA_PasteLink_Method')}

The Paste Link command lets you paste an object from the Clipboard and link it to your active chart.
After you link an object to a chart, any changes made to the object in its source file in the original 
program (the object application) are reflected in the chart.

{button Related Topics,PI(`',`IDH_RT_Paste_Link_command')}



PasterLink Method



Pastes an object from the Clipboard and link it to your active chart.
After you link an object to a chart, any changes made to the object in its source file in the original 
program (the object application) are reflected in the chart.



To link an object to a chart
Paste command
Edit menu



Links command
The Links command opens a list of objects linked to the active chart.
Use this command to update the object with changes made in the source file, open the source file, 
change the source file or item, or break the link to the source file.

Note
You can only change the links of linked objects. For example, you cannot break a link of an 

inserted object.

{button Related Topics,PI(`',`IDH_RT_Links_Command')}



To view the links to a chart
To change a link
Edit menu



Opens a list of the objects linked to the active chart.



Object command (Edit menu)
{button OLE

Automation,PI(`',`IDH_OA_InsertObjectFromFile_Method')}
If you insert from an existing file, you can link the object to the source file. You also have the option 
to display the inserted object as an icon instead of a full graphic.
This command displays a submenu when the active object is an inserted object. You can change, 
open, or convert the inserted object via this submenu.
The name of the command varies, depending upon the object linked to or embedded in the chart. 
For example, the command reads “WordPad Document Object” when the document is a WordPad 
document.

{button Related Topics,PI(`',`IDH_RT_Object_Command_Editmenu')}



To insert a new object in a chart
To insert an object from a file
To change an inserted object 

Converting Object Embedded In ABC FlowCharter 4.0 
Object command (Edit menu) 
Object command (Insert menu) 
Edit menu 



InsertObjectFromFile Method



To change an inserted object
1 Double-click the object in the chart or open the Edit menu, and then click Edit <Name> Object. 

The object program opens.
2 Make changes to the object in the program.
3 On the File menu for the object program, click Update.
4 Minimize the object program. FlowCharter displays the changes to the object.

Note
If you try to exit the object program without choosing Update, it displays a message asking 

whether you want to update the object. Click Yes to update the object in FlowCharter. The object 
program closes.

{button Related Topics,PI(`',`IDH_RT_To_change_an_inserted_object')}



To convert an inserted object 
Object command (Edit menu)
Edit menu



To convert an inserted object
1 On the Edit menu, click the last item. (The command itself varies, based on the inserted object 

type. For example, if the object is a Microsoft Word document, the command is Document 
Object.)

2 Click Convert.
3 Click the type to convert to.
4 Click Display as Icon if you want the object to appear as an icon in your chart.
5 Click OK.

Note
This command converts an object from one type to another. For example if you insert a 

Paintbrush object into your chart, you can convert it to any other compatible object type. The 
compatible object types are listed in the Convert dialog box.

{button Related Topics,PI(`',`IDH_RT_Converting_objects')}



To change an inserted object 
To change objects embedded with ABC FlowCharter 4 
Converting Object Embedded In ABC FlowCharter 4.0 
Object command (Edit menu)
Edit menu



Displays a submenu when the active object is an inserted object. You can change, open, or convert 
the inserted object via this submenu.



Opens the inserted object to make the changes in the object while in your chart.



Opens the inserted object in its source file to make changes directly to the object.



Converts the inserted object to another object type. You can convert the object to any other type of 
object listed in the Object Type list.



Offers several formats for pasting the information from the Clipboard, depending on the type of 
information you are pasting and the program in which it was created.



Convert dialog box
The Convert dialog box converts the inserted object to another object type. You can convert the 
object to any other type of object listed in the Object Type list.

{button Related Topics,PI(`',`IDH_RT_Convert_db')}



To convert an inserted object 
To change objects embedded with ABC FlowCharter 4 
Object command (Edit menu) 
Edit menu 



Converts the selected object to the object type selected from the Object Type list.



Activates the selected object to the object type selected from the Object Type list.



Lists the available object types that you can convert the object to or activate the object as.



Describes what happens when you select the selected object type.



Shows the object as an icon rather than the object itself in your chart. 



Paste Special dialog box

The Paste Special dialog box may offer several formats for pasting the information from the 
Clipboard, depending on the type of information you are pasting and the program in which it was 
created.

Paste Option
The Paste option is selected by default. The following formats may be available if you use this 
option.

Format Function

<Name> Object Lets you double-click on the object in your chart to open the 
source file and change the object.

FlowCharter Native Pastes the object as a chart shape since it was created in the
program..

FlowCharter 7 Rich 
Text

Pastes the text from a chart shape, keeping the text styles 
such as bold, italic, and underline.

Rich Text Format (RTF) Pastes the text with the text styles. (Many word-processing 
programs provide RTF on the Clipboard.)

Unformatted Text Pastes the text without the text styles.
Metafile Pastes the information as a new FlowCharter shape. You can 

move and resize the shape, add text and a shape number, 
and connect it automatically to other chart shapes.

Device-Independent 
Bitmap

Brings the color information with the bitmap, so that the 
original colors are maintained in FlowCharter.

Bitmap Does not bring the color information with the bitmap; 
therefore, the bitmap colors may appear different in your 
program.

Paste Link Option
If you choose the Paste Link option, the object is linked to, not embedded in, your program. The 
Paste Link option in the dialog box is the same as the Paste Link command in the Edit menu.

Display as Icon Option
Click to check the Display as Icon option if you want the object to appear as an icon rather than as a
full graphic. This option is available only if you select the Object format in the    box.

Result Area
This area describes the result of the paste option combined with the highlighted format.

{button Related Topics,PI(`',`IDH_RT_Paste_Special_Dialog_Box')}



To paste OLE and non-OLE information in a chart
Paste Special command
Edit menu



ClipboardFormatAvailable Property



Links dialog box

The Links dialog box displays the name and location of the source file, the object type (such as Excel
Worksheet), and the update method (automatic or manual).
You can change the links to a chart using the Links dialog box. The dialog box contains several 
options for changing a link.

Break Link
Disconnects the link between the object that appears in FlowCharter and its source file. The object is
converted to a static picture in FlowCharter. The object can no longer be changed from FlowCharter 
or updated automatically.

{button Related Topics,PI(`',`IDH_RT_Links_Dialog_Box')}



To view the links to a chart
To change a link
Links command
Edit menu



Find command
The Find command lets you search for text in the chart.
You can search the chart (including shapes, lines, and master Items), in notes, in data fields, or in all
of these elements. You can look for the text as a whole word and search for the text exactly as you 
have entered its case.

{button Related Topics,PI(`',`IDH_RT_Find_Command')}



Replace command
Edit menu



Searches for text in the chart.



To find text
1 On the Edit menu, click Find.
2 Enter the text to find.
3 Select the options you want to use.

Note
The search will find text only in the chart. It cannot search objects inserted via OLE from other 

programs. To find text in inserted objects, open the object and search for the text within its program.
Tip

You can search the chart (including shapes, lines, and master items), in notes, in data fields, or
in all of these elements.

{button Related Topics,PI(`',`IDH_RT_Finding_text')}



To replace text in a chart
To open inserted objects
Find command
Edit menu



To open inserted objects
1 Select the object to open.
2 On the Edit menu, click the command at the bottom of the menu. (The name of the command 

varies based on the type of object that you are opening.)
3 On the Edit menu, click Open.

{button Related Topics,PI(`',`IDH_RT_Opening_inserted_objects')}



To change an inserted object 
To change objects embedded with ABC FlowCharter 4 
Object command (Edit menu) 
Edit menu



Find dialog box

The Find dialog box is used to find text in your chart.

Note
The search will find text only in the chart. It cannot search objects inserted via OLE from other 

programs. To find text in inserted objects, use the Edit, Object, Open command to open the object and 
search for the text within the program.

{button Related Topics,PI(`',`IDH_RT_Find_Dialog_Box')}



To find text
To replace text in a chart
Find command
Replace command



Finds this text only if it is a whole word. For example, if you entered “car” the search will not find 
“cars” or “carted.”



Searches for the text that exactly matches the case as you have entered it. For example, if you 
enter “car” the search will not find “Car.”



Specifies where to look for the text. Choose Shapes and Lines, Data fields, or Notes, or choose Entire
chart to look everywhere for the text.



Replace command
The Replace command lets you search and replace text in shapes, lines, notes, and entire chart.

Note
You cannot replace shape numbers or Master Item text.

{button Related Topics,PI(`',`IDH_RT_Replace_Command')}



To replace text in a chart
To find text
Find command
Edit menu



Searches and replaces text in the shapes, lines, notes, and entire chart.



Replace dialog box

The Replace dialog box allows you to search for and replace specific text in a chart.

Note
You cannot replace shape numbers or Master Item text.

{button Related Topics,PI(`',`IDH_RT_Replace_Dialog_Box')}



To replace text in a chart
Replace command
Edit menu



Lets you type the text you want to replace.



Lets you type the text that will replace the found text.



Replaces text only if the text is a whole word.



Searches for text that matches the case of the text.



Specifies where to look for the text. Choose Shapes and Lines, Data fields, or Notes, or choose Entire
chart to look everywhere for the text.



Leaves the text unchanged and search for the next occurrence.



Replaces the text and find the next occurrence.



Changes all occurrences without confirmation.



To replace text in a chart
1 In the Edit menu, click Replace.
2 Type the text to find in the Find box.
3 Type the text you want to use as replacement text in the Replace box.

Note
You cannot replace shape numbers or text in the Master Items.

{button Related Topics,PI(`',`IDH_RT_Replacing_text')}



To replace text in a chart
To find text
Replace command
Edit menu



Duplicate command
The Duplicate command lets you duplicate the selected objects.



Duplicates the selected objects.



To duplicate objects
1 Select the object or objects you want to duplicate.
2 On the Edit menu, click Duplicate.

Note
You can also press and hold the Ctrl key and drag the selected objects to duplicate them.

{button Related Topics,PI(`',`IDH_RT_Duplicating_Objects')}



Duplicate command
Edit menu



Converting Objects Embedded in ABC FlowCharter 4.0
{button Tell me

how . . .,PI(`',`IDH_HT_Converting_Embedded_Objects')}

If you have a file created in ABC FlowCharter 4.0 and you open it in FlowCharter 7, you cannot edit 
any OLE-embedded objects until you run a utility named Convert4.exe, located in Program Files\
Micrografx\FlowCharter.

{button Related Topics,PI(`',`IDH_RT_Converting_Embedded_Objects')}



To change objects embedded with ABC FlowCharter 4 



To change an inserted object 
Edit menu 
Object command (Edit menu) 
Object command (Insert menu) 



To change objects embedded with ABC FlowCharter 4
1 Open the Explorer.
2 Locate the directory in which FlowCharter is installed (C:\Program Files\Micrografx\FlowCharter, 

by default).
3 Select the Convert folder.
4 Double-click the file Convert4.exe.

{button Related Topics,PI(`',`IDH_RT_To_change_objects_embedded_with_ABCFlowcharter4')}



To change an inserted object 
Edit menu 
Object command (Edit menu) 
Object command (Insert menu) 



What is an Object?
{button Tell me how . . .,PI(`',`IDH_HT_What_is_an_object')}

An object is the main element of a FlowCharter chart. You create custom flowcharts by creating, 
arranging, and editing objects. You can manipulate objects in a variety of ways to enhance and help 
organize your chart. For example, objects can be colored, combined with other objects, duplicated, 
and resized.

An object in FlowCharter can be:
Shapes - A shape is an object with more than two connect points.
Lines - A line is an object with only two connect points, one at each end for connecting to 

shapes.
Freeform text - Freeform text is a text block that behaves like a shape, that is, it has more than 

two connect points.
You can create shapes using the:

Shape tool

Shape tool
Draw tool

Draw tool
You can create lines using the:

Connector Lines tool

Connector Lines tool
You can create text using the:

Text tool

Text tool
Note

All shapes and lines created by the Draw tool are shapes. To create a line that is not a shape, 
use the Connector Lines tool.

{button Related Topics,PI(`',`IDH_RT_What_is_an_Object')}



To place a connected shape
To replace shapes 

To draw a connector curved line 
To draw a connector direct line 
To draw a connector org chart line 
To draw a connector right angle line 

To create a text block 
To insert text 



Drawing Shapes 
Drawing Lines 
Drawn Lines vs Connector Lines 
Creating text blocks 



Working with Objects
{button Tell me how . . .,PI(`',`IDH_HT_Working_with_Objects')}

You can work with objects by:
Resizing shapes, texts, multiple objects
Repositioning lines
Reshaping shapes
Aligning single objects and multiple objects
Spacing objects
Moving objects and points
Changing the order of objects
Combining objects
Slicing objects
Joining objects
Outlining objects
Trimming objects
Intersecting objects
Fragmenting objects
Punching objects

{button Related Topics,PI(`',`IDH_RT_Working_with_Objects')}



Selecting objects
Understanding Channel Alignment
Options command (Tools menu) 



To bring an object to the front
To move one or more objects
To replace shapes

To reposition a line connected to a shape
To reshape a curve
To resize multiple objects at the same time

To resize a shapes or text block
To send an object to the back
To undo an action



Selecting Objects
{button OLE Automation,PI(`',`IDH_OA_Selected_Property')}

You can select any number of objects in your chart. You can select an object with the Selector tool 
from the Toolbox. Also, by clicking the right-mouse button, you can access the Selector tool from the
Switch Tool command. Click the right mouse button to toggle to the Selector tool from any other 
tool.    Click the right mouse button again to return to the original tool.

To select Do this

A single object Using the Selector tool, point to the
object, and click the left mouse 
button.

A group of adjacent 
objects

Using the Selector tool, press and 
hold the left mouse button, and 
drag the pointer around the 
objects.

A group of nonadjacent 
objects

Using the Selector tool, press Shift
and click each object.

All objects On the Edit menu, click Select All.
All shapes On the Edit menu, click Select, and 

then click Shapes.
All shapes of a particular 
type

On the Edit menu, click Select, click
Shapes, and then click the type of 
shape from the    box.

All lines On the Edit menu, click Select, and 
then click Lines.

All text On the Edit menu, click Select, and 
then click Text Blocks.

All OLE objects On the Edit menu, click Select, and 
then click OLE Objects.

Tips
To deselect one of a group of objects, press Shift and click the selected object.
Press Ctrl+A to select all objects.

{button Related Topics,PI(`',`IDH_RT_SELECTOBJECTS')}



Working with objects
Options command (Tools menu) 



Selected Property



To move one or more objects
1 Click the Selector tool.

Selector tool
2 Select the objects to move.
3 Point to one of the selected objects.
4 Press and hold the left mouse button, and drag the object to the position you want. A dotted 

rectangle surrounds the selected objects and follows the movement of the pointer.
5 Release the mouse button.

Tips
You can also move the object with the keyboard and the mouse, combined. First, select the 

object by clicking on it. Hold the left mouse button down and use the arrow keys to move the object. 
When the object is where you want it to be, release the mouse button.

When you move a shape connected to a line, the line moves with the shape.
You can snap shapes together while moving them. Just drag a shape in the chart to the edge of

another shape. The two shape edges snap together instantly. This feature is ideal for creating row and 
column headings for deployment flowcharts.

{button Related Topics,PI(`',`IDH_RT_Moving_Objects')}



Working with objects
Options command (Tools menu)



To resize a shape or text block
1 Click the Selector tool.

Selector tool
2 Select the shape or text block to resize. Control points appear around the selected object.
3 Point to a control point. The pointer changes to a two-headed arrow.
4 Press and hold the left mouse button, and drag the handle until the object is the size you want.
5 Release the mouse button.

Tips
Use the corner handles to change the width and height of the object proportionally; use the 

middle handles to change either the width or height.
Press and hold Shift while you drag a handle to disable proportional resizing.

{button Related Topics,PI(`',`IDH_RT_Resizing_Shapes_and_Text_Blocks')}



To resize multiple objects at the same time
Working with objects
Options command (Tools menu)



To reposition a line connected to a shape

{button Show me how . . .,PI(`',`IDH_AVI_torepositionlines0024')}
1 Click the Selector tool.

Selector tool
2 Select the line to reposition. Control points appear on the selected line.
3 Point to the control point on the endpoint connected to the shape.
4 Press and hold the left mouse button, and drag the handle to another connect point on the 

shape.
5 Release the mouse button.

Tips
When you connect lines to a shape, the line endpoints snap to the connect points on the 

shape. You can move the line endpoints to other connect points on the shape.
You can also reconnect the line to another shape by dragging the line endpoint to the shape.

{button Related Topics,PI(`',`IDH_RT_Repositioning_Lines_Connected_to_Shapes')}



{mci PLAY NOMENU NOPLAYBAR,CAP0024.AVI}



Working with objects
Options command (Tools menu)



To resize multiple objects at the same time
1 Click the Selector tool.

Selector tool
2 Press Shift and click each of the objects you want to resize. Release Shift.
3 Point to a control point on one of the selected objects. The pointer changes to a two-headed 

arrow.
4 Press and hold the left mouse button, and drag the control point until the objects are the sizes 

you want.
5 Release the mouse button.

{button Related Topics,PI(`',`IDH_RT_Resizing_Multiple_Objects')}



To resize a shapes or text block
To fit shapes to text
Working with objects
Options command (Tools menu) 



Reshaping Shapes
{button Tell me how . . .,PI(`',`IDH_HT_Reshaping_Shapes')}

The Reshape tool of the Edit tool lets you edit a shape by dragging its points. Reshaping is available 
for all objects.
A shape has just enough points to retain its original shape. If you remove even one point, the shape 
changes. A simple shape such as a line has only two points. More complicated shapes, such as a 
polygon, have more.
You can edit objects by:

Using the Edit tool on the Toolbox
Moving an object point on the selected object

The Edit tool provides elements that let you reshape objects by editing:
Shapes
Connect points
Text layout

{button Related Topics,PI(`',`IDH_RT_Reshaping_Shapes')}



To edit shapes with the Edit tool
To edit connect points with the Edit tool
To edit text layout with the Edit tool
To edit objects by moving object points



Understanding Channel Alignment 
Combining Objects 
Working with Objects 
Ordering Objects 



Reshape toolbar

Edit Points tool Lets you edit a shape using the 
shape's points.

Edit Curves tool Lets you edit a curve using the 
shape's points.

Add Point tool Lets you add points to the selected
shape.

Delete Points tool Lets you delete points from the 
selected shape.

{button Related Topics,PI(`',`IDH_RT_Reshape_toolbar')}



To edit shapes with the Edit tool
To edit connect points with the Edit tool 
To edit text layout with the Edit tool



Lets you edit a shape using the shape's points.



Lets you edit a curve using the shape's points.



Lets you add points to the selected shape.



Lets you delete points from the selected shape.



Edit Connect Points toolbar

Select tool Lets you select the connect point 
on the selected shape to edit.

Add Connect Point
tool

Lets you add connect points to the 
selected shape.

Delete Connect 
Point tool

Lets you deleted connect points 
from the selected shape.

Generate Default 
Connect Points 
tool

Lets you add new default connect 
points to the selected shape.

{button Related Topics,PI(`',`IDH_RT_Edit_Connect_points_toolbar')}



Lets you select the connect point on the selected shape to edit.



Lets you add connect points to the selected shape.



Lets you deleted connect points from the selected shape.



Lets you add new default connect points to the selected shape.



To edit shapes with the Edit tool
To edit connect points with the Edit tool 
To edit text layout with the Edit tool



Edit Text Area Layout toolbar

Select tool Lets you select the text area you 
want to edit in the selected shape.

Rotate Text tool Rotates the text in the selected 
shape.

Center Text tool Centers the text in the selected 
shape.

Move Text Below 
tool

Moves the text below the selected 
shape.

Left Align Label 
tool

Left aligns any labels, such as 
shape number or indicator, in the 
selected shape.

Center Align Label
tool

Centers any labels, such as shape 
number or indicator, in the 
selected shape.

Right Align Label 
tool

Right aligns any labels, such as 
shape number or indicator, in the 
selected shape.

{button Related Topics,PI(`',`IDH_RT_Edit_Text_Area_Layout_toolbar')}



Lets you select the text area you want to edit in the selected shape.



Rotates the text in the selected shape.



Centers the text in the selected shape.



Moves the text below the selected shape.



Left aligns any labels, such as shape number or indicator, in the selected shape.



Centers any labels, such as shape number or indicator, in the selected shape.



Right aligns any labels, such as shape number or indicator, in the selected shape.



To edit shapes with the Edit tool
To edit connect points with the Edit tool 
To edit text layout with the Edit tool



To edit shapes with the Edit tool
1 Click the Selector tool.

Selector tool
2 Select the object to reshape.
3 Click the Edit tool.

Edit tool
4 Click Shape.
5 Point to an edit point.
6 Press and hold the left mouse button, and drag the edit point.
7 Release the mouse button.
8 Repeat steps 5 through 7 until the shape is the shape you want.
9 Click Finished, or click the right mouse button and click Switch tool.

{button Related Topics,PI(`',`IDH_RT_Editing_shapes_with_Edit_tool')}



To edit connect points with the Edit tool
To edit text layout with the Edit tool
To edit objects by moving object points



To edit connect points with the Edit tool

{button Show me how . . .,PI(`',`IDH_AVI_toeditconnectpoints49')}
1 Click the Selector tool.

Selector tool
2 Select the object to reshape.
3 Click the Edit tool.

Edit tool
4 Click Connect Points.
5 Point to a connect point.
6 Press and hold the left mouse button, and drag the connect point. 
7 Release the mouse button.
8 Repeat steps 5 through 7 until the connect points are where you want them.
9 Click Finished, or click the right mouse button and click Switch tool.

{button Related Topics,PI(`',`IDH_RT_Editing_connect_point_with_Edit_tool')}
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To edit shapes with the Edit tool
To edit text layout with the Edit tool
To edit objects by moving object points



To edit text layout with the Edit tool
1 Click the Selector tool.

Selector tool
2 Select the object with the text block to edit.
3 Click the Edit tool.

4 Click Text Layout.
5 Click the editing button you want from the Edit Text Area Layout toolbar. You can click a tool to 
select text, rotate text, center text, move text below current position, and align labels (for example, 
shape number) withing the shape.
6 Click Finished, or click the right mouse button and click Switch tool.

{button Related Topics,PI(`',`IDH_RT_Editing_text_layout_with_Edit_tool')}



To edit shapes with the Edit tool
To edit connect points with the Edit tool
To edit objects by moving object points



To edit objects by moving object points
1 Click the Selector tool.

Selector tool
2 Select the object to reshape.
3 Point to a control point near the object.
4 Press and hold the left mouse button, and drag the control point until the object is the shape you 

want.
5 Release the mouse button.
6 Repeat steps 3 through 5 with other control points to continue reshaping the object.

Tip
When curved lines are selected, two control points appear in addition to the end point handles.

The control points let you reshape the curved line.

{button Related Topics,PI(`',`IDH_RT_Editing_objects_by_moving_object_points')}



To edit shapes with the Edit tool
To edit connect points with the Edit tool
To edit text layout with the Edit tool 



Understanding Channel Alignment
{button Tell me how . . .,PI(`',`IDH_HT_channel_and_touch')}

Invisible channels extend from each shape to help you align shapes. If you are dragging a shape and
it approaches the channel of another shape, it is attracted to the channel. You can then glide the 
shape along the channel of the reference shape, and the shape will snap to increments in the 
channel. It can snap to up to four increments away from the reference shape in any direction.

{button Related Topics,PI(`',`IDH_RT_Understanding_Channel_and_Touch_Alignment')}



To align a shape using channel alignment
To space objects
To align multiple objects



Aligning shapes to guidelines
Working with objects
Options command (Tools menu) 



To align a shape using channel alignment
1 On the Tools menu, click Options.
2 Click the Alignment tab.
3 Select Channel Alignment, if necessary, and click OK.
4 Click the Selector tool.

Selector tool
5 Point to a shape in the chart.
6 Press and hold the left mouse button, and drag the shape over another shape in the chart. Marks 

appear on the second shape as the pointer tip passes over it. This shape is now the reference 
shape.

7 Drag the shape out of the reference shape.
8 Release the mouse button when the shape is where you want it. The shape is aligned to the 

middle of the reference shape.

{button Related Topics,PI(`',`IDH_RT_Aligning_a_Shape_Using_Channel_and_Touch_Alignment')}



To space objects
To align multiple objects
Aligning shapes to guidelines
Understanding Channel Alignment

Working with objects
Options command (Tools menu)



To align multiple objects
1 Click the Selector tool.

Selector tool
2 Select the objects to space evenly and/or align. More than one object must be selected.
3 Click an alignment buttons on the Arrange toolbar.

Note
Only shapes and text blocks can be aligned with these buttons. Lines cannot be aligned.

{button Related Topics,PI(`',`IDH_RT_SPACEALIGNMULTI')}



To align a shape using channel alignment
To space objects
Aligning shapes to guidelines 

Working with objects
Options command (Tools menu) 



To space objects
1 On the Tools menu, click Options .
2 Click the Alignment tab.
3 Click the Shape Spacing check box, if necessary.
4 In the Horizontal and Vertical boxes, enter the spacing value.
5 Click OK.

Tip
Use the Apply button to make your changes and view the results without closing the dialog 

box.

{button Related Topics,PI(`',`IDH_RT_Spacing_Objects')}



To align a shape using channel alignment
To align objects
Aligning shapes to guidelines
Working with objects

Options command (Tools menu) 



Combining Objects
{button Tell me how . . .,PI(`',`IDH_HT_Combining_Objects')}

You can combine objects in a variety of ways:

Connecting Closed Objects
You can use the Connect Closed command to close open shapes or to connect and fill closed shapes.
You can use Connect Closed with one or more objects. On selected objects with open endpoints, the 
Connect Closed command draws a line between all endpoints, creating a completely closed shape. 
On selected objects with no endpoints (already closed shapes), the Connect Closed command 
connects the objects and the resulting object is filled with the fill color of the first drawn object (the 
one in back). Note that in this case no lines are drawn.

Connecting Open Objects
You can use the Connect Open command to combine two or more objects with open endpoints. The 
Connect Open command joins selected objects by drawing a line between the open endpoints, 
leaving the last side open.

Joining Objects
You can create a new shape by joining selected objects together.

Outlining Objects
You can create a new shape from the outline of the selected shapes.

Trimming Objects
You can create a new shape by trimming the bottom shape with the top one.

Intersecting Objects
You can create a new shape from the intersection of the selected objects.

Fragmenting Objects
You can createa series of new shapes by fragmenting the selected, overlapping shapes.

Punching Objects
If you use overlap objects, the Punch commands the front object cuts or "punches" a hole in the 
underlying object. 

Slicing Objects
Slicing an object severs the line of an object. Slicing opens a closed object and creates two 
endpoints where the slice occurs. You can cut one line at a time. You can also slice an object 
specifically at an anchor point. After you slice the object, the single anchor point becomes two 
anchor points that you can move separately.

Tip
The Disconnect command on the Arrange menu disconnects connected objects.

{button Related Topics,PI(`',`IDH_RT_Combining_Objects')}



Combine command 
Connect Closed command 
Connect Open command 
Disconnect command 
Join command 

Outline command 
Trim command 
Intersect command 
Fragment command 

Punch command 
Slice command 
Arrange menu 



To connect open objects 
To connect closed objects 
To disconnect objects 
To join objects 

To outline objects 
To trim objects 
To intersect objects 
To fragment objects 

To punch objects 
To slice objects 



To connect closed objects
1 Click the Selector tool.

Selector tool
2 Select the closed objects you want to connect.
3 On the Arrange menu, click Combine.
4 Click Connect Closed.

Tip
You can also use the Connect Closed button on the Arrange+ toolbar.

Connect Closed button

{button Related Topics,PI(`',`IDH_RT_ConnectClosedP')}



Combining Objects 
To connect open objects 
To disconnect objects 
Combine command 
Arrange menu 



To connect open objects
1 Click the Selector tool.

Selector tool
2 Select the open objects you want to connect.
3 On the Arrange menu, click Combine, and click Connect Open

Tip
You can also use the Connect Open button on the Arrange+ toolbar.

Connect Open button

{button Related Topics,PI(`',`IDH_RT_connectingopenP')}



Combining Objects 
Combine command 
Arrange menu 



To disconnect objects
1 Click the Selector tool.

Selector tool
2 Select the object you want to disconnect.
3 On the Arrange menu, click Combine, and click Disconnect

Tip
You can also use the Disconnect button on the Arrange+ toolbar.

Disconnect button

{button Related Topics,PI(`',`IDH_RT_disconnectingobjectsP')}



Combining Objects 
Combine command 
Arrange menu 



To join objects
1 Click the Selector tool.

Selector tool
2 Select the objects you want to join.
3 On the Arrange menu, click Combine, and click Join

Tip
You can also use theJoin button on the Arrange+ toolbar.

Join button

{button Related Topics,PI(`',`IDH_RT_joiningobjectsP')}



Combining Objects 
Combine command 
Arrange menu 



To outline objects
1 Click the Selector tool.

Selector tool
2 Select the objects you want to use to form your outline.
3 On the Arrange menu, click Combine, and click Outline

Tip
You can also use the Outline button on the Arrange+ toolbar.

Outline button

{button Related Topics,PI(`',`IDH_RT_OutliningObjectsP')}



Combining Objects 
Combine command 
Arrange menu 



To trim objects
1 Click the Selector tool.

Selector tool
2 Select the objects you want to trim.
3 On the Arrange menu, click Combine, and click Trim

Tip
You can also use the Trim button on the Arrange+ toolbar.

Trim button

{button Related Topics,PI(`',`IDH_RT_trimmingobjectsP')}



Combining Objects 
Combine command 
Arrange menu 



To intersect objects
1 Click the Selector tool.

Selector tool
2 Select the objects you want to intersect.
3 On the Arrange menu, click Combine, and click Intersect.

Tip
You can also use the Intersect button on the Arrange+ toolbar.

Intersect button

{button Related Topics,PI(`',`IDH_RT_intersectingobjectsP')}



Combining Objects 
Combine command 
Arrange menu 



To fragment objects
1 Click the Selector tool.

Selector tool
2 Select the overlapping objects you want to fragment.
3 On the Arrange menu, click Combine, and click Fragment.

Tip
You can also use the Fragment button on the Arrange+ toolbar.

Fragment button

{button Related Topics,PI(`',`IDH_RT_fragmentingobjectsP')}



Combining Objects 
Combine command 
Arrange menu 



To punch objects
1 Click the Selector tool.

Selector tool
2 Select the objects you want to punch.
3 On the Arrange menu, click Combine, and click Punch.

Tip
You can also use the Punch button on the Arrange+ toolbar.

Punch button

{button Related Topics,PI(`',`IDH_RT_PunchingObjectsP')}



Combining Objects 
Combine command 
Arrange menu 



To slice objects
1 Click the Selector tool.

Selector tool
2 Select the open and closed object you want to use for the slice process.
3 On the Arrange menu, click Combine, and click Slice.

Note
The Slice command is used only when you are using an open object to slice through a closed 

object. The Slice command is not available if you select two open objects.
Tip

You can also use the Slice button on the Arrange+ toolbar.

Slice button

{button Related Topics,PI(`',`IDH_RT_SlicingObjectsP')}



Combining Objects 
Combine command 
Arrange menu 



Ordering Objects

Every object drawn in FlowCharter is in an inherent order. This is the order in which objects are 
stored and the order in which these objects are placed on the screen and printer. Typically this is 
apparent only when objects overlap other objects. In these cases the order determines which 
objects are shown or printed over the others.
By default, the order of your objects is the same as the order in which you created them: newer 
objects are placed on top of older objects. However, you can change this order using the Order 
commands on the Arrange menu or the Arrange toolbar. For example, the Bring to Front command 
places the selected object at the top of the stack so that it covers all other objects. Similarly, Bring 
Forward causes the selected object to shift one place in the object order, exchanging it with the 
object that was directly above it. If two objects happen to overlap, you can see the difference 
immediately.

{button Related Topics,PI(`',`IDH_RT_Ordering_Objects')}



Bring to Front command 
Send to Back command 
Bring Forward command 
Send Backward command 



Using Data Fields
{button Tell me how . . .,PI(`',`IDH_HT_Overview_data_fields')}

After you create a chart, you will want to provide a description for each shape. This description 
consists of characteristics referred to as fields. The database can contain up to 250 data fields. For 
each field, you must define the following characteristics:

Field name
Field type
Field format
Accumulation method (formula)
Hidden option

Any changes you make to the field descriptions are applied to all fields on your chart. A field 
database can also be stored on files that you save as templates, so you can use them again in other
charts.
When creating a link from an existing chart to a new chart, the existing chart’s field table (its 
structure) is copied to the new chart. This feature means that you do not have to recreate the field 
descriptions in each new chart.
You can enter data in your chart in one of the following ways:

Field Viewer command - used to manually enter data for individual, active shapes in your chart
Import Data command - used to import data from an Excel file, another database format, or 

text file
Worksheet command - used to manually enter or change data in a worksheet associated with 

your chart

{button Related Topics,PI(`',`IDH_RT_Overview_Data_Fields')}



Data Field command
Using Data Fields - example
Linking Data Fields
Field Name field 
Field Type field

Field Format field
Accumulation Method field
Hidden Field check box
Report command
Field Viewer command



To set up a data field
To enter data in the Field Viewer 
To enter data in a worksheet 
To display shape data

To edit data on charts 
To change a field
To delete a field
To format fields
To rearrange the order of fields



Using Data Fields - Examples
{button Tell me how . . .,PI(`',`IDH_HT_Using_Data_Fields')}

A flowchart becomes a powerful analysis tool when data is added to the chart. In general, data fields
provide visual explanation of your flowchart, that is, they can show what each object is for. The 
power is better evidenced in this program’s ability to accumulate data for results purposes. 
Examples of using data fields for the main flowcharts are:

Accumulate data in a chart.
Subtotal data up through chart hierarchies
Print data in reports
Pass data to spreadsheets and databases
Graph data

In general, data fields provide visual explanation of your flowchart. They can show what each object 
is for, and even accumulate data for results purposes. Examples of using data fields for the some of 
the major flowcharts are:

Organization charts
You can use data fields to display employee/officer name , employee/officer title, and company 
functional area.

Deployment charts
You can use data fields to label the connector lines to delineate the flow of information and 
materials. You can use data fields to label the different organizational units that are receiving the 
information and materials. By applying a duration data field, you can identify how time is being used
in a process.

Analysis charts
The data fields in the following analysis chart provide the chart user with enough information to 
quickly perform their own analysis.

As demonstrated in this chart, the data fields that can be used are:
Cost
Duration
Delay

Network charts
The data fields in the following network chart depict the connections among hardware and software 
in a system and show how the components of the system interact.



Some of the data fields you can use in a network chart are:
Network names
Equipment type
Equipment usage
Connection type

When using data fields, you will want to plan which fields to display and how you want them 
displayed. You can then enter the data into the fields manually or by importing fields from an 
existing database.

Note
You can use up to a maximum of 250 data fields. 

{button Related Topics,PI(`',`IDH_RT_Using_Data_Fields')}



To set up a data field
To enter data in the Field Viewer 
To enter data in a worksheet 
To import all data from Excel 

To import selected data from Excel 
To import data from a database 
To import data from a text file 



Using Data Fields 
Importing Data into your Chart 
Using Accumulated Data in a Chart 



Using Accumulated Data in a Chart
{button Tell me how . . .,PI(`',`IDH_HT_Using_Accumulated_Data')}

Accumulating data allows you to:
Accumulate data in a chart.
Subtotal data up through chart hierarchies
Print data in reports
Pass data to spreadsheets and databases
Graph data

An accumulation method is a way to combine, or accumulate, data of some types. As you run 
through the chart, data accumulates along the path you take. For example, you can combine the 
cost of a process.    The method you use to combine the data is to add it or "Sum" it.

The Legend shows the accumulated data for the chart: the sum of the data for the Cost field. When 
displayed in the Legend, the accumulation method’s result reflects all the objects (lines and shapes)
in the chart.
The Accumulation Method field indicates to a linked shape how the data for this field should be 
combined. For instance, costs should be summed and times should be averaged. The accumulation 
method is used when you are combining data in a linked shape.
Data is accumulated in your chart in the following ways:

Within an unlinked chart
Across linked charts
Within a Living FlowChart

Tip
The Update Data Fields button in the Data toolbar lets you automatically update linked field 

data. If there are no linked fields in your chart, this command is not available.
If a chart has linked data fields, the data fields are automatically updated when you open the 

chart.
Not all accumulation methods are available for all data field types. For example, a text field 

cannot have mathematical accumulation methods; it can have only No Accumulation, Object Count, 
and Filled Count. A Date field cannot have a Sum or a Range.

When displayed in an entity of a Living FlowChart, this number reflects the lines and shapes in 
the entity’s path.

If you are having a problem with a chart that uses accumulated data, click Worksheet on the 
Tools menu to view the data in each entity.

{button Related Topics,PI(`',`IDH_RT_Using_Accumulated_Data')}



To set up a data field 
To enter data in the Field Viewer 
To enter data in a worksheet 
To format fields 

To import all data from Excel 
To import selected data from Excel 
To import data from a database 
To import data from a text file 



Using Data Fields 
Linking Data Fields 
Importing Data into your Chart 
Accumulation Method field 

Accumulation Methods 
Understanding Data Accumulation 
Using Data in a Living FlowChart 



Linking Data Fields
{button Tell me how . . .,PI(`',`IDH_HT_Linking_Field_Tables')}

When a shape in a local chart is linked to another chart, any additional fields in the remote chart’s 
field table entries are added to the local chart’s field table. You are not required to add fields to the 
chart just to see the combined data.
When data is updated later, only the data values come across, not the current field type. This lets 
you modify the displayed field format in the local chart, which may be different from the format in 
the remote chart.
Fields that have been created but contain no data (null data) are not displayed. This feature lets you
link to several charts and show only the appropriate data for each linked shape.

{button Related Topics,PI(`',`IDH_RT_Linking_Field_Tables')}



To link a shape to another chart 
To updata field data



Using Data Fields
Data Field command



Data Field command
You can associate and attach data fields to shapes. Before you can attach fields to a shape, you 
must set up the fields. The field descriptions includes field names, field type, field format, an 
accumulation method (formula), and an option to show or hide the field descriptions in the chart. 
The field descriptions apply to all shapes in a chart. Therefore, any changes you make to the field 
description table will be applied to all the shapes that have fields attached. The Setup Fields 
command is in the Insert menu.

{button Related Topics,PI(`',`IDH_RT_Setup_Command')}



To set up a data field
To change a field
To delete a field
To format fields

To rearrange the order of fields
Using Data Fields
Insert menu



To set up a data field 
1 On the Insert menu, click Data Field.
2 Type a name in the Field Name box, such as Cost or Cycle Time.
3 Click the down arrow beside the Field Type box.
4 Scroll through the field types, and highlight one to select it.
5 Click the down arrow beside the Accumulation Method box.
6 Scroll through the methods and highlight one to select it.
7 Click the down arrow beside the Field Format box.
8 Scroll through the formats and highlight one to select it.
9 Click to check the Hidden Field option to hide the field in the chart.
10 Click Add. 
11 Click OK.

{button 
Related 
Topics,PI(`',`I
DH_RT_Addin
g_Fields')}

{button OLE 
Automation,
PI(`',`IDH_O
A_Add_Meth
od_FieldTem
plates_Colle
ction')}

Field Name field 
Field Type field 
Field Format field 
Accumulation Method field 

Understanding Data Accumulation 
Hidden Field check box 
Using Data Fields
Data Field command



Add_Method_FieldTemplates_Collection



To format fields
1 With a chart active, click the right mouse button.
2 Click Chart Properties.
3 Click the Data Fields tab.
4 Choose a new placement option, font, point size, style, and color for the field.

or
Click Hide Field Names to hide the field names on the chart.

5 Click OK.

{button 
Related 
Topics,PI(`',`I
DH_RT_Form
atting_Fields'
)}

{button OLE 
Automation,
PI(`',`IDH_O
A_FieldFont_
Property')}

To set up a data field
To change a field
To delete a field
To rearrange the order of fields

Using Data Fields
Data Field command



FieldFont property



To rearrange the order of the fields
1 On the Insert menu, click Data Field. 
2 Point to the field name in the Field box at the left that you want to move.
3 Press and hold the left mouse button, and drag the field name where you want it.

{button Related Topics,PI(`',`IDH_RT_Rearranging_Fields')}



To set up a data field
To change a field
To delete a field
To format fields

Using Data Fields
Data Field command



To change a field
1 On the Insert menu, click Data Field.
2 Click a field in the Field box at the left.
3 You can change the field name, choose a new field type, field format, or accumulation method, or

change the Hidden Field option.
4 Click Change.
5 Click OK.

{button Related Topics,PI(`',`IDH_RT_Changing_Fields')}



To set up a data field
To delete a field
To format fields
To rearrange the order of fields

Using Data Fields
Data Field command



To delete a field
1 On the Insert menu, click Data Field.
2 Select a field in the Field box at the left.
3 Click Delete.
4 Click OK.

{button 
Related 
Topics,PI(`',`I
DH_RT_Delet
ing_Fields')}

{button OLE 
Automation,
PI(`',`IDH_O
A_DeleteFiel
d_Method')}

To set up a data field
To change a field
To format fields
To rearrange the order of fields

Using Data Fields
Data Field command



DeleteField Method



Setup Fields dialog box

This dialog box lets you set up data fields for your chart.

{button Related Topics,PI(`',`IDH_RT_Setup_Fields_Dialog_Box')}



Setting Up Fields
Using Data Fields
Data Field command



Lists the currently defined fields for this chart. The order of the fields in this list shows the order in 
which the fields are displayed in the chart. Click on a field name to select it for changing or deletion.
To change the order of the fields in the list, drag the selection to its new position.



Adds the field to the chart.



Makes the changes you made to the field.



Deletes the selected field from the chart.



Field Name field
{button OLE

Automation,PI(`',`IDH_OA_Name_Property_FieldTemplate_Object')}

The field name displays in reports and on charts, if the Hidden Field check box is clear.    It also is 
used to match fields when updating linked data.

{button Related Topics,PI(`',`IDH_RT_Field_Name_Field')}



To set up a data field
To change a field
To delete a field
To format fields

To rearrange the order of fields
Using Data Fields
Data Field command



Name Property FieldTemplate Object



Displays in reports and on charts, if the Hidden Field check box is clear.    It also is used to match 
fields when updating linked data.    It is user-defined name of up to 32 characters. 



Field Type field
{button OLE

Automation,PI(`',`IDH_OA_Type_Property_FieldTemplate_Object')}

The Field Type field controls the type of data you can enter into a field. The following table lists the 
available fields types with the accumulation methods for each.

Field Type Accumulation 
Methods

Text No Accumulation
Object Count
Filled Count

Duration No Accumulation
Sum
Mean
Median
Min (minimum)
Max (maximum)
Range
Object Count
Filled Count

Date No Accumulation
Mean
Median
Min (minimum)
Max (maximum)
Range
Object Count
Filled Count

Currency No Accumulation
Sum
Mean
Median
Min (minimum)
Max (maximum)
Range
Object Count
Filled Count

Percent No Accumulation
Sum
Mean
Median
Min (minimum)
Max (maximum)
Range
Object Count
Filled Count

Number No Accumulation
Sum



Mean
Median
Min (minimum)
Max (maximum)
Range
Object Count
Filled Count

{button Related Topics,PI(`',`IDH_RT_Field_Type_Field')}



To set up a data field
To change a field
To delete a field
To format fields

To rearrange the order of fields
Accumulation Method field 
Using Data Fields
Data Field command



Displays data in the field and validates that the correct type of data is being entered. Used to select 
the set of field formats that are appropriate for the field data.
You can select several field types, including those for text, duration (time), date, currency, 
percentage, and general numbers. The field type adjusts automatically for international settings.



Field Format field
{button OLE Automation,PI(`',`IDH_OA_Type_Property_FieldTemplate_Object')}

The Field Format field controls the way data is displayed in the field. The following table lists the 
available fields types with the available field formats for each.

Field 
Type

Field Formats Entry Field Display

Text Text Preside
nt

President

Duration #w.
#weeks
#d.
#days
#h.
#hrs.
#hours
#m.
#mins
#minutes
#s.
#secs.
#seconds
#TMU*
h:m
m:s
h:m:s

2
2
2
2
2
2
2
2
2
2
2
2
2
2
2.2
2:2
2:2:2

2 w.
2 weeks
2 d.
2 days
2 h.
2 hrs.
2 hours
2 m.
2 mins
2 minutes
2 s.
2 secs.
2 seconds
2 TMU
2:02
2:02
2:02:02

*Time Measurement Unit - is one 100,000-th of an 
hour.    It is used by industries as the atomic unit of 
time tasks are measured by.

Date m/d/yy
mm-d-yy
MMM dd, yyyy
mmm-yy
MMMM yyyy

2/2/96
2/2/96
2/2/96
2/2/96
2/2/96

2/2/96
Feb-2-96
February 02, 1996
Feb-96
February 1996

Currenc
y

$###0.00;
($###0.00)*
$#,##0.00;
($#,##0.00)*
$###0;($###0)*
$#,##0;($#,##0)*

200
2000
200
2000

$200.00
$2,000.00
$200
$2,000

*A currency amount in parenthese indicates a 
negative amount. You enter the amount as a 
negative. The program displays it within 
parentheses without the negative sign.

Percent ##%
#0.00%

20
20

20%
20.00%

Number ###0
###0.00
###0.0000

2000
2000
2000

2000
2000.00
2000.0000



#,##0
#,##0.00
#,##0.000

2000
2000
2000

2,000
2,000.00
2,000.0000

{button Related Topics,PI(`',`IDH_RT_Field_Format_Field')}



To set up a data field
To change a field
To delete a field
To format fields

To rearrange the order of fields
Using Data Fields
Data Field command



Type Property FieldTemplate Object



Defines the way that the data is to be shown in the field. Validates that the correct type of data is 
being entered.
You can select field formats that are appropriate for its field types. For example, the percentage field
type has ##% and #0.00% as its formats. The first format displays percentages as integers only; 
the second format shows fractional percentages rounded to hundredths (1.34%, 18.90%). The field 
formats adjust automatically for international settings.



Accumulation Method field
{button OLE Automation,PI(`',`IDH_OA_AccumulationMethod_Property')}

{button Tell me how . . .,PI(`',`IDH_HT_Accumulation_Method_field')}

The Accumulation Method field indicates to a linked shape how the data for this field should be 
combined. For instance, costs should be summed and times should be averaged. The accumulation 
method is used when you are combining data in a chart with linked shapes. Accumulation methods 
are also used in Living FlowCharts.
Method Function
No 
accumulation

No value is accumulated for 
the linked shape.

Sum Sum of the data in the shapes.
Mean Average of the data in the 

shapes.
Median Middle value of the range of 

the data in the shapes.
Min Minimum value of the data in 

the shapes.
Max Maximum value of the data in 

the shapes.
Range Difference between the highest

value and the lowest value in 
the data.

Object Count Number of objects that can 
have a field.

Filled Count Number of objects that have a 
value for this particular field.

Tip
Not all accumulation methods are available for all data field types. For example, a text field 

cannot have mathematical accumulation methods; it can have only No Accumulation, Object Count, 
and Filled Count. A Date field cannot have a Sum or a Range.

When displayed in the Legend, the accumulation method’s result reflects all the objects (lines 
and shapes) in the chart.

When displayed in an entity of a Living FlowChart, this number reflects the lines and shapes in 
the entity’s path.

{button Related Topics,PI(`',`IDH_RT_Accumulation_Method_Field')}



To set up a data field
To change a field
To delete a field
To format fields
To rearrange the order of fields



Using Accumulated Data in a Chart 
Using Data Fields
Data Field command



AccumulationMethod Property



Indicates to a linked shape how the data for this field should be combined. For instance, costs 
should be summed and times should be averaged.



Hidden Field check box
{button OLE Automation,PI(`',`IDH_OA_Hidden_Property')}

The Hidden Field check box determines whether the data field is hidden or displayed on the chart..

{button Related Topics,PI(`',`IDH_RT_Hidden_Field_Check_Box')}



To set up a data field
To change a field
To delete a field
To format fields

To rearrange the order of fields
Using Data Fields
Data Field command



Hidden Property



Determines whether this field is displayed or not displayed in the chart.



Chart dialog box - Data Fields tab
{button OLE Automation,PI(`',`IDH_OA_Data_Field_tab')}

The Data Fields tab of the Chart Properties dialog box contains the following:
Placement Select the position of the data fields in relation to

the shapes to which they are attached.
Hide Field 
Names

Click to hide the field names in the chart. When 
the check box is clear, the fields are not hidden.

Hours Per 
Day 

Enter the number of hours in a workday. The 
value can range from 1 to 24. This value is used 
when data are converted from hours to days.    
For example, the value is used if you change the 
field’s format from hours to days or you link to a 
chart that displays data fields in a different 
format.

Days Per 
Week

Enter the number of days in a workweek.    The 
value can range from 1 to 7.    This value is used 
when a field is converted from days to weeks. For
example, the value is used if you change the 
field’s format from days to weeks or you link to a 
chart that displays data in a different format.

Font Area
Font Click on the down arrow to drop down a menu of 

fonts and click on the font you want for the text 
of the data.

Font Size Click on the down arrow to drop down a menu of 
type sizes and click on the size you want for the 
text of the data.

Bold, Italic, 
and 
Underline 
check boxes

Click the styles you want, Bold, Italic, or 
Underline, for the text of the data.

Color Click the down arrow to drop down a palette of 
colors and click the color you want for the text of 
the data.

Opaque Click to make the fields’ background opaque. 
This option is especially useful when the fields 
are drawn on lines.

{button Related Topics,PI(`',`IDH_RT_Field_Preferences_Command')}



To set up a data field
Using Data Fields
Data Field command
Insert menu



FieldPlacement Property
FieldNamesHidden Property
FieldsHoursPerDay Property
FieldsDaysPerWeek Property
FieldsOpaque Property



Report command
The Report command in the Tools menu lets you output the data in a chart’s shapes. You can 
generate three types of reports from the entered field data: Input, Output, and Metrics.
When you choose the Report command, the Report submenu opens and displays the following 
commands:

Input
Output
Metric

You can either print the data, copy it to a clipboard so that you can paste it into another program, or
send the data to a file.

{button Related Topics,PI(`',`IDH_RT_Report_Command')}



Input command
Metrics command
Output command
Insert menu



Lets you create a report of the data in a chart’s shapes. You can either print the data, copy it to a 
clipboard so that you can paste it into another program, or send the data to a file.



Input command
The Input command in the Report submenu generates a report that lists the chart’s shapes, each 
followed by the lines coming into them. This type of report is commonly used to find redundant 
activities.
You can print a data report, copy it to the clipboard, or save it in a file.

{button Related Topics,PI(`',`IDH_RT_Input_Command')}



Reporting field data
Report command



Lists the chart’s shapes, each followed by the lines coming into them. This type of report is 
commonly used to find redundant activities.



Reporting Field Data

You can send the data to a printed report, to a file, or to the Windows Clipboard. 
For printed reports, the selected shape information is printed in a tabbed-column format, with 
column headings based on field names and column results based on the accumulation method. 
For file and Clipboard output, the selected shape information will be in a tab-delimited format, 
suitable for import into spreadsheets and databases, excluding result information.
There are three types of reports: Input, Output and Metrics. The Input report lists shapes, each 
followed by the lines coming into them. The Output report lists shapes, each followed by the lines 
leaving them. The Metrics report lists data for shapes, then for lines.

{button Related Topics,PI(`',`IDH_RT_Reporting_Field_Data')}



To copy a report to the Clipboard
To print data
To save data reports to a file

Input command
Metrics command
Output command
Report command



To print data
1 On the Tools menu, click Report.
2 Click the type of report you want: Input, Output, or Metrics. 
3 Click the Output to Printer option to select it.
4 Click Options.
5 Select a sort method, choose the page orientation, and choose the items to be included in the 

report.
6 Click OK to close the dialog box. 
7 Click OK. 
8 Click OK. 

{button Related Topics,PI(`',`IDH_RT_Printing_Reports')}



To copy a report to the Clipboard
To save a report to a file

Input command
Metrics command
Output command
Report command



To save a report to a file
1 On the Tools menu, click Report.
2 Click the type of report you want: Input, Output, or Metrics. 
3 Click the Output to File option to select it.
4 Click Options. 
5 Select a sort method, choose the page orientation, and choose the items to be included in the 

report.
6 Click OK to close the dialog box.
7 Click OK. 
8 Type a name in the File Name box. (The tab-delimited file type is selected by default.)
9 Click OK. 

{button Related Topics,PI(`',`IDH_RT_Saving_reports')}



To copy a report to the Clipboard
To print data

Input command
Output command
Metrics command
Report command



To copy a report to the Clipboard
1 On the Tools menu, click Report.
2 Click the type of report you want: Input, Output, or Metrics. 
3 Click the Copy to Clipboard option to select it.
4 Click Options. 
5 Select a sort method, and choose the items to be included in the report.
6 Click OK to close the dialog box.
7 Click OK. A dialog box message states that the field report has been copied to the Clipboard.
8 Click OK.

Note
Data from data fields can be copied to the Clipboard and pasted in another chart for use as 

text only, not as data fields.

{button Related Topics,PI(`',`IDH_RT_Copying_reports')}



To print data
To save a report to a file

Input command
Metrics command
Output command
Report command



Lists the chart’s shapes, each followed by the lines coming into them.



Lists the chart’s shapes, each followed by the lines leaving them.



Lists the chart’s shapes and other elements, followed by all the lines for the chart.



Destination dialog box

This dialog box lets you send the report data to the printer, to a file, or to the Clipboard. Click on the
destination where you want to send the data.

{button Related Topics,PI(`',`IDH_RT_Field_Report_Dialog_Box')}



Reporting field data
Input command
Output command
Metrics command

Report command



Prints a report. Prints selected shape information in a tabbed-column format, with column headings 
based on field names and column results based on the accumulation method.



Saves the report in a file. The selected shape information is in a tab-delimited format, suitable for 
import into spreadsheets and databases, excluding result information.



Puts a report on the Windows Clipboard. The selected shape information is in a tab-delimited format,
suitable for pasting into spreadsheets and databases, excluding result information.



Sets up report options. You can select information to include in the report, specify how the 
information is sorted, and specify how the page will be oriented.



Report Options dialog box

This dialog box lets you select the report settings, including the sort method, the data to include in 
the report, and how you want the report oriented on the page, landscape or portrait.
Each report type, Input, Output, and Metrics, has its own set of options. When you change the 
settings for the Output report, the settings for the Input and Metrics reports do not change.

{button Related Topics,PI(`',`IDH_RT_Field_Report_Dialog_Box')}



Includes the shape number in the report.



Includes the shape name in the report.



Includes the shape text in the report.



Includes the data fields in the report.



Includes the subtotals of the data fields in the report in addition to grand totals according to the 
Accumulation Method selected.



Includes the hidden fields in the report.



Sorts by the name of the shape.



Sorts by the number of the shape.



Sorts by the text of the shape.



Sorts by the contents of the first data field of the shape.



Prints the page oriented so that the page is taller than it is wide.



Prints the page lengthwise (so that the page is wider than it is tall).



Save Field Report dialog box

This dialog box lets you save a data report as a file, so you can print the file at a later date, send it 
via electronic mail, or use it some other way.

{button Related Topics,PI(`',`IDH_RT_Field_Report_Dialog_Box')}



Output command
The Output command in the Report submenu generates a report that lists the chart’s shapes, each 
followed by the lines leaving them. This report is commonly used to find unused activities.

{button Related Topics,PI(`',`IDH_RT_Output_Command')}



Reporting field data
Report command



Lists the chart’s shapes, each followed by the lines leaving them. This report is commonly used to 
find unused activities. You can either print the data, copy it to a clipboard so that you can paste it 
into another program, or send the data to a file.



Metrics command
The Metrics command in the Report submenu generates a report that lists the chart’s shapes and 
other elements, followed by all the lines for the chart. This report is commonly used to find total 
cycle times.

{button Related Topics,PI(`',`IDH_RT_Metrics_Command')}



Reporting field data
Report command



Lists the chart’s shapes and other elements, followed by all the lines for the chart. This report is 
commonly used to find total cycle times. You can either print the data, copy it to a clipboard so that 
you can paste it into another program, or send the data to a file.



To update field data
On the Data toolbar menu, click the Update Data Fields button.

Update Data Fields button
Note

You will also be asked whether to update data when a linked chart that requires updating is 
opened.

If a chart has linked data fields, the data fields are automatically updated when you open the 
chart.

{button Related Topics,PI(`',`IDH_RT_Updating_Data_Fields')}



Linking Data Fields
Tools menu



Field Viewer command
The Field Viewer command in the View menu opens the Field Viewer dialog box. You enter data for 
the selected shape into the Field Viewer dialog box.

{button Related Topics,PI(`',`IDH_RT_Show_Viewer')}



To hide the Field Viewer
To show the Field Viewer
Field Viewer button
View menu



Opens the Field Viewer dialog box, where you can enter data into the selected shape’s fields.



To show the Field Viewer
1 Select a shape in the chart.
2 On the View menu, click Field Viewer.

or

Click the Field Viewer button on the Data toolbar.

Tips
To define the position of the data, with a chart active, click the right mouse button, then click 

the Data Fields tab.
Click on one shape to view its data. If no shape is selected or if more than one shape is 

selected, the Field Viewer displays no data.
You do not need to close the viewer. You can click on shape after shape to review data for each 

shape.

{button 
Related 
Topics,PI(`',`I
DH_RT_Show
ing_the_Field
_Viewer')}

{button OLE 
Automation,
PI(`',`IDH_O
A_FieldViewe
rVisible_Prop
erty')}

To hide the Field Viewer
To set up a data field
Data toolbar
Field Viewer command



FieldViewerVisible Property



To hide the Field Viewer
On the View menu, click Field Viewer.
or
 

 Click the Field Viewer button on the Data toolbar.

{button Related Topics,PI(`',`IDH_RT_Hiding_the_Field_Viewer')}



To show the Field Viewer
Data toolbar
Field Viewer command



Field Viewer dialog box

This dialog box lets you enter data in the fields. It displays the selected shape's number in the title 
bar. It also displays the field names with edit boxes for entering data. The current field's type is 
displayed below the last field’s edit box. The field type changes when you move from edit box to 
edit box, to reflect the field type of the current field. In this example, the cursor is in the Birthdate 
field. The Field Type reflects its field type, Date.

Edit Boxes {button OLE Automation,PI(`',`IDH_OA_Value_Property')}
When your cursor is in an edit box, you can enter data into it.

Note
Hidden field names are followed by an asterisk (*). If the chart is protected by a password, no 

hidden fields will be shown in the Viewer.
Tip

You can press Tab to move from field to field.

{button Related Topics,PI(`',`IDH_RT_Field_Viewer_Dialog_Box')}



To show the Field Viewer
To hide the Field Viewer
To enter data in the Field Viewer 
Field Viewer command
Data toolbar



Value Property



To enter data in the Field Viewer
1 Click a shape in the chart.
2 On the View menu, click Field Viewer.
3 Enter the data for each field. (The format that each field requires is shown at the bottom of the 

Field Viewer.)
4 Press Enter to save the data and move to the next field.
5 To enter data for another shape, click another shape on the chart. (You need not close the Field 

Viewer dialog box.) Repeat this procedure from step 3 until you have entered data for all the 
fields.

6 When you are done, click the Close button to close the dialog box.

Tips
You can open the Field Viewer by double-clicking on an existing data field of a shape. When the

Field Viewer opens, the data for the shape will show in the Field Viewer. If the Field Viewer is already 
open, click on an existing data field area to load the data into the Field Viewer.

You can leave fields blank. Blank fields will not show on the chart. Additional fields move up to 
properly space the data on the chart.

{button Related Topics,PI(`',`IDH_RT_To_enter_data')}



To show the Field Viewer
To hide the Field Viewer
To open the Setup Fields dialog box from the Field Viewer dialog box
Field Viewer command
Data toolbar



To open the Setup Fields dialog box from the Field Viewer dialog box
Click the box for the field you want to see in the Setup Fields dialog box, and click the Setup 

button.
or
Double-click the area to the left of the field you want to see in the Setup Fields dialog box.

{button Related Topics,PI(`',`IDH_RT_Opening_Setup_Fields_dialog_from_Viewer')}



To set up a data field
To enter data in the Field Viewer
Field Viewer command



To display shape data
1 Select a shape in the chart.
2 On the View menu, click Field Viewer to open the Field Viewer dialog box. The Field Viewer dialog 

box opens, displaying the field names and any data that has already been entered.

Tips
You also can click the Field Viewer button in the Data toolbar to open the Field Viewer dialog 

box. 

Field Viewer button
You also can enter data into lines, bitmaps, and OLE objects.

{button Related Topics,PI(`',`IDH_RT_Entering_Field_Data')}



To enter data in the Field Viewer
To open the Setup Fields dialog box from the Field Viewer dialog box
Field Viewer command



Opens the Field Viewer window. The Field Viewer window lets you enter data for the selected object.



Closes the dialog box.



Lets you enter a name for your field or change the one displayed.



Opens the Setup Fields dialog box to let you change or add fields.



Displays the field format type.



To hide data
1 On the Insert menu, click Data Field.
2 In the Field list on the left side, click the field you want to hide.
3 Click Hidden Field.
4 Click Change.
Notes

Use this feature if you want to enter data, but you do not want it to show on the chart.
Hidden data is excluded from reports.

{button Related Topics,PI(`',`IDH_RT_To_hide_data')}



To set up a data field
To change a field
To display shape data 

Data Field command
Insert menu



Legend command
{button OLE Automation,PI(`',`IDH_OA_ShowLegend_Property')}

The Legend is a special shape which reports the totals of the fields. The reported totals reflect the 
current state of the fields on the chart and update automatically when any field changes. As with 
other shapes the "totals" in this shape will be shown in the same font and style as other data. The 
Legend command is in the Insert menu.

Note
This legend is not the same as the legend for an SPC chart. To display or hide an SPC chart’s 

legend, activate the SPC chart by double-clicking on it. On the Insert menu, click Legend. An SPC 
chart’s legend identifies the different elements of the SPC chart.

{button Related Topics,PI(`',`IDH_RT_Show_Legend')}



To display or hide the legend
Insert menu



ShowLegend Property



To display or hide the legend
1 On the Insert menu, click Legend. If the legend was hidden it is now displayed.    If it was shown, 

it is now hidden.
2 Move the shape to where you want it. You can move the legend just like any other shape.

Tips
You can select, retype, and style the legend title.
You can replace and style the legend shape.
This legend is not the same as the legend for an SPC chart. To display or hide an SPC chart’s 

legend, activate the SPC chart by double-clicking on it. On the Insert menu, click Legend. An SPC 
chart’s legend identifies the different elements of the SPC chart.

{button Related Topics,PI(`',`IDH_RT_Showing_and_Hiding_the_Legend')}



Legend command
Insert menu



To edit data on charts
1 On a chart, select the data you want to edit
2 When it is highlighted, click the mouse button again.
3 Type in the new data.
4 Press Enter when you are finished.

Note
You must enter data that matches the field type you selected for that field in the Setup Fields 

dialog box.
Tip

Pressing Esc or clicking outside the data field area before finishing the data changes returns 
the field to the previous data.

{button Related Topics,PI(`',`IDH_RT_To_edit_data_on_charts')}



Using Data Fields 
To set up a data field
To enter data in the Field Viewer 
To display shape data



This dialog box lets you enter data in the fields. It displays the selected shape's number in the title 
bar. It also displays the field names with edit boxes for entering data. The current field's type is 
displayed below the last field’s edit box. The field type changes when you move from edit box to 
edit box, to reflect the field type of the current field. In this example, the cursor is in the Birthdate 
field. The Field Type reflects its field type, Date.
When your cursor is in an edit box, you can enter data into it.

Note
Hidden field names are followed by an asterisk (*). If the chart is protected by a password, no 

hidden fields will be shown in the Viewer.
Tip

You can press Tab to move from field to field.



 File menu 

Click a command below to learn more about it.
New Opens a new, blank chart window.
Open Opens a previously saved chart, template,

or workspace.
Close Closes the active chart.
Close All Closes all of the windows of all charts.
Save Saves the file on which you are working, 

using the current filename.
Save As Make a copy of the file under a new name

or in another location.
Save 
Workspace

Saves the names of open charts and their 
window arrangement in a file.

Import Imports a shape from another file.
Export Exports a chart to another file.
Page Setup Sets up the page dimensions and 

orientation.
Print Preview Previews how the page will look.
Print Selects print range and other options 

before printing a chart.
Print Setup Selects a printer and printer options.
Send Creates an e-mail message with the 

current chart as an attachment.
Recent File List Lists the last four charts you opened or 

saved.
Exit Closes open chart files and the program.

{button Related Topics,PI(`',`IDH_RT_File_Menu')}



New command
Open command
Close command
Close All command
Save command

Save As command
Save Workspace command
Import command
Export command

Page Setup command
Print Preview command
Print command
Print Setup command

Send command
Recent File list
Exit command



Creates and opens a new chart. When you choose this command, a blank chart window opens in 
front of the currently open charts. The shortcut key is Ctrl+N.



New command
{button OLE Automation,PI(`',`IDH_OA_New_method')}

The New command lets you create a new chart. When you choose this command, a blank chart 
window opens in front of the currently open charts. The shortcut key is Ctrl+N.

{button Related Topics,PI(`',`IDH_RT_New_Command')}



To create a chart
To create a chart from a template
File menu



New method



To create a new chart
Click New on the File menu. A blank chart window opens in front of the currently open charts.

Tip
You can also press Ctrl+N. 

{button Related Topics,PI(`',`IDH_RT_NEWP')}



To open existing charts
To create an SPC chart
New command
File menu



To create a chart from a template
1 On the File menu, click Open.
2 In the Look in box, choose the drive where the file resides.
3 In the box, double-click on folders to open them, until you open the folder where your file resides.
4 In the Files of type box, select FlowCharter Template (*.aft).
5 Click the template.
6 Click Open.
7 On the File menu, click Save As.
8 In the Save as type box, select Micrografx FlowCharter 7 (*.flo).
9 Save the file under a new name.

Tip
If you save the chart with the name DEFAULT.AFT, this chart will be the template that is used 

every time you create a new chart.
You can also change the view your chart opens with (for example, Page to Normal) by saving 

your default template with a different view state.

{button Related Topics,PI(`',`IDH_RT_NEWFROMTEMPLATEP')}



To create a new template 
Open command
File menu



To create a new template
1 On the File menu, click New.
2 Make changes to the settings, styles, and master items that you want in your template.
3 On the File menu, click Save As.
4 In the Save as type box, click FlowCharter Template (*.aft).
5 Give a name to the template in the File name text box.
6 In the Save in box, you can click the drive where you want to save the template.
7 In the box, double-click the folder where you want to save the template.
8 Click Save.

Notes
A template includes all chart settings, styles, and master items. It does not include objects.
If you save the chart with the name DEFAULT.AFT, this chart will be the template that is used 

every time you create a new chart.
You cannot use templates created in FlowCharter 7 in earlier versions of FlowCharter. Instead 

you must save them as ABC FlowCharter 3.0/4.0 files and convert them to templates within ABC 
FlowCharter 3.0/4.0.              {button Tell me 
how. . .,JI(`',`IDH_To_use_ABC_FlowCharter_7_templates_in_ABC_FlowCharter_3_0_or_4_0')}

{button Related Topics,PI(`',`IDH_RT_NEWTEMPLATE')}



To create a chart from a template 
To use FlowCharter 7 templates in ABC FlowCharter 3.0 or 4.0.
New command
File menu



To use FlowCharter 7 templates in ABC FlowCharter 3.0 or 4.0.
1 Open the template in FlowCharter 7.
2 On the File menu, click Save As.
3 In the Save as type box, click “Micrografx ABC FlowCharter 3.0/4.0 *.af3.”
4 Click Save.
5 On the File menu, click Exit.
6 Run ABC FlowCharter 3.0 or 4.0.
7 Open the file.
8 On the File menu, click Save As.
9 In the File Type box, click Template.
10 Enter a name for the template file.
11 Click OK.

{button Related Topics,PI(`',`IDH_RT_Using_7_templates_in_3_0_or_4_0')}



To create a new template
To create a chart from a template 
Save As command
File menu



Opens an existing chart. The shortcut key is: Ctrl+O.



Open command
{button OLE Automation,PI(`',`IDH_OA_Open_Method')}

The Open command lets you
Open an existing chart
Open a workspace

You can open these file types:
Charts (filenames ending with an AF3, or ABC extension; files that contain the shapes, lines, 

and text that comprise your charts)
Templates (filenames ending with the AFT extension; files that contain settings you want to 

reuse in charts)
Workspaces (filenames ending with the AFW extension; files that contain information about 

your current work environment, including the names of charts used in a project and their window 
arrangement)
Tip

 The shortcut key is Ctrl+O.

{button Related Topics,PI(`',`IDH_RT_Open_Command')}



To open a file
File menu



Open method



Open File dialog box

This dialog box lets you open an existing file.
If the file you want to open is not listed:

Choose another drive and/or folder in the Look in: box.
Choose the correct file type in the Files of type box.

or
Enter the exact filename in the File Name box.

{button Related Topics,PI(`',`IDH_RT_Open_File_Dialog_Box')}



To open a file
Open command
File menu



Lets you type the name of the file you want to open in the File Name text box.



Displays the filenames in the current directory. Click a filename in the box to display it in the File 
Name text box.

In the Files box, type the first letter of a filename to move the cursor to the files beginning with
that letter.



Contains the file formats that FlowCharter supports (AF3, AF2, ABC, AFT, and AFW). Click the down 
arrow to the right of the box to display the file formats, then choose the one you want.



Displays directories on the current drive. To see the filenames in another directory, double-click the 
directory name in the box.



Displays disk drives. If you choose A:, the directories on the diskette in drive A appear in the 
Directory box.



Displays name of the chart you want to open.



Lets you type a new name for the converted file.



Lets you rename the chart you opened.



To open a file
1 On the File menu, click Open.
2 In the Look in box, choose the drive where the file resides.
3 In the box, double-click on folders to open them, until you open the folder where your file resides.
4 Choose the type of file you want to open in the Files of type box, if necessary.
5 Click the file you want to open.

Tips
You can also use the shortcut key: Ctrl+O or the Open button on the Standard toolbar.

Open button
You can double-click on a filename to open it.
You can type in the path and filename in File name text box.
You can select the last four documents you opened or saved from the File menu.

{button Related Topics,PI(`',`IDH_RT_OPENP')}



Open command
File menu



Closes the active chart.



Close command
{button OLE Automation,PI(`',`IDH_OA_CloseChart_Method')}

The Close command lets you close the active chart.

Tips
You can also double-click on the Control menu box in the upper-left corner of the chart window.
You can hold down the Shift key when you click Close to close all charts.

{button Related Topics,PI(`',`IDH_RT_Close_Command')}



To close the active chart
File menu



Close Chart method



To close the active chart
Click Close on the File menu.

Tips
You can hold down the Shift key when you click Close to close all charts.
You can also double-click the Control menu box in the upper-left corner of the chart window.
If the active chart contains changes that you have not saved, a message displays asking if you 

want to save the changes. Respond to the message in one of three ways: 
1 Click Yes to save the 

changes. If you saved the
chart previously, the 
changes are saved the 
changes and the active 
chart is closed. If you 
have not saved the chart 
yet, the Save File dialog 
box opens.

2 Click No to discard the 
changes. The active chart
closes without saving the 
changes.

3 Click Cancel to return to 
the chart.

{button Related Topics,PI(`',`IDH_RT_CLOSEP')}



Close command
File menu



Close All command
The Close All command lets you close all chart windows.

Tip
You can hold down the Shift key when you click Close to close all charts.

{button Related Topics,PI(`',`IDH_RT_Close_All_Command')}



To close all chart windows
File menu



Closes all open chart windows.



To close all chart windows
On the File menu, click Close All.

Tips
You also can close all chart windows by holding down the Shift key and clicking Close.
If the active chart contains changes that you have not saved, a message display asking if you 

want to save the changes. Respond to the message in one of three ways: 
1 Click Yes to save the changes. If you saved the chart 

previously, the changes are saved and the active chart is 
closed. If you have not saved the chart yet, the Save File 
dialog box opens.

2 Click No to discard the changes. The active chart closes 
without saving the changes.

3 Click Cancel to return to the chart.

{button Related Topics,PI(`',`IDH_RT_To_close_all_chart_windows')}



Close All Command
File menu



Recent file list

Use the Recent file list in the File menu to quickly open charts you recently changed. The names of 
the last four charts you opened or saved appear in the File menu. The complete path name appears 
for charts outside the current directory.
A number appears beside each chart name. You can type the number to open the chart or click the 
chart name.

{button Related Topics,PI(`',`IDH_RT_Recall_Command')}



To reopen a chart
File menu



Lists the last four charts you opened or saved.



To reopen a chart
On the File menu, click the number of the file to open.

Note
If the chart you choose is already open, a message displays asking if you want to revert to the 

last saved version of the chart.

{button Related Topics,PI(`',`IDH_RT_RECALLP')}



Recent file list
File menu



Stores a chart or template in a file on disk. All charts (including linked charts) are saved in separate 
files. You can also use the shortcut key:    Ctrl+S



Save command
{button OLE Automation,PI(`',`IDH_OA_Save_Method')}

The Save command lets you store a chart or template in a file on disk. All charts (including linked 
charts) are saved in separate files.
The first time you save a new chart or create a new, linked chart, you name the file that contains it 
and choose where you want to store the file. Afterwards, each time you choose the Save command, 
your changes are saved in that file. You also can choose to save templates for use with new charts.

{button Related Topics,PI(`',`IDH_RT_SAVE')}



To save a chart or template
To save files in ABC FlowCharter version 3.0/4.0 format
Save As command
File menu



Save method



To save a chart or template
1 On the File menu, click Save. If you are saving a file for the first time, the Save As dialog box 

opens. If you already have saved the file, your changes are saved in the file you named earlier.
2 Type the filename in the File Name box.
3 Choose the drive and directory in which you want to store the file in the Save in box.
4 Choose the file format you want (Chart or Template) in the Save as type box.

Note
If you entered an existing filename, a message appears, asking if you want to replace the 

existing file. Click No if you do not want to replace the file. You return to the Save As dialog box. Type a 
different name in the File Name text box or choose another directory.
or

Click Yes to replace the file.
Tips

You can also use the shortcut key: Ctrl+S
Pressing a character key when a filename is highlighted in the File Name text box makes the 

name disappear. To change the filename, press the Right Arrow to remove the highlight. Then press 
the Right or Left Arrow to move the text cursor. To delete characters to the left of the text cursor, 
press Backspace.

A template includes all chart settings, styles, and master items. It does not include objects.
You cannot use templates created in FlowCharter 7 in earlier versions of FlowCharter. Instead 

you must save them as ABC FlowCharter 3.0/4.0 files and convert them to templates within ABC 
FlowCharter 3.0/4.0.              {button Tell me 
how. . .,JI(`',`IDH_To_use_ABC_FlowCharter_7_templates_in_ABC_FlowCharter_3_0_or_4_0')}

{button Related Topics,PI(`',`IDH_RT_SAVEP')}



Save As command
Save command
File menu



Renames a chart, so that you have the original chart and a new version. This option is useful for 
making a copy of a file without using the Windows Copy command.



Save As command
The Save As command lets you rename a chart, so that you have the original chart and a new 
version. This option is useful for making a copy of a file without using the Windows Copy command.

{button Related Topics,PI(`',`IDH_RT_SAVEAS')}



To save a copy of a chart
To save files in ABC FlowCharter version 3.0/4.0 format
Save command
File menu



Save File dialog box

This dialog box lets you save files.

{button Related Topics,PI(`',`IDH_RT_Save_File_Dialog_Box')}



To save files in ABC FlowCharter version 3.0/4.0 format
To save a copy of a chart
Save As command
File menu



Lets you type the name of the file you want to save.



Displays the folders and filenames in the current directory. Click a filename in the box to display it in
the File Name text box.

In the box, type the first letter of a filename to move the cursor to the files beginning with that 
letter.



Contains the file formats that are supported. Click the down arrow to the right of the box to display 
the file formats, then choose the one you want.



Displays directories on the current drive. To see the filenames in another directory, double-click the 
directory name in the box.



Displays disk drives and folders of the current drive. If you choose another drive, the directories on 
the drive appear in the box.



To save a copy of a chart
1 On the File menu, click Save As.
2 Type a filename for the chart copy. Use a different name to distinguish between the copy and the 

original.
3 Choose the drive and directory in which you want to store the copy.
4 Click OK. A copy of the active chart is stored with the new filename.

{button Related Topics,PI(`',`IDH_RT_SAVEASP')}



To save files in ABC FlowCharter version 3.0/4.0 format
Save As command
File menu



To save files in ABC FlowCharter version 3.0/4.0 format
1 On the File menu, click Save As.
2 Choose the Micrografx ABC FlowCharter 3.0/4.0 File (*.af3) format in the Save as type box.
3 Type the filename you want in the File name text box.
4 Choose the drive and directory where    you want to store the file.
5 Click OK. The chart is saved in a file ready to be opened by ABC FlowCharter 3.0/4.0.

Notes
You can save files for use in ABC FlowCharter versions 3.0 and 4.0. Files created in FlowCharter 

3.0 and 4.0 can be opened without saving in a special format.    Just select "Micrografx ABC FlowCharter
3.0/4.0 File" in the Save as type list for both 3.0 and 4.0 files. 

When you save files with SPC charts you created in the "Micrografx ABC FlowCharter 3.0/4.0 
File" file type, the SPC chart information will be lost.

Files in version 3.0/4.0 formats only support shape numbers that are 16 characters long. (In 
version 6, you can have shape numbers that are 20 characters long.)    When you convert a 6 format 
file to 3.0/4.0 format, the first five characters of the shape number information are lost and replaced 
with an asterisk.

{button Related Topics,PI(`',`IDH_RT_ABC20SAVE')}



Save As command
File menu



Saves your workspace in a file. The file contains the names and screen setup of the charts in the 
program window.



Save Workspace command
The Save Workspace command saves your workspace in a file. The file contains the names and 
screen setup of the charts in the program window.
Because you often may work on the same set of charts for a project, this feature lets you quickly 
open the charts to resume your work. When you save your workspace, you can save the names of 
the open charts (not the charts themselves) and the arrangement of the charts in the program 
window.
When you open a workspace file, the chart files opens and restores the arrangement.

{button Related Topics,PI(`',`IDH_RT_Save_Workspace_Command')}



To save your workspace
To reopen the workspace
Save As command
Save command

File menu



Save Workspace dialog box

The Save Workspace dialog box lets you give a name to the current workspace and save it to disk.

{button Related Topics,PI(`',`IDH_RT_Save_Workspace_Dialog_Box')}



What is a workspace?
To save your workspace
To reopen the workspace
Save Workspace command

File menu



What Is a Workspace?

A workspace is the set of currently open charts.
Because you often may work on the same set of charts for a project, the workspace feature lets you 
quickly open the charts to resume your work. When you save your workspace, you can save the 
names of the open charts (not the charts themselves) and the arrangement of the charts in the 
program window.

{button Related Topics,PI(`',`IDH_RT_What_is_a_workspace')}



To save your workspace
To reopen the workspace
Save Workspace command
File menu



Lets you type the name of the workspace file you want to save.



Displays the filenames in the current directory. Workspace files have an AFW extension.Click a 
filename in the box to display it in the File Name text box.

In the Files box, type the first letter of a filename to move the cursor to the files beginning with
that letter.



Displays Workspace as the default file type.



Displays directories on the current drive. To see the filenames in another directory, double-click the 
directory name in the box.



Displays disk drives. If you choose A:, the directories on the diskette in drive A appear in the 
Directory box.



Saves the objects in your workspace.



To save your workspace
1 On the File menu, click Save Workspace. 
2 Type a name for the workspace file in the File Name text box.
3 Choose the drive and directory in which you want to store the workspace file.
4 Click OK. The workspace is saved in a file.
Only saved charts are included in the workspace file. If any of the charts in the workspace have not 
been saved, the Save File dialog box opens to let you save them.

Note
If you open more than one workspace and you choose the Save Workspace command, all the 

open workspaces are saved as one workspace. For example, if you open the workspace Test, then open
the workspace Pass and choose the Save Workspace command, the workspace Pass is saved, and 
includes the workspace Test.

{button Related Topics,PI(`',`IDH_RT_SAVEWORKSPACEP')}



To reopen the workspace
Save Workspace command
File menu



To reopen the workspace
1 On the File menu, click Open.
2 Choose Workspace in the Files of Type box.
3 Choose the drive and directory that contain the workspace file you want.
4 Click the file you want to open.
5 Click OK. The charts saved in the workspace file open and the chart arrangement is restored.

{button Related Topics,PI(`',`IDH_RT_REOPENWORKSPACE')}



To save your workspace
Save Workspace command
File menu



Sets the size of the page, the size of the page margins (borders), and the orientation of the page 
(portrait or landscape).

Note
If you change your page margin, the objects on the page will move as well.



Import command
The Import command imports a shape into the chart. This command opens the Import Shape dialog 
box for you to make your choices from.

{button Related Topics,PI(`',`IDH_RT_Import_command')}



To import a shape using the File menu
Export command
File menu



To import a shape using the File menu
1 On the File menu, click Import.
2 In the Look in box, choose the drive where the file resides.
3 In the box, double-click on folders to open them, until you open the folder where your file resides.
4 Choose the type of file you want to open in the Files of type box, if necessary.
5 Click the file you want to import.
6 Click Open.

{button Related Topics,PI(`',`IDH_RT_To_import_a_shape_using_the_File_menu')}



Import command
Export command
File menu



Imports a shape into your chart.



Export command
The Export command exports your chart. This command opens the Export Chart dialog box for you 
to chose the pathname and file type for your chart.

{button Related Topics,PI(`',`IDH_RT_Export_command')}



To export a chart using the File menu
Import command
File menu



Exports a chart.



To export a chart using the File menu
1 On the File menu, click Export.
2 Type the filename in the File Name text box.
3 Choose the drive and directory in which you want to store the file in the Save in box.
4 Choose the file format you want in the Save as type box.
5 Click Save.

{button Related Topics,PI(`',`IDH_RT_To_export_a_chart_using_the_File_menu')}



Import command
File menu



Page Setup command
The Page Setup command:

Sets the size of the page. The default page size is determined by the selected printer.
Sets the size of the page margins (borders)
Set the orientation of the page (portrait or landscape)
Prints Notes
Prints blank pages
Sets the order in which pages are printed
Fits the entire chart on a page

Note
If you change your page margin, the objects on the page will move as well.

{button Related Topics,PI(`',`IDH_RT_Page_Setup_Command')}



To define the page setup
File menu



Fit To Page option

The Fit To Page option fits the chart to a single page. The entire chart is reduced proportionally, 
including the TrueType fonts. (Bitmap and printer fonts do not necessarily reduce properly.) When 
multiple-page charts are reduced to one page, the master items are printed only once and the All, 
Selection, and Pages print range options are still valid.

Note
Charts cannot be enlarged with the Fit to Page option.

{button Related Topics,PI(`',`IDH_RT_Fit_to_Page_option')}



To define the page setup
Page Setup command
File menu



Page Setup dialog box

The Page Setup dialog box lets you choose the page size, margins, and other options to prepare the 
chart for printing or viewing.
Page breaks display on the screen based on the paper size and margins you choose. The maximum 
paper size is 100" x 100".

Note
If you change your page margin, the objects on the page will move as well.

Tip
To fit your chart on the fewest pages, click Portrait if your chart is oriented vertically or 

Landscape if your chart is oriented horizontally.

{button Related Topics,PI(`',`IDH_RT_Page_Setup_Dialog_Box')}



To define the page setup
Paper Size option 
Print Blank Pages option
Print Range options 

Page Order option 
Measure option 
Fit To Page option 
Orientation option 

Page Height 
Page Setup command
File menu



Paper Size option
{button OLE Automation,PI(`',`IDH_OA_PaperSize_Property')}

You should choose the paper size on which you plan to print your chart. Many popular paper sizes 
are provided, including letter (8 ½" x 11"), legal (8 ½" x 14"), tabloid (11" x 17"), and C sheet (17" x 
22").

{button Related Topics,PI(`',`IDH_RT_Paper_Size_option')}



To define the page setup
Page Setup command
File menu



Paper Size property



Page Height
{button OLE Automation,PI(`',`IDH_OA_PageHeight_Property')}

In the Page Setup dialog, click the down arrow in the Paper Size area and choose one of the preset 
paper sizes from the list.
or
Select the Width and Height text boxes and type the page dimensions you want (in inches or 
centimeters, depending upon your measure choice). The maximum paper size you can set is 100" x 
100".



Page Height property



Selects the paper size on which you plan to print your chart. Many popular paper sizesare provided, 
including letter (8 ½" x 11"), legal (8 ½" x 14"), tabloid (11" x 17"), and C sheet (17" x 22"). 
Click the down arrow in the Paper Size area and choose one of the preset paper sizes from the list, 
or select the Width and Height text boxes and type the page dimensions you want (in inches or 
centimeters, depending upon your measure choice). The maximum paper size you can set is 100" x 
100".



Specifies the width of the page. You can enter the width in inches or centimeters. The maximum 
paper size is 100" x 100". 



Specifies the height of the page. You can enter the height in inches or centimeters. The maximum 
paper size is 100" x 100".



Defines the page spread when the chart extends beyond one page. You set the number of pages 
across and down.



Pages option
{button Tell me

how . . .,PI(`',`IDH_HT_Page_options_PageSetup_db')}
The Pages option on the Page Setup dialog box lets you set the number of pages for your chart. You 
can use this option to add pages to an existing chart. You can add pages so that your chart is longer 
horizontally or vertically, or even both.

{button Related Topics,PI(`',`IDH_RT_Page_options_PageSetup_db')}



To add pages to your chart 



Page Setup command 
To define the page setup 



To add pages to your chart
1 On the File menu, click Page Setup.
2 In the Pages area, type a larger number in the Across box to add pages horizontally to your chart.
or

Type a larger number in the Down box to add pages vertically to your chart.
or

Type a larger number in the Across and Down boxes to add pages horizontally and vertically to 
your chart.

3 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_add_pages_to_your_chart')}



Page Setup command 
To define the page setup 



Margins
{button OLE 
Automation,PI(`',`I
DH_OA_MarginBott
om_Property')}
{button Tell me 
how . . .,PI(`',`ID
H_HT_PageMargi
n_Options')}

The margins you specify are used to define the print area on each page and to determine the page 
breaks. For example, if you choose an 8 ½" x 11" (letter) page size and specify a 0.5" margin on all 
sides, the print area is 7 ½" x 10".
Select each of the Margins text boxes individually, and type the margin you want (in inches or 
centimeters, depending upon your measure choice). The numbers you enter are rounded to the 
nearest hundredth of an inch or tenth of a centimeter.

Note
If you change your page margin, the objects on the page will move as well.



Margin Bottom property



To set up page margins for your chart 



Specifies the top margin of the page.

Note
If you change your page margin, the objects on the page will move as well.



Specifies the bottom margin of the page.

Note
If you change your page margin, the objects on the page will move as well.



Specifies the left margin of the page.

Note
If you change your page margin, the objects on the page will move as well.



Specifies the right margin of the page.

Note
If you change your page margin, the objects on the page will move as well.



To set up page margins for your chart
1 On the File menu, click Page Setup.
2 Click the Margin tab.
3 Select each of the Margins text boxes individually and type the margin you want (in inches or 

centimeters, depending upon your measure choice).
4 Click OK.

Note
If you change your page margin, the objects on the page move as well.
The numbers you enter are rounded to the nearest hundredth of an inch or tenth of a 

centimeter.

{button Related Topics,PI(`',`IDH_RT_To_setup_page_margins')}



Page Setup command 
Margins 
File menu 



Selects either Portrait (tall) or Landscape (wide) for your page orientation. To fit your chart on the 
fewest pages, click Portrait if your chart is vertically oriented or Landscape if your chart is 
horizontally oriented.



Orientation option
{button OLE Automation,PI(`',`IDH_OA_Orientation_Property')}

You can choose either Portrait (tall) or Landscape (wide) for your page orientation. To fit your chart 
on the fewest pages, click Portrait if your chart is vertically oriented or Landscape if your chart is 
horizontally oriented.



Orientation property



Specifies that the chart should be printed with its top along the short edge of the paper (portrait).



Specifies that the chart should be printed with its top along the long edge of the paper (landscape).



Measurement command
{button OLE

Automation,PI(`',`IDH_OA_Units_Property_Chart_Object')}
You can choose inches or centimeters for your measurement units. The units you choose are used in
the rulers and in other options where you specify size, such as margins and page size. Click Inches 
or Centimeters to choose the units you want. 



Units Property Chart object



Selects either inches or centimeters for your measurement units. The units you choose are used in 
the rulers and in other options where you specify size, such as margins and page size. Click Inches 
or Centimeters to choose the units you want. 



To select the chart's measurement unit
1 In the Rulers area, click the right mouse button.
2 Click Measurement.
3 Click the measurement unit you want: Inches or Centimeters.

{button Related Topics,PI(`',`IDH_RT_To_choose_charts_measurement_unit')}



Measurement command 



Page Order option
{button OLE Automation,PI(`',`IDH_OA_PageOrder_Property')}

You can choose the order in which the pages of your chart are printed. The orders are Down, then 
Across and Across, then Down. 



Page Order property



Selects order in which the pages of your chart are printed. The orders are Down, then Across and 
Across, then Down.



Print Blank Pages option
{button OLE

Automation,PI(`',`IDH_OA_PrintBlankPages_Property')}

You can choose to print or omit pages that do not have any objects on them.

Tip
Select to print blank pages when assembling a poster of a chart.



Print Blank Pages property



Prints or omits pages that do not have any objects on them.



Prints or omits pages that do not have any objects on them. This option is useful when you want to 
print blank pages when assembling a poster of a chart.



Prints or omits notes.



Prints the pages beginning with the first page in the first column, printing the next page down until 
it reaches the bottommost page of the column, and then beginning printing the topmost in the next 
column to the right.



Prints the pages beginning with the first page in the first column, printing the next page to the right 
until it reaches the rightmost page of the row, and then beginning printing the leftmost page in the 
next row.



Fits the chart to a single page. The entire chart is reduced proportionally, including the TrueType 
fonts.



Changes the Paper Size, Margins, Orientation, and Measure settings to match the current printer.



Shows what the options selected will look like.



Shows what the chart will look like. In this view of the chart, you can zoom in or out on your charts 
and preview one or two pages at a time in the order the pages will be printed.
You can also print from the Print Preview dialog box.



To define the page setup
1 On the File menu, click Page Setup.
2 Choose the page setup options you want.
3 Click OK. Your page setup choices are applied to the chart.

{button Related Topics,PI(`',`IDH_RT_PAGESETUPP')}



Page Setup command
File menu



Prints your charts and adds them to presentations and reports. You can print all the pages, a range 
of pages, or only selected objects in the chart. You can also use the shortcut key: Ctrl+P



Print command
{button OLE Automation,PI(`',`IDH_OA_PrintOut_Method')}

Use the Print command to print your charts and add them to presentations and reports.
You can print all the pages, a range of pages, or only selected objects in the chart. To print only 
selected objects, select the objects you want to print before you choose the Print command.

Tip
You can also use the shortcut key: Ctrl+P.

{button Related Topics,PI(`',`IDH_RT_Print_Command')}



To print a chart
File menu



Print Out method



Print dialog box
Print Range options

Click All to print all the pages in the chart.
Click Selection to print only the objects selected in the chart. {button OLE 

Automation,PI(`',`IDH_OA_PrintSelected_Method')}
Click Pages and type starting and ending page numbers to print a range of pages.

Print to File option
Click Print to File if you want to send the output to a file instead of a printer.

Copies text box
Click the up or down arrow to choose the number of copies, or type a number in the text box.

Properties button
Click the Properties button to open the printer’s Properties dialog box.

{button Related Topics,PI(`',`IDH_RT_Print_Dialog_Box')}



To print a chart
Print command
File menu



All prints all the pages in the chart.
Selection prints only the objects selected in the chart. 
Prints a range of pages.



Print Range options
 {button OLE Automation,PI(`',`IDH_OA_PrintSelected_Method')}

Click All to print all the pages in the chart.
Click Selection to print only the objects selected in the chart.
Click Pages and type starting and ending page numbers to print a range of pages.



Print Selected method



Reduces a multiple-page chart proportionally to fit to a single page.



Sends the output to a file instead of a printer.



Prints the notes attached to the shapes in the chart.



Selects the number of copies, or type a number in the text box.



Opens the Printer Setup dialog box.



To print a chart
1 On the File menu, click Print.    Information about the printer appears at the top of the dialog box. 

(The printer information is for the printer to which the next print job will be sent.)
2 Choose a Print Range option.
3 Type the number of copies you want in the Copies text box.
4 Click the Print to File box if you want to send the output to a file instead of a printer.
5 Click OK to save the changes in the Print dialog box and to print your chart.

Tips
If you choose the Print to File option, a dialog box opens. Type the filename you want and click 

OK. The chart information is saved in a file in the current directory.
To print Notes, blank pages, choose the print order, and fit the chart to the page, click Page 

Setup on the File menu. Click the Print Options tab.
You can also use the shortcut key: Ctrl+P.

{button Related Topics,PI(`',`IDH_RT_PRINTP')}



Print command
File menu



Selects the current printer and printer options.



Print Setup command
The Print Setup command provides the current printer and printer options.
If you do not change the current printer, you can use the default printer as the current printer. The 
default printer is the printer selected in the Windows Control Panel. See your Windows 
documentation for information about changing the default printer.

{button Related Topics,PI(`',`IDH_RT_Printer_Setup_Command')}



To select a printer
File menu



Printer Setup dialog box
Printer area
The Printer area lists the currently installed Windows printer drivers. Click the name of the printer 
you want to be the currently active printer. Printer drivers can be added or deleted through the 
Windows Control Panel. Any installed printer driver can be activated and used by this program.

Options button
Click the Options button to open the currently selected printer dialog box. Choose printer options 
(page size, orientation, etc.) and click OK.

{button Related Topics,PI(`',`IDH_RT_Printer_Setup_Dialog_Box')}



To select a printer
Print Setup command
File menu



Lists the currently installed Windows printer drivers. Click the name of the printer you want to be 
the currently active printer. Printer drivers can be added or deleted through the Windows Control 
Panel. Any installed printer driver can be activated and used by this program.



Opens the currently selected printer dialog box. Choose printer options (page size, orientation, etc.) 
and click OK.



To select a printer
1 On the File menu, click Print Setup. 
2 Select the print device you want to use.
3 Click OK.

{button Related Topics,PI(`',`IDH_RT_PRINTERSETUPP')}



Print Setup command
File menu



Exit command
{button OLE Automation,PI(`',`IDH_OA_Quit_Method')}

The Exit command closes this program. Use this command when you finish working with the 
program, or when you want to free memory to work in another program.

{button Related Topics,PI(`',`IDH_RT_Exit_Command')}



To close this program
File menu



Quit method



To close this program
1 On the File menu, click Exit.        {button Shortcuts,PI(`',`IDH_Shortcut_Exit')} 
2 If any open chart has changed, and you did not save it before closing, the Save Changes dialog 

box opens and requests that you select one of three choices: Yes, No, or Cancel.
Click Yes to save changes to the current chart before closing. If you have not saved 
the chart previously, the Save File dialog box opens. Type a name in the File Name 
text box and press Enter.
Click No to discard the changes to the chart and close the program.
Click Cancel to cancel the Exit command and return to the active chart.

{button Related Topics,PI(`',`IDH_RT_EXITP')}



Exit command
File menu



Closes the program. 



Press Alt+F4.



Creates an e-mail message with the current chart as an attachment.

Note
This feature works with any MAPI E-mail system. MAPI e-mail systems include Microsoft Mail, 

Microsoft Exchange, and Lotus cc:Mail.



Send command
{button OLE Automation,PI(`',`IDH_OA_SendMail_Method')}

The Send command creates an e-mail message with the current chart as an attachment. After the 
message is created, you address the e-mail and create a message as you usually do.

Note
This feature works with any MAPI E-mail system. MAPI e-mail systems include Microsoft Mail, 

Microsoft Exchange, and Lotus cc:Mail.

{button Related Topics,PI(`',`IDH_RT_Send_Mail_Command')}



To send a chart as an e-mail attachment
File menu



Send Mail method



To send a chart as an e-mail attachment
1 Open the chart to attach to an e-mail message.
2 On the File menu, click Send. An e-mail message displays with the chart as an attachment. 
3 Address the e-mail and create a message as you usually do.

Notes
This feature works with any MAPI E-mail system. MAPI e-mail systems include Microsoft Mail, 

Microsoft Exchange, and Lotus cc:Mail.
 If the mail system is not running when you click the Send command, it will start. When you 

finish the e-mail, it will close after sending the message.

{button Related Topics,PI(`',`IDH_RT_Sending_Email')}



Send command
File menu



Print Preview command
The Print Preview command previews the chart to see what it will look like when you print it.

{button Related Topics,PI(`',`IDH_RT_Print_Preview')}



To print a chart
To view your chart as it will be printed
File menu



Displays preview of what your page will look like when you print it.



To view your chart as it will be printed
On the File menu, click Print Preview.

Tip
You can zoom in by clicking on the chart in the area you want to see in more detail.



Prints the chart.



Previews the next page of the chart.



Previews the previous page of the chart.



Previews two pages of the chart at a time.



Magnifies the chart.



Displays more of the chart.



Closes the Preview window and returns to the normal view.



To print your selection on one page
1 Select all the items you want to print.
2 On the File menu, click Page Setup.
3 Click the Print Options tab.
4 Click Fit to Page to place an x in the check box.
5 Click OK.
6 On the File menu, click Print.
7 Click Selection.
8 Click OK.

Note
The selected items must be contiguous.

Tip
You use this procedure when you want to print all the selected items, and make them fit onto 

one page.

{button Related Topics,PI(`',`IDH_RT_print_all_selected_items')}



To print a chart 
To select a printer 
File menu 



To import a chart from SnapGrafx 2.0
1 On the File menu, click Open.
2 Choose Micrografx ABC SnapGrafx 2.0 File (*.sg) in the Files of Type box.
3 Choose the drive and directory that contain the SnapGrafx 2.0 file you want.
4 Click the file you want to open.
5 Click OK. The SnapGrafx 2.0 file you selected displays in your chart.

Tips
You can also use the shortcut key: Ctrl+O or the Open button on the Standard toolbar.

Open button
You can double-click on a filename to open it.
You can type in the path and filename in File name text box.

{button Related Topics,PI(`',`IDH_RT__To_open_SnapGrafx20')}



Open command
File menu



Closes this dialog box, and saves any changes you have made. 



Prints the chart.



Displays a preview of the next page in the print sequence. The print sequences is determined by the
Page Order option of the Page Setup command.



Displays a preview of the previous page in the print sequence. The print sequences is determined by
the Page Order option of the Page Setup command.



Changes the number of pages you are previewing at a time.



Zooms in on a part of a page.



Displays more of the chart.



Closes this dialog box.



Page Setup Margins Tab dialog box

This dialog box lets you choose the margins of the chart.
Page breaks display on the screen based on the paper size and margins you choose. The maximum 
paper size is 100" x 100".



Page Setup Print Options Tab dialog box

This dialog box lets you choose the print options.



Page Setup Page Tab dialog box

This dialog box lets you choose the page size of the chart, the chart orientation, and the number of 
pages for the chart. Use the Page Setup - Page Tab dialog box to add pages to your active chart.
Page breaks display on the screen based on the paper size and margins you choose. The maximum 
paper size is 100" x 100".

Tip
To fit your chart on the fewest pages, click Portrait if your chart is vertically oriented or 

Landscape if your chart is horizontally oriented.

{button Related Topics,PI(`',`IDH_RT_Page_Setup_Pagetab')}



Paper Size option 
Orientation option 
Pages option 
Page Setup command 



Opens this chart.



Opens this chart.



Opens this chart.



Opens this chart.



Displays information about this dialog box.



Runs Picture Publisher.



Runs Designer.



Closes all chart windows.



Displays information on how to use the Help system.



Displays the Help Topics dialog box of the Help system.



New dialog box
The New dialog box opens a new, blank chart window. You can either open a blank page without a 
template or a blank chart with a template.



Closes this dialog box without saving changes you have made.



Opens a dialog box that lets you browse through folders to find the file you want.



Displays your changes without closing the dialog box.



Closes the dialog box.



Displays templates available for your use. Double-clicking a template under the General, Living 
FlowCharts, or CoolSheets tab opens a chart with that template applied.



Displays Living FlowChart templates available for your use. Double-clicking a template opens a 
blank chart with that template applied.



Displays CoolSheets templates available for your use. Double-clicking a template opens a blank 
chart with that template applied.



Displays template files in one of three ways: large icons, file list, or file list with details, such as file 
size, file type, and date and time modified.



Displays template files as a file list.



Displays template files as a file list with details, such as file size, file type, and date and time 
modified



Opens a chart with no objects applied.



Available template file.



Saving Files with File Type AF3
You can save files for use in ABC FlowCharter versions 3.0 and 4.0. Files created in FlowCharter 

3.0 and 4.0 can be opened without saving in a special format.    Just select "Micrografx ABC FlowCharter
3.0/4.0 File" in the Save as type list for both 3.0 and 4.0 files. 

When you save files that include SPC charts you created in the "Micrografx ABC FlowCharter 
3.0/4.0 File" file type, the SPC chart information will be lost.

Files in version 3.0/4.0 formats only support shape numbers that are 16 characters long. (In 
version 6, you can have shape numbers that are 20 characters long.)    When you convert a 6 format 
file to 3.0/4.0 format, the first five characters of the shape number information are lost and replaced 
with an asterisk.



Completes the wizard using the selections you have made.



Returns to the previous wizard page without making any changes.



Advances to the next wizard page based on your selections.



Determining the Way Lines Look
{button OLE 
Automation,PI(`',`I
DH_OA_Determinin
g_the_way_lines_lo
ok')}
{button Tell me 
how . . .,PI(`',`ID
H_HT_Determinin
g_the_way_lines_
look')}

You can change the appearance of existing lines and choose the way new lines will look.

Line styles include:
Line Color
Line Style
Line Weight

Arrowhead styles include:
Source Arrowhead Color
Destination Arrowhead Color
Source Arrowhead Size
Destination Arrowhead Size
Source Arrowhead Style
Destination Arrowhead Style

You can view the current styles and store new styles in the Line Styles list on the Preset Styles 
toolbar.

Line routing types include:
Direct Line
Right Angle Line
Curved Line
Org Chart Line
Cause and Effect Line

You can choose the way lines look when they cross.

Crossovers include:
Crossover Style
Crossover Size

Nodes:
Appear at end points and where lines connect
Help you distinguish between connecting lines and lines that merely overlap
Are represented by small solid circles on lines

You can click a node and drag to resize or reposition the line.You also can choose whether to show 
nodes on lines.

Text
You can:

Attach text to lines
Detach text to lines

{button Related Topics,PI(`',`IDH_RT_Determining_How_Lines_Look')}





Attaching Text to Lines
Choosing Line Styles That Enhance Your Chart
Crossovers

Preset Line Styles
To connect a new line to an existing line
To draw an unconnected line



To change the way existing lines look
To choose arrowhead styles
To choose line styles for new lines

To add a preset line style
To choose a preset line style
To delete a preset line style

To choose the line crossover
To show and hide nodes
To add text to a line



StemColor Property
StemStyle Property
StemWidth Property

SourceArrowColor Property
DestArrowColor Property
SourceArrowSize Property
DestArrowSize Property
SourceArrowStyle Property
DestArrowStyle Property

CurrentLineRouting Property
LineCrossoverStyle Property
LineCrossoverSize    Property

ShowNodeso Lines Property
AttachText Method
UnattachFromLine method



Drawing Connector Lines
{button Tell me

how . . .,PI(`',`IDH_HT_Drawing_Connector_Lines')}

The Connector Lines tool lets you draw different types of connector lines.
Connector lines automatically display and snap to points on closed shapes. After placing a connector
line, you can easily detach it and reattach it at a different snap point. When you attach connector 
lines to a shape, you can move the shape and the line remains attached.

The boxes in this chart are 
connected with connector 
lines.

The line remains connected to the 
box when the box is moved.

Connector lines are a powerful tool that makes it easy to create flowcharts, organization charts, 
timelines, and other drawings in which you want to connect lines and shapes quickly.

{button Related Topics,PI(`',`IDH_RT_Drawing_Connector_Lines')}



To draw connected direct line
To draw connected right angle lines
To draw connected org chart lines
To draw connected cause and effect lines

To draw connector freehand line
To draw connected curved lines



Drawing Basics
Snapping to the Grid
Drawing Lines
Drawn Lines vs Connector Lines
Drawing Shapes



To draw connected direct lines
1 Click the Connector Lines tool, and then click Direct Line.
2 Point where you want to begin the connected direct lines.
3 Click and drag to draw the line. If you drag the line to a closed shape, connector points on the 

shape display, and the line "snaps" to the closest point.
4 Release the mouse button when you finish drawing the line.

{button Related Topics,PI(`',`IDH_RT_To_draw_a_connector_direct_line')}



To draw connected right angle lines
To draw connected org chart lines
To draw connected cause and effect lines
To draw a connector freehand line

To draw connected curved lines
Drawing Connector Lines



To draw connected right angle lines
1 Click the Connector Lines tool, and then click Right Angle Line.
2 Point where you want to begin the connected right angle lines.
3 Click and drag to draw the right angle line. If you drag the line to a closed shape, connector 

points on the shape display, and the line "snaps" to the closest point.
4 Release the mouse button when you finish drawing the line.

{button Related Topics,PI(`',`IDH_RT_To_draw_connected_right_angle_lines')}



To draw connected direct line
To draw connected org chart lines
To draw connected cause and effect lines
To draw a connector freehand line

To draw connected curved lines
Drawing Connector Lines



To draw connected org chart lines
1 Click the Connector Lines tool, and then click Org Chart.
2 Point where you want to begin the connected org chart line.
3 Click and drag to draw a segment of the org chart line.
4 Release the mouse button.
5 Repeat steps 3 and 4 to add more org chart line segments. If you drag the line to a closed shape,

connector points on the shape display, and the line "snaps" to the closest point.
6 Click the left mouse button away from the connector org chart line or press Esc when you finish.

{button Related Topics,PI(`',`IDH_RT_To_draw_connected_orgchart_lines')}



To draw connected direct lines
To draw connected right angle lines
To draw connected cause and effect lines
To draw a connector freehand line

To draw connected curved lines
Drawing Connector Lines



To draw connected cause and effect lines
1 Click the Connector Lines tool, and then click Cause and Effect.
2 Point where you want to begin the connected cause and effect lines.
3 Click and drag to draw a segment of the cause and effect line.
4 Release the mouse button.
5 Repeat steps 3 and 4 to add more cause and effect line segments. If you drag the line to a closed

shape, connector points on the shape display, and the line "snaps" to the closest point.
6 Click the left mouse button away from the connector cause and effect or press Esc when you 

finish.

{button Related Topics,PI(`',`IDH_RT_To_draw_connected_causeandeffect_lines')}



To draw connected direct lines
To draw connected right angle lines
To draw connected org chart lines
To draw a connector freehand line

To draw connected curved lines
Drawing Connector Lines



To draw a connector freehand line
1 Click the Connector Lines tool, and then click Direct Line.
2 Point where you want to begin the connected freehand lines.
3 Click and drag to draw the line. If you drag the line to a closed shape, connector points on the 

shape display, and the line "snaps" to the closest point.
4 Release the mouse button when you finish drawing the line.

{button Related Topics,PI(`',`IDH_RT_To_draw_a_connector_freehand_line')}



To draw connected direct lines
To draw connected right angle lines
To draw connected org chart lines
To draw connected cause and effect lines

To draw connected curved lines
Drawing Connector Lines



To draw connected curved lines
1 Click the Connector Lines tool, and then click Curved Line.
2 Point where you want to begin the connected curved lines.
3 Click and drag to draw a line.
4 Release the mouse button.
5 Click again and drag the pointer. The line curves in the direction you move the pointer.
6 Release the mouse button when the curve is the shape and length you want.
7 Repeat steps 5 and 6 to add more curved segments. If you drag the curve to a closed shape, 

connector points on the shape display, and the curve "snaps" to the closest point.
8 Click the left mouse button or press Esc when you finish.

{button Related Topics,PI(`',`IDH_RT_To_draw_connected_curved_lines')}



To draw connected direct lines
To draw connected right angle lines
To draw connected org chart lines
To draw connected cause and effect lines

To draw a connector freehand line
Drawing Connector Lines



Choosing Line Styles That Enhance Your Chart
{button Tell me how . . .,PI(`',`IDH_HT_Choosing_Line_Styles_That_Enhance_Your_Chart')}

You have a number of styles you can use for lines, including solid and dashed lines. You can use line 
styles to convey information about data flow in your chart. For example, line styles are commonly 
used in flowcharts to convey the following information:

Line Style Meaning

Solid lines with 
arrows

Show data flow

Dashed lines Represent multiple transitions and 
optional steps

Center lines Heavier weight lines that represent 
enclosure outlines or draw attention to
a specific chart element

You can choose different line weights for each line and arrowhead. Varying line weights can be used 
to distinguish data flows and to draw attention to certain transitions or data transfers in a chart.
You can choose different colors for each line and arrowhead. To enhance your chart, you could use 
one color for all beginning arrowheads and another for all ending arrowheads.

{button Related Topics,PI(`',`IDH_RT_Choosing_Line_Styles_That_Enhance_Your_Chart')}



Determining the Way Lines Look
Choosing Line Styles 
Choosing Arrowhead Styles
Using Shapes and Lines Effectively 
Preset Line Styles

To change the way existing lines look
To choose arrowhead styles
To choose line styles for new lines



To draw connected direct lines
To draw connected right angle line 
To draw connected curved lines 
To draw connected    org chart lines 

To draw connected cause and effect lines 
To draw a connector freehand line 
To connect a new line to an existing line
To draw an unconnected line



Preset Line Styles
{button Tell me how. . .,PI(`',`IDH_HT_Preset_Line_Styles')}

As you create charts, you may find that you often reuse the same line styles. You can store these 
"preset styles" in a list.
The list opens when you click the down arrow to the right of the Line Styles box on the Preset Styles 
toolbar.

{button Related Topics,PI(`',`IDH_RT_Preset_Line_Styles')}



Determining the Way Lines Look
To add a preset line style
To rename a preset line style
To choose a preset line style
To delete a preset line style



To add a preset line style
To rename a preset line style
To choose a preset line style
To delete a preset line style



Connecting Shapes with Lines
{button OLE Automation,PI(`',`IDH_OA_Drawing_Methods')}

You can use any of the five line types (routing) tools to connect shapes:
Direct Line
Right Angle Line
Curved Line
Org Chart Line
Cause and Effect Line

You can:
Draw lines by either clicking or dragging
Connect two shapes with a line. When you connect the shapes with a line, the end points of the

line snap to the nearest connect points in the shapes.
Draw freestanding lines
Draw a line from a point in space to a shape

{button Related Topics,PI(`',`IDH_RT_Connecting_Shapes_with_Lines')}



Determining the Way Lines Look
To connect two shapes by clicking
To connect two shapes by dragging
To connect two shapes with a multisegment line

To choose line routing type



DrawLine Method
DrawFreeLine Method
DrawLinetoOneObject Method



Attaching Text to Lines
{button Tell me how . . .,PI(`',`IDH_HT_Attaching_Text_to_Lines')}

You can attach text to lines in a chart by typing the text when the line is selected or by attaching an 
existing text block.
Text on lines can describe the flow of information and relationships between connected shapes. You 
can choose the font, size, style, and color for one or more characters in the text.
Text can be positioned anywhere on a line. When you move a line, the attached text moves with it.

{button Related Topics,PI(`',`IDH_RT_Attaching_Text_to_Lines')}



Determining the Way Text Looks
To add text to a line
To attach existing text to a line



To add text to a line
To attach existing text to a line



Line Options
{button OLE Automation,PI(`',`IDH_OA_Line_Options')}

When you connect shapes with right angle lines, you can choose how far the line segments are 
offset from the shapes. This feature is useful if the line segments are too short or too long. Your 
choice affects only right angle lines. The spacing options are set in the Line Spacing tab of the Tools 
Options dialog box.

Horizontal spacing
The Horizontal shape spacing option lets you set the amount of horizontal space between lines and 
shapes.

Vertical spacing 
The Vertical shape spacing option lets you set the amount of vertical space between lines and 
shapes.
For example, the following picture shows a vertical spacing of one inch.    When the line was drawn, 
it automatically turned at a right angle one inch above the shape.

{button Related Topics,PI(`',`IDH_RT_LINESPACE')}



To set the line spacing
Options command (Tools menu)



LineSpacingX Property)
LineSpacingY Property)



Crossovers
{button Tell me how . . .,PI(`',`IDH_HT_Crossovers')}

You can set the style and size when lines cross over each other. You can choose from three different 
styles of line crossovers. If you do not choose a crossover style, the lines cross with no indication, 
which may make it difficult to tell which lines connect which shapes.

Bunny hops. If the line is on 
top, it shows the hop; if it is 
on the bottom, it shows as a 
solid line.
Broken lines. If the line is on 
top, it shows as a solid line; if 
it is on the bottom, it shows 
as a broken line.
Solid lines. If the line is on 
top, it shows as a solid line; if 
it is on the bottom, it shows 
as a solid line.

You can specify the crossover style of individual lines. Thus, if you have a bunny-hop line over a 
broken line, both the bunny hop and the gap are shown. If, however, you have a bunny-hop line 
under a broken line, two solid lines are shown. In general, it is best to use one crossover style 
throughout your chart.

Tip
When you draw a line, if the line crosses any existing lines or shapes it will go behind the lines 

or shapes. To bring the line to the front, select it and then click the Bring to Front button on the Arrange
toolbar.

You can specify the size of the crossover when one line crosses another. The setting applies to 
bunny hops and broken lines, but has no effect when the crossover style is solid lines.

Small

Medium

Large
You set the style and size of crossovers by clicking Crossovers in the Format menu, and then selecting 
the type and size you want. You also can choose the crossovers style by clicking the Crossovers button 
on the Formatting toolbar, and then clicking the type you want.

Crossovers button

{button Related Topics,PI(`',`IDH_RT_Crossovers')}



Using Control Points



To choose the line crossover



To reshape a curve
1 Click the Selector tool

Selector tool
2 Select the curved line you want to reshape. Control and edit points appear around the selected
object.
3 Point to an anchor point. The pointer changes to a cross with the Curved Line symbol.

Curved Line pointer
4 Press and hold the left mouse button, and drag the Curved Line pointer until that part of the 

curve is the size you want.
5 Release the mouse button.
6 Repeat steps 3 through 5 until the curve is the shape you want.
7 Point the cursor away from the shape when you are finished.

{button Related Topics,PI(`',`IDH_RT_Reshaping_Bezier_Curves')}



Using Control Points
What is an Object? 
Working with Objects 



Using Control Points
{button Tell me how . . .,PI(`',`IDH_HT_Using_Control_Points')}

Control points. are mathematically defined points that determine an object's edges. Control points 
are always connected to edit points., and there are control points for each edit point. Control points 
look like small checkerboards. Control points are displayed only when curve reshaping.

Edit points Control points with edit points
To display a curve's control points, click one of the edit points. Because there are control points for 
each edit point on an edge, you must decide which control points you want to use to reshape the 
curve. After a little experience with control point reshaping, this choice is usually obvious.
Dragging a control point changes the shape of the edge associated with the point.    Think of a 
control point as a magnet that attracts the edge. When you drag a control point, the edit point does 
not move. Instead, it anchors the control point to the object.
Control points control the angle of an edge as it leaves an anchor point. Control points affect both 
the direction and the distance that the edge travels to the next anchor point.
A control point usually appears above or below the edge it controls. Dragging the control point 
moves the edge toward the control point’s location.

Before curve 
reshaping

Curve during reshaping After curve reshaping

Tip
When you move the mouse pointer over a control point, FlowCharter draws a preview line 

between the control point and its anchor. This lets you quickly identify the anchor to which a control 
point is connected.

{button Related Topics,PI(`',`IDH_RT_Using_Control_Points')}



To reshape a line with control points
To edit connect points with the Edit tool 
To edit objects by moving object points 
To edit shapes with the Edit tool 
To edit text layout with the Edit tool 



What is an Object? 
Working with Objects 



To choose line styles using the Format menu
1 To change the style for existing lines as well as future lines, select the lines you want to change.
2 On the Formatting menu, click Line.
3 To change the line color, click the down arrow by the Color box and select the color.
4 To change the line weight for a solid line, click the up or down arrow by the Weight box.
5 To change the line style, click the down arrow by the Style box and select the style.
6 Click the Ends tab.
7 To change the Start or End arrowhead type, click the down arrow by the Type box and select the 

type.
8 To change the Start or End arrowhead size, click the up or down arrow by the Size box.
9 To change the Start or End arrowhead color, click the down arrow by the Color box and select the 

color.
10 To change the crossovers type, click the type.
11 To change the crossovers size, click the up or down arrow by the Size box.
12 When the line in the Preview box looks the way you want it, click OK.

Tips
Use the Apply button to make your changes and view the results without closing the dialog 

box.
If you have a line selected when you change line styles, the changes will affect the selected 

line and any new line that you place.
You also can use the buttons on the Formatting toolbar.
You also can choose a preset style in the Line Styles list on the Preset Styles toolbar.
The line weight for dotted and dashed lines is hairline. You cannot draw a dotted or dashed line

with a heavy line weight.

{button Related Topics,PI(`',`IDH_RT_To_choose_line_styles_using_the_Format_menu')}



Choosing Line Styles That Enhance Your Chart
Crossovers
Determining the Way Lines Look
Preset Line Styles

To change the way existing lines look
To choose arrowhead styles
To choose line routing type
To choose line styles for new lines
To choose a preset line style

Format menu
Formatting toolbar



To change line color
1 To change the color of existing lines as well as future lines, select the lines you want to change.
2 On the Formatting menu, click Line.
3 Click the down arrow by the Color box and select the color.
4 When the line in the Preview box looks the way you want it, click OK.

Tips
Use the Apply button to make your changes and view the results without closing the dialog 

box.
If you have a line selected when you change line color, the changes will affect the selected line

and any new line that you place.
You can also use the Line Color button on the Formatting toolbar.

Line Color button
You can also choose a preset style in the Line Styles list on the Preset Styles toolbar.

{button Related Topics,PI(`',`IDH_RT_To_choose_line_styles_using_the_Format_menu')}



To choose line styles for new lines
1 Click the Connector Lines tool.

Connector 
Lines tool

2 Click a line type:

Direct 
Line

Right 
Angle 
Line

Curved 
Line

Org 
Chart 
Line

Cause 
and 
Effect 
Line

3 To set the color, on the Formatting toolbar, click the down arrow by the Line Color button, and 
click the color you want.

Line Color button
4 To set the line style, click the Line Style button, and click a style.

Line Style button
5 To set the line weight for a solid line, click the Line Weight button, and click a weight.

Line Weight button
6 To set the arrowhead styles, click the Arrowheads button, and click an arrowhead.

Arrowheads button
7 To see additional arrowhead styles or to set arrowhead weight and color, in the Arrowheads list,
click More.
8 To change the crossover style, click the Crossovers button, and click a style.

Crossovers button
9 Draw your connected line or drawn line.
Tips

If you have a line selected when you choose styles, the changes will affect the selected line 
and any new lines that you place.

You also can use the Line and Ends commands on the Format menu.
You also can choose a preset style in the Line Styles list on the Preset Styles toolbar.
The line weight for dotted and dashed lines is hairline. A dotted or dashed line cannot have a 

heavier line weight.
You can drag the formatting buttons off the toolbar to make floating palettes.

{button Related Topics,PI(`',`IDH_RT_To_choose_line_styles_for_new_lines')}



Choosing Line Styles That Enhance Your Chart
Crossovers
Determining the Way Lines Look
Preset Line Styles

To change the way existing lines look
To choose arrowhead styles
To choose line routing type
To choose a preset line style

To choose line styles using the Format menu
Format menu
Formatting toolbar



To change the way existing lines look
1 Click the Selector tool.

Selector tool
2 Select the line or lines that you want to change.
3 To set the line color, on the Formatting toolbar, click the down arrow by the Line Color button, 
and then click the color you want in the palette. (To return the line to the color defined by your 
Windows color scheme, click Automatic.)

Line Color button
4 To set the line style, click the Line Style button, and click a style.

Line Style button
5 To set the line weight for a solid line, click the Line Weight button, and click a weight.

Line Weight button
6 To set the arrowhead styles, click the Arrowheads button, and click an arrowhead.

Arrowheads button
7 To see additional arrowhead styles or to set arrowhead weight and color, in the Arrowheads list,
click More.
8 To change the crossover style and size for this line only, click the Crossovers button, and click a
style.

Crossovers button
Tips

If you have a line selected when you choose styles, the changes will affect the selected line 
and any new lines that you place.

You also can use the Line and Ends commands on the Format menu.
You also can choose a preset style in the Line Styles list on the Preset Styles toolbar.
The line style for dotted and dashed lines is hairline. You cannot draw a dotted or dashed line 

with a heavy line weight.
You can drag the formatting buttons off the toolbar to make floating palettes.

{button Related Topics,PI(`',`IDH_RT_To_change_how_existing_lines_look')}
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To choose arrowhead styles
To choose line styles for new lines
To choose a preset line style

Format menu
Formatting toolbar



To select more than one line, press shift and click the left mouse button on each line.



To make a line dotted or dashed
1 Select the line or lines you want to be dotted.
2 On the Formatting toolbar, click the Line Style button.

Line Style button
3 Select the line style you want.
Tips

You can also format new lines to be dotted or dashed.
If you want to use this line style frequently, add a preset line style.

{button Related Topics,PI(`',`IDH_RT_To_make_a_line_dotted_or_dashed')}



To choose line styles for new lines
To add a preset line style

Choosing Line Styles That Enhance Your Chart
Determining the Way Lines Look
Format menu
Formatting toolbar



A line's style is the pattern that the line has. A line can be solid, dotted, or dashed.    To change a line
style, click the Line Style button.

Line Style button



You can save a line's style, color, weight, crossover, and arrowhead settings as a preset style. 



To choose arrowhead styles
1 Click the Connector Lines tool.

Connector Lines tool
2 On the Formatting toolbar, click the Arrowheads button.

Arrowheads button
3 Click the arrowhead you want, or click More to access additional options.
4 If you clicked More:

Select a different Source arrowhead.
Select a different Destination arrowhead.
Select a different Source arrowhead size.
Select a different Destination arrowhead size.

Select a different Source arrowhead color.
Select a different Destination arrowhead color.

{button Related Topics,PI(`',`IDH_RT_To_choose_line_end_styles')}



To change the way existing lines look
To choose line styles for new lines

Format menu
Formatting toolbar
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Determining the Way Lines Look



To add a preset line style
1 If the Formatting toolbar is not displayed, on the View menu, click Toolbars, and then click 

Formatting.
2 Make sure no line is selected.    
3 Choose the line formats for the style you want to create (color, style, weight, arrowheads).
4 On the Preset Styles toolbar, click the Add Line Style button. The line styles are stored as a single

item in the Line Styles list.

Add Line Style button
Tip

You also can add a line style to the list by selecting a line with the desired style in steps 2 and 
3. If multiple lines are selected, the Add Style button is inoperative.

{button Related Topics,PI(`',`IDH_RT_To_add_a_preset_line_style')}
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To choose a preset line style
To rename a preset line style
To delete a preset line style
Preset Styles toolbar



To choose a preset line style
1 Click the Connector Lines tool.

Connector Lines tool
2 If you want to apply the preset style to an existing line, select the line(s) to which you want to 
apply the style.
3 On the Preset Styles toolbar, click the down arrow to the right of the Line Styles box. The Line 
Styles list opens.
4 Click the line style you want. The style is applied to the selected line.
Tips

If no line is selected, the preset style becomes the current line style.
If you select a line before you choose a line style, the style is applied to the selected line and 

to future lines.

{button Related Topics,PI(`',`IDH_RT_To_choose_a_preset_line_style')}



To add a preset line style
To rename a preset line style
To delete a preset line style
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Determining the Way Lines Look
Preset Line Styles



To rename a preset line style
1 Click the Connector Lines tool.

Connector Lines tool
2 In the Preset Styles toolbar, click the Edit Line Style button.

Edit Line Styles button
3 Click the line style you want to rename.
4 Click Rename, and then type the new name in the Rename Style box.

{button Related Topics,PI(`',`IDH_RT_To_rename_a_preset_line_style')}



To add a preset line style
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Preset Styles toolbar
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Preset Line Styles



To delete a preset line style
1 Make sure no lines are selected.
2 Click the Connector Lines tool.

Connector Lines tool
3 On the Preset Styles toolbar, click the Edit Line Styles button to the right of the Line Styles box.

Edit Line Styles button
4 Click the line style you want to delete.
5 Click Remove. The style is removed from the Line Styles list.

{button Related Topics,PI(`',`IDH_RT_To_delete_a_preset_line_style')}



To add a preset line style
To choose a preset line style
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Preset Styles toolbar
Determining the Way Lines Look
Preset Line Styles



To choose line routing types
1 Click the Connector Lines tool.

Connector Lines tool
2 Click the type of line you want; there is a tool for each type: 

Direct 
Line

Right 
Angle 
Line

Curved
Line

Org 
Chart 
Line 
tool

Cause 
and 
Effect 
Line 
tool

3 Select any line style that you want.

Tip
Add a preset style to define a frequently used line type and style combination.

{button Related Topics,PI(`',`IDH_RT_To_choose_line_routing_type')}



To choose line styles for new lines
Determining the Way Lines Look
Connector Lines tool
Direct Line tool

Right Angle Line tool
Curved Line tool
Org Line tool
Cause and Effect Line tool

Toolbox toolbar



To connect two shapes by clicking
1 Click the Connector Lines tool.

Connector Lines tool
2 Click the line type you want.
3 Point to the first shape and click the left mouse button. A solid line is attached to the pointer.
4 Move the pointer to the side of the first shape where you want the line to begin. Do not press 
the left mouse button as you move the pointer.
5 Move the pointer to the side of the second shape where you want the line to end.
6 Click the left mouse button. A line is drawn between the two shapes.
Tip

If the line crosses any existing lines or shapes, it will go behind the lines or shapes. To bring the
line to the front, select it and then click the Bring to Front button on the Arrange toolbar.

{button Related Topics,PI(`',`IDH_RT_To_connect_two_shapes_by_clicking')}



To connect two shapes by dragging
To connect two shapes with a multisegment line
To choose line routing type

Connecting Shapes with Lines
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To connect two shapes by dragging
1 Click the Connector Lines tool.

Connector Lines tool
2 Click the line type you want.
3 Select any line style you want.
4 Point inside the first shape, press and hold the left mouse button, then drag the pointer to the 
side of the first shape where you want the line to begin. A line traces the movement of the pointer.
5 Trace the path you want the line to follow.
6 Drag the pointer to the side of the second shape where you want the line to end.
7 Release the mouse button. A line is drawn between the two shapes.
Tips

Press the Ctrl key as you draw a line to prevent it from snapping to nearby shapes and lines. 
(Note, however, that for direct lines, the Ctrl key forces lines in 15-degree increments. Ishikawa lines 
automatically draw at 15-degree increments; for them, the Ctrl key releases that constraint.) The 
starting and ending points of the line still snap to connect points in shapes, which may override the 15-
degree angle.

If the line crosses any existing lines or shapes, it will go behind the lines or shapes. To bring the
line to the front, select it and then click the Bring to Front button on the Arrange toolbar.

{button Related Topics,PI(`',`IDH_RT_To_connect_two_shapes_by_dragging')}
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To connect two shapes with a multisegment line
1 Click the Connector Lines tool.

Connector Lines tool
2 Click the Direct Line tool.

Direct Line tool
3 Select any line style you want.
4 Click inside the first shape. A line is attached to the pointer.
5 Move the pointer to the side of the first shape where you want the line to begin. Do not press 
the left mouse button as you move the pointer.
6 Move the pointer to a blank area in the chart and click the left mouse button.
7 Repeat step 5 to define additional line segments outside the shapes.
8 Move the pointer to the side of the second shape where you want the line to end.
9 Click the left mouse button. A multisegment line is drawn between the two shapes.

Tips
Press the Ctrl    key as you draw a line to prevent it from snapping to nearby shapes and lines. 

(Note, however, that for direct lines, the Ctrl key forces lines in 15-degree increments. Ishikawa lines 
automatically draw at 15-degree increments; for them, the Ctrl key releases that constraint.) The 
starting and ending points of the line still snap to connect points in shapes, which may override the 15-
degree angle.

If the line crosses any existing lines or shapes, it will go behind the lines or shapes. To bring the
line to the front, select it and then click the Bring to Front button on the Arrange toolbar.

{button Related Topics,PI(`',`IDH_RT_To_connect_two_shapes_with_a_multisegment_line')}
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To draw an unconnected line
1 Click the Connector Lines tool.

Connector Lines tool
2 Click the line type tool you want.
3 Point where you want the unconnected line to begin, and click the left mouse button.
4 Point where you want the line segment to end, and click the left mouse button.
Tips

Press the Ctrl    key as you draw a line to prevent it from snapping to nearby shapes and lines. 
(Note, however, that for direct lines, the Ctrl key forces lines in 15-degree increments. Ishikawa lines 
automatically draw at 15-degree increments; for them, the Ctrl    key releases that constraint.) The 
starting and ending points of the line still snap to connect points in shapes, which may override the 15-
degree angle.

If the line crosses any existing lines or shapes, it will go behind the lines or shapes. To bring the
line to the front, select it and then click the Bring to Front button on the Arrange toolbar.

{button Related Topics,PI(`',`IDH_RT_To_draw_an_unconnected_line')}
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To show and hide nodes
1 On the Format menu, click Chart Properties.
2 Click the Indicators tab.
3 Click the Show Nodes On Lines check box. When the box is checked, nodes are shown. When it is 

not checked, nodes are hidden.

Tip
Nodes help you distinguish between connecting lines and lines that merely overlap. Nodes are 

represented by small solid circles at the intersection.

{button Related Topics,PI(`',`IDH_RT_To_show_and_hide_nodes')}
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Shows or hides the nodes on lines.



To attach existing text to a line

{button Show me how . . .,PI(`',`IDH_AVI_toattachtexttolines0062')}
1 Click the Selector tool.

Selector tool
2 Select the text block. (If you create a new text block, press Esc to quit changing.)
3 Drag the text onto the line. It snaps into place.
4 Drag the text block to the middle or end of a line in the chart. A blue outline of the text block 
moves with the pointer.
5 Release the mouse button when the blue outline snaps to the line where you want it.
Tips

You can snap text blocks to any point on a line. You can slide text anywhere along the line by 
dragging it. When you move the line, the text block stays snapped and moves with the line.

You can unsnap the text from the line by selecting it and dragging it off the line.
To prevent a text block from snapping to a line when you position it near a line, press and hold 

shift while dragging it into place.

{button Related Topics,PI(`',`IDH_RT_To_attach_text_to_a_line')}
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Attaching Text to Lines
To add text to a line
Toolbox toolbar



To add text to a line 
1 Click the Text tool.

Text tool
2 Click the line to which you want to add text.
3 Type the text you want. The text appears on the selected line.
4 Press Esc when you are finished entering text.
5 If the text is not positioned where you want it, select the text with the Selector tool and drag it 
along the line.

Selector tool
Tip

If the text you type exceeds the space in the text rectangle, you can resize the text rectangle 
as you would a shape.

{button Related Topics,PI(`',`IDH_RT_To_add_text_to_a_line')}



Attaching Text to Lines
To attach existing text to a line
Toolbox toolbar



To reshape a line with control points
1 Select the curved line you want to reshape. The line displays anchor points and control points.
2 Click the Selector tool.

Selector tool
3 Move the pointer to a control point. The pointer shows a handle, and a direction line appears 
between the control point and the associated anchor point.
4 Drag the control point to adjust the curved line.
5 Repeat steps 3 and 4 to continue reshaping.
6 Click the left mouse button to finish reshaping the line.

{button Related Topics,PI(`',`IDH_RT_To_reshape_a_line_with_control_points')}



Using Control Points
Toolbox toolbar



To connect a new line to an existing line
1 Click the Connector Lines tool.

Connector Lines tool
2 Click the line type you want.
3 Select any line styles that you want.
4 Point to the line to which you want to connect the new line, and click the left mouse button. 
(You must place the end point of the new line directly on top of the first line while starting the new 
line.)
5 Point where you want the new line segment to end, and click the left mouse button.
Tips

You can use Direct Line to draw multisegment lines by pointing and clicking repeatedly as you 
move the cursor. To end the final line segment, double-click the left mouse button instead of single 
clicking.

Direct Line
When you move a line that is connected to other lines, the connected lines move as well.
If the Show Nodes On Lines option is selected in the Format Chart - Indicators tab dialog box, a 

node (small solid circle) appears at the point at which two lines are connected.
You cannot disconnect connected lines.

{button Related Topics,PI(`',`IDH_RT_To_connect_a_new_line_to_an_existing_line')}
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To create an organization chart
1 On the File menu, click New.
2 Click the Connector Lines tool.

Connector Lines tool
3 Click Org Line.

Org Line 
4 On the Formatting toolbar, click the Arrowheads button, and click the first arrowhead style in 
the list (no arrow).

Arrowheads button
5 Click the first shape (Process) in the Standard Shape palette, and click in the chart window to 
place the top shape.
6 Press and hold the left mouse button, and drag the pointer straight down out of the top shape.
7 Release the mouse button.
8 Point again inside the top shape.
9 Press and hold the left mouse button, and drag another shape straight down until it is directly 

over the shape below. Continue pressing the mouse button.
10 Drag the new shape to the right. This aligns the two shapes.
11 Release the mouse button.
12 Repeat steps 8 through 11 to place a connected shape at the left on the row.

Tip
You also can create an organization chart with the Organization Chart demo file.

{button Related Topics,PI(`',`IDH_RT_To_create_an_organization_chart')}



Org Line tool
Toolbox toolbar



To create a cause-and-effect chart from the template
1 On the File menu, click Open.
2 Choose the Samples subdirectory.
3 In the Files of type box, select Micrografx ABC Template (*.aft).
4 Double-click Causeff.aft.
5 On the File menu, click Save As.
6 Enter a new name in the File name box.
7 Click Save.
8 Click the Selector tool.

Selector tool
9 Scroll to the Effect shape on the right side of the diagram.
10 Click the Effect shape, and type a new label. (The new label replaces the old label.)
11 Repeat for the rest of the Cause shapes.
12 Click the line label for a sub-cause and type a new label.
13 Repeat step 12 for the rest of the cause lines.

Tips
You also can create a cause-and-effect diagram with the Cause and Effect Line tool.
Press the Ctrl key as you draw a line to prevent it from snapping to nearby shapes and lines. 

(Note, however, that for direct lines, the Ctrl key forces lines in 15-degree increments. Ishikawa lines 
automatically draw at 15-degree increments; for them, the ctrl key releases that constraint.) The 
starting and ending points of the line still snap to connect points in shapes, which may override the 15-
degree angle.

To move a line, drag from the center of the line. The label follows the line.
To duplicate a line, press Ctrl while you drag an existing line.
To delete the “How-To Hints” shape, select it and press del.
To delete unused cause and sub-cause lines, select the lines you want to delete and press del.
To draw a new cause or sub-cause line, click Cause and Effect. Click the line to which the new 

line will be attached. Click the line end. Type a cause or sub-cause.

Cause and Effect Line

{button Related Topics,PI(`',`IDH_RT_To_create_a_cause_and_effect_diagram_from_the_template')}



Cause and Effect Line tool
Toolbox toolbar



To set the line spacing
1 On the Tools menu, click Options.
2 Click the Line Spacing tab, if necessary.
3 Click the Horizontal box and enter the distance you want between the shape and the first right 

angle of a horizontal line.
4 Click the Vertical box and enter the distance you want between the shape and the first right 

angle of a horizontal line.

Tips
The line weight for dotted and dashed lines is hairline. A dotted or dashed line cannot have a 

heavier line weight.
The units to be used (inches or centimeters) are displayed next to the box. The units apply to 

the whole chart. To change the units, click the ruler with your right mouse button, select Units and click
the units you want.

You can also create a toolbar with the inches and centimeters buttons. To do this, click Tools, 
click Customize, and click the View category. Click on the buttons, drag them outside of the Customize 
dialog box, and drop them. (When you drop the second button, be sure it is more or less on top of the 
first button. That way, it gets added to the same toolbar instead of creating a second toolbar with one 
button in it.) Now that you have a toolbar with the inches and centimeter buttons, you can click them 
to change the unit of measurement.

{button Related Topics,PI(`',`IDH_RT_To_choose_the_line_offset')}



Line Options
To choose the line crossover
Toolbox toolbar



To choose the line crossover
1 On the Format menu, click Ends.
2 Select the type for the intersection you want when one line crosses over another one.
3 If you have selected the dashed line or bunny-hop line option, select the size for the intersection 

you want when one line crosses over another one.

{button Related Topics,PI(`',`IDH_RT_To_choose_the_line_crossover')}
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Notes Overview
{button OLE Automation,PI(`',`IDH_OA_Notes')}

The Note window contains text you have attached to a certain shape.
You can open and close the Note window using the Note command on the View menu or by pressing 
Alt + F6.
You can attach notes to each shape and hide or show the notes, depending upon your needs. Notes 
can contain detailed information about a step or process that you do not want to display in a chart.
You enter and change notes inside the Note window. The Note window displays the shape number of
the selected shape (if any) and the text attached to the shape. You can move and resize the Note 
window like other windows.
If you select a different shape while the Note window is open, the text is updated. You can change 
and choose the font, size, style, and color for the text in the Note window the same as you can for 
text in shapes, text blocks, and line segments.

{button Related Topics,PI(`',`IDH_RT_Notes')}



Note menu
View menu
To attach a note to a shape
To open and close the Note window

To print a note
To delete text in the Note window



NoteText Property
NoteViewerVisible Property



To open and close the Note window
Click Note on the View menu.

Tips
You can press Alt + F6 to open and close the Note window.
You can double-click the control menu box on the Note window to close it.

{button Related Topics,PI(`',`IDH_RT_To_open_and_close_the_Note_window')}



Notes Overview
To attach a note to a shape
To print a note
View menu



To attach a note to a shape
1 If the Note window is not displayed, click Note on the View menu.
2 Click the Selector tool.

Selector tool
3 Select the shape to which you want to attach a note.
4 Click in the Note window, and type the information you want.
5 Repeat steps 3 through 5 to attach notes to other shapes.
6 Close the Note window when you are finished.

Tips
You can press Alt+F6 to open and close the Note window.
You can double-click the control menu box on the Note window to close it.

{button Related Topics,PI(`',`IDH_RT_To_attach_a_note_to_a_shape')}



Notes Overview
To open and close the Note window
To print a note
View menu



To cut text in the Note window
1 If the Note window is not displayed, click Note on the View menu.
2 Select the shape to which the note is attached.
3 Point inside the Note window. The pointer changes to the I-beam pointer. You use the I-beam 

pointer to define the insertion point and select text.
4 Select the text you want to cut.
5 On the Note menu, click Cut.

Tip
You also can press Ctrl+X to cut text in the Note window.
You can press Alt+F6 to open and close the Note window.
You can double-click the control menu box on the Note window to close it.

{button Related Topics,PI(`',`IDH_RT_To_cut_text_in_the_Note_window')}



Notes Overview
To attach a note to a shape
To open and close the Note window
To print a note

To copy text in the Note window
View menu



To copy text in the Note window
1 If the Note window is not displayed, click Note on the View menu
2 Select the shape to which the note is attached.
3 Point inside the Note window. The pointer changes to the I-beam pointer. You use the I-beam 

pointer to define the insertion point and select text.
4 Select the text you want to copy.
5 On the Note menu, click Copy.

Tip
You also can press Ctrl+C to cut text in the Note window.
You can press Alt+F6 to open and close the Note window.
You can double-click the control menu box on the Note window to close it.

{button Related Topics,PI(`',`IDH_RT_To_copy_text_in_the_Note_window')}
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To paste text in the Note window
1 Select the shape into which you want to paste text.
2 If the Note window is not displayed, click Note on the View menu.
3 Point inside the Note window. The pointer changes to the I-beam pointer. You use the I-beam 

pointer to define the insertion point.
4 On the Note menu, click Paste.

Tip
You also can press Ctrl+V to paste text in the Note window.
You must have text copied in the Clipboard before pasting.
You can press Alt+F6 to open and close the Note window.
You can double-click the control menu box on the Note window to close it.

{button Related Topics,PI(`',`IDH_RT_To_paste_text_in_the_Note_window')}
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View menu



To delete text in the Note window
1 If the Note window is not displayed, click Note on the View menu.
2 Select the shape to which the note is attached.
3 Point inside the Note window. The pointer changes to the I-beam pointer. You use the I-beam 

pointer to define the insertion point and select text.
4 Select the text you want to delete.
5 On the Note menu, click Clear or press the Del key.

Tip
You can press Alt+F6 to open and close the Note window.
You can double-click the control menu box on the Note window to close it.

{button Related Topics,PI(`',`IDH_RT_To_delete_text_in_the_Note_window')}



Note menu
To attach a note to a shape
To open and close the Note window



To print a note
1 If the Note window is not displayed, click Note on the View menu.
2 Select the shape to which the note is attached.
3 On the Note menu, click Print. The Print dialog box opens.
4 Choose Current Note.
5 Choose the print options you want.
6 Click OK.

Tip
You can press Alt+F6 to open and close the Note window.
You can double-click the control menu box on the Note window to close it.
When you print a note, the wrapped text in the Note window moves onto one line. To rewrap 

the text, point to the Note window border, press and hold the left mouse button, and drag the border 
out until the entire line of text appears (or drag the window border out and back to its former size). The
text rewraps in the window.

{button Related Topics,PI(`',`IDH_RT_To_print_a_note')}



Note menu
To attach a note to a shape
To open and close the Note window
To print all notes



To print all notes
1 If the Note window is not displayed, on the View menu, click Note.
2 On the Note menu, click Print .
3 Choose Pages from 1 to 1.
4 Choose the print options you want.
5 Click OK.

Tip
You can press Alt+F6 to open and close the Note window.
You can double-click the control menu box on the Note window to close it.
When you print a note, the wrapped text in the Note window will move onto one line. To rewrap

the text, point to the Note window border, press and hold the left mouse button, and drag the border 
out until the entire line of text appears (or drag the window border out and back to its former size). The
text rewraps in the window.

{button Related Topics,PI(`',`IDH_RT_To_print_all_notes')}



Note menu
To attach a note to a shape
To open and close the Note window
To print a note



Note menu
The Note menu appears in the Note window. You use the Note window to attach text information to 
shapes. The Note menu contains commands you use to change and print the text in the Note 
window.

Cut command
Copy command
Paste command
Clear command
Print command
Close command

{button Related Topics,PI(`',`IDH_RT_Note_Menu')}



Notes Overview



Cut command (Note Menu)
The Cut command on the Note menu removes the selected text from the Note window and places a 
copy of the text on the Clipboard.

Tip
You also can press Ctrl+X to cut text in the Note window.

{button Related Topics,PI(`',`IDH_RT_NoteCut')}



Note menu



Copy command (Note Menu)
The Copy command on the Note menu copies the selected text in the Note window and places the 
copy on the Clipboard.

Tip
You also can press Ctrl+C to cut text in the Note window.

{button Related Topics,PI(`',`IDH_RT_NoteCopy')}



Note menu



Paste command (Note menu)
The Paste command on the Note menu places the text on the Clipboard into the Note window.

Tip
You also can press Ctrl+V to paste text in the Note window.

{button Related Topics,PI(`',`IDH_RT_NotePaste')}



Note menu



Clear command (Note menu)
The Clear command removes the selected text from the Note window. It does not place a copy of 
the text on the Clipboard.

{button Related Topics,PI(`',`IDH_RT_NoteClear')}



Note menu



Print command (Note menu)
The Print command lets you print the text in the Note window. When you choose the Print command,
a dialog box opens. Use this dialog box to choose print options and print the text.

{button Related Topics,PI(`',`IDH_RT_NotePrint')}



Note menu
To print a note 



Close command (Note menu)
The Close command closes the Note window.

{button Related Topics,PI(`',`IDH_RT_NoteClose')}



Note menu



Lets you print the text in the Note window. When you choose the Print command, a dialog box 
opens. Use this dialog box to choose print options and print the text.



Removes the selected text from the Note window and places a copy of the text on the Clipboard.



Copies the selected text in the Note window and places the copy on the Clipboard.

Tip
You also can press Ctrl+C to cut text in the Note window.



Places the text on the Clipboard into the Note window.

Tip
You also can press Ctrl+V to paste text in the Note window.



Removes the selected text from the Note window. It does not place a copy of the text on the 
Clipboard.



Closes the Note window.



The Note window contains text you have attached to a certain shape. You can open and close the 
Note window using the Note command on the View menu or by pressing Alt + F6. You can attach 
notes to each shape and hide or show the notes, depending upon your needs. Notes can contain 
detailed information about a step or process that you do not want to display in a chart.
You enter and change notes inside the Note window. The Note window displays the shape number of
the selected shape (if any) and the text attached to the shape. You can move and resize the Note 
window like other windows.
If you select a different shape while the Note window is open, the text is updated. You can change 
and choose the font, size, style, and color for the text in the Note window the same as you can for 
text in shapes, text blocks, and line segments.



Selecting Objects
{button Tell me how . . .,PI(`',`IDH_HT_Selecting_Objects')}

The shapes, lines, and text blocks in your charts are all objects.
In general, you create objects with the shape, line, drawing, and text tools. Once you have created 
an object, you can select it using the Selector tool. 

Selector tool
After you have selected an object, you can move it around on the chart, change its orientation, resize 
it, or change its style attributes such as color, font, or line weight.

{button Related Topics,PI(`',`IDH_RT_Selecting_Objects')}



To select an object
To select multiple groups 
To select multiple objects 
To resize multiple objects at the same time 

To resize multiple objects at the same time 
To change the properties for a selected shape 
To align objects
To space objects evenly

To make objects the same size
To rotate an object
To flip an object



Working with Objects
What is an Object?
Arrange menu



To select an object
1 Click the Selector tool.

Selector tool
2 Click the object you want to select.

Tips
To select multiple objects, press and hold Shift as you click each object.
You can use the Select All and Select commands on the Edit menu to select all objects, all 

shapes, all lines, and other special combinations quickly.
To select an object beneath other objects, press and hold Ctrl, and click the top object. As you 

continue to click, the objects below the top object are selected.

{button Related Topics,PI(`',`IDH_RT_To_select_an_object')}



To align objects
To bring an object to the front
To send an object to the back
To space objects evenly

To make objects the same size
To rotate an object
To rotate an object by angle
To flip an object

Arrange menu
Working with Objects



To bring an object to the front
1 Click the Selector tool.

Selector tool
2 Select the object you want to bring to the front.
3 On the Arrange menu, click Order.
4 Click the Bring to Front command. The selected object appears in front of all overlapping objects.

Tips
To select an object beneath other objects, press and hold CTRL, and click the top object. As 

you continue to click, the objects below the top object are selected.
You can also bring the object to front by clicking the Bring to Front button on the Arrange 

toolbar.

Bring to Front button

{button Related Topics,PI(`',`IDH_RT_To_bring_an_object_to_the_front')}



To select an object
To align objects
To send an object to the back
To space objects evenly

To make objects the same size
To rotate an object
To rotate an object by angle
To flip an object

Arrange menu



To send an object to the back
1 Click the Selector tool.

Selector tool
2 Select the object you want to move to the back.
3 On the Arrange menu, click Order.
4 Click the Send to Back command. The selected object appears behind all overlapping objects.

Tips
To select an object beneath other objects, press and hold CTRL, and click the top object. As 

you continue to click, the objects below the top object are selected.
You can also send the object to back by clicking the Send to Back button on the Arrange 

toolbar.

Send to Back button

{button Related Topics,PI(`',`IDH_RT_To_send_an_object_to_the_back')}



To select an object
To align objects
To bring an object to the front
To space objects evenly

To make objects the same size
To rotate an object
To rotate an object by angle
To flip an object

Arrange menu



To rotate an object
1 Click the Selector tool.

Selector tool
2 Select the object you want to rotate.
3 On the Arrange menu, click Order.
4 Click the Rotate/Flip command. 
5 Click either the Rotate Right command or the Rotate Left command.

Tip
You can also rotate the object by clicking the Rotate Right button or the Rotate Left button on 

the Arrange toolbar.

Rotate 
Right 
button

Rotate 
Left 
button

{button Related Topics,PI(`',`IDH_RT_To_rotate_an_object')}



To select an object
To align objects
To bring an object to the front
To send an object to the back

To space objects evenly
To make objects the same size
To rotate an object by angle
To flip an object

Arrange menu



To rotate an object by angle
1 Click the Selector tool.

Selector tool
2 Select the object you want to rotate.
3 On the Arrange menu, click Rotate/Flip.
4 Click the Angle command. 

Tip
Use the Apply button to make your changes and view the results without closing the dialog 

box.

{button Related Topics,PI(`',`IDH_RT_To_rotate_an_object_by_angle')}



To select an object
To align objects
To bring an object to the front
To send an object to the back

To space objects evenly
To make objects the same size
To rotate an object

To flip an object
Arrange menu



To flip an object
1 Click the Selector tool.

Selector tool
2 Select the object you want to flip.
3 On the Arrange menu, click Rotate/Flip.
4 Click either Flip Horizontal or Flip Vertical.

Tip
On the Arrange toolbar, click either the Flip Horizontal button or the Flip Vertical button.

Flip 
Horizontal
button

Flip 
Vertical 
button

{button Related Topics,PI(`',`IDH_RT_To_flip_an_object')}



To select an object
To align objects
To bring an object to the front
To send an object to the back

To space objects evenly
To make objects the same size
To rotate an object
To rotate an object by angle

Arrange menu



To align objects
1 Click the Selector tool.

Selector tool
2 Select the objects you want to align.
3 On the Arrange menu, click Align.
4 Click Left, Center, Right, Page Center, Top, Middle, Bottom, or Page Middle.

Tip
There are shortcut keys for aligning shapes: Align Top (Alt+4), Align Middle (Alt+6), Align 

Bottom (Alt+8), Align Left (Alt+3), Align Center (Alt+5), and Align Right (Alt+7).
You can also use the align buttons (Align Left, Align Center, Align Right, Align Top, Align Middle, 

or Align Bottom) on the Arrange toolbar.

{button Related Topics,PI(`',`IDH_RT_To_align_objects')}



To select an object
To bring an object to the front
To send an object to the back
To space objects evenly

To make objects the same size
To rotate an object
To rotate an object by angle
To flip an object

Arrange menu



To make objects the same size
1 Click the Selector tool.

Selector tool
2 Select the objects you want to make the same size.
3 On the Arrange menu, click Make Same Size.
4 Click Width, Height, Both, or Fit to Text.

Tip
You can also use the Make Same Size buttons on the Arrange toolbar.

Make 
Same Size,
Width 
button

Make Same 
Size, Height 
button

Make 
Same Size,
Both 
button

Make Same 
Size, Fit to 
Text button

{button Related Topics,PI(`',`IDH_RT_To_make_objects_the_same_size')}



To select an object
To align objects
To bring an object to the front
To send an object to the back

To space objects evenly
To rotate an object
To rotate an object by angle
To flip an object

Arrange menu



To space objects evenly
1 Click the Selector tool.

Selector tool
2 Select the objects you want to space evenly.
3 On the Arrange menu, click Space Evenly.
4 Click Across, Centers; Down, Centers; Across, Edges; or Down, Edges).

Tip
You also can use the Space Evenly Across, Centers; Space Evenly Down, Centers; Space Evenly

Across, Edges; and Space Evenly Down, Edges buttons.

Space 
Evenly 
Across, 
Centers 
button

Space 
Evenly 
Down, 
Centers 
button

Space 
Evenly 
Across, 
Edges 
button

Space 
Evenly, 
Down Edges 
button

{button Related Topics,PI(`',`IDH_RT_To_space_objects_evenly')}



To select an object
To align objects
To bring an object to the front
To send an object to the back

To space objects evenly
To make objects the same size
To rotate an object
To rotate an object by angle

To flip an object



To select a group
1 Click the Selector tool.

Selector tool
2 Move the cursor within the group you want to select.
3 Click the left mouse button. The group is selected when handles display around the group.

{button Related Topics,PI(`',`IDH_RT_To_select_a_group')}



To select multiple groups
To select multiple objects



To select multiple groups
1 Click the Selector tool.

Selector tool
2 Move the cursor to the group you want to select.
3 Click the left mouse button. The group is selected when handles display around the group.
4 Hold down the Shift key, and repeat steps 2 and 3 until you have selected all of the groups you 

wanted to select.

Tip
With the Select All command or Select command on the Edit menu, you can select all objects.

{button Related Topics,PI(`',`IDH_RT_To_select_multiple_groups')}



To select a group
To select multiple objects



To select multiple objects
1 On the Edit menu, click Select.
2 Click the check box for each of the object types you want to select:

Shapes
Lines
Text blocks
OLE objects

or
Click All to automatically check all of the object types.

Tip
You can specify whether to select all shape types or specify a shape type.

{button Related Topics,PI(`',`IDH_RT_To_select_multiple_objects')}



To select a group
To select multiple groups



Shape Palettes Overview
{button OLE Automation,PI(`',`IDH_OA_Shape_Palette_Overview')}
The Shape Palettes button on the Standard toolbar opens and closes the Shape palette. The Shape 

palette displays the shapes that you can place in a chart. When you open FlowCharter for the first 
time, a set of commonly used symbols appears in the Shape palette. The name of the Shape palette 
appears in the title bar. The available shapes appear as buttons in the palette.

Many additional shapes are available in the Shape palette files included with the program. 

Creating Custom Shapes
You can create a custom shape in a Windows drawing, painting, or image-changing program and 
insert it into a Shape palette. Any picture (monochrome, color vector, or bitmap) that you can copy 
from a Windows program can be pasted into a Shape palette. Once you have pasted the new shape 
into a Shape palette, you can name the shape, adjust its number and text area, define connect 
points, and choose other properties as for any other shape.

Reorganizing the Shape Palette
As you work with your charts, you may find that you use some shapes more often than others. In 
this case, you may prefer to have the commonly used shapes appear in the most convenient areas 
of the Shape palette. You also may want to organize related shapes together in the palette. You can 
easily arrange shapes any way you want. You can move shapes to the top or bottom of the palette 
or organize the shapes according to their functions.

Adding Shapes from Other Palettes
You can copy shapes from one Shape palette to another. This lets you create your own Shape 
palettes designed for specific purposes. For example, you could create a custom Shape palette for 
quality management flowcharts, documentation flowcharts, software design flowcharts, or any 
purpose you want. (Many program-specific Shape palettes are already provided.) Or you can add 
shapes you use often to one palette and work with this one palette on most of your projects. This 
saves you from having to open different palettes to access different shapes.

The Shape Palette and the Media Manager {button Tell me 
how . . .,PI(`',`IDH_HT_Shape_Palette_Media_Manager')}
The Shape palette is actually part of the Media Manager. The following terminology is used:

FlowCharter Media Manager
shape in a palette item in a subject
Some of the procedures that you can use with Media Manager that are helpful with FlowCharter are:

Opening a different Shape palette
Creating a new Shape palette
Arranging shapes in the Shape palette
Copying a shape from one palette to another
Moving a shape from one palette to another
Deleting shapes from the Shape palette

{button Related Topics,PI(`',`IDH_RT_Shape_Palette_Overview')}



Creating New Shapes
To add a shape from another program to FlowCharter 7
To create a compound shape in FlowCharter 7 and add it to the Shape palettes



CurrentShape Property



To open a different Shape palette
To create a new Shape palette
To arrange shapes in the Shape palette
To copy a shape from one palette to another
To move a shape from one palette to another
To delete shapes from the Shape palette



Using Shape Palettes in FlowCharter
{button Tell me how . . .,PI(`',`IDH_HT_Using_Shape_Palettes')}

FlowCharter has several shape palettes that you can use. The Shape palette displays the shapes 
that you can place in a chart. When you open FlowCharter for the first time, a set of commonly used
symbols appears in the Shape palette. The name of the Shape palette appears in the title bar. The 
available shapes appear as buttons in the palette.
Shapes in Shape palettes are organized in three levels:

Collections (Shape palette categories, for example, FlowCharter CoolSheet Palettes)
Subjects (group of related shapes, for example, Basic Diagram)
Items (individual shapes, for example, Decision)

Collections are made up of subjects, and subjects are made up of items.
Each Shape palette is a subject accessed from Media Manager. The Shape palette has one menu 
item: Options. Options has the following commands:

Subject (lists all of the subjects available for your use)
Find (finds a specific subject)
Last Find (performs the last find you did on FlowCharter)
Item (displays information on the shape and lets you copy, paste, or delete shapes)
Properties (displays information on the appearance and action of the Shape palette)
View (lets you select how you want to view the shapes in the Shape palette , for example, 

pictures or name)
Add Files (lets you add files for additional palettes)
Tools (converts Micrografx Clip Art)
Help (provides MediaManger help information)

{button Related Topics,PI(`',`IDH_RT_Using_Shape_Palettes')}



To copy a shape from one palette to another 
To display a new or different Shape palette 
To add a drawn object to a Shape palette 



Shape Palettes Overview 
Changing Shape Palettes 



Changing Shape Palettes
{button Tell me

how . . .,PI(`',`IDH_HT_Changing_Shape_palettes')}

FlowCharter standardly has the following Shape palettes available for your use with several subjects
under each:

FlowCharter Basic palettes
FlowCharter CoolSheet palettes
FlowCharter palettes
FlowCharter Technical palettes
Living Shapes
Media Manager
Office
People
Transportation

When you open FlowCharter , the program displays the Shape palette that you were using when you
closed FlowCharter.    You can change to another palette as many times as you want during a session
of FlowCharter and even display more than one palette at a time.

{button Related Topics,PI(`',`IDH_RT_Changing_Shape_palettes')}



Shape Palettes Overview
Using Shape Palettes in FlowCharter>large
Dragging Shapes to a Shape Palette 



To display a new or different Shape palette



Creating New Shapes
{button Tell me how . . .,PI(`',`IDH_HT_Creating_New_Shapes')}

You can create new shapes for use in the program. You can paste new shapes into a Shape palette 
and use them again in your charts.
The new shapes can come from a variety of sources. You can create new shapes, including 
compound shapes. A compound shape is a shape composed of two or more shapes (like a paper 
form). Or you can create a custom shape in a drawing program (such as Designer) or in a painting or
image-changing program (such as Picture Publisher) and paste it in as a FlowCharter shape.
This feature lets you create and use custom shapes in your charts. You can draw shapes to 
represent unique steps or objects and use them in your charts.
New shapes can be added to a palette from many sources, including

Other palette files
Combinations of other FlowCharter shapes
Computer clip art libraries
Drawings (from programs such as Micrografx Designer

)
Scanned images and pictures (from programs such as Picture Publisher®)

After you paste a new shape into a Shape palette, you can use the new shape just like any other 
FlowCharter shape.

{button Related Topics,PI(`',`IDH_RT_Creating_New_Shapes')}



To add a shape from another program to FlowCharter 7
To create a compound shape in FlowCharter 7 and add it to the Shape palettes



Shape Palette Overview



To create a compound shape in FlowCharter 7 and add it to the Shape palettes
1 Draw the shapes and lines that compose the compound shape in FlowCharter. The shape can be 

made up of multiple shapes and lines.
2 Select the new shape. Make sure you select all the lines and shapes in the new shape.
3 Open the Edit menu and choose Copy.
4 Open the Shape palette in which you want to store the new shape. Make sure the Shape palette 

is the active window.
5 On the Edit menu, click Paste.

{button Related Topics,PI(`',`IDH_RT_To_create_a_compound_shape')}



Shape Palette Overview
Creating New Shapes
To add a shape from another program to FlowCharter 7



To add a shape from another program to FlowCharter 7
1 Create the shape in the other program.
2 Select the shape you want in the other program.
3 Copy the shape to the Clipboard.
4 Open FlowCharter.
5 Open the Shape palette in which you want to store the new shape. Make sure the Shape palette 

is the active window.
6 On the Edit menu, click Paste.

Note
The changes you make to the Shape palette are saved automatically. You can reinstall any of 

the original palettes using the Installation program. First delete or rename the files you want to 
reinstall, then run the Installation program, choose Custom, and choose to install FlowCharter. (The 
installation process is fast because the Installation file replaces only older or missing files.)

{button Related Topics,PI(`',`IDH_RT_To_add_a_shape_from_another_application')}



To create a compound shape in FlowCharter 7 and add it to the Shape palettes
Creating New Shapes
Shape Palette Overview



Object Properties

You can change the object properties for any selected object. Object properties include:
Name (type) of the object
Using proportional resizing
Using the shape's default style
Rotating text with objects
Width and height of the object
Object ID, if the object is assigned a script
Script password (for reference, the object is provided)

{button Related Topics,PI(`',`IDH_RT_Shape_Properties')}



To change the properties for new shapes
To change the properties of an existing shape
Changing Object Properties



Changing Object Properties
{button Tell me how. . .,PI(`',`IDH_HT_Shape_Properties')}

Object properties are changed in the Object Properties dialog box, which is accessed by clicking the 
object and then clicking Object Properties on the Format menu. 

The properties you can change on the Properties tab include name, proportion, use of default 
style, ability to rotate text, and size. There is also a tab for Living FlowCharts on this dialog box that 
lets you apply a script password for the object, if applicable.

You can change the properties for objects already in a chart. This lets you assign behavior and sizes 
without changing the properties of the objects you place later.
You also can change the properties for new objects that you place in the chart.

{button Related Topics,PI(`',`IDH_RT_Changing_Shape_Properties')}



Object Properties
To change a Living FlowChart's password 



To change the properties for new objects
To change the properties of an existing object



To change the properties of an existing object
1 Select the object you want in the chart.
2 On the Format menu, click Object Properties.
3 Click the Properties tab, if necessary.
4 To resize the object proportionally, make sure the Resize Proportionally box is checked. Clear the 

box if you do want to resize theobject proportionally.
5 To keep the default style for new objects, make sure the Use Default Style When Dropped into 

New Chart box is checked. Clear the box if you do want to use default styles.
6 To rotate text with shapes, make sure the Rotate Text With Shape box is checked.    Clear the box 

if you do want to rotate text with objects.
7 To resize the object, enter the values in the Width and Height boxes.
8 Click OK.

Note
The properties you define are applied only to the selected object in the chart.

Tip
Use the Apply button to make your changes and view the results without closing the dialog 

box.

{button Related Topics,PI(`',`IDH_RT_To_change_the_properties_of_an_existing_shape')}



Object Properties
Changing Object Properties
To change the properties for new objects



To change the properties for new objects
1 Select the object you want in the chart.
2 On the Format menu, click Object Properties.
3 Click the Properties tab, if necessary.
4 To resize the object proportionally, make sure the Resize Proportionally box is checked. Clear the 

box if you do want to resize the object proportionally.
5 To keep the default style for new objects, make sure the Use Default Style When Dropped into 

New Chart box is checked. Clear the box if you do want to use default styles.
6 To rotate text with objects, make sure the Rotate Text With Shape box is checked.    Clear the box 

if you do want to rotate text with objects.
7 To resize the object, enter the values in the Width and Height boxes.
8 Click OK.

Note
The properties you define are applied only to the selected object in the chart.

Tip
Use the Apply button to make your changes and view the results without closing the dialog 

box.

{button Related Topics,PI(`',`IDH_RT_To_change_the_properties_for_new_shapes')}



Object Properties
Changing Object Properties
To change the properties of an existing object



Displays the name of the shape in the Shape palette that is selected. The next time you place a new
shape, it will be the one named here, until you select another shape in the Shape palette.



Displays the shapes that you can place in a chart.



To display a new or different Shape palette
1 Click the Shape Palettes button to open it, if necessary.

Shape Palettes button.
2 On the Shape palette, click Options.
3 Click Subject.
4 If the palette you want is not displayed, click Expand All.
5 Double-click the palette you want.
6 Click OK.
Tips

The Shape palette is actually the ABC Media Manager. 
The Standard Shape palette is under the FlowCharter Basic Palettes group.
To display more than one Shape palette, select the Open in New Window check box. This will 

display the Shape palette you currently have open and the new Shape palette. 

{button Related Topics,PI(`',`IDH_RT_To_display_a_new_or_different_shape_palette')}



To create a new Shape palette
To rearrange shapes in the Shape palette
To copy a shape from one palette to another

To delete shapes from the Shape palette
To create a compound shape in FlowCharter 7 and add it to the Shape palettes

Creating New Shapes
Shape Palette Overview



Dragging Shapes to a Shape Palette
{button Tell me how . . .,PI(`',`IDH_HT_Dragging_Shapes')}

The Shape palettes in FlowCharter have shapes for your immediate use. As you work more with 
FlowCharter, you will find that you want to customize the types of shapes on your Shape palettes.
FlowCharter allows you to customize your Shape palettes by dragging shapes to a Shape palette, 
regardless of whether you are creating your own or moving/copying from an existing Shape palette. 
This provides you with greater control over the flowcharts you create. You no longer have to create a
unique shape each time you want to use it, or save it to another file. After dragging it to a Shape 
palette and naming it, the shape is there for your use each time you open FlowCharter.

{button Related Topics,PI(`',`IDH_RT_Dragging_Shapes')}



Shape Palettes Overview 
Using Shape Palettes in FlowCharter 
Creating New Shapes 



To add a drawn object to a Shape palette
To copy a shape from one palette to another



To add a drawn object to a Shape palette
1 Open the Shape palette, if it is not open already. (On the View menu, click Shape Palettes.)
2 Click the Selector tool.

Selector tool
3 Put the cursor over the selected object.
4 When the cursor becomes a four-headed arrow, press the left mouse button and drag the 
object over the Shape palette.

Four-headed arrow
5 When the cursor becomes a pointer with a plus sign, drop the object onto the Shape palette 
(just release the left mouse button). The object is added to the Shape palette.
6 Double-click the new shape in the Shape palette.
7 Type the name of you new shape in the Name box.
8 Click OK. When you place your cursor over the shape, the ToolTip displays the name of your new 

shape.

Tip
If you drop the shape before the pointer changes, the shape is not added to the palette.
If the shape you drag to the palette has data fields and/or shape actions, the data fields and/or

shape actions are retained in the Shape palette.

{button Related Topics,PI(`',`IDH_RT_To_display_a_new_or_different_shape_palette')}



To copy a shape from one palette to another

{button Show me how . . .,PI(`',`IDH_AVI_tocopyshapesbetweenpalettes0035')}
1 Open the Shape palette, if it is not open already. (On the View menu, click Shape Palettes.)
2 On the Shape palette, click Options.
3 Click Subject.
4 Select another Shape palette to open.
5 Select the Open in New Window check box.
6 Click OK.
7 Click the Selector tool.

Selector tool
8 In the Shape palette, select the shape you want to copy.
9 Click the left mouse button, and drag the shape to the palette that you want to have that 
shape.
10 When the cursor has a small plus sign attached, release the mouse button, and the shape is 
dropped into the palette.

Plus sign pointer
Tip

If you drop the shape before the cursor changes, the shape will not be added to the palette.

{button Related Topics,PI(`',`IDH_RT_to_copy_a_shape_from_one_palette_to_another')}
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To display a new or different Shape palette
To add a drawn object to a Shape palette
To add a shape from another program to FlowCharter 7
Creating New Shapes 
Shape Palettes Overview 



Determining the Way Shapes Look
{button OLE 
Automation,PI(`',
`IDH_OA_Determi
ning_the_way_sh
apes_look')}
{button Tell me 
how. . .,PI(`',`IDH
_HT_Determining
_the_way_shapes
_look')}

You can change the appearance of existing shapes and choose the way new shapes will look.

Shape styles include:
Line Style
Line Width
Line Color
Fill Pattern
Fill Color
Shadow Style
Shadow Offset
Shadow Color
3D Style
3D Offset
3D Color

You can view the current styles and store new styles in the Shape Styles list on the Preset Styles 
toolbar.

Text
You can add text to shapes to explain what step, process, or function each shape represents in your 
chart. The text you enter inside shapes appears within the text area defined for the shape. The text 
area is an invisible box inside a shape that defines how much text is visible in the shape and where 
the text appears. You can fit the shape to the text.

Numbering
You can automatically number shapes if you wish.

{button Related Topics,PI(`',`IDH_RT_Determining_How_Shapes_Look')}



Choosing Shape Styles That Enhance Your Chart
Preset Shape Styles



To change the way existing shapes look
To change the properties for new shapes

To add a preset shape style
To delete a preset shape style

To add text to a shape
To fit a shape or text block to text

To number shapes



StemColor Property
Fill Pattern Property
FillColor Property

ShadowStyle Property
ShadowOffset Property
ShadowColor Property

Text Property
FitShapeToText Method



Choosing Shape Styles That Enhance Your Chart
Color
You can choose what color you want shapes to be. You can use different colors to identify different 
flows, to color-code shapes, or just to enhance a chart’s appearance.
You can also choose the color of lines for shape outlines, effects, and fill patterns independently.

Shape Outlines
You can choose different line styles for shape outlines.Shape lines includes not only the outside part 
of a shape, but also any interior lines used in the shape (for example, the concentric circles on the 
inside 5.25" floppy disk shape). There are many useful line styles for oultines, including solid, 
dashed, and center lines. 
You can choose the width of shape outlines. You can vary the width and offset to customize shapes 
and achieve the visual effect that you want.

Effects
You can add a shadow to shapes. You can choose one of eight positions for the shadow. Shadows 
can be used as an indicator, or just for appearance.
You can also alter the appearance of the shape to be 3D. You can choose one of ten positions for the
3D appearance of your shape.

Fill patterns
You can choose one of the many fill patterns that come with this program. You also can apply a color
to the fill pattern.
Different colors and fill patterns can be used to differentiate flows and to identify individual shapes. 
For example, you could use a cross-hatched gray fill to identify incomplete processes and a solid 
yellow fill to identify completed processes.

{button Related Topics,PI(`',`IDH_RT_Choosing_Shape_Styles_that_Enhance_Your_Chart')}



Determining the Way Shapes Look
What Shapes Should I Use? 
Basic Flowchart Shapes 
How Do I Create a Flowchart? 

Using Shapes and Lines Effectively 
Format menu



Preset Shape Styles
{button Tell me how. . .,PI(`',`IDH_HT_Preset_Shape_Styles')}

As you create charts, you may often reuse the same shape styles. For example, you may use the 
same border style and fill pattern for decision shapes in a certain flow.
You can choose the styles you want to reuse and store them in a list. These styles are called "preset 
styles." The list opens when you click the down arrow to the right of the Shape Styles box on the 
Preset Styles toolbar.

{button Related Topics,PI(`',`IDH_RT_Preset_Shape_Styles')}



Choosing Shape Styles That Enhance Your Chart
Determining the Way Shapes Look
To add a preset shape style
To rename a preset shape style

To choose a preset shape style
To delete a preset shape style



To add a preset shape style
To rename a preset shape style
To choose a preset shape style
To delete a preset shape style



Placing Shapes in a Chart
{button OLE Automation,PI(`',`IDH_OA_Draw_Shape_method')}

You can place shapes in a chart to represent certain information. After you place the shapes, you 
can connect them with lines to show the flow of data. The appearance of new shapes is determined 
by the current styles.
When the Shape tool is selected, a copy of the current shape that is selected in the Shape palette is 
placed in the chart each time you click the chart. (Just click a shape in the Shape palette to select 
it.) You also can place a shape by pressing and holding the left mouse button, and dragging the 
shape from the palette to the place you want it.
To make shapes connect easily, you can place a new shape and automatically connect it to another 
shape in the chart. The connecting line is drawn with the current line styles.
New shapes display a number if the Show Number option is selected in the Shape Numbering dialog 
box. The number is based on the next number chosen.
If you click the left mouse button immediately after placing a shape and before moving the mouse, 
the pointer automatically changes to the Selector tool.

Replacing shapes
After you have placed a shape, you can replace it with a different shape without losing attached 
lines using the Replace Shape command on the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_Placing_Shapes_in_a_Chart')}



Choosing Shape Styles That Enhance Your Chart
Determining the Way Shapes Look
To place a connected shape
To replace shapes 

Arrange toolbar
Shape Palette Over view



DrawShape Method
ReplaceShape Method



Indicators
{button OLE 
Automation,PI(`',`IDH
_OA_Indicators')}

{button Tell me 
how . . .,PI(`',`IDH_
HT_Indicators')}

Indicators are shadows and symbols added to shapes, and nodes added to lines. Shape indicators 
help you identify shapes that are used to open linked charts (or launch other applications) or that 
have notes attached to them.

Shapes that open linked charts (or launch other applications) may be indicated with text, a 
shadow, or an icon.

Shapes that have notes attached to them may be indicated with text or a shadow.
You can use shadows and choose the symbols used for indicators. The default indicators are a 
shadow for link and -N for notes. You can use up to three text characters to create your own 
indicators.
You can choose the font, point size, color, and style you want for text indicators. The settings you 
choose also are used for shape numbers.

{button Related Topics,PI(`',`IDH_RT_Indicators')}



To choose indicators for shapes



To choose indicators for shapes
Format menu



LinkIndicator Property
LinkShadow Property
NoteIndicator Property
NoteShadow Property
NumberFont Property



Alignment and Snapping
{button Tell me how. . .,PI(`',`IDH_HT_Alignment')}

There are a number of alignment options for shapes, lines, and text that determine their alignment 
when they are placed or moved. These options are set on the Alignment tab of the Options dialog 
box.
Additionally, there are several options for aligning shapes in relationship to each other after the 
shapes are created.

{button Related Topics,PI(`',`IDH_RT_Alignment_and_Snapping')}



To align objects 
To select alignment options
To turn snapping on or off 



Snap to Grid
Shape Spacing
Channel Alignment
Relative Alignment



Snap to Grid
{button OLE Automation,PI(`',`IDH_OA_Snap_to_Grid')}

You can snap objects and guidelines to ruler positions using the Snap To Grid option. Coarse 
alignment makes the pointer snap at 1/8" increments; fine alignment makes it snap at 1/16" 
increments (when inches is selected as the unit of measure).
When Snap to Grid is turned off, as you move and place objects, they are not snapped to the grid. 
However, they are snapped to other lines and shapes. In other words, if you place a shape near 
another shape, the second shape is automatically aligned with the first, so that you don't have to try
and position it precisely. Also, text snaps onto lines and lines onto shapes.

Tip
If you want to prevent this snapping behavior (to place text near but not on a line, for 

example), hold Shift as you drag the object into place.

{button Related Topics,PI(`',`IDH_RT_Snap_Alignment_and_Snapping')}



Shape Spacing
Channel Alignment
Relative Alignment



AlignToRulers Property



Shape Spacing
{button OLE Automation,PI(`',`IDH_OA_Shape_Spacing')}

The Shape Spacing option lets you define how far shapes snap from each other when placed in a 
chart. For example, if you set 0.5" horizontal spacing and drag a new shape out of an existing 
shape, the new shape snaps half an inch away if you release the mouse button near that location.

Note
This distance between shapes is from the centers of the shapes, not the edges

{button Related Topics,PI(`',`IDH_RT_Shape_Alignment_and_Snapping')}



Snap to Grid
Channel Alignment
Relative Alignment



SmartShapeSpacing Property



Channel Alignment
{button OLE Automation,PI(`',`IDH_OA_Channel_Alignment')}

The Channel Alignment option aligns shapes horizontally and vertically (in a channel) when you drag
to place connected shapes. Channel alignment also works when you click to place shapes if you 
click near the center of the channel.

{button Related Topics,PI(`',`IDH_RT_Channel_Alignment_and_Snapping')}



Snap to Grid
Shape Spacing
Relative Alignment



ChannelAlignment Property



Relative Alignment

You also can align shapes (and text blocks) relative to each other, based on their edges or centers 
using the Align options on the Arrange menu or the Align buttons on on the Arrange toolbar. You can
align them based on their top, bottom, left, or right edges, or on their vertical or horizontal centers.

{button Related Topics,PI(`',`IDH_RT_Relative_Alignment_and_Snapping')}



Snap to Grid
Shape Spacing
Channel Alignment



To add a preset shape style
1 Click the Selector tool, and click a shape.

Selector tool
2 On the Formatting toolbar, select the shape styles you want (line color, fill color, line style, line 
weight; arrowhead, crossovers, filled lines, shadow, and 3D style).
3 Click the Add Shape Style button on the Preset Styles toolbar. The shape styles are stored as a 
single item in the Shape Styles list.

Add Shape Style button
Tips

You also can add a shape style to the list by selecting a shape with the desired style in steps 2 
and 3. If multiple shapes are selected, the Add Style button is inoperative.

If the Formatting toolbar is not displayed, click Toolbars on the View menu, and then click 
Formatting.

If the Preset Styles toolbar is not displayed, click Toolbars on the View menu, and then click 
Preset Styles.

{button Related Topics,PI(`',`IDH_RT_To_add_a_preset_shape_style')}



Choosing Shape Styles That Enhance Your Chart
Determining the Way Shapes Look
Preset Shape Styles
To rename a preset shape style

To choose a preset shape style
To delete a preset shape style



To choose a preset shape style
1 Click the Shape tool.

Shape tool
2 If you want to apply the preset style to an existing shape, select the shape(s) to which you 
want to apply the style.
3 Click the down arrow to the right of the Shape Styles box on the Preset Styles toolbar.
4 Click the shape style you want. The style is applied to the selected shape.
Notes

If no shape is selected, the preset style appears in the Sample button and becomes the current
shape style.

If you select a shape before you choose a shape style, the style is applied to the selected 
shape and to future shapes.
Tip

If the Preset Styles toolbar is not displayed, click Toolbars on the View menu, and then click 
Preset Styles.

{button Related Topics,PI(`',`IDH_RT_To_choose_a_preset_shape_style')}



Choosing Shape Styles That Enhance Your Chart
Determining the Way Shapes Look
Preset Shape Styles

To add a preset shape style
To rename a preset shape style
To delete a preset shape style



To rename a preset shape style
1 Click the Shape tool.

Shape tool
2 Click the Edit Shape Styles button to the right of the Shape Styles box.

Edit Shape Styles button
3 Click the preset shape style you want to rename.
4 Click Rename, and then type the new name in the Rename Style dialog box.
5 Click OK.
6 Click OK.
Tip

If the Preset Styles toolbar is not displayed, click Toolbars on the View menu, and then click 
Preset Styles.

{button Related Topics,PI(`',`IDH_RT_To_rename_a_preset_shape_style')}



Choosing Shape Styles That Enhance Your Chart
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Preset Shape Styles
To add a preset shape style

To choose a preset shape style
To delete a preset shape style



To delete a preset shape style
1 Make sure no shape is selected.
2 Click the Shape tool.

Shape tool
3 On the Preset Styles toolbar, click the Edit Shape Styles button to the right of the Shape Styles 
box.

Edit Shape Styles button
4 Click the shape style you want to delete.
5 Click Remove. The style is removed from the Shape Styles list.
6 Click OK.
Tip

If the Preset Styles toolbar is not displayed, click Toolbars on the View menu, and then click 
Preset Styles.

{button Related Topics,PI(`',`IDH_RT_To_delete_a_preset_shape_style')}



Choosing Shape Styles That Enhance Your Chart
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Preset Shape Styles

To add a preset shape style
To rename a preset shape style
To choose a preset shape style



To place a connected shape
1 Click the shape you want in the Shape palette.
2 Point inside the shape to which you want to connect the new shape. The pointer shows two boxes

connected with a line.
3 Press and hold the left mouse button, and drag the new shape where you want it. A line 

automatically connects the new shape to the other shape.

Tip
If the Shape palette is not displayed, click Shape Palettes on the View menu.

{button Related Topics,PI(`',`IDH_RT_To_place_a_connected_shape')}



Choosing Shape Styles That Enhance Your Chart
Determining the Way Shapes Look
Placing Shapes in a Chart



To add text to a shape
1 Place a new shape in a chart or select an existing shape.
2 Select any text-formatting options that you want.
3 Click Text tool.

Text tool
4 Click the shape you want to place the text in.
5 Type the text you want. The text you type appears in the text area in the shape. If the shape 
already contains text, the new text is added to the old text where you start typing.

{button Related Topics,PI(`',`IDH_RT_To_add_text_to_a_shape')}



Choosing Shape Styles That Enhance Your Chart
Determining the Way Shapes Look
Placing Shapes in a Chart
Determining the Way Text Looks



To change the properties for a selected shape
1 Select the shape that you want to change properties for.
2 Click Shape tool.

Shape tool
3 On the Format menu, click Properties.
4 Change the properties you want.
5 Click OK.
Note

The properties you define are applied to the selected shape.
Tip

Use the Apply button to make your changes and view the results without closing the dialog 
box.

{button Related Topics,PI(`',`IDH_RT_To_change_the_properties_for_a_selected_shape')}



Placing Shapes in a Chart



To replace shapes

{button Show me how . . .,PI(`',`IDH_AVI_toreplaceshapes30')}
1 Select the shapes in the chart you want to replace.
2 Click the shape in the Shape palette you want in place of the selected shapes.
3 Click the Replace Shape button on the Arrange toolbar. The shapes selected in the chart are 

replaced with the new shape.

Notes
Any manually resized shape or shape that has been fitted to text that is replaced will need to 

be resized again after you replace the shape.
When you replace shapes, the new shapes connect to the lines on the old shapes. The program

automatically chooses the closest connect point on the new shapes.
The program automatically preserves shape numbers, colors, borders, patterns, and text size 

when the shape is replaced.
Tip

If the Arrange toolbar is not displayed, click the right mouse button, and click Arrange.

{button Related Topics,PI(`',`IDH_RT_To_replace_shapes')}
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Using Control Points
Placing Shapes in a Chart



To choose indicators for shapes
1 On the Format menu, click Chart Properties.
2 Click the Indicators tab.
3 To select the indicator type to indicate a shape with a link, click the down arrow in the Link area 

and select from the list.
4 If you want to use a text symbol to indicate a shape with a note, type up to three characters in 

the box in the Note area.
5 If you want to use a shadow to indicate a shape with a note, click the Shadow check box.
6 Choose the font, size, style, and color you want for the indicators. (These options apply to all 

indicators and to shape numbers.)
7 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_choose_indicators_for_shapes')}



Indicators



To select alignment options
1 On the Tools menu, click Options.
2 Click the Alignment tab.
3 Click the Shape Spacing box.
4 Type spacing values in the Horizontal and Vertical boxes.
5 If you want shapes to align in a channel, select the Channel Alignment box.
6 If you want objects and guidelines to snap to ruler positions, select Snap To Grid.
7 Select the Coarse or Fine option, depending upon the snap increments you want.
8 Click OK.

Tip
Use the Apply button to make your changes and view the results without closing the dialog 

box.

{button Related Topics,PI(`',`IDH_RT_To_select_alignment_options')}



Alignment and Snapping
Options command (Tools menu)
To turn snapping on or off



To turn snapping on or off 
1 On the Tools menu, click Options.
2 Click the Alignment tab.
3 Click Snap To Grid. 
4 Click OK.

Notes
If you want shapes to stop snapping to each other, turn off Touch Alignment.
You should also turn off the grid to completely disable snapping. To do so, on the View menu, 

click Grid to remove the check mark from the Grid option. 
Tip

Use the Apply button to make your changes and view the results without closing the dialog 
box.

{button Related Topics,PI(`',`IDH_RT_To_turn_on_or_off_snapping')}



Alignment and snapping
To align objects
To select alignment options 



To change where a line connects
1 Click the Selector tool, and click the line to change.

Selector tool
2 Place the cursor over the end of the line that you want to change. 
3 When the cursor changes to a cross with the line type displayed, hold and drag the left mouse 
button moving the line.
4 Move the line to the connect point that you want to change the connection to.
5 When the connector you want changes to a blinking green dot, release the mouse button.

{button Related Topics,PI(`',`IDH_RT_To_change_where_a_line_connects')}



Alignment and Snapping
Connecting Shapes with Lines 



Applying Shadows to Shapes
{button Tell me

how . . .,PI(`',`IDH_HT_Applying_Shadows_to_Shapes')}

In this program , you can apply shadows to shapes as an additional visual effect. After you have 
applied the shadow, you can change the color, depth, and direction of the shadow.

Note
You have to apply shadows to lines separately.

{button Related Topics,PI(`',`IDH_RT_Applying_Shadows_to_Shapes')}



To color a shadow
To change shadow depth
To change the shadow direction
Format menu



To choose object effects 
To color a shadow
To change shadow depth
To change the shadow direction



To color a shadow
1 Click the Selector tool, and click a shape.

Selector tool
2 On the Format menu, click Effect.
3 To change the shadow color, click the down arrow, and click a color on the color palette.
4 Click OK.
Tip

Use the Apply button to make your changes and view the results without closing the dialog 
box.

{button Related Topics,PI(`',`IDH_RT_To_color_a_shadow')}



To change shadow depth
To change the shadow direction
Format menu



To change shadow depth
1 Click the Selector tool, and click a shape.

Selector tool
2 On the Format menu, click Effect.
3 To change the shadow depth, click the up or down arrow by the Depth box and select the depth
you want.
4 Click OK.
Tip

Use the Apply button to make your changes and view the results without closing the dialog 
box.

{button Related Topics,PI(`',`IDH_RT_To_change_shadow_depth')}



To color a shadow
To change the shadow direction
Format menu



To change the shadow direction
1 Click the Selector tool, and click a shape.

Selector tool
2 On the Format menu, click Effect.
3 To change the shadow direction, click the style with the direction you want. Move the scroll bar 
to find additional styles.
4 Click OK.
Tip

Use the Apply button to make your changes and view the results without closing the dialog 
box.

You also can use the Shadow button on the Formatting toolbar to change the shadow direction.

{button Related Topics,PI(`',`IDH_RT_To_change_the_shadow_direction')}



To color a shadow
To change shadow depth
Format menu



Rename Style dialog box

The Rename Style dialog box lets you enter a new name for the style you selected to rename.



Lets you enter a new name for the style you selected to rename.



Window menu

Click a command below to learn more about it.
New Window Creates a new chart window.
Arrange All Arranges all the chart windows so that 

they can be viewed simultaneously.
Split Divides the current chart into separate, 

active sections.
Chart List Lists the names of open charts.

{button Related Topics,PI(`',`IDH_RT_Window_Menu')}



Arrange All command 
Chart List
New Window command 
Split command 
FlowCharter 7 menus 



New Window command
The New Window command creates a new window for the active chart.

{button Related Topics,PI(`',`IDH_RT_New_Window_command')}



Arrange All command
Chart List
Split command
FlowCharter 7 menus 
Window menu 



Creates a new window for the active chart.



Arrange All command
The Arrange All command arranges all the chart windows so that they can be viewed 
simultaneously.

{button Related Topics,PI(`',`IDH_RT_Arrange_All_command')}



To arrange windows    
Window menu 
FlowCharter 7 menus 



Arranges all the chart windows so that they can be viewed simultaneously.



To arrange windows
On the Window menu, click Arrange All. The windows are arranged in the workspace so that 

you can view them all.

{button Related Topics,PI(`',`IDH_RT_To_Arrange_Windows')}



Arrange All command



Split command
The Split command divides the active window into four panes. You can then view more than one part
of your chart at the same time.

Note
You can also split the window into separate panes by dragging either of the split boxes. One 

split box is above the vertical scroll bar, the other is beside the horizontal scroll bar.

{button Related Topics,PI(`',`IDH_RT_Split_Command')}



Arrange All command
Chart List
New Window command
Window menu 
FlowCharter 7 menus



Divides the active window into four panes. You can then view more than one part of your chart at 
the same time.
You can also split the window into separate panes by dragging either of the split boxes. One split 
box is above the vertical scroll bar, the other is beside the horizontal scroll bar.



Chart List
The chart list displays the names of the charts currently open. The numbers indicate the order in 
which the charts were opened. A check mark indicates which chart is active.

{button Related Topics,PI(`',`IDH_RT_Chart_List')}



To activate an open chart
Arrange All command
New Window command
Split command

Window menu 
FlowCharter 7 menus



Displays the names of the charts currently open. The numbers indicate the order in which the charts
were opened. The active chart has a check mark beside its name.



To activate an open chart
On the Window menu, click the chart you want in the chart list.

{button Related Topics,PI(`',`IDH_RT_Activating_Open_Charts')}



Arrange All command
Chart list
New Window command
Split command

Window menu 
FlowCharter 7 menus 



View menu 

Click a command below to learn more about it.
Normal Displays objects at their actual sizes.
Page Displays the entire page.
Full Screen Shows all of the elements of your chart on the screen

without menus or buttons.
Toolbars Hides or shows any of the toolbars.
Status Bar Hides or shows the status bar.
Rulers Hides or shows the rulers.
Shape 
Palettes 

Hides or shows the Shape palette.

Worksheet Hides or shows the data fields worksheet.
Entity 
Manager

Hides or shows the Entity Manager.

Field Viewer Opens the Field Viewer dialog box, where you can 
enter data into the selected shape’s fields.

Note Hides or shows the Note window.
CoolSheets Hides or shows CoolSheets..
Guidelines Hides or shows guidelines.
Grid Hides or shows a grid.
QuickZoom Hides or shows the QuickZoom window.
Zoom Changes the magnification of a chart.

{button Related Topics,PI(`',`IDH_RT_View_Menu')}



Full Screen command
Zoom command 



Normal command
The Normal command in the View menu displays objects at their actual sizes.
The Normal view is the best all-purpose view for creating and changing charts.    Use the Normal 
command to return to this view from the Page view. This view is useful for selecting specific objects 
and precisely positioning objects and lines. If an object is selected in the chart when you click this 
button, the chart displays at its actual size with the selected object centered in the window.

Note
If you do not select any objects, the Normal command matches the upper-left corner with the 

previous upper-left corner of the chart.

{button Related Topics,PI(`',`IDH_RT_Normal_Command')}



To save your default template in another view state 
Page command
Full Screen command
View menu



Displays objects at their actual sizes. The Normal view is the best all-purpose view for creating and 
changing charts.    Use the Normal command to return to this view from the Page view. This view is 
useful for selecting specific objects and precisely positioning objects and lines. If an object is 
selected in the chart when you click this button, the chart displays at its actual size with the 
selected object centered in the window.

Note
If you do not select any objects, the Normal command matches the upper-left corner with the 

previous upper-left corner of the chart.



Page command
The Page command displays the entire page. It is useful for selecting a group of objects, quickly 
connecting shapes with lines, and roughly placing and moving objects.

{button Related Topics,PI(`',`IDH_RT_Current_Page_Command')}



To save your default template in another view state 
Normal command
Full Screen command
View menu



Displays the entire page.



Full Screen command
{button OLE Automation,PI(`',`IDH_OA_Full_Screen_command')}

The Full Screen command in the Edit menu displays all of the elements of your chart on the screen 
without menus or buttons. Press Esc to return to the previous view.

{button Related Topics,PI(`',`IDH_RT_Full_Screen_Command')}



To use Full Screen view
Normal command
Page command
View menu



FullScreen Method



Shows all of the elements of your chart on the screen without menus or buttons. Press Esc to return 
to the previous view.



To use Full Screen view
1 On the View menu, click Full Screen.
2 Press the left mouse button and drag to draw in red.

or
Press the right mouse button and drag to draw in green.
or
Press both mouse buttons and drag to draw in yellow.

3 Press the Esc key to leave the full-screen view.

Tips
Use the Full Screen view to show someone the chart and do a "chalk talk" about it. While you 

are in full-screen mode, you can draw on the screen. When you finish, press the Esc key to return to 
the previous view.

The following keys are available in full-screen view.
Del, Spacebar, E - Erase chart
annotations
Tab, Page Down, N - Go to the
next chart window
Shift+Tab, Page Up, P - Go to
the previous chart window

{button Related Topics,PI(`',`IDH_RT_Elements_Naked')}



To change your view of a chart
Full Screen command



Using Full Screen View

Use the Full Screen view to show someone the chart and do a "chalk talk" about it. While you are in 
full-screen mode, you can draw on the screen. When you finish, press the Esc key to return to the 
previous view. In the Full Screen view, you can use the mouse buttons to draw using different colors.

Press the left mouse button and drag to draw in red.
Press the right mouse button and drag to draw in green.
Press both mouse buttons and drag to draw in yellow.
The following keys are available for working in the full-screen view.

Del, Spacebar, E - Erase chart
annotations
Tab, Page Down, N - Go to the
next chart window
Shift+Tab, Page Up, P - Go to
the previous chart window

Toolbars command
The Toolbars command on the View menu lets you display or hide toolbars. It also allows you to 
customize the toolbars, reset toolbars, create new toolbars, delete custom toolbars, choose large or 
small button sizes, choose color or black and white buttons, and show or hide ToolTips.

{button Related Topics,PI(`',`IDH_RT_Toolbars_Command')}



To choose color buttons 
To choose toolbar button sizes 
To create new toolbars 
To delete toolbars 

To rename toolbars 
To reset toolbars 
To show and hide toolbars
To show or hide ToolTips 

Customize command
View menu



To show or hide toolbars
1 On the View menu, click Toolbars.
2 Click the check box next to the toolbar you want to show or hide. A cleared check box means that

the toolbar is hidden.

{button Related Topics,PI(`',`IDH_RT_Showing_and_hiding_toolbars')}



To add toolbar buttons 
To delete toolbar buttons 
To create a floating palette 
Customizing Toolbars 

Toolbars command
Customize command 
View menu



Displays or hides toolbars.



Status Bar command
The Status Bar command in the View menu displays or hides the status bar.

{button Related Topics,PI(`',`IDH_RT_StatusBar_command')}



To show and hide the status bar 
View menu



To show and hide the status bar
On the View menu, click Status Bar.

{button Related Topics,PI(`',`IDH_RT_Showing_and_hiding_statusbar')}



Status Bar command 
View menu



Displays or hides the status bar.



Rulers command
{button OLE Automation,PI(`',`IDH_OA_Rulers_command')}

The Rulers command in the View menu displays or hides the rulers.

{button Related Topics,PI(`',`IDH_RT_Rulers_Command')}



To show and hide rulers
View menu



Displays or hides the rulers.



ShowRulers Property



To show and hide the rulers
On the View menu, click Rulers.

{button Related Topics,PI(`',`IDH_RT_Showing_and_hiding_rulers')}



Rulers command
View menu



Shape Palettes command
The Shape Palettes command displays or hides the Shape palette.

{button Related Topics,PI(`',`IDH_RT_Shape_Palettes_Command')}



Placing Shapes in a Chart
View menu



Displays or hides the Shape palettes.



Hides or shows the data fields worksheet.



Field Viewer command
The Field Viewer command opens the Field Viewer dialog box, where you can enter data into the 
selected shape’s fields.

{button Related Topics,PI(`',`IDH_RT_Field_Viewer_Command')}



To show and hide the Field Viewer
View menu



Opens the Field Viewer dialog box, where you can enter data into the selected shape’s fields.



To show and hide the Field Viewer
Click Field Viewer on the View menu.

{button Related Topics,PI(`',`IDH_RT_Showing_and_hiding_FieldViewer')}



Field Viewer command
View menu



QuickZoom command
The QuickZoom command displays or hides the QuickZoom window.

{button Related Topics,PI(`',`IDH_RT_Zoom_Window_Command')}



To use the QuickZoom window
View menu



Displays or hides the QuickZoom window.



To use the QuickZoom window
1 On the View menu, click QuickZoom.
2 In the QuickZoom window, click and drag a box around the area of the chart you want to magnify.
3 Release the mouse button.

Tip
Double-click in the QuickZoom window to return to your last magnification before you used 

QuickZoom to zoom in.

{button Related Topics,PI(`',`IDH_RT_Using_the_zoom_window')}



To choose a zoom percentage
QuickZoom command
Zoom command
View menu



Note command
The Note command displays or hides the Note window.

{button Related Topics,PI(`',`IDH_RT_Note_Command')}



To attach a note to a shape
View menu



Displays or hides the Note window.



Displays or hides the Entity Manager.



To show and hide the Entity Manager
Click Entity Manager on the View menu.

{button Related Topics,PI(`',`IDH_RT_Showing_and_hiding_EntityManager')}



Entity Manager command
View menu



Guidelines command
The Guidelines command in the View menu displays or hides the guidelines.

{button Related Topics,PI(`',`IDH_RT_Guidelines_Command')}



To show and hide guidelines
View menu



Displays or hides the guidelines.



To show and hide guidelines
Click Guidelines on the View menu.

{button Related Topics,PI(`',`IDH_RT_Showing_and_hiding_Guidelines')}



Guidelines command
View menu



Grid command
The Grid command in the View menu displays or hides the grid.

{button Related Topics,PI(`',`IDH_RT_Grid_Command')}



View menu



Displays or hides the grid.



To show or hide grids
Click Grids on the View menu.

{button Related Topics,PI(`',`IDH_RT_Showing_and_hiding_Grids')}



Grid command
View menu



Zoom command
{button OLE Automation,PI(`',`IDH_OA_Zoom_command')}

The Zoom command in the View menu zooms in on or out of a part of a chart. 

Tip
To “zoom in” means to magnify. To zoom out means to reduce the magnification.

{button Related Topics,PI(`',`IDH_RT_Zoom_Command')}



To choose a zoom percentage
To use the QuickZoom window
QuickZoom command 
View menu



Zooms in on or out of a part of a chart.



ZoomPercentage Property



To change your view of a chart
1 Select the object you want centered in the window.
2 On the View menu, click one of the following commands:

Normal
Page
Zoom
Full Screen

{button Related Topics,PI(`',`IDH_RT_Changing_chart_view')}



To change your view of a chart 



Zoom dialog box
{button OLE Automation,PI(`',`IDH_OA_Zoom_command')}

This dialog box lets you choose the magnification level you wish.

Zoom to
Select how large or small you want your document to appear as a percentage of its normal size. 
Choose a predefined percentage, or enter your own percentage, between 5 and 1600, in the Percent
text box.

{button Related Topics,PI(`',`IDH_RT_View_Zoom_Percentage')}



To choose a zoom percentage



Displays the chart at a magnification of 400%.



Displays the chart at a magnification of 200%.



Displays the chart at a magnification of 100%; in other words, at its actual size.



Displays the chart at a magnification of 75%.



Displays the chart at a magnification of 50%.



Displays the chart at a magnification of 25%.



Specifies the percentage at which you want to view the chart.



To choose a zoom percentage
1 Click the object you want centered in the window.
2 Click the down arrow of the Zoom box in the Standard toolbar.
3 Click the viewing percentage at which you want to view the chart.

Tips
You can enter another percentage in the text box if one you want is not one of the options.
You can use the Zoom command on the View menu to do the same thing.

{button Related Topics,PI(`',`IDH_RT_View_Zoom_Percentage')}



To use the QuickZoom window 
To change your view of a chart 
To change your view of a chart 



To view a particular area of a chart
1 Click QuickZoom in the View menu.
2 Point to a corner of the area that you want to show.
3 Press and hold the mouse button.
4 Drag the cursor to the opposite corner of the area you want to show. As you drag, a box shows 

the area you have chosen.
5 Release the mouse button. The chart is redrawn with the area you selected shown on the screen.

Tip
If you wish, you can move the box while still holding the left mouse button. Press and hold the 

right mouse button and move the cursor. Release the right mouse button (while still holding the left 
mouse button) to continue changing the size of the box.

{button Related Topics,PI(`',`IDH_RT_Viewing_chart_area')}



To change your view of a chart 
To use the QuickZoom window 



Toolbars dialog box

This dialog box:
Shows or hides toolbars
Chooses color or monochrome buttons
Chooses regular or large buttons
Shows or hide ToolTips
Creates new toolbars
Renames toolbars
Reset toolbars to the way they were when you installed FlowCharter. Resetting the toolbars 

only affects those buttons added or removed through the Customize feature of the Toolbars dialog box 
or Customize command on the Tools menu. Resetting does not reset large buttons, color buttons, or 
ToolTips.

Change to the Customize Toolbars dialog, where you can add or remove buttons to toolbars

{button Related Topics,PI(`',`IDH_RT_toolbars_dialog_box')}



To choose color buttons
To choose toolbar button sizes
To create new toolbars
To delete toolbars

To rename toolbars
To reset toolbars
To show or hide toolbars
To show or hide ToolTips

To add toolbar buttons 
To delete toolbar buttons 
To create a floating palette
Customizing Toolbars

Toolbars command



Shows or hides the toolbar.



Specifies whether the toolbar buttons are color or monochrome.



Specifies whether the toolbar buttons are large or small.



Specifies whether ToolTips show when you rest the pointer over program elements.



Creates a new toolbar.



Renames the selected toolbar.



Adds or deletes buttons from a toolbar.



Reverts the selected toolbar to the way it was when you installed FlowCharter. Resetting the 
toolbars only affects those buttons added or removed through the Customize feature of the Toolbars 
dialog box or Customize command on the Tools menu. Resetting does not reset large buttons, color 
buttons, or ToolTips.



To choose color buttons
1 On the View menu, click Toolbars.
2 Click Color Buttons to place a check in the check box.

To choose monochrome (black and white) buttons
1 On the View menu, click Toolbars.
2 Click Color Buttons to clear the check box.

{button Related Topics,PI(`',`IDH_RT_Choosing_Color_Buttons')}



To choose toolbar button sizes
To create new toolbars
To delete toolbars
To rename toolbars

To reset toolbars
To show or hide toolbars
To show or hide ToolTips
To add toolbar buttons 

To delete toolbar buttons 
To create a floating palette
Customizing Toolbars
Toolbars command



To choose toolbar button sizes
1 On the View menu, click Toolbars.
2 Click Large Buttons.

Tip
This check box switches between regular    buttons and large buttons.

{button Related Topics,PI(`',`IDH_RT_Choosing_toolbar_button_types')}



To choose color buttons
To create new toolbars
To delete toolbars
To rename toolbars

To reset toolbars
To show or hide toolbars
To show or hide ToolTips
To add toolbar buttons 

To delete toolbar buttons 
To create a floating palette
Customizing Toolbars
Toolbars command



To create new toolbars
1 On the View menu, click Toolbars.
2 Click New.
3 Type a name for the new toolbar and click OK. The new toolbar appears as a floating palette and 

the Customize dialog box opens.
4 Drag the buttons you want from the Customize dialog box to your new toolbar. 

Tips
You can drag a button from the Customize dialog box and drop it into an empty space to create

a new toolbar.
You can press CTRL and drag a button from a toolbar and drop it into empty space to create a 

new toolbar.

{button Related Topics,PI(`',`IDH_RT_Creating_new_toolbars')}



To choose color buttons
To choose toolbar button sizes
To delete toolbars
To rename toolbars

To reset toolbars
To show or hide toolbars
To show or hide ToolTips
To add toolbar buttons 

To delete toolbar buttons 
To create a floating palette
Customizing Toolbars
Toolbars command



Names for the new toolbar.



To rename toolbars
1 On the View menu, click Toolbars.
2 Click the toolbar you want to rename.
3 Click Rename.
4 Enter a new name for the toolbar.

Note
You cannot rename a Micrografx toolbar. You can only rename a toolbar that you have created.

{button Related Topics,PI(`',`IDH_RT_Renaming_toolbars')}



To choose color buttons
To choose toolbar button sizes
To create new toolbars
To delete toolbars

To reset toolbars
To show or hide toolbars
To show or hide ToolTips
To add toolbar buttons 

To delete toolbar buttons 
To create a floating palette
Customizing Toolbars
Toolbars command



To delete toolbars
1 On the View menu, click Toolbars.
2 Click the toolbar you want to delete.
3 Click Delete.

Note
You cannot delete a Micrografx toolbar. You can only delete a toolbar that you have created.

{button Related Topics,PI(`',`IDH_RT_Deleting_toolbars')}



To choose color buttons
To choose toolbar button sizes
To create new toolbars
To rename toolbars

To reset toolbars
To show or hide toolbars
To show or hide ToolTips
To add toolbar buttons 

To delete toolbar buttons 
To create a floating palette
Customizing Toolbars
Toolbars command



To reset toolbars
1 On the View menu, click Toolbars.
2 Click the toolbar you want to reset.
3 Click Reset.

Notes
Resetting the toolbars returns the Micrografx toolbars to the way they were when you first 

installed FlowCharter. It removes any buttons that you have added and adds buttons that were 
originally on the toolbars.

Resetting the toolbars only affects those buttons added or removed through the Customize 
feature of the Toolbars dialog box or Customize command on the Tools menu. Resetting does not reset 
large buttons, color buttons, or ToolTips.

Only the selected toolbar is reset.

{button Related Topics,PI(`',`IDH_RT_Resetting_toolbars')}



To choose color buttons
To choose toolbar button sizes
To create new toolbars
To delete toolbars

To rename toolbars
To show or hide toolbars
To show or hide ToolTips
To add toolbar buttons 

To delete toolbar buttons 
To create a floating palette
Customizing Toolbars
Toolbars command



To show or hide ToolTips
1 On the View menu, click Toolbars.
2 Click Show ToolTips.

Note
When the check box is checked, ToolTips do not display .

{button Related Topics,PI(`',`IDH_RT_Showing_hiding_tooltips')}



To choose color buttons
To choose toolbar button sizes
To create new toolbars
To delete toolbars

To rename toolbars
To reset toolbars
To show or hide toolbars
Toolbars command



CoolSheets command (View menu)
The CoolSheets command on the View menu hides or displays CoolsSheets.

{button Related Topics,PI(`',`IDH_RT_CoolSheets_command_Viewmenu')}



Using CoolSheets 



Hides or displays CoolsSheets.



Displays the selected area on your chart. Shows the zoomed chart after you use QuickZoom to zoom
in.



QuickZoom window

The QuickZoom window displays the selected area on your chart. This window shows the zoomed 
chart after you use QuickZoom to zoom in.

{button Related Topics,PI(`',`IDH_RT_QuickZoom_Window')}



To use the QuickZoom window
View menu



Standard toolbar
{button Tell me how . . .,PI(`',`IDH_HT_Standard_Toolbar')}

New button Creates a new chart.
Open button Opens a previously existing chart.
Save button Saves the active chart.
Print button Prints the active chart.
Print Preview 
button

Shows the chart as it will look 
when you print it.

Spelling button Checks the spelling of text in your
chart.

Cut button Removes the selected item and 
places it on the Clipboard.

Copy button Copies the selected item and 
places it on the Clipboard.

Paste button Places the contents of the 
Clipboard on the chart.

Format Painter 
button

Copies the formatting of the 
selected object to another object.

Undo button Lets you undo an action or 
change.

Redo button Reverses the last undo you made.
Find button Lets you find text in your chart.
View Shape 
Palettes button

Shows or hides the Shape palette.

View 
Worksheet 
button

Displays or hides the worksheet.

Insert 
CoolSheet 
button

Creates CoolSheets.

Link button Lets you link the selected shape 
or shapes to another chart or file.

Insert SPC 
Chart button

Creates a statistical process 
control chart.

Import Shape 
button

Imports a shape that you have 
created in another program.

Shape Action 
wizard button

Creates a Living FlowChart.

Run button Runs a Living FlowChart.
Zoom Control 
button

Lets you select the zoom tool you 
want to use.



Zoom Percent 
list box

Magnifies the chart by the 
percentage you select.

Help button Displays information about the 
item you click next. 

To dock toolbars
To hide toolbars



Contains common tools found in most Office programs, like New, Open, Save and so on. It also 
contains some FlowCharter specific tools, like the View Shape Palettes button, the Link button, the 
Insert SPC Chart button, zoom tools, and the Help button.
To show or hide the Standard toolbar, click the right mouse button over the toolbar area, and click 
Standard.



Creates a new chart.



Opens a previously existing chart.



Saves the active chart.



Prints the active chart.



Shows the chart as it will look when you print it.



Checks the spelling of text in your chart.



Removes the selected item and places it on the Clipboard.



Copies the selected item and places it on the Clipboard.



Places the contents of the Clipboard in the chart.



Format Painter button
The Format Painter button copies the formatting of the selected text, shapes, or lines to other 

text, shapes, or lines.

{button Related Topics,PI(`',`IDH_RT_FormatPainter_button')}



To copy the format of an item
Standard toolbar



To copy the format of an item
1 Click the line, text, or shape that has a format you want to copy.
2 Click the Format Painter button.

Format Painter button
3 Click the item you want to format.
Notes

The format painter feature can copy the styles of lines, shapes, or text.
In lines, it copies:

Style
Weight
Arrowhead style
It does not copy the line type.
In shapes, it copies:
Fill color
Pattern
Border
Shadow
It does not copy the shape size or number.

In text, it copies:
font

size
style (bold, italic, underline)

{button Related Topics,PI(`',`IDH_RT_Copying_the_format_of_an_item')}



To change the way existing shapes look 
To change the properties for a selected shape 
To add a preset shape style 
Choosing shape styles that enhance your chart
Standard toolbar



Copies the formatting of the selected text, shapes, or lines to other text, shapes, or lines.



Lets you undo an action or change.



Reverses the last undo you made.



Lets you find text in your chart.



View Shape Palettes button
{button OLE Automation,PI(`',`IDH_AT_Shape_Palette_Button')}
The View Shape Palettes button opens and closes the Shape palettes. The Shape palettes 

display the shapes that you can place in a chart, and contain the ABC Media Manager Options menu.
You can make the Shape palette appear on the screen and use it to place shapes in a chart. When 
you open FlowCharter for the first time, a set of commonly used symbols appears in the Shape 
palette. The name of the Shape palette appears in the palette's title bar. The available shapes 
appear as buttons in the palette. 
Many additional shapes are available in the Shape palette files included with the program. 

{button Related Topics,PI(`',`IDH_RT_Shape_Palette_Button')}



To add a preset shape style
ABC Media Manager Overview
Standard toolbar



ShapePaletteVisible Property
CurrentShape Property



Shows or hides the Shape palette.



View Worksheet button
The View Worksheet buttons displays or hides the worksheet. The worksheet lets you view and 

change data. You can enter data by typing in the worksheet or by using the Field Viewer command. 
Tips

You can change the data by typing over data directly in the worksheet, in the Field Viewer 
dialog box, or on the chart.

To import external data, use the Import Data command or the Import Data button on the Data 
toolbar.

Import Data button

{button Related Topics,PI(`',`IDH_RT_View_Worksheet_button')}



Worksheet command



Displays or hides the worksheet.



Insert CoolSheet button
The Insert CoolSheet button lets you insert a CoolSheet template for your chart. You can create

several CoolSheets, including:
Block CoolSheets
Cascade CoolSheets
Deployment CoolSheets
Basic CoolSheets
Process CoolSheets
Pyramid CoolSheets
Comparison CoolSheets
Timeline CoolSheets
Circle-Spoke CoolSheets
Target CoolSheets
DrawBar CoolSheets
Checklist CoolSheets

{button Related Topics,PI(`',`IDH_RT_Insert_CoolSheet_button')}



Using CoolSheets
To create a CoolSheet
To change a CoolSheet



Creates CoolSheets.



Creates Living FlowCharts.



Link button
 The Link button lets you link charts. After the charts are linked, you can double-click a designated 
shape in one chart to open the linked chart.

This button lets you create hierarchies among charts. One chart can provide an overview of the 
main topics and contain links to subcharts that provide detailed information about the various 
topics.
You can use symbols and shadows to identify shapes that open linked charts. The symbols, which 
you can define, appear after shape numbers.

{button Related Topics,PI(`',`IDH_RT_Link_Button')}



To link an object to a chart
To group and link objects
To open linked charts
To clear a link

Standard toolbar



Lets you link the selected shape or shapes to another chart or file.



Creates a statistical process control chart.



Lets you import a graphic and insert it into your chart as a shape.



Lets you select the zoom tool you want to use.



Magnifies the chart by the percentage you select.



Displays information about the item you click next.



Run button
The Run button runs a Living FlowChart.

{button Related Topics,PI(`',`IDH_RT_Run_button')}



Run FlowChart command 



Runs a Living FlowChart.



Link dialog box
{button Tell me how . . .,PI(`',`IDH_HT_Link_Dialog_Box')}

The Link dialog box opens when you click the Link button on the Standard toolbar, or when you 
double-click a shape that has no pre-existing link.    You use this dialog to create links. The active 
chart contains the shape or shapes you use to open the linked chart.
From this dialog box, you can: {button OLE Automation,PI(`',`IDH_OA_Link_Dialog_Box')}

Link to charts (or other files). In this dialog box, click one of the options under Link to. For 
details, click the Tell me how button and click To link a shape to another chart.

Clear a link. In this dialog box, click Clear.
Group selected objects in a chart and automatically move them to another chart. The group is 

replaced with the shape selected in the Shape palette. You use this shape to open the linked chart that 
contains the grouped objects. You use group links to create hierarchies in a chart. For example, you 
can use one chart as an overview of a process and then set links to charts that contain detailed 
information about the minor steps in the process. In this dialog box, click Move Group to Other Chart.    
For details, Tell me how button and select To group and link objects.

Show the accumulated data from the linked chart. For example, if your linked chart has fields 
with time-related data, the times are totaled and displayed on the active chart when you select this 
option. In this dialog box, click Show Accumulated Data.

Apply a link to a Web address. Objects link to 'ABC' files on Web sites, ftp sites, and through 
gopher sites.    Entering a start of a URL automatically selects the 'Internet' radio button. Valid internet 
address starts should include: 'http://', 'ftp://', 'ftp.' Using the Update Data Fields button completes a 
new download. For details, click the Tell me how button and select To link a shape to a Web 
address.

Update Data Fields button

{button Related Topics,PI(`',`IDH_RT_Link_Dialog_Box')}



To clear a link
To group and link objects
To link a shape to another chart
To open linked charts
To link a shape to a Web address



GroupAndLink Method
LinkedChartName Property
LinkFields Property



LinkedChartName Property
GroupAndLink Method
LinkFieldsProperty



Links to a new flowchart. The name of the file that will be created is specified in the File box.



Links to an existing flowchart. You enter the file to link to in the File box.



Links to a file created by another program. You enter the file to link to in the File box.



Links to a Web address. You enter the address to link to in the File box.



Lets you type the name of the file to which you want to link the selected chart.



Specifies a link to a chart. When you click OK, you set the link and open the chart specified in the 
File box.



Specifies a link to a chart only (without opening the chart). When you click OK, you return to the 
active chart.



Clears a link between charts. Choose this option when you decide you no longer want this link.



Shows the results of the data. The data results are based on the accumulation method you specify in
the Setup Fields command on the Data menu.



Moves the selected objects to another chart, replace the selected objects with a single object, and 
link this new object to the second chart. The single new shape shows the accumulation of data from 
the linked chart when you also select Show Accumulated Data.



Searches for the file you want to link to.



To link a shape to another chart
1 Click the Selector tool.

Selector tool
2 Select the shape or shapes in the active chart you want to link.
3 Click the Link button on the Standard toolbar. The name of a new chart appears in the File text 

box.
4 Click the Browse button if you want to link to a chart other than the new chart named in the File 

text box. Click Open when you have selected the chart name.
5 Click Set Only or Set and Jump.
6 Click OK.
You can set up the link indicators via the Format menu’s Chart command. The Indicators tab lets you
set up the Link and Note indicators, and the font used for both.

{button Related Topics,PI(`',`IDH_RT_Linking_a_shape')}



To choose indicators for shapes 
To clear a link
To group and link objects
To open linked charts



To group and link objects
1 Click the shape in the Shape palette you want to use to open the linked chart.
2 Click the Selector tool

Selector tool
3 Select the objects in the chart you want to group and link.
4 Click the Link button on the Standard toolbar.
5 Select the chart you want to link to.
6 Click Move Group to Other Chart.
7 Click OK.

{button 
Related 
Topics,PI(`',`I
DH_RT_Movi
ng_groups_t
o_linked_cha
rt')}

{button OLE 
Automation,
PI(`',`IDH_O
A_To_group_
and_link_obj
ects')}

To clear a link
To link a shape to another chart
To open linked charts



GroupAndLink Method



To open linked charts
Double-click the linked shape. The linked chart opens in the window and becomes the active 

chart.

{button 
Related 
Topics,PI(`',`I
DH_RT_Open
ing_a_linked
_chart')}

{button OLE 
Automation,
PI(`',`IDH_O
A_To_open_a
_linked_char
t')}

To clear a link
To group and link objects
To link a shape to another chart



Link Method



To clear a link
1 Click the Selector tool.

Selector tool
2 Select the linked shape.
3 Click the Link button on the Standard toolbar.
4 Click Clear Link.
5 Click OK. The link between the two charts is removed, and the link indicators on the shape 

disappear.

Note
You cannot change a shape’s link by double-clicking. When you double-click a linked shape, 

you jump to the linked chart.

{button Related Topics,PI(`',`IDH_RT_Clearing_links')}



To group and link objects
To link a shape to another chart
To open linked charts



To link a shape to a program
1 Click the Selector tool.

Selector tool
2 Double-click the shape you want.
3 In the Link dialog box, click Other program or file.
4 In the File box, enter the path and program you want to run.
Tips

If you don't know the path or the exact filename of the program you want to run, click the 
Browse button and look for it.

Click Set and Jump to run the program when you click OK.
Click Set Only to set the link and return to the active chart.
Click Clear    to delete the link to a file or program.
You can only have one link per shape. If the shape is already linked to another file or program, 

double-clicking on it will jump to the file or program.

{button Related Topics,PI(`',`IDH_RT_To_link_a_shape_to_a_program')}



Example:Linking a shape to a program
To clear a link 



To link a shape to a Web address
1 Click the Selector tool.

Selector tool
2 Double-click the shape you want.
3 In the Link dialog box, click Internet.
4 In the File box, enter the path and program you want to run.
Tips

Entering a start of a URL automatically selects the 'Internet' radio button. Valid internet 
address starts should include: http://, ftp://, and ftp.

Click Set and Jump to open the Web site when you click OK.
Click Set Only to set the link and return to the active chart.
Click Clear to delete the link to a Web site.
You can only have one link per shape. If the shape is already linked to another file or program, 

double-clicking it jumps to the file or program.
Using the Update Data Fields button completes a new download.

Update Data Fields button



Example: Linking a shape to a program
1 Place a shape.
2 Double-click the shape.
3 Click Other program or file.
4 In the File box, enter c:\windows\clock.exe
5 Click Set and Jump.
6 Click OK.

Notes
This procedure only works if you have installed Windows into the default directory. If you have 

installed Windows on another drive or in another directory, change the path in step 4 to match your 
configuration.

When you click OK, the clock utility runs. Any time you want to run the clock, you can double-
click the shape.

{button Related Topics,PI(`',`IDH_RT_Example_Linking_a_shape_to_a_program')}



To clear a link



To link a shape to a sound file
1 Click the Selector tool.

Selector tool
2 Double-click the shape you want.
3 In the Link dialog box, click Other program or file.
4 In the File box, enter the path and sound file you want to play.

Tips
If you don't know the path or the exact filename of the sound file    you want to play, click the 

Browse button and look for it.
Click Set and Jump to play the sound when you click OK.
Click Set Only to set the link and return to the active chart.
Click Clear to delete the link to the sound file.
You can only have one link per shape. If the shape is already linked to another file or program, 

double-clicking on it will jump to the file or program.

{button Related Topics,PI(`',`IDH_RT_To_link_a_shape_to_a_sound_file')}



To clear a link 



Protecting Charts
{button OLE 
Automation,PI(`',`I
DH_OA_SetProtecti
on_Method')}
{button Tell me 
how . . .,PI(`',`ID
H_HT_Protecting_
Charts')}

At times, you may want to prevent other people from entering field data into your chart. You can 
protect a chart by assigning it a password. No one is able to enter field data into it until the 
password is entered correctly. If the chart contains hidden data fields, they are hidden from view 
until the password is entered correctly.
You can use password protection to manage linked files. By assigning each person in a workgroup a 
different password, you can ensure that each person has access only to his or her own charts.
Use the Protect Chart command on the Tools menu to protect your chart from unauthorized changes.

{button Related Topics,PI(`',`IDH_RT_Protecting_Charts')}



To protect a chart
To unprotect a chart



To protect a chart
To unprotect a chart
Tools menu 



SetProtection Method



Master Items
{button OLE 
Automation,PI(`',`IDH
_OA_Master_Items')}

{button Tell me 
how. . .,PI(`',`IDH_HT
_Master_Items')}

Master items are text that appears on the chart that identify several chart characteristics. The 
default display for your chart displays the Chart Name, Date, Time, and Page Number.
You can choose to display:

All Master items
No Master items

Or you can mix and match:
Chart Name
Chart Name is updated automatically if you change the file name. 

Page Number
Page Number displays the page number at the bottom of each page. You can display text before the 
number. Type the text you want before the number sign (#) in the Page Text box. The number sign is
replaced with the actual page number when you print the chart

Date
Date shows the system time when you created the file or the current date.

Date format
Use the    box to select a different date format, if you want.

Update Date and Time
You can click Update Date and Time in the associated information area to match the date and time 
master items with the current system date and time.

Time
Time shows the system time when you created the file or the current time. When Time is the current
master item in the Format Chart dialog box, the time format is displayed in the associated 
information area. You can click Update Date and Time in the associated information area to match 
the Date and Time master items with the current system date and time.

Tips
You can change the date and time formats in the Master Items dialog box to different 

standards by changing the international settings in the Control Panel. The new standards are reflected 
immediately FlowCharter.
Text 1 and Text 2
Text 1 and Text 2 display text on the first page or on each page of a chart. You can use these boxes 
to add information about a chart. For example, you could show the name of the creator and the 
purpose of the chart. To change the text, type the text you want in the box.

Tip
Use the Text 1 and Text 2 boxes to add a header and footer to the chart pages. Type text in the 

boxes and choose the All Pages option. In the chart, move the text items to the top and bottom, 
respectively, of the first chart page. The items appear at the top and bottom of each chart page.



Logo
Logo lets you use any bitmap (.BMP) file as your logo.

LogoPathname
If there is no current logo, you can click Logo to import a logo into a chart. The Logo dialog box 
opens. The logo you import is saved in the chart file. You can display and hide the logo after you 
import it.

All Pages or First Page Only
You can specify whether you want to display the master items on all pages or the first page only. 

Tip
You can use the Search feature to search for any text in the master items. You cannot, 

however, replace text in the master items.

{button Related Topics,PI(`',`IDH_RT_Master_Items')}



To define master items
Format menu



To define master items
To display or hide page numbers 
To display or hide the chart date and time of creation 
To display or hide the chart filename and path 
To add a logo to a chart 



Range Property
ShowAll Method
HideAll Method
PageNumberShown Property

DateShown Property
DateStyle Property
UpdateDateAndTime Method
TimeShown Property

Text1Shown Property
Text2Shown Property
LogoShown Property
LogoPathname_Property



Export Overview
{button Tell me how. . .,PI(`',`IDH_HT_Export_Overview')}

The Export command on the File menu lets you export a chart or selected items in a chart to files in 
a variety of formats that you can use in word processing, presentation, and other software 
programs.
When you choose the Export command, the Export Chart dialog box opens. This dialog box lets you 
choose the file type, name the exported chart file, and select the drive and directory in which you 
want to store it.

{button Related Topics,PI(`',`IDH_RT_Export_Overview')}



To export a chart



Export command



Spell Checking
{button Tell me how . . .,PI(`',`IDH_HT_Spell_Checking')}

The program checks spelling by comparing words in your document with words in a dictionary. The 
default dictionary is a file containing thousands of words. If a word is found that is not in the 
dictionary, the word is considered a possible misspelling. You can:

Define user dictionaries for special purposes.
Specify the program to ignore words with numbers during spell checking.

A list of words displays similar to the misspelled word from the currently used dictionary. You can 
select one of the words, type the correct spelling yourself, ignore the word, or add the "misspelled" 
word to the user dictionary.

{button Related Topics,PI(`',`IDH_RT_Spellingprefs')}



To choose spelling options



Tools menu 
To choose spelling options



To define master items
1 On the Format menu, click Chart Properties.
2 If necessary, click the Master Items tab.
3 In the box, select the master items you want.
4 Click to select whether you want to display the master items on all pages or only on the first 

page of the chart.
5 Click OK.

Tips
Double-click a master item in a chart to open the Master Items dialog box.
After master items are in the chart, you can select and move them individually with the mouse.

{button Related Topics,PI(`',`IDH_RT_To_define_Master_Items')}



Master Items
Format menu



To move master items
1 Click the Selector tool.

Selector tool
2 Select the master item on the first page you want to move. (To select more than one item, 
press and hold shift as you select the items.)
3 Press and hold the left mouse button, and drag the item where you want it.
4 Release the mouse button.
Note

When you move an item on the first page, the corresponding items on other pages move to the
same relative position if master items appear on all chart pages.

{button Related Topics,PI(`',`IDH_RT_To_move_Master_Items')}



Master Items
To define Master items
Format menu



To protect a chart
1 On the Tools menu, click Protect Chart .
2 Type a password. Press tab.
3 Type the password again, exactly as before.
4 Click OK.

Note
If you open a chart that is protected, you receive a message reminding you that you have to 

enter the password before you can make changes to it.

{button Related Topics,PI(`',`IDH_RT_To_protect_a_chart')}



To unprotect a chart
Protect Chart command
Protecting charts



To unprotect a chart
1 On the Tools menu, click Unprotect Chart .
2 Type the correct password.
3 Click OK.

Note
If you enter the wrong password, a message displays telling you that the password is incorrect.

Click OK and enter the correct password. Click Cancel in the Unprotect Chart dialog box if you do not 
know the password. You can change the chart after you enter the correct password.

{button Related Topics,PI(`',`IDH_RT_To_remove_chart_protection')}



To protect a chart
Protect Chart command
Protecting charts



To choose spelling options
1 On the Tools menu, click Options .
2 Click the Spelling tab.
3 Type the path and file name of the dictionary to be used for spell checking.
4 To ignore words with numbers, click Ignore Words with Numbers.
5 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_choose_spelling_options')}



Spell Checking
Spelling command
Options command (Tools menu)
To check spelling
Tools menu



To check spelling
1 Select the elements you want to spell check. (The entire chart is spell checked if no elements are

selected.)
2 On the Tools menu, click Spelling.

Possibly misspelled words are displayed in the Not in Dictionary box in the dialog box. A 
suggested replacement is shown in the Change To box.

3 You may type in a replacement or choose another replacement from the list, if you wish.
4 To correct the word, click Change or Change All.
5 If the word is not misspelled, click Add to add the word to the user dictionary and continue, or 

click Ignore or Ignore All to ignore the word or every instance of the word, respectively.

{button Related Topics,PI(`',`IDH_RT_To_check_spelling')}



Spell Checking
Spelling command
Options command (Tools menu)
To choose spelling options
Tools menu



To export a chart
1 Open the chart you want to export.
2 On the File menu, click Export.
3 Enter a new name for the chart.
4 In the Save as type list, click the type of file you want to create.
5 Click Save.

{button Related Topics,PI(`',`IDH_RT_To_export_a_chart')}



Export Overview
File menu



To display or hide page numbers
1 On the Format menu, click Chart Properties.
2 If necessary, click the Master Items tab.
3 Clear the Page Number check box.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_displayhide_page_numbers')}



To define master items
To move page numbers
To move master items
Master Items
Format menu



To move page numbers
1 Click the Selector tool.

Selector tool
2 Select the page number master item on the first page you want to move. (To select more than 
one item, press and hold shift as you select the items.)
3 Press and hold the left mouse button, and drag the item where you want it.
4 Release the mouse button.

{button Related Topics,PI(`',`IDH_RT_move_page_numbers')}



To define master items
To move master items
To display or hide page numbers
Master Items



To display or hide the chart date and time of creation
1 On the Format menu, click Chart Properties.
2 If necessary, click the Master Items tab.
3 Clear Date check box and the Time check box.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_displayhide_chart_datetime')}



To define master items
To move master items
Master Items
Format menu



To add a logo to a chart
1 On the Format menu, click Chart Properties.
2 If necessary, click the Master Items tab.
3 Select the Logo master item check box.
4 If there is no current logo, you can click the Logo button to import a logo into a chart. The Logo 

dialog box opens.
5 Click the file with the logo you want to use.
6 Click Open.

Tip
The logo you import is saved in the chart file. You can display and hide the logo after you 

import it.

{button Related Topics,PI(`',`IDH_RT_add_logo_to_a_chart')}



To define master items
To move master items
Master Items
Format menu



To display or hide the chart filename and path
1 On the Format menu, click Chart Properties.
2 If necessary, click the Master Items tab.
3 Clear Chart Name check box.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_displayhide_chart_filename_path')}



To define master items
To move master items
Master Items
Format menu



To change the appearance of your page
1 Click the Selector tool.

Selector tool
2 To move a master item, select the master item on the first page you want to move. (To select 
more than one item, press and hold shift as you select the items.)
3 Press and hold the left mouse button, and drag the item where you want it.
4 Release the mouse button.
5 To hide a master item that is displayed, double-click that master item with the Selector tool.
6 Clear the item from the Master Items tab, and click OK.
7 To display a master item or change text, on the Format menu, click Chart Properties.
8 If necessary, click the Master Items tab.
9 Select the item to display.
10 Click OK.

{button Related Topics,PI(`',`IDH_RT_to_change_the_appearance_of_page')}



To define master items
To move master items
To display or hide page numbers
To add a logo to a chart

To display or hide the chart filename and path
To display or hide the chart date and time of creation
Master Items
Format menu



To automatically lay out a chart
1 On the Format menu, click Chart Properties.
2 If necessary, click the Master Items tab.
3 Select all master items you want on the page.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_automatically_layout_chart')}



To define master items
Master Items
Format menu



To set up a header
1 On the Format menu, click Chart Properties.
2 If necessary, click the Master Items tab, and select all master items you want in the header.
3 Click OK.
4 Using the Selector tool, arrange the master items as you want them to appear on your chart's 

header.

{button Related Topics,PI(`',`IDH_RT_To_set_up_header')}



To define master items
To move master items
To set up a header

Master Items
Format menu



To set up a footer
1 On the Format menu, click Chart Properties.
2 If necessary, click the Master Items tab, and select the Page Number check box.
3 Select the All Pages radio button.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_set_up_footer')}



To define master items
To display or hide page numbers
To set up a header

Master Items
Format menu



Data toolbar
{button Tell me how . . .,PI(`',`IDH_HT_Data_Toolbar')}

Insert Data Fields 
button

Enters data into data fields.

Data Fields 
Options button

Lets you set up the placement and 
styles for your data fields in 
relation to your shapes.

Input Report 
button

Generates a report that lists the 
chart’s shapes, each followed by 
the lines coming into them.

Output Report 
button

Generates a report that lists the 
chart’s shapes, each followed by 
the lines leaving them.

Metrics Report 
button

Generates a report that lists the 
chart’s shapes and other elements,
followed by all the lines for the 
chart.

Update Data 
Fields button

Lets you automatically update 
linked field data.

Field Viewer 
button

Lets you enter data for the 
selected shape into the Field 
Viewer dialog box.

Insert Legend 
button

Hides or shows a chart legend.

Import Data 
button

Lets you import data to your active
worksheet.

{button Related Topics,PI(`',`IDH_RT_Data_toolbar')}



Insert Data Fields button 
Data Field Options button 

Input Report button 
Output Report button 
Metrics Report button 

Update Data Fields button 
Field Viewer button
Insert Legend button 
Import Data button



To dock toolbars
To hide toolbars



Insert Data Fields button
You can attach fields to shapes so that you can associate data with them. Before you can 

attach fields to a shape, you must set up the fields. The table of fields includes field names, field type, 
field format, an accumulation method (formula), and an option to show or hide the field descriptions in 
the chart. 

The field descriptions apply to all shapes in a chart. Therefore, any changes you make to the field 
description table will be applied to all the shapes that have fields attached. The Setup Fields 
command is on the Insert menu.

{button Related Topics,PI(`',`IDH_RT_Setup_Fields_button')}



To set up a data field 
To delete a field 
To display shape data 

To format fields 
To rearrange the order of fields 
To save a report to a file 



Lets you attach fields to shapes so that you can associate data with them.



Data Field Options button
Lets you specify where to place the data in respect to the shape and how you want the data to 

look.

{button Related Topics,PI(`',`IDH_RT_Data_Field_Options_button')}



To format fields 



Lets you specify where to place the data and how the data will look.



Input Report button
The Input Report button generates a report that lists the chart’s shapes, each followed by the 

lines coming into them. This type of report is commonly used to find redundant activities.

{button Related Topics,PI(`',`IDH_RT_Input_Report_button')}



To print data 
To save a report to a file 
Reporting Field Data



Generates a report that lists the chart’s shapes, each followed by the lines coming into them. This 
type of report is commonly used to find redundant activities.



Output Report button
The Output Report button generates a report that lists the chart’s shapes, each followed by the

lines leaving them. This type of report is commonly used to find unused activities.

{button Related Topics,PI(`',`IDH_RT_Output_Report_button')}



To print data
To save a report to a file
Reporting Field Data



Generates a report that lists the chart’s shapes, each followed by the lines leaving them. This type 
of report is commonly used to find unused activities.



Metrics Report button
The Metrics command on the Report submenu generates a report that lists the chart’s shapes 

and other elements, followed by all the lines for the chart. This report is commonly used to find total 
cycle times.

{button Related Topics,PI(`',`IDH_RT_Metrics_button')}



To print data 
To save a report to a file
Reporting Field Data



Generates a report that lists the chart’s shapes and other elements, followed by all the lines for the 
chart. This report is commonly used to find total cycle times.



Update Data Fields button
The Update Data Fields button lets you automatically update linked field data. If there are no 

linked fields in your chart, this command is gray.
Note
 If a chart has linked data fields, the data fields are automatically updated when you open the 

chart.

{button Related Topics,PI(`',`IDH_RT_Update_button')}



To update field data



Automatically updates linked field data. If there are no linked fields in your chart, this command is 
gray.

Note
 If a chart has linked data fields, the data fields are automatically updated when you open the 

chart.



Field Viewer button
The Field Viewer button opens the Field Viewer dialog box, where you can enter data into the 

chart’s fields.

{button Related Topics,PI(`',`IDH_RT_Viewer_button')}



To show the Field Viewer
To hide the Field Viewer



Opens the Field Viewer dialog box.



Insert Legend button
The Legend is a special shape, which reports the totals of the fields within the bounds of the 

shape. The reported totals reflect the current state of the fields in the chart and update automatically 
when any field changes. As with other shapes, the "totals" in this shape are shown in the same font 
and style as other field data.
Note

This button only displays or hides the legend. It does not display or hide the legend for an SPC 
chart. To display or hide an SPC chart’s legend, activate the SPC chart by double-clicking on it. On the 
Insert menu, click Legend. An SPC chart’s legend identifies the different elements of the SPC chart.

{button Related Topics,PI(`',`IDH_RT_Legend_button')}



To display or hide the legend



Displays or hides the legend. The legend reports the totals of the fields.



Import Data button
The Import Data button imports data into your active worksheet. The Import Data button opens

the Data Import wizard.

{button Related Topics,PI(`',`IDH_RT_Get_Data_button')}



Worksheet command
Import Data command
View menu
Tools menu



Imports data into your active worksheet by opening the Data Import wizard.



Toolbox toolbar
{button Tell me how . . .,PI(`',`IDH_HT_Toolbox')}

The Toolbox toolbar gives you easy access to the tools you use most to create and change charts.
Click an icon below to read more information about the tool.

Selector tool Selects, moves, and resizes objects
in a chart.

Rotate tool Rotates objects in a chart.
Edit tool Resizes and reshapes objects in a 

chart.
Shape tool Places shapes in a chart and 

selects shape attributes and 
properties.

Connector 
Lines tool

Connects shapes with different 
types of lines. Choose from Direct, 
Right Angle, Curved, Org Chart, 
and Cause and Effect lines.

Text tool Enters and changes text.
Renumber 
tool

Renumbers shapes.

Draw tool Draws freehand lines and shapes 
in your chart.

{button Related Topics,PI(`',`IDH_RT_TOOLBOX')}



To dock toolbars
To hide toolbars
To place a connected shape
To draw an unconnected line

To create a text block
To renumber shapes manually
To view a particular area of a chart
To choose line routing type



Selector tool
Rotate tool
Edit tool
Shape tool

Connector Lines tool
Text tool
Renumber tool
Draw tool



Selector tool
The Selector tool selects and resizes objects in a chart.

{button Related Topics,PI(`',`IDH_RT_OBJSEL')}



Toolbox toolbar
Placing Shapes in a Chart



Selects and resizes objects in a chart.



Rotate tool
The Rotate tool rotates objects in a chart.

{button Related Topics,PI(`',`IDH_RT_TB_Rotate')}



To rotate an object
Toolbox toolbar



Rotates objects in a chart.



Edit tool
The Edit tool resizes and reshapes objects in a chart.

{button Related Topics,PI(`',`IDH_RT_EDITTOOL')}



To resize and reshape shapes
Toolbox toolbar



Changes objects, connect points, and text layout    in a chart.



To resize and reshape objects
1 Click the Selector tool, and select the object you want to resize or reshape.

Selector tool
2 Click the Edit tool.

Edit tool
3 Click Shape.
4 Click a handle on the shape, and move the cursor in the direction you want to resize or 
reshape.
5 When you are finished, click the Selector tool.

{button Related Topics,PI(`',`IDH_RT_To_resize_and_reshape_shapes')}



Edit tool
Toolbox toolbar



Shape tool
The Shape tool places shapes in a chart.

You can use different shapes to represent steps, documents, events, and other information in charts.

{button Related Topics,PI(`',`IDH_RT_SHAPETOOL')}



Toolbox toolbar
Determining the Way Shapes Look
Choosing Shape Styles That Enhance Your Chart
Placing Shapes in a Chart
Preset Shape Styles



Places shapes in a chart.



Connector Lines tool
The Connector Lines tool connects shapes with different types of lines and to create org charts 

and cause-and-effect charts.
You can use lines to show data and sequence flows and control transfers in charts.
Arrows and other line end styles can represent the direction of data flow, as well as transitions and 
relationships between steps. When you connect shapes with a line and then move the shapes, the 
line stays attached to the shapes.
You can also adds text to lines. You can use text to identify the relationship between steps or simply 
to label the lines.

{button Related Topics,PI(`',`IDH_RT_LINETOOL')}



Toolbox toolbar
To choose line routing types
Direct Line tool
Right Angle Line tool

Curved Line tool
Org Line tool
Cause and Effect tool



Connects shapes with different types of lines and create org charts and cause-and-effect charts.



Text tool
The Text tool types text blocks, types text on lines, and changes text. (It is not necessary to 

select the Text tool to add text to a selected shape.)

{button Related Topics,PI(`',`IDH_RT_TEXTTOOL')}



Toolbox toolbar
Creating Text Blocks
Determining the Way Text Looks



Types text blocks, types text on lines, and changes text. (It is not necessary to select the Text tool to
add text to a selected shape.)



Renumber tool
The Renumber tool numbers and renumbers shapes.

When you choose the Renumber tool, the cursor becomes a numbering wand and numbers shapes 
in the sequence that you choose them.

{button Related Topics,PI(`',`IDH_RT_NUMBERTOOL')}



Toolbox toolbar
Shape Numbers Overview



Numbers and renumbers shapes.
When you choose the Renumber tool, the cursor becomes a numbering wand and numbers shapes 
in the sequence that you choose them.



Draw tool
The Draw tool draws freehand lines and shapes in your chart. 

The Draw tool provides the following freehand lines and shapes for you to draw with:
Square
Rounded square
Rectangle
Rounded rectangle
Circle
Ellipse
Polygon
Smoothed polygon
Jointed Line
Curved Line

{button Related Topics,PI(`',`IDH_RT_DrawTool')}



Drawing Basics
Drawing Lines
Drawing Shapes
Toolbox toolbar



Draws freehand lines and shapes in your chart.



Draws a square



Draws a square with rounded corners



Draws a rectangle



Draws a rectangle with rounded corners



Draws a circle



Draws an ellipse



Draws an irregular polygon



# IDH_CSH_Smoothed_polygon_tool_on_Draw_toolboxDraws an irregular polygon with smoothed 
corners



Draws shapes made of connected line segments



# IDH_CSH_Curved_Line_tool_on_Draw_toolboxDraws shapes made of curved lines



Direct Line tool
The Direct Line draws direct (straight) lines in a chart, allowing you to draw a horizontal, 

vertical, or diagonal line from one shape to another. You also can use the Direct Line tool to create 
multisegment lines.

{button Related Topics,PI(`',`IDH_RT_LINE')}



Toolbox toolbar
Connector Lines tool
To choose line routing type
To connect two shapes with a multisegment line



Draws direct (straight) lines in a chart, allowing you to draw a horizontal, vertical, or diagonal line 
from one shape to another. You also can use the Direct Line tool to create multisegment lines.



Curved Line tool
The Curved Line draws curved lines in a chart.

Some data-flow charts use curved lines to connect shapes.

{button Related Topics,PI(`',`IDH_RT_CURVEDLINE')}



Toolbox toolbar
Connector Lines tool
To choose line routing type
To connect two shapes with a multisegment line



Draws curved lines in a chart.



Right Angle Line tool
The Right Angle Line draws multisegment, right-angle lines.

Right-angle lines often are used because they fit easily between rows and columns of shapes, 
whereas direct and curved lines may pass through unrelated shapes.

{button Related Topics,PI(`',`IDH_RT_RIGHTLINE')}



Toolbox toolbar
Connector Lines tool
To choose line routing type
To connect two shapes with a multisegment line



Direct Line - draws direct (straight) lines in a chart, allowing you to draw a horizontal, vertical, or 
diagonal line from one shape to another. You also can use Direct Lines to create multisegment lines.
Right Angle Line - draws multisegment, right-angle lines.
Curved Line - draws curved lines in a chart.
Org Line - automatically draws a three-segment line.
Cause and Effect Line- draws cause-and-effect charts (also called Ishikawa or fishbone charts).



Org Line tool
The Org Line draws organization charts. This line type automatically draws a three-segment 

line. When multiple lines exit a shape at the same connect point, the second segments always align. 
Dragging the handle on any of the second segments drags all of them.

Organization lines can exit a shape in any direction; therefore, you can create family trees, reverse 
hierarchies, and tree charts in any direction.

{button Related Topics,PI(`',`IDH_RT_ORGLINE')}



Toolbox toolbar
Connector Lines tool
To choose line routing type
To create an organization chart



Automatically draws a three-segment line.



Cause and Effect Line tool
Cause and Effect draws cause-and-effect charts (also called Ishikawa or fishbone charts).

This tool automatically draws cause and sub-cause lines that are constrained to a 15-degree angle. 
Lines can be snapped to shapes. Sub-cause lines (also called factor lines) can be snapped to cause 
lines. 

Tips
To release the 15-degree increment constraint, press the Ctrl key.
Several levels of sub-cause lines can be added to the chart. 
Each cause-and-effect line has a text block automatically attached to its end.

{button Related Topics,PI(`',`IDH_RT_CAUSELINE')}



Connector Lines tool
To choose line routing type
To create a cause-and-effect chart from the template



Draws cause-and-effect charts (also called Ishikawa or fishbone charts).



Formatting toolbar
{button Tell me how . . .,PI(`',`IDH_HT_Formatting_Toolbar')}

The Formatting toolbar gives you easy access to the formatting options you use most to define the 
way text, lines, and shapes look in your charts. Additional formatting options can be accessed from 
the Format menu.
Click an icon below to read more information about the tool.

Font name box Displays and change the font 
name.

Font size box Displays and changes the font 
size.

Bold button Specifies text as bold.
Italic button Specifies text as italic.
Underline 
button

Specifies text as underline.

Vertical Align 
button

Aligns text vertically.

Horizontal 
Align button

Aligns text horizontally.

Text Color 
button

Changes the text color.

Fill Color 
button

Changes the fill color for shapes.

Line Color 
button

Changes the color for lines.

Line Style 
button

Changes the style (solid, dashed, 
dotted) for lines and shape 
borders.

Line Weight 
button

Changes the weight for lines and 
for shape borders.

Arrowheads 
button

Selects arrowhead styles.

Crossovers 
button

Selects the crossover style.

Filled Line 
button

Changes the line to an outline 
appearance.

 Shadow button Selects whether or not you want a
shadow.

3D button Selects whether or not you want 
the selection to be 3D.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting')}



To dock toolbars
To hide toolbars
To create a floating palette



Format menu
Font name box
Font size box

Bold button
Italic button
Underline button
Vertical Align button
Horizontal Align button

Text Color button
Fill Color button
Line Color button
Line Style button

Line Weight button
Arrowheads button
Crossovers button
Filled Line button

Shadow button
3D button



Contains tools that let you format text, lines, and shapes.
To display the Formatting toolbar, click Toolbars on the View menu, and then click Formatting.



Font Name box
The Font Name box displays and changes the name of the current font or the font of the text 

that contains the text cursor.
Tip

You also can use the commands on the Format menu to specify formats.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_FontName')}



Formatting toolbar
To change the way existing text looks
To choose text styles for new text



Displays and changes the name of the current font or the font of the text that contains the text 
cursor.



Font Size box
The Font Size box shows the current point size or the point size of the text that contains the 

text cursor and allows you to change it.
Tip

You also can use the commands on the Format menu to specify formats.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_FontSize')}



Shows the current point size or the point size of the text that contains the text cursor and allows you
to change it.



Formatting toolbar
To change the way existing text looks
To choose text styles for new text



Bold button
The Bold button turns text bold (or removes bold, if it is already bold).

Tip
You also can use the commands on the Format menu to specify formats.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_Bold')}



Formatting toolbar
To change the way existing text looks
To choose text styles for new text



Changes text to bold (or remove bold, if it is already bold).



Italic button
The Italic text style button turns text italic (or removes italic, if it is already italic).

Tip
You also can use the commands on the Format menu to specify formats.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_Italic')}



Formatting toolbar
To change the way existing text looks
To choose text styles for new text



Changes to text to italic style (or removes italic, if it is already italic).



Underline button
The Underline text style button underlines text (or removes underline, if it is already 

underlined).
Tip

You also can use the commands on the Format menu to specify formats. 

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_Underline')}



Formatting toolbar
To change the way existing text looks
To choose text styles for new text



Underlines text (or removes underline, if it is already underlined).



Vertical Align button
The Vertical Align button specifies Top, Middle, or Bottom alignment. Click the button and then 

choose from the menu.
Tips

You also can use the commands on the Format menu to specify formats.
There are also shortcut keys for aligning shapes: Top (Alt+4), Middle (Alt+6), Bottom (Alt+8).

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_VerticalAlign')}



Formatting toolbar
To change the way existing text looks
To choose text styles for new text



Specifies the selected object(s) to have top, middle, or bottom alignment.



Horizontal Align button
The Horizontal Align button specifies Left, Center, or Right alignment. Click the button and then

choose from the menu.
Tips

You also can use the commands on the Format menu to specify formats.
There are also shortcut keys for aligning shapes: Left (Alt+3), Center (Alt+5), Right (Alt+7).

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_HorizontalAlign')}



Formatting toolbar
To change the way existing text looks
To choose text styles for new text



Specifies the selected object(s) to have left, center, or right alignment.



Text Color button
The Text Color button applies color to text. 

When you click the down arrow next to the button, a palette of colors opens. If you click a color, it 
will be applied to the next shape or currently selected shapes. To set a custom color, click More 
Colors, and the Color dialog box opens.

Tip
You also can use the commands on the Format menu to specify text colors.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_TextColor')}



Formatting toolbar
To change the way existing text looks
To choose text styles for new text



Applies color to text.



Fill Color button
The Fill Color button specifies the color for a shape.

When you click the down arrow next to the button, a palette of colors opens. If you click a color, it 
will be applied to the next shape or currently selected shapes. To set a custom color, click More 
Colors, and the Color dialog box opens.

Tip
You also can use the commands on the Format menu to specify fill colors.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_FillColor')}



Formatting toolbar
To change the way existing shapes look
To change the properties for new shapes



Specifies a color for a shape.



Line Color button
The Line Color button applies color to lines, line endings, and shape borders.

When you click the Line Color button, the color palette opens for you to select a color. To set a 
custom color, click More Colors, and the Color dialog box opens.

Tip
You also can use the commands on the Format menu to specify line colors.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_LineColor')}



Specifies a color for selected lines, line endings, and shape borders.



Formatting toolbar
To change the way existing lines look
To choose line styles for new lines

To change the way existing shapes look
To change the properties for new shapes



Line Style button
The Line Style button lets you select from several line styles, such as solid and dotted, which 

are also used to define the border styles for shapes.
When you click the Line Style button, the Line Style menu opens. The menu contains the line style 
options for lines.

Tip
You also can use the commands on the Format menu to specify line styles.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_LineStyle')}



Formatting toolbar
To change the way existing lines look
To choose line styles for new lines
To change the way existing shapes look

To change the properties for new shapes



Specifies a line style, such as solid and dotted.



Line Weight button
The Line Weight button selects the weight of lines. Click the button and then use the arrows to 

adjust the weight.
It is also used to set the border weight for shapes.

Tips
You also can use the commands on the Format menu to specify line weight.
You cannot change the weight on dashed and dotted lines and borders.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_LineThickness')}



Formatting toolbar
To change the way existing lines look
To choose line styles for new lines
To change the way existing shapes look

To change the properties for new shapes



Selects the weight of lines and shape borders.



Arrowheads button
The Arrowheads button lets you select the arrowhead styles for the selected line.

When you click the button, a list of the most commonly used arrowheads opens. For a wider 
selection of arrowhead styles, click More at the bottom of the list.

Tip
You also can use the commands on the Format menu to specify arrowhead (Ends).

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_Arrowheads')}



Formatting toolbar
To change the way existing lines look
To choose line styles for new lines



Selects the arrowheads style for the selected line.



Crossovers button
The Crossovers button lets you change the crossover style for the currently selected line.

To change the crossover style for the entire chart, use the Crossovers option on the Format menu.

Tip
You also can use the commands on the Format menu to specify crossovers.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_Crossovers')}



Formatting toolbar
To change the way existing lines look
To choose line styles for new lines



Changes the crossover style for the currently selected line.



Filled Line button
The Filled Line button lets you change the selected line style to an outline appearance.

To change the filled line style for the entire chart, use the Filled Line option on the Format Object 
dialog box - Line tab.

Tip
You also can use the commands on the Format menu to specify styles for filled lines.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_FilledLines')}



Formatting toolbar
To change the way existing lines look
To choose line styles for new lines



Changes the selected line style to an outline appearance.



Shadow button
The Shadow button selects a drop shadow for the current shape.

When you click the Shadow button, the Shadow menu opens.

Tip
You also can use the commands on the Format menu to specify shadows.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_Shadow')}



Formatting toolbar
To change the way existing shapes look
To change the properties for new shapes



Selects a drop shadow for the current shape.



3D button
The 3D button selects a 3D effect for the current shape.

When you click the 3D button, the 3D menu of styles opens.

Tip
You also can use the Effects command on the Format menu to specify 3D effects.

{button Related Topics,PI(`',`IDH_RT_TB_Formatting_3D')}



Formatting toolbar
To change the properties of an existing shape 
To change the properties for new shapes



Selects a 3D effect for the current shape.



Preset Styles toolbar
{button Tell me how . . .,PI(`',`IDH_HT_PresetStyles_Toolbar')}

The Preset Styles toolbar stores and accesses the styles that you use most frequently for text, 
shapes, and lines.
Click an icon below to read more information about the tool.

Shape Style 
box

Contains the list of 
current preset styles.

Add Shape 
Style button

Adds a preset style to 
the list.

Edit Shape 
Styles button

Renames or removes 
a preset style.

Line Style box Contains the list of 
current preset styles.

Add Line Style 
button

Adds a preset style to 
the list.

Edit Line 
Styles button

Renames or removes 
a preset style.

Text Style box Contains the list of 
current preset styles.

Add Text Style 
button

Adds a preset style to 
the list.

Edit Text 
Styles button

Renames or removes 
a preset style.

{button Related Topics,PI(`',`IDH_RT_TB_PresetStyles')}



To dock toolbars
To hide toolbars



Preset Shape Styles
Preset Line Styles
Preset Text Styles
Formatting toolbar

Shape Style box
Add Shape Style button
Edit Shape Styles button
Line Style box

Add Line Style button
Edit Line Styles button
Text Style box
Add Text Style button

Edit Text Styles button



Creates and uses preset styles for text, lines, and shapes.



Shape Style box
The Shape Style box shows the current styles for shapes, including the border and shadow 

style and width, fill pattern, and color. The styles are applied to the next shape you place in your chart.
When you click the down arrow, the Shape Style list opens. Use this list to choose styles you have 
saved and want to apply to new or existing shapes.

{button Related Topics,PI(`',`IDH_RT_TB_PresetStyles_ShapeList')}



Preset Shape Styles
Add Shape Style button
Edit Shape Styles button

To add a preset shape style
To delete a preset shape style
To rename a preset shape style



Shows the current styles for shapes, including the border and shadow style and width, fill pattern, 
and color. The styles are applied to the next shape you place in your chart.



Add Shape Style button
The Add Shape Style button adds the current shape style to the Shape Style list.

{button Related Topics,PI(`',`IDH_RT_TB_PresetStyles_ShapeAdd')}



Preset Shape Styles
Shape styles box
Edit Shape Styles button

To add a preset shape style
To delete a preset shape style
To rename a preset shape style



Adds the current shape styles to the Shape Style list.



Edit Shape Styles button
The Edit Shape Styles button renames or removes the selected item from the Shape Style list.

{button Related Topics,PI(`',`IDH_RT_TB_PresetStyles_ShapeEdit')}



Preset Shape Styles
Shape styles box
Add Shape Style button

To add a preset shape style
To delete a preset shape style
To rename a preset shape style



Opens a dialog box that renames or removes an item from the Shape Style list.



Line Styles box
The Line Styles box shows the current styles for lines, including the line and arrow styles, 

widths, and colors. The styles are applied to the next line you draw.
When you click the down arrow, the Line Style list opens. Use this list to choose styles you have 
saved and want to apply to new or existing lines.

{button Related Topics,PI(`',`IDH_RT_TB_PresetStyles_LineList')}



Preset Line Styles
Add Line Style button
Edit Line Styles button

To add a preset line style
To delete a preset line style
To rename a preset line style



Shows the current styles for lines, including the line and arrow styles, widths, and colors. The styles 
are applied to the next line you draw.



Add Line Style button
The Add Line Style button adds the current line style to the Line Style list.

{button Related Topics,PI(`',`IDH_RT_TB_PresetStyles_LineAdd')}



Preset Line Styles
Line styles box
Edit Line Styles button

To add a preset line style
To delete a preset line style
To rename a preset line style



Adds the current line styles to the Line Style list.



Edit Line Styles button
The Edit Line Styles button renames or removes the selected item from the Line Style list.

{button Related Topics,PI(`',`IDH_RT_TB_PresetStyles_LineEdit')}



Preset Line Styles
Line styles box
Add Line Style button

To add a preset line style
To delete a preset line style
To rename a preset line style



Opens a dialog box that renames or removes a style from the Line Style list.



Text Style box
The Text Style box shows the current styles for text, including the font, size, style, and color. 

The styles are applied to the next character you type.
When you click the down arrow, the Text Style list opens. Use this list to choose styles you have 
saved and want to apply to new or existing text.

{button Related Topics,PI(`',`IDH_RT_TB_PresetStyles_TextList')}



Preset Text Styles
Add Text Style button
Edit Text Styles button

To add a preset text style
To delete a preset text style
To rename a preset text style



Shows the current styles for text, including the font, size, style, and color. The styles are applied to 
the next character you type.
When you click the down arrow, the Text Style list opens. Use this list to choose styles you have 
saved and want to apply to new or existing text.



Add Text Style button
The Add Text Style button adds the current text style to the Text Style box.

{button Related Topics,PI(`',`IDH_RT_TB_PresetStyles_TextAdd')}



Preset Text Styles
Text styles box
Edit Text Styles button

To add a preset text style
To delete a preset text style
To rename a preset text style



Adds the current text styles to the Text Style list.



Edit Text Styles button
The Edit Text Styles button renames or removes the selected item from the Text Style list.

{button Related Topics,PI(`',`IDH_RT_TB_PresetStyles_TextEdit')}



Preset Text Styles
Text styles box
Add Text Style button

To add a preset text style
To delete a preset text style
To rename a preset text style



Opens a dialog box that renames or removes an item from the Text Style list.



Edit Styles dialog box - Shape Styles tab

The Edit Styles dialog box - Shape Styles tab manages the list of preset shape styles by removing 
unwanted items and assigning meaningful names to the styles.

{button Related Topics,PI(`',`IDH_RT_DB_EditStyles_ShapeStyles')}



To delete a preset shape style
To rename a preset shape style



Shows the available styles.



Removes the highlighted style from the list.



Assigns a meaningful name to a style, such as “red - priority.”



Edit Styles dialog box - Line Styles tab

The Edit Styles dialog box - Line Styles tab manages the list of preset line styles by removing 
unwanted items and assigning meaningful names to the styles.

Tip
You cannot change the line settings of a preset style.    If you want to change a preset style, 

delete the old preset style and create a new one with the same name.

{button Related Topics,PI(`',`IDH_RT_DB_EditStyles_LineStyles')}



To delete a preset line style
To rename a preset line style



Shows the available line styles.



Removes the highlighted line style from the list of preset styles.



Assigns a meaningful name to a line style, such as “green dashed - outside vendor.”



Edit Styles dialog Box - Text Styles tab

The Edit Styles dialog Box - Text Styles tab manages the list of preset text styles by removing 
unwanted items and assigning meaningful names to the styles.

{button Related Topics,PI(`',`IDH_RT_DB_EditStyles_TextStyles')}



To delete a preset text style
To rename a preset text style



Shows the available text styles.



Removes the highlighted text style from the list of preset styles.



Assigns a name to a text style, such as “Arial 15 pt, blue.”



Arrange toolbar
{button Tell Me how . . .,PI(`',`IDH_HT_Arrange_Toolbar')}

The Arrange toolbar gives you easy access to the buttons that help you arrange the shapes on your 
charts. These actions are also accessible from the Arrange menu.
Click an icon below to read more information about the tool.

Bring to 
Front

Brings the selected objects to the front.

Send to Back Sends the selected objects to the back.
Bring 
Forward

Brings the selected object one place 
forward.

Send 
Backward

Sends the selected object one place 
backward.

Rotate Right Rotates the selected objects 90 degrees
to the right.

Rotate Left Rotates the selected objects 90 degrees
to the left.

Flip 
Horizontal

Flips the selected objects horizontally.

Flip Vertical Flips the selected objects vertically.
Replace 
Shape

Replaces the selected shapes with the 
current shape from the Shape palette.

Fit to Text Resizes shapes and text blocks to fit the
text.

Align Left Aligns the selected shapes vertically 
along their left edges.

Align Center Aligns the selected shapes vertically 
along their centers.

Align Right Aligns the selected shapes vertically 
along their right edges.

Align Top Aligns the selected shapes horizontally 
along their top edges.

Align Middle Aligns the selected shapes horizontally 
along their middles.

Align Bottom Aligns the selected shapes horizontally 
along their bottom edges.

Make Same 
Size, Width

Makes the selected shapes the same 
width.

Make Same 
Size, Height

Makes the selected shapes the same 
height.

Make Same 
Size, Both

Makes the selected shapes the same 
size based on both width and height.

Make Same Makes the selected shapes the same 



Size, Fit to 
Text

size based on their text.

Space Evenly
Across, 
Centers

Spaces the selected shapes evenly 
across the chart based on the centers.

Space Evenly
Down, 
Centers

Spaces the selected shapes evenly 
down the chart based on the centers.

Space Evenly
Across, 
Edges

Spaces the selected shapes evenly 
across the chart based on the edges.

Space Evenly
Down, Edges

Spaces the selected shapes evenly 
down the chart based on the edges.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange')}



Arrange menu
To dock toolbars
To hide toolbars

Bring to Front button
Send to Back button
Bring Forward button
Send Backward button

Rotate Right button
Rotate Left button

Flip Horizontal button
Flip Vertical button
Replace Shape button
Fit to Text button

Align Left button
Align Center button
Align Right button

Align Top button
Align Middle button
Align Bottom button

Make Same Size, Width button
Make Same Size, Height button
Make Same Size, Both button
Make Same Size, Fit to Text button

Space Evenly Across, Centers button
Space Evenly Down, Centers button
Space Evenly Across, Edges button
Space Evenly Down, Edges button



To dock toolbars
To hide toolbars



Bring to Front button
The Bring to Front button brings the selected objects to the front.

Tip
You also can use the Bring to Front command on the Order submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_BringToFront')}



Arrange menu
Arrange toolbar
Bring to Front command
To bring an object to the front



Brings the selected objects to the front.



Send to Back button
The Send to Back button sends the selected objects to the back.

Tip
You also can use the Send to Back command on the Order submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_SendToBack')}



Arrange menu
Arrange toolbar
Send to Back command
To send an object to the back



Sends the selected objects to the back.



Bring Forward button
The Bring Forward button brings the selected object one place forward.

Tip
You also can use the Bring Forward command on the Order submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_BringForward')}



Arrange menu
Arrange toolbar
Bring Forward command
To move an object forward one layer



Brings the selected object one place forward.



Send Backward button
The Send Backward button sends the selected object one place backward.

Tip
You also can use the Send Backward command on the Order submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_SendBackward')}



Arrange menu
Arrange toolbar
Send Backward command
To move an object back one layer



Sends the selected object one place backward.



Rotate Right button
The Rotate Right button rotates the selected objects 90 degrees to the right.

Tip
You also can use the Rotate Right command on the Rotate/Flip submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_RotateRight')}



Arrange menu
Arrange toolbar
Rotate Right command
To rotate an object



Rotates the selected objects 90 degrees to the right.



Rotate Left button
The Rotate Left button rotates the selected objects 90 degrees to the left.

Tip
You also can use the Rotate Left command on the Rotate/Flip submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_RotateLeft')}



Arrange menu
Arrange toolbar
Rotate Left command
To rotate an object



Rotates the selected objects 90 degrees to the left.



Flip buttons
The Flip Horizontal button flips the selected objects horizontally.
The Flip Vertical button flips the selected objects vertically.

Tip
You also can use the Flip Horizontal and Flip Vertical commands on the Rotate/Flip submenu of 

the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_Flip')}



Arrange menu
Arrange toolbar
To flip an object



Flips the selected objects horizontally.



Flips the selected objects vertically.



Replace Shape button
The Replace Shape button replaces the selected shapes with the current shape from the Shape

palette.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_ReplaceShape')}



Arrange toolbar
Replace Shape command
To replace shapes



Replaces the selected shapes with the current shape from the Shape palette.



Fit to Text button
The Fit to Text button resizes shapes and text blocks to fit the text.

Tip
You also can use the Fit to Text command on the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_FitToText')}



Arrange menu
Arrange toolbar
Fit to Text command
To fit a shape to text



Align buttons

The align buttons are on the Arrange toolbar.
Align Left 
button

Aligns the selected shapes vertically 
along their left edges.

Align Center 
button

Aligns the selected shapes vertically 
along their centers.

Align Right 
button

Aligns the selected shapes vertically 
along their right edges.

Align Top 
button

Aligns the selected shapes 
horizontally along their top edges.

Align Middle 
button

Aligns the selected shapes 
horizontally along their middles.

Align Bottom 
button

Aligns the selected shapes 
horizontally along their bottom 
edges.

Tips
You also can use the Align submenu commands on the Arrange menu.
There are also shortcut keys for aligning shapes: Align Top (Alt+4), Align Middle (Alt+6), Align 

Bottom (Alt+8), Align Left (Alt+3), Align Center (Alt+5), and Align Right (Alt+7).

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_Align')}



To align objects
To show and hide toolbars
Align command
Arrange menu

Arrange toolbar



Aligns the selected shapes vertically along their left edges.



Aligns the selected shapes vertically along their centers.



Aligns the selected shapes vertically along their right edges.



Aligns the selected shapes vertically along their top edges.



Aligns the selected shapes vertically along their middles.



Aligns the selected shapes vertically along their bottom edges.



Make Same Size buttons

The Make Same Size buttons are on the Arrange toolbar. 
Makes the selected shapes the same width.
Makes the selected shapes the same height.
Makes the selected shapes the same size based on both width 
and height.
Makes the selected shapes the same size based on their text.

Tip
You also can use the Make Same Size submenu commands on the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_MakeSameSize')}



Arrange menu
Arrange toolbar
Make Same Size command
To make objects the same size



Makes the selected shapes the same width.



Makes the selected shapes the same height.



Makes the selected shapes the same size based on both width and height.



Makes the selected shapes the same size based on their text.



Space Evenly buttons

The Space Evenly buttons are on the Arrange toolbar. 
Spaces the selected shapes evenly across the chart based on 
the centers.
Spaces the selected shapes evenly down the chart based on 
the centers.
Spaces the selected shapes evenly across the chart based on 
the edges.
Spaces the selected shapes evenly down the chart based on 
the edges.

Tip
You also can use the Space Evenly submenu commands on the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Arrange_SpaceEvenly')}



Arrange menu
Arrange toolbar
Space Evenly command
To space objects evenly



Spaces the selected shapes evenly across the chart based on the centers.



Spaces the selected shapes evenly down the chart based on the centers.



Spaces the selected shapes evenly across the chart based on the edges.



Spaces the selected shapes evenly down the chart based on the edges.



Contains tools that let you align, flip, rotate, reorder, replace, and otherwise arrange objects. 
Objects include shapes, text, and lines. You cannot perform all operations on all types of objects.    
For example, you can only rotate or flip shapes.



Arrange+ toolbar
{button Tell Me how . . .,PI(`',`IDH_HT_Arrangeplus_Toolbar')}

The Arrange+ toolbar gives you easy access to the buttons that help you arrange the shapes on 
your charts. These actions are also accessible from commands on submenus of the Arrange menu.
Click an icon below to read more information about the tool.

Combine Into
New Shape 
button

Creates a new shape from the selected 
objects.

Break Apart 
button

Breaks apart a new shape that was 
formed with the Make New Shape 
command or Combine Into New Shape 
button.

Connect 
Open button

Connects open objects.

Connect 
Closed 
button

Connects closed objects.

Disconnect 
button

Disconnects connected objects.

Join button Creates a new shape by joining the 
selected objects together.

Intersect 
button

Creates new shape from the 
intersection of the selected objects.

Punch button Creates a new shape by punching the 
bottom shape with the top one.

Fragment 
button

Creates a series of new shapes by 
fragmenting the selected, overlapping 
shapes. The Fragment button makes 
new shapes out of the overlapping 
areas and trims the remaining areas 
into new shapes as well.

Trim button Creates a new shape by trimming the 
bottom shape with the top one.

Outline 
button

Creates a new shape from the outline of
the selected shapes.

Slice button Slices the selected closed shape with 
the selected open shape.

Replace 
Shape button

Replaces the selected shape(s) with the 
shape in the Shape palette.

Reverse Ends
button

Reverses the ends of the selected line.

Fit to Text 
button

Resizes the selected object or objects 
based on their text.

Layer Displays information on each layer, and 



Manager 
button

lets you 

Add Layer 
button

Add layer to the chart.

Edit All 
Layers 
button

Edits the layers for the chart.

Move To 
Layer button

Moves objects between layers.

Move Back 
One Layer 
button

Moves you back one layer.

Move 
Forward One 
Layer button

Moves you forward one layer.

{button Related Topics,PI(`',`IDH_RT_Arrangeplus_toolbar')}



Combine Into New Shape button
Break Apart button
Connect Open button
Connect Closed button

Disconnect button
Join button
Intersect button
Punch button

Fragment button
Trim button
Outline button
Slice button

Replace Shape button
Reverse Ends button
Fit to Text button
Layer Manager button

Add Layer button
Edit All Layers button
Move to Layer button
Move Back One Layer button

Move Forward One Layer button



To dock toolbars
To hide toolbars



Combine Into New Shape button
The Combine Into New Shape button creates a new shape from the selected objects.

Tip
You also can use the Make New Shape command on the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_Combine_Into_New_Shape_button')}



To make a new shape 
Make New Shape command 
Arrange menu 



Creates a new shape from the selected objects.



Break Apart button
The Break Apart button breaks apart a new shape that was formed with the Make New Shape 

command or Combine Into New Shape button.
Tip

You also can use the Break Apart command on the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_Break_Apart_button')}



To break apart a shape 
Break Apart command 
Arrange menu 



Breaks apart a new shape that was formed with the Make New Shape command or Combine Into 
New Shape button.



Fragment button
The Fragment button creates a series of new shapes by fragmenting the selected, overlapping 

shapes. The Fragment button makes new shapes out of the overlapping areas and trims the remaining 
areas into new shapes as well.
Tip

You also can use the Fragment command on the Combine submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_Fragment_button')}



To fragment objects 
Fragment command 
Arrange menu 



Creates a series of new shapes by fragmenting the selected, overlapping shapes. The Fragment 
button makes new shapes out of the overlapping areas and trims the remaining areas into new 
shapes as well.



Fit to Text button
The Fit To Text button resizes the selected object or objects based on their text.

Tip
You also can use the Fit To Text command on the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_Fit_to_Text_button')}



To fit a shape to text 
Fit To Text command 
Arrange menu 



Resizes the selected object or objects based on their text.



Reverse Ends button
The Reverse Ends button reverses the ends of the selected line.

Tip
You also can use the Reverse Ends command on the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Reverse_Ends')}



Arrange menu
Arrange+ toolbar
Reverse Ends command



Reverses the ends of the selected line.



Layer Manager button
The Layer Manager button opens the Layer Manager that lists the layers defined for the active 

document and performs layer operations. In Layer Manger, you can change the visible, print, and lock 
properties of layers. Also, Layer Manager selects the current layer; adds, deletes, and renames layers; 
changes the order of layers; and specifies whether you want to change the current or all layers.
Tip

You also can use the Layer Manager command on the Layers submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Layer_Manager')}



Arrange menu
Arrange+ toolbar



Opens the Layer Manager that lists the layers defined for the active document and performs layer 
operations.



Add Layer button
The Add Layer button adds a new layer.

Tip
You also can use the Add Layer command on the Layers submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Add_Layer')}



To add a layer to the active chart 
Arrange menu
Arrange+ toolbar



Adds a new layer.



Edit All Layers button
The Edit All Layers button lets you select, move, and change all objects in the active chart, 

regardless of the layer on which they are located. When changing all layers, you cannot move an 
object on a lower layer in front of an object on a higher layer.
Tip

You also can use the Edit All Layers command on the Layers submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Edit_All_Layers')}



To change all layers 
Arrange menu
Arrange+ toolbar



Selects, moves, and changes all objects in the active chart, regardless of the layer on which they are
located. When changing all layers, you cannot move an object on a lower layer in front of an object 
on a higher layer.



Move To Layer button
The Move To Layer button lets you move to another layer.

Tip
You also can use the Move To Layer command on the Layers submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Move_to_Layer')}



To move an object to a different layer 
Arrange menu
Arrange+ toolbar



Moves the selected object to another layer.



Move Back One Layer button
The Move Back One Layer button lets you move the active layer back one layer.

Tip
You also can use the Move To Layer command on the Layers submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Move_Back_One_Layer')}



To move an object back one layer 
Arrange menu
Arrange+ toolbar



Moves the active layer back one layer.



Move Forward One Layer button
The Move Forward One Layer button moves the active layer forward one layer.

Tip
You also can use the Move Forward One Layer command on the Layers submenu of the Arrange

menu.

{button Related Topics,PI(`',`IDH_RT_TB_Move_Forward_One_Layer')}



To move an object forward one layer 
Arrange menu
Arrange+ toolbar



Moves the active layer forward one layer.



Connect Open button
The Connect Open button connects the objects and closes them.

Tip
You also can use the Connect Open command on the Combine submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Connect_Open')}



To connect open objects 
Connect Closed command 
Connect Open command 
Disconnect command 
Arrange menu 



Connects the objects and closes them.



Connect Closed button
The Connect Closed button connects the selected, closed objects.

Tip
You also can use the Connect Closed command on the Combine submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Connect_Closed')}



To connect closed objects 
Connect Closed command 
Connect Open command 
Disconnect command 
Arrange menu 



Connects the selected, closed objects.



Disconnect button
The Disconnect button disconnects the selected connected object.

Tip
You also can use the Disconnect command on the Combine submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Disconnect')}



To disconnect objects 
Disconnect command 
Arrange menu
Arrange+ toolbar



Disconnects the selected connected object.



Join button
The Join button creates a new shape by joining the selected objects together.

Tip
You also can use the Join command on the Combine submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Join')}



To join objects 
Join command 
Arrange menu
Arrange+ toolbar



Creates a new shape by joining the selected objects together. 



Intersect button
The Intersect button creates new shape from the intersection of the selected objects.

Tip
You also can use the Intersect command on the Combine submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Intersect')}



To intersect objects 
Intersect command 
Arrange menu
Arrange+ toolbar



Creates new shape from the intersection of the selected objects.



Slice button
The Slice button slices the selected closed shape with the selected open shape.

Tip
You also can use the Slice command on the Combine submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_TB_Slice')}



To slice objects
Slice command 
Arrange menu
Arrange+ toolbar



Slices the selected closed shape with the selected open shape.



Outline button
The Outline button creates a new shape from the outline of the selected shapes.

Tip
You can also use the Outline command on the Combine submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_Outline_button')}



To outline objects 
Outline command 
Arrange menu
Arrange+ toolbar



Creates a new shape from the outline of the selected shapes.



Trim button
The Trim button creates a new shape by trimming the bottom shape with the top one.

Tip
You can also use the Trim command on the Combine submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_Trim_button')}



To trim objects 
Trim command 
Arrange menu
Arrange+ toolbar



Creates a new shape by trimming the bottom shape with the top one.



Punch button
The Punch button creates a new shape by punching the bottom shape with the top one.

Tip
You can also use the Punch command on the Combine submenu of the Arrange menu.

{button Related Topics,PI(`',`IDH_RT_Punch_button')}



To punch objects 
Punch command 
Arrange menu
Arrange+ toolbar



Creates a new shape by punching the bottom shape with the top one.



Customizing Toolbars
{button Tell me how . . .,PI(`',`IDH_HT_Customizing_Toolbars')}

You can customize the toolbars to create an efficient work environment.
You can show the toolbars you are using, and hide the toolbars you are not using.
You can drag and dock the toolbars.
You can create new toolbars.
You can delete any toolbars you have created and no longer want.
You can add buttons to existing toolbars (including the buttons on the default toolbars).
You can remove buttons from toolbars (including the buttons on the default toolbars).
Additionally, you can create floating palettes for some of the buttons on the Formatting toolbar.

The commands used to customize toolbars are the Toolbars command on the View menu and the 
Customize command on the Tools menu.

{button Related Topics,PI(`',`IDH_RT_Customizing_Toolbars')}



Customize command
Toolbars command



To show and hide toolbars
To dock toolbars
To create new toolbars
To delete toolbars

To add toolbar buttons
To delete toolbar buttons
To create a floating palette



To add toolbar buttons
1 On the Tools menu, click Customize.
2 To add a button to an existing toolbar, click the name of the category with which the button you 

want is associated, and then drag the button from the Customize dialog box and drop it onto the 
toolbar in the position where you want it.

3 To create a new toolbar, drag the button onto the chart. A floating toolbar is created.

Tips
Floating toolbars are dockable. Just drag the toolbar to the position where you want it.
The Customize dialog box has buttons that are not on the default toolbars.
You can use the Toolbars command on the View menu to rename a new toolbar after you 

create it.
To rearrange existing buttons on a toolbar, just drag them to the desired position while the 

Customize dialog box is open.

{button Related Topics,PI(`',`IDH_RT_To_add_toolbar_buttons')}



To delete toolbar buttons 
Customizing Toolbars
Customize command
Toolbars command



To delete toolbar buttons
1 On the Tools menu, click Customize.
2 To delete a button from a toolbar, drag it from the toolbar onto the chart.

Note
To delete buttons from toolbars, you must have the Customize dialog box open.

{button Related Topics,PI(`',`IDH_RT_To_delete_toolbar_buttons')}



To add toolbar buttons 
Customizing Toolbars
Customize command
Toolbars command



To create a floating palette
1 Click one of the following buttons. (These buttons are on the Formatting toolbar.)

Text 
Color

Fill Color Line 
Color

Line 
Style

Line 
Weigh
t

Filled 
Line

Arrowhe
ads

Crossove
rs

Shadow 3D
2 Drag the palette off the button.
3 If you want, you can now close the Formatting toolbar. The floating palette remains until you 

close it.

{button Related Topics,PI(`',`IDH_RT_To_create_a_floating_palette')}



Customizing Toolbars
Formatting Toolbar



To make a toolbar a floating palette
1 Click in a blank area of the toolbar.
2 Hold down the mouse button and drag the toolbar from its position.

{button Related Topics,PI(`',`IDH_RT_To_make_a_toolbar_a_floating_palette')}



To dock a floating toolbar



To dock a floating toolbar
1 Click in a blank area of the toolbar.
2 Drag the toolbar to any side of the program's window. 
3 When the border changes from thick to thin, you can drop the toolbar into position.

{button Related Topics,PI(`',`IDH_RT_To_dock_a_floating_toolbar')}



To make a toolbar a floating palette



Overview: Text
{button Tell me how . . .,PI(`',`IDH_HT_Overview_Text')}

There are three kinds of text: freeform, shape text, and text on lines.
Freeform - Freeform text is a text block that behaves like a shape, that is, it has more than two 

connect points.
Shape text - Shape text is text that is associated with a shape. It is part of the shape and 

behaves with the shape.
Text on lines - Text on lines is freeform text that you place near lines

You can:
Style text
Align text
Rotate text
Make text vertical

{button Related Topics,PI(`',`IDH_RT_Overview_Text')}



Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively



To create a text block 
To fit a shape to text 
To insert text 
To add text to a line 

To attach existing text to a line 
To change how existing text looks 
To choose text styles for new text 
To align text 

To rotate text 
To create vertical text 



Determining the Way Text Looks
{button OLE 
Automation,PI(`',`IDH
_OA_Determing_the_
way_text_looks')}

{button Tell me 
how. . .,PI(`',`IDH_HT
_Text_Looks')}

You can choose the styles you want for new text you enter in a chart. You can change all the text in 
a shape, text block, or line. Or you can change selected characters or words.

Text styles include
Font
Size
Bold
Italic
Underline
Strikethrough
Alignment
Color
Opaque

{button Related Topics,PI(`',`IDH_RT_Determining_How_Text_Looks')}



Overview: Text 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

To change the way existing text looks
To fit a shape to text
To choose text styles for new text
To align text



To change the way existing text looks
To choose text styles for new text



NamePropertyFont Object
Size Property
Bold Property
Italic Property

Underline Property
Strikethrough Property
Color Property Font Object
Opaque Property



Creating Text Blocks
{button OLE 
Automation,PI(`',`IDH
_OA_Creating_Text_Bl
ocks')}

{button Tell me 
how . . .,PI(`',`IDH_
HT_Creating_Text_B
locks')}

You can create blocks of text and place them anywhere in a chart.
Text blocks can contain detailed descriptions about a chart. For example, you can use text blocks to 
describe steps and processes. Like shapes, you can move and resize text blocks.

{button Related Topics,PI(`',`IDH_RT_TEXTBLOCKS')}



To create a text block
To choose text styles for new text



Overview: Text 
Determining the Way Text Looks 
Preset Text Styles
Using Fonts and Text Effectively 



DrawTextBlock Method



Preset Text Styles
{button Tell me how. . .,PI(`',`IDH_HT_Preset_Text_Styles')}

As you create charts, you may often reuse the same text styles.You can save these "preset styles" in
a menu to use again later. You can save a chart with preset styles as a template so the styles are 
available for future charts.
Preset styles let you apply multiple styles to text at one time.

{button Related Topics,PI(`',`IDH_RT_TEXTADD')}



To change the way existing text looks
To choose text styles for new text
To add a preset text style
To choose a preset text style

To delete a preset text style
To rename a preset text style
Overview: Text 
Determining the Way Text Looks 

Creating Text Blocks
Using Fonts and Text Effectively 



To add a preset text style
To choose a preset text style
To delete a preset text style
To rename a preset text style



To align text
1 Click the Selector tool.

Selector tool
2 Select the text block or the shape that contains the text.
3 Click the Text tool.

Text tool
4 To change the vertical alignment, click the Vertical Align button on the Formatting toolbar, and 
then click Align Text Top, Align Text Middle, or Align Text Bottom.

Vertical Align button
5 To change the horizontal alignment, click the Horizontal Align button on the Formatting toolbar,
and then click Align Text Left, Align Text Center, or Align Text Right.

Horizontal Align button
Tips

To select more than one object, press Shift and click the left mouse button.
If the Formatting toolbar is not displayed, click the right mouse button on a toolbar, and then 

click Formatting.

{button Related Topics,PI(`',`IDH_RT_To_align_text')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

To fit a shape



To fit a shape to text
1 Click the Selector tool.

Selector tool
2 Select the text block or the shape that contains the text.
3 Click the Fit to Text command on the Arrange toolbar. The selected objects are resized to fit the
text.

Fit to Text button
Tips

You can press F8 to fit shape or a text block to text quickly.
You can also use the Fit to Text command to resize a text block so that all of its text displays.
You also can use the Fit to Text button on the Arrange toolbar. If the Arrange toolbar is not 

displayed, on the View menu, click Toolbars, and then click Arrange. 

Fit to Text button

{button Related Topics,PI(`',`IDH_RT_To_fit_a_shape_to_text')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

To align text



To create a text block
1 Click the Text tool.

Text tool
2 Point where you want the text block to appear. Point outside existing shapes and text blocks to 
create a new text block.
3 Click the left mouse button. The text cursor appears.
4 Type the text you want in the text block. Press enter to start a new line.
5 Click outside the text to start a new text block or click the Finished button when you finish 
typing.
Tip

Clicking Esc in a text block will also let you start a new text block.

{button Related Topics,PI(`',`IDH_RT_To_create_a_text_block')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

Preset Text Styles



To select all the text in an object
1 Click the Selector tool.

Selector tool
2 Click the shape or text block you want.
Tips

Press Shift and click to select more than one object.
Any text options you choose are applied to all the text in the selected objects.

{button Related Topics,PI(`',`IDH_RT_To_select_all_the_text_in_a_object')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

To place the text cursor in text
To select text by dragging
To select text by using Shift
To move the text cursor using the keyboard

To select text using the keyboard



To place the text cursor in text
1 Click the Text tool.

Text tool
2 Click inside the text you want to change. The text cursor appears where you clicked.

{button Related Topics,PI(`',`IDH_RT_To_place_the_text_cursor_in_text')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 



To select text by dragging
1 Click the Text tool.

Text tool
2 Click at the beginning of the text you want to select.
3 Press and hold the left mouse button, and drag across the text you want. Drag up or down to 
select multiple lines of text.
4 Release the mouse button when you are finished. The text is selected.

{button Related Topics,PI(`',`IDH_RT_To_place_the_text_cursor_in_text')}



To select text by using Shift
1 Click the Text tool.

Text tool
2 Click at the beginning of the text you want to select.
3 Move the text cursor to the end of the text you want.
4 Press and hold the Shift key.
5 Click the left mouse button. The text in the specified range is highlighted.
6 Release the Shift key when you are finished.

{button Related Topics,PI(`',`IDH_RT_To_place_the_text_cursor_in_text')}



To move the text cursor using the keyboard
1 Click the Text tool.

Text tool
2 Click to place the text cursor in the text you want.
3 Press the right or left arrow keys to move the text cursor one character. Press Ctrl+right arrow 
or Ctrl+left arrow to move the cursor one word. Press the up or down arrow keys to move the cursor 
one line.

{button Related Topics,PI(`',`IDH_RT_To_place_the_text_cursor_in_text')}



To select text using the keyboard
1 Click the Text tool.

Text tool
2 Click to place the text cursor at the beginning of the text you want.
3 Press and hold the Shift key.
4 Press the right or left arrow keys to select one character at a time. Press Ctrl+right arrow or 
Ctrl+left arrow to select one word at a time. Press the up or down Arrow keys to select one line up or 
down from the text cursor.
5 Release the Shift key when you are finished.

{button Related Topics,PI(`',`IDH_RT_To_place_the_text_cursor_in_text')}



To add a preset text style
1 Select the text styles you want (font, size, style, and color).
2 On the Preset Styles toolbar, click the Add Text Style button. The text styles are stored as a single

item in the Text Styles list.

Add Text Style button
Tips

In step 1, you can select existing text with the desired style, if you prefer. If multiple text 
blocks are selected, the Add Style button is inoperative.

You also can add a text style to the list by selecting text with the desired style in steps 2 and 3.
If multiple objects are selected, the Add Style button is inoperative.

If the Preset Styles toolbar is not displayed, click the right mouse button with your cursor in a 
toolbar, and then click Preset Styles.

{button Related Topics,PI(`',`IDH_RT_To_add_a_preset_text_style')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

To rename a preset text style
To choose a preset text style
To delete a preset text style



To choose a preset text style
1 Click the Text tool.

Text tool
2 If you want to apply the preset style to existing text, select the text to which you want to apply
the style.
3 On the Preset Styles toolbar, click the down arrow to the right of the Text Styles box. The Text 
Styles list opens.
4 Click the text style you want. The style is applied to the selected text.
Notes

If no text is selected, the preset style becomes the current text style.
If you select text before you choose a text style, the style is applied to the selected text and to 

future text.
Tip

If the Preset Styles toolbar is not displayed, click the right mouse button with your cursor in a 
toolbar, and then click Preset Styles.

{button Related Topics,PI(`',`IDH_RT_To_choose_a_preset_text_style')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

To add a preset text style
To rename a preset text style
To delete a preset text style



To rename a preset text style
1 Click the Text tool.

Text tool
2 Click the Edit Text Style button to the right of the Text Styles box.

Edit Text Style button
3 Click the style you want to rename.
4 Click Rename, and then type the new name in the Rename Style dialog box.
Tip

If the Preset Styles toolbar is not displayed, click the right mouse button with your cursor in a 
toolbar, and then click Preset Styles.

{button Related Topics,PI(`',`IDH_RT_To_rename_a_preset_text_style')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

To add a preset text style
To choose a preset text style
To delete a preset text style



To delete a preset text style
1 Make sure no text is selected in the chart.
2 Click the Text tool.

Text tool
3 On the Preset Styles toolbar, click the Edit Text Styles button to the right of the Text Style text 
box. The Text Styles tab of the Edit Styles dialog box opens.

Edit Text Styles button
4 Click the text style you want to delete.
5 Click Remove. The style is removed from the Text Styles list.
Tip

If the Preset Styles toolbar is not displayed, click the right mouse button with your cursor in a 
toolbar, and then click Preset Styles.

{button Related Topics,PI(`',`IDH_RT_To_delete_a_preset_text_style')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

To add a preset text style
To rename a preset text style
To choose a preset text style



To insert text
1 Click the Text tool.

Text tool
2 Click to place the text cursor where you want to begin inserting text.
3 Type the text you want.

{button Related Topics,PI(`',`IDH_RT_To_insert_text')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

Preset Text Styles
To delete text



To delete text
1 Click the Text tool.

Text tool
2 Click to place the text cursor where you want to begin deleting text.
3 Press backspace to delete text to the left of the text cursor or delete to delete text to the right 
of the cursor.

{button Related Topics,PI(`',`IDH_RT_To_delete_text')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

Preset Text Styles
To insert text



To choose text styles using the Format menu
1 If you want to change the style for existing text as well as future text, select the text you want to 

change.
2 On the Formatting menu, click Font.
3 To change the font, scroll through the font list and click the font you want.
4 To change the font size, scroll through the size list and click the size you want.
5 To turn text effects on or off, click the box next to Bold, Italic, Underline, and Strikethrough. (You 

can select more than one.)
6 To change the text color, click the down arrow by the Text Color box and select the color.
7 To change whether the background of the text is transparent or opaque, click the Opaque Text 

box.
8 Click the Alignment tab.
9 To change the horizontal alignment, click Left, Center, or Right.
10 To change the vertical alignment, click Top, Middle, or Bottom.
11 To change the orientation, click Horizontal or Vertical.
12 When the text in the Preview box looks the way you want it, click OK.

Tips
If you have text selected when you change text styles, the changes affect the selected text 

and any new text that you place.
You also can use the buttons on the Formatting toolbar.
You also can choose a text style in the Text Styles list on the Preset Styles toolbar.

{button Related Topics,PI(`',`IDH_RT_To_choose_text_styles_using_the_Format_menu')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

To change the way existing text looks
To choose a preset text style
To choose text styles for new text



To choose text styles for new text
1 Click the Text tool.

Text tool
2 To set the font, on the Formatting toolbar, click the down arrow by the Font Name box, and 
then click the name of the font you want in the list.
3 To set the size, on the Formatting toolbar, click the down arrow by the Font Size box, and then 
click the size you want in the list.
4 To set font attributes such as Bold, Italic, or Underline, on the Formatting toolbar, click the 
button for the attribute. (You may choose more than one.)
5 To change the alignment, click the Vertical Alignment or Horizontal Alignment button on the 
Formatting toolbar, and then click the alignment you want from the menu.
7 To set the color, on the Formatting toolbar, click the down arrow by the Text Color button, and 

then click the color you want in the palette.

Note
If you have text selected when you change text styles, the changes affect the selected text 

and any new text that you place.
Tips

If the Formatting toolbar is not displayed, click the right mouse button with your cursor in a 
toolbar, and then click Formatting.

You also can use the Font and Paragraph commands on the Format menu.
You also can choose a text style in the Text Styles list on the Preset Styles toolbar.
You can drag the formatting buttons off the toolbar to make floating palettes.
In step 5, you also can use shortcut keys for Bold (Ctrl+B), Italic (Ctrl+I), and Underline 

(Ctrl+U).

{button Related Topics,PI(`',`IDH_RT_To_choose_text_styles_for_new_texts')}



Overview: Text 
Determining the Way Text Looks 
Creating Text Blocks
Preset Text Styles
Using Fonts and Text Effectively 

Using Fonts and Text Effectively 
To change the way existing text looks
To choose a preset text style



To change the way existing text looks
1 Select the text you want to change.
2 If the Formatting toolbar is not displayed, on the View menu, click Toolbars, and then click 

Formatting.
3 To set the font, on the Formatting toolbar, click the down arrow by the Font Name box, and then 

click the name of the font you want in the list.
4 To set the size, on the Formatting toolbar, click the down arrow by the Font Size box, and then 

click the size you want in the list.
5 To set font attributes such as Bold, Italic, or Underline, on the Formatting toolbar, click the button

for the attribute. (You may choose more than one.)
6 To change the alignment, click the Vertical Alignment or Horizontal Alignment button on the 

Formatting toolbar, and then click the alignment you want from the menu.
7 To set the color, on the Formatting toolbar, click the down arrow by the Text Color button, and 

then click the color you want in the palette.    (To return the text to the color defined by your 
Windows color scheme, click Automatic. To create a custom color, click More Colors.)

Tips
In step 1, you may select the shape or text block or just a portion of the text in the shape or 

text block.
If you have text selected when you change text styles, the changes affect the selected text 

and any new text that you place.
Press Shift and click the left mouse button to select more than one object in step 1.
You also can choose a preset style in the Text Styles list on the Preset Styles toolbar.
You also can use the Font and Paragraph commands on the Format menu.
You can drag the formatting buttons off the toolbar to make floating palettes.
If the Formatting toolbar is not displayed, click the right mouse button with your cursor in a 

toolbar, and then click Formatting.

{button Related Topics,PI(`',`IDH_RT_To_change_how_existing_text_looks')}



Overview: Text 
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Using Fonts and Text Effectively 
To choose text styles for new text
To choose text styles using the Format menu

To choose a preset text style



To make the text background opaque or transparent
When text is set as opaque, the background of the text becomes opaque; when text is not checked, 
the background is transparent.
1 Click the Selector tool.

Selector tool
2 Select the shape, text block, or text on a line with the background you want to change.
3 On the Format menu, click Font.
4 In the Font tab of the Format Font dialog box, click Opaque Text.
5 Click OK.
Tip

When you create a text block and drag it onto a colored shape, make sure Opaque Text is not 
checked so the text displays the same color background as the shape.

In step 2, to select more than one text item, press Shift and click the left mouse button.

{button Related Topics,PI(`',`IDH_RT_To_make_the_text_background_opaque_or_transparent')}
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To rotate text in a text block

{button Show me how . . .,PI(`',`IDH_AVI_torotatetext0040')}
1 Click the Selector tool.

Selector tool
2 Select the text block you want to rotate.
3 Click the Rotate Tool.

Rotate Tool
4 Place the cursor over one of the handles of a corner of the text block you want to rotate.
5 With the mouse, rotate the text in the direction you want.
6 Click the Finished button when you are done.

{button Related Topics,PI(`',`IDH_RT_To_rotate_text')}



{mci PLAY NOMENU NOPLAYBAR,CAP0040.AVI}



Overview: Text 
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To rotate text in a shape
1 Click the Selector tool.

Selector tool
2 Select the object with the text you want to rotate.
3 Click the Edit Tool.

Edit Tool
4 Click Text Layout.
5 In the Edit Text Area Layout toolbar, click Rotate Text.

Rotate Text.
6 Place the cursor over one of the handles of a corner of the text you want to rotate.
7 With the mouse, rotate the text in the direction you want.
8 Click the Finished button when you are done.

{button Related Topics,PI(`',`IDH_RT_To_rotate_text_in_a_shape')}



Edit Text Area Layout toolbar 
Edit Connect Points toolbar 
Reshape toolbar 
To insert text
To rotate text in a text block 



To create vertical text
1 Click the Selector tool.

Selector tool
2 Select the text you want to make vertical.
3 On the Format menu, click Text Alignment.
4 In the Orientation area, click Vertical.
5 Click OK.

Tip
Use the Apply button to make your changes and view the results without closing the dialog 

box.

{button Related Topics,PI(`',`IDH_RT_To_create_vertical_text')}
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Messages and Solutions
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A
A file error occurred while checking spelling in chart. 
Add (fieldname) as a new field?
All connect points are selected and are about to be deleted. A line cannot attach to a shape unless it
has at least one connect point. Do you want to delete all connect points?

All edits to connect points will be lost. Do you want to proceed and let FlowCharter automatically 
generate new connect points?
An error occurred while accessing the spelling dictionary. 
An error occurred while accessing the user spelling dictionary. 
An error occurred while checking spelling in the chart. 
An error occurred while initializing the spell checking system. 
An error occurred while saving the user dictionary. Words added in this session have not been saved.



Are you sure?
Are you sure you want to delete the selected connect points?  
By saving your template file in the default template directory, it will automatically appear in the 
New From Template dialog  

C
Can't combine these shapes! 
Can't connect to (number). A suitable Internet browser may not exist or be installed properly. 
Can't import (shapenumber). 
Can't load shape. 
Can't read '(  value  )' as '(fieldtype)'. Re-enter the data in this format.    
Cannot complete this transaction. There has been a shutdown. 
Cannot create file. Please make sure you have access rights to this directory. 
Cannot edit script. Object has been deleted. 
Cannot find linked chart (filename). 
Cannot find %s. File is missing. 
Cannot load Script Generator. 
Cannot open   (program name)  . FlowCharter cannot find the required external application   (program   
name)  . Make sure that   (program name)   is in the Windows System directory or in the DOS path and   
try to open   (program name)  . again  . 
Cannot open   (program name)  . There is not enough memory to run the required external application   
(program name)  . Quit one or more Windows applications and then try to open   (program name)     
again. 
Cannot open file:   filename  

Cannot paste. Number of characters must be less than 10,000. 
Cannot register FLowCharter OLE Automation Event. The event '(  eventname  )' is not supported.   
Check spelling. 
Cannot register the '(  eventname  )' FlowCharter OLE Automation Event. There is a conflict between   
the running '(  program1name  )' program and the '(  program2name  )' program trying to register with   
FlowCharter Automation. Close '(  program1name  )' before running '(  program2name  )' again.  
Cannot save to (filename). Access to this path is denied. 
Cannot save to (filename). Access to this path is denied. 
Cannot save to (filename). The disk is full. 
Cannot save to (filename). The selected directory is full. 
Cannot save to (filename). The selected path is bad. 
Cannot save to (filename). There are too many files open. 
Cannot save to (filename). There is a general problem with thIs file. 
Cannot save to (filename). There is a hardware problem with the selected volume. 
Cannot save to (filename). 'SHARE.EXE' is not loaded or a region of this file is locked. 



Cannot send FlowCharter OLE Automation Event. The running Automation VBX/OCX is the wrong 
version. 
Close All Documents?  
Command failed. 
Complex or high color objects exist in this chart which are not supported by ABC Flowcharter 
3.0/4.0.
Correction alternatives couldn't be found because this word contains only one letter. 
Could not paste. 
Could not start print job. 
Couldn't load workspace 
Couldn't save workspace 
Current active layer must be visible and unlocked. 

D
Do you wish to delete the   (toolbar)   toolbar?  

F
Failed to create empty document. 
Failed to create object. Make sure the object is entered in the system registry. 
Failed to open document. 
Failed to verify password. 
Field report copied to clipboard. 
Field report written to file: (  filename  ).   
(filename) is already open. 
(  filename  ) is a protected file. You will not be able to make changes to the file without first   
unprotecting it with a password.
(  filename  ) is a read-only file or is in use by another user. Would you like to open it as a read-only   
file?

FlowCharter cannot execute the command line: 
FlowCharter cannot find (program name). Check the path stored in the FLOW70.INI. 
FlowCharter has finished searching the document. 
FlowCharter 7 is unable to open this file. 
Font name entered is invalid. 
Font size must be an integer between 4 and 72. 

I
Internet connection has been aborted. 
Internet connection has been reset. 
Internet connection stopped. There has been an internal error. Please try again later. 



Internet connection stopped. There has been an invalid server response. 
Internet item not found. 
Internet transaction has timed out. 
"%1" already exists. 



M
Micrografx Designer is not installed. 
Micrografx Picture Publisher is not installed. 

N
Not enough disk space. Please delete files or use a different drive. 
Not enough memory. 
Not enough memory to run (program name). Quit one or more Windows applications and then try 
again. 
%d replacements were made.

O
OLE Initialization Failed. Make sure that the OLE libraries are the correct version. 
Out of memory. 
%d replacement was made.

P
Please enter a number. 
Please enter a number between %1 and %2. 
Please Select A Date Style

S
Save changes in field '(  fieldname  )'?  
Save changes to (filename)? 
This chart may contain FlowCharter 7 data which will be lost when saving to a previous FlowChart 
file format. Do you wish to continue? 
Selected layer has objects on it. 
Spell check completed for selected objects. Would you like to check the remainder of the chart?
Spell check completed in chart. 

T
Text not found in data fields. 
Text not found in notes. 
Text not found in shapes or lines. 
Text not found. 
The document must contain an object to import data. 
The filename %1 is invalid. 

The filename is too long. 
The file (filename) does not exist. 



The name you have selected is already in use. Please enter another. 
The ordinal number suffix (i.e., '1st' , '2nd', etc.) for this word appears to be incorrect. 
The preferred spelling for this word is without periods. 
The selected data to paste in the Worksheet is too large. Continue? 
The selected paper size does not match page settings. Do you want page settings to be changed to 
match?

There was no usable text. Please make a different selection and try again.
The worksheet must be visible to import data. Go to the View menu and select Worksheet. 
This chart contains data linked from other charts. Would you like to update the data now?
This chart has been set up to run with multiple entities. Selecting a start shape will remove all 
existing entities. You can add additional entities through the Entitiy Manager.  
This chart has more shape types than are supported in the AF3 file format. Some data may be lost. 
This file is in use. Cannot drop into current chart. 
This file was originally saved in an older file format. Would you like to update it to FlowCharter 7? 
This operation will remove text and data fields associated with the selected objects. Proceed? 
This shape does not have any editable points. Please select another shape. 
This word appears twice and may be redundant. 
This word contains a possibly incorrect hyphen. 
This word contains a possibly incorrect trailing period. 
This word contains possibly incorrect punctuation. 
This word is usually preceded by 'a' instead of 'an' 
This word is usually preceded by 'an instead of 'a' 
This word may contain incorrectly capitalized letters. 
This word may contain incorrectly leading characters. 
This word may contain incorrectly trailing characters. 
This word was marked as 'negative' in the user dictionary. 

U
Unable to browse. Check that a suitable Internet browser is installed properly. 
Unable to execute   (filename)  . Would you like to re-link?   
Unable to logon to Internet session. 
Unable to make this Internet connection. 
Unable to open   (number)  . A suitable Internet browser may not exist or be installed properly. Would   
you like to re-link? 
Unable to open download cache file on this machine. 
Unable to resolve Internet name. 
URL is not valid. 



Y
You are making permanent changes to the chart's field setup. This operation could cause some 
entered field data to be lost and cannot be undone. Do you wish to continue?
You cannot link a chart to itself. 
You cannot group and link a chart to itself. 
You cannot move object(s) to a locked layer. To unlock this layer, select Layer Manager . ..from the 
Layers command on the Arrange menu. 
You cannot delete the only unlocked and visible layer. 
You do not have any Data Fields setup yet. 

Z
Zoom Value Must Be Between 5% and 1600%. 



A file error occurred while checking spelling in chart.
The spell checker had problems accessing the installed spelling dictionary on disk.

Reinstall FlowCharter 7 or contact Technical Support. You will not be able to check spelling until the 
problem is resolved.



A memory error occurred while checking spelling in the chart.
FlowCharter 7 ran out of memory while spell checking.

Close one or more open files and programs and try again.



Add (fieldname) as a new field?
You have added a field and clicked OK without clicking the Add button.

Click Yes if you want the field name added as a field.



All connect points are selected and are about to be deleted. A line cannot attach to a 
shape unless it has at least one connect point. Do you want to delete all connect points?
You have selected all connect points and clicked the Delete Points button.

It is recommended that a shape always have at least one connect point so that a line can attach to 
the shape. To leave one point, click No, and deselect one point. If you really want to delete all points,
click Yes.



All edits to connect points will be lost. Do you want to proceed and let FlowCharter 
automatically generate new connect points?
You are attempting to edit connect points, and this edit will delete all connect points.

Click Yes if you want to proceed.



An error occurred while accessing the spelling dictionary.
The spell checker had problems accessing the installed spelling dictionary on disk.

Reinstall FlowCharter 7 or contact Technical Support. You will not be able to check spelling until the 
problem is resolved.



An error occurred while accessing the user spelling dictionary.
The spell checker had problems accessing your current user dictionary on disk.

Choose a new user dictionary in the Spelling Preferences dialog box or contact Technical Support to 
use the current user dictionary. This dictionary cannot be used until the problem is resolved; 
however, you can spell check using other dictionaries.



An error occurred while checking spelling in the chart.
A general problem happened while spell checking.

Reinstall FlowCharter 7 or contact Technical Support. You will not be able to check spelling until the 
problem is resolved.



An error occurred while initializing the spell checking system.
A general problem happened while starting the spell check.

Reinstall FlowCharter 7 or contact Technical Support. You will not be able to check spelling until the 
problem is resolved.



An error occurred while saving the user dictionary. Words added in this session have not 
been saved.
You changed the user dictionary file name in the Spelling Preferences dialog box, and FlowCharter 7 
had a problem saving the current dictionary to the new name. Because of this problem, all words 
added to the user dictionary since the last time you ran FlowCharter 7 or since the last time you 
changed dictionaries have been lost.

Re-add any words that were added to the dictionary during this session.



Are you sure?
You are about to delete your selection.

Click Yes if you want to delete them. Click No if you do not.



Are you sure you want to delete the selected connect points?
You are about to delete connect points you have selected.

Click Yes if you want to delete them. Click No if you do not.



By saving your template file in the default template directory, it will automatically 
appear in the New From Template dialog box. Do you want to save this template file in 
the default template directory?
You are saving a template file you have created. By default, the program saves it in the default 
template directory. You are asked if you want to save it in this default template directory.

Click Yes to save your template file in the default template directory for the program.



Can't combine these shapes!
You are trying to combine shapes that cannot be combined.

Select different shapes.



Can't connect to (number). A suitable Internet browser may not exist or be installed 
properly.
You have tried to connect to a remote site, but were unable to.

Check the Internet address or check that the Internet browser has been installed properly.



Can't export file.
Please make sure sure your disk is not full.
You have tried to export a file that requires more space than is available on the disk.

Select another drive, insert a different disk, or delete any unnecessary files and directories from the 
current drive or disk.



Can't import (shapenumber).
FlowCharter cannot create a new shape from any objects in this file.
You are trying to import a shape from a file that does not have any objects that FlowCharter can 
import as a shape.

Select another file to import a shape from.



Can't load shape.
Please update the file link or select another shape.
You have tried to load a linked shape whose file link has changed. 

Relink the shape, or select another shape to load.



Can't read '(value)' as '(fieldtype)'. Re-enter the data in this format.
You have tried to enter a field value that does not correspond to the designated field type.

Reenter the value or press ESC and change the data type for the field in the Setup Fields dialog box.



Cannot complete this transaction. There has been a shutdown.
Your Internet transaction has stop responding as a result of an Internet shutdown.

Try again later.



Cannot create file. Please make sure you have access rights to this directory.
You cannot write to the directory to which you are trying to save the file.

The directory may be on a network that you do not have write access to. The directory may be on a 
device that is read-only, such as a CD-ROM. In some cases, there may be too many files or programs
open. In that case, close unneeded applications and files and try again.
This error can occur any time you are creating a new file, including by linking to a new file.



Cannot edit script. Object has been deleted.
You are trying to edit script for an object that has been deleted.

You will need to create the object that you want the script for.



Cannot find linked chart (filename).
Would you like to relink?
FlowCharter cannot find the linked chart filename you specified.

Click Yes to relink the chart.



Cannot find %s. File is missing.
Would you like to browse for the templates directory?
FlowCharter cannot find the file name you typed in the specified directory.

Check to see whether you typed the file name correctly and whether you are using the correct drive 
and directory. Click Browse to search for another directory.



Cannot load Script Generator.
You have tried to load the Script Generator, but are unable to.

Check to see if you have Script Generator on your system.



Cannot open (program name). FlowCharter cannot find the required external application 
(program name). Make sure that (program name) is in the Windows System directory or 
in the DOS path and try to open (program name). again.
You have tried to open an external program that the program cannot locate.

Check to see whether you typed the file name correctly and whether you are using the correct drive 
and directory. Check the location of the application you are trying to open. Your system also may be 
low on memory; therefore, close one or more open files and programs and try again. 



Cannot open (program name). There is not enough memory to run the required external 
application (program name). Quit one or more Windows applications and then try to 
open (program name) again.
You have tried to open an external program, and you have too many other programs open for 
Windows to access enough memory to open the external program.

With all of the program open, your system is low on memory; therefore, close one or more open 
programs and try again.



Cannot open file: (filename)

The file name you typed does not exist in the specified directory. You also may be trying to open a 
linked file.

Check to see whether you typed the file name correctly and whether you are using the correct drive 
and directory. Your system also may be low on memory; therefore, close one or more open files and 
programs and try again.



Cannot open (program name). FlowCharter cannot find the required external application 
(program name).    Make sure (program name) is in the Windows System directory or in 
the DOS path and try to open (program name) again.
The program you typed does not exist in the specified directory. 

Check to see whether you typed the file name correctly and whether you are using the correct drive 
and directory. Your system also may be low on memory; therefore, close one or more open files and 
programs and try again.



Cannot paste. Number of characters must be less than 10,000.
You are trying to paste a block of text that is too large.

Click OK. Delete some text and try again or copy and paste the text in several smaller blocks.



Cannot register FlowCharter OLE Automation Event. The event '(eventname)' is not 
supported. Check spelling.
An OLE Automation program is running and is unable to register an event as requested, probably 
because the event is not spelled correctly.

The program must be changed so the name of the event is spelled correctly.



Cannot register the '(eventname)' FlowCharter OLE Automation Event. There is a conflict 
between the running '(program1name)' program and the '(program2name)' program 
trying to register with FlowCharter Automation. Close '(program1name)' before running 
'(program2name)' again.
An OLE Automation program is running and is unable to register an event as requested, probably 
because another OLE program has already registered an event with the same name.

Close the running program, and then run the second program again. If you need to run both at the 
same time, then the programs must be changed so there are no VBX conflicts. Conflicts occur when 
two programs are asking to register the same event for the same chart type. If you define the chart 
types to be different from each other, then the conflict should not occur.
For more information, see Type Property (Chart Object) in the OLE Automation help.



Cannot save to (filename). This file is read only or is in use by someone else. Save to 
another file?
You are trying to save a file that is read-only, which means you are not allowed to save changes to 
it.

Type a different file name or save the file in another directory. The original file will not be changed or
erased.



Cannot save to (filename). Access to this path is denied.
Save to another file?
You cannot write to the directory to which you are trying to save the file.

The directory may be on a network that you do not have write access to. The directory may be on a 
device that is read-only, such as a CD-ROM. In some cases, there may be too many files or programs
open. In that case, close unneeded applications and files and try again. OR
Type another pathname.



Cannot save to (filename). Access to this path is denied.
This volume may not support long filenames.
Save to another file?
You have entered a file name with more than 254 characters.

Enter a shorter file name.



Cannot save to (filename). The disk is full.
Save to another file?
You have tried to save a file or carry out an action that requires more space than is available on the 
disk.

Select another drive, insert a different disk, or delete any unnecessary files and directories from the 
current drive or disk.



Cannot save to (filename). The selected directory is full.

Save to another file?
You cannot write to the directory to which you are trying to save the file.

The selected directory may be on a device or network with that is already full. Type another 
pathname.



Cannot save to (filename). The selected path is bad.

Save to another file?
The pathname you have selected to save to is bad.

Type another pathname.



Cannot save to (filename). There are too many files open.
You are trying to save files, and there are too many files open.

With all of the files open, your system is low on memory; therefore, close one or more open files and
try again.



Cannot save to (filename). There is a general problem with this file.

Save to another file?
You are trying to save files, and there is a general problem with the file you selected to save to.

Try another file name.



Cannot save to (filename). There is a hardware problem with the selected volume.

Save to another file?
You are trying to save files, and there is a hardware problem with the volume you selected to save 
to.

Try another volume.



Cannot save to (filename). 'SHARE.EXE' is not loaded or a region of this file is locked.

Save to another file?
You are trying to save files, and your SHARE.EXE is not loaded 

Contact your system administrator.



Cannot send FlowCharter OLE Automation Event. The running Automation VBX/OCX is the
wrong version.
An OLE Automation program is running and is unable to send an event as requested because you 
have the wrong version of VBX/OCX in FlowCharter for the event you are sending.

The program must be changed so that you have the compatible VBX/OCX and FlowCharter OLE 
Automation versions.



Close All Documents?
You are requesting to close all documents.

Click Yes to close all documents. Click No to not close all documents.



Command failed.
You have typed a command incorrectly or requested an invalid command.

Check the command entry, and retype the command.



Complex or high color objects exist in this chart which are not supported by Flowcharter 
3.0/4.0.

Continue anyway?
You have tried to save objects that cannot be transferred to ABC FlowCharter 3.0 or 4.0. These 
objects include metafiles larger than 64K, device independent bitmaps (DIBs) that use more than 
256 colors, and DIBs that are larger than 64K.

Click Yes to convert the rest of the chart to ABC FlowCharter 3.0/4.0. If you click Yes, the chart will be
converted. When you bring the chart up in ABC FlowCharter 3.0 or 4.0, the object that could not be 
converted appears as a rectangle with a red outline and a red X in the middle of it.    You can 
manually replace the shape.
Click No to abort the conversion attempt.



Correction alternatives couldn't be found because this word contains only one letter.
The spell checker has detected text that has only one letter. The spell checker does not recognize 
single characters words.

Click Ignore for the program to accept the single-character text in the chart, click Add to add the 
single-character to the spelling dictionary, or change the word.



Could not paste.
You have tried to paste informaton, but were unable to do so.

Your system may be low on memory; therefore, close one or more open files and programs and try 
again.



Could not start print job.
You have tried to print, but FlowCharter was unable to start the print job. 

Check the printer connections.



Couldn't load workspace
You have tried to load a workspace (file with .afw extension), and FlowCharter was unable to 
complete the request.

Check to see whether you typed the file name correctly and whether you are using the correct drive 
and directory. Your system also may be low on memory; therefore, close one or more open files and 
programs and try again.



Couldn't save workspace
You have tried to save a workspace (file with .afw extension), and FlowCharter was unable to 
complete the request.

Select another drive, insert a different disk, or delete any unnecessary files and directories from the 
current drive or disk.



Current active layer must be visible and unlocked.
You have selected to perform a task on a layer that is invisible and locked.

Make the selected layer visible and unlocked or select another layer that is.



Do you wish to delete the (toolbar) toolbar?
You are about to delete a toolbar that you created.

Click Yes if you want to delete it. Click No if you do not.



Failed to create empty document.
You have attempted to create a document, but the creation was not successful.

Check the system registry.



Failed to create object. Make sure the object is entered in the system registry.
You have attempted to create an object, but the creation was not successful.

Check the system registry.



Failed to open document.
You have tried to open a document, and FlowCharter is unable to complete the task.

Check to see whether you typed the file name correctly and whether you are using the correct drive 
and directory. Your system also may be low on memory; therefore, close one or more open files and 
programs and try again.



Failed to verify password.
You have typed in a password that is incorrect.

Check the password you typed, and retype it.



Field report copied to clipboard.
The Clipboard field report is complete.



Field report written to file: (filename).
The field report has been saved to the file.



(filename) is already open.
Revert to saved version?
The filename you are attempting to open is already open. 
Click yes to revert to the saved version of the file.



(filename) is a protected file. You will not be able to make changes to the file without 
first unprotecting it with a password.
The chart you opened is protected by a password.

To unprotect the chart so you can work with it, choose the Unprotect Chart command on the Tools 
menu, enter the password, and choose OK.



(filename) is a read-only file or is in use by another user. Would you like to open it as a 
read-only file?
You are trying to open a file that is read-only.

Click OK to open the file. You cannot save changes to the file using the current file name and 
directory. If you want to save changes, give the file a new name or store it in another directory.



FlowCharter cannot execute the command line:
(number)
Make sure that the correct path and filename are given.
Be sure quotes are properly placed around long pathnames and filenames.
You have entered a command FlowCharter does not recognize. Check the path name and file name, 
and check for quotes around long path names and file names.

Type a valid path and file in the command line.



FlowCharter cannot find (program name). Check the path stored in the FLOW70.INI.
You are trying to open a program that FlowCharter is unable to location. Either the program does not
exist or you have typed the name incorrectly.

Check your program name. Type it again correctly, or change the path to find the program.



FlowCharter has finished searching the document.
FlowCharter has finished searching the document.



FlowCharter 7 is unable to open this file.
The file format has been altered or corrupted, or you are trying to open a file that is not an accepted
file format.

Load your backup copy of the file and try again or try another file.



Font name entered is invalid.
You have deleted the name in the Font name box and pressed enter.

You must either type a font name or select a name from the list.



Font size must be an integer between 4 and 72.
You have typed an invalid font size or entered a non-numeric character.

Type a number between 4 and 72.



Internet connection has been aborted.
You have attempted to make an Internet connection, but it has been aborted.

Try again later.



Internet connection has been reset.
You have attempted to make an Internet connection, but it has been reset.

Try again later.



Internet connection stopped. There has been an internal error. Please try again later.
You have attemped to connect to a remote site, but the connection has been stopped by an internal 
error.

Try again later, or see your System Administrator.



Internet connection stopped. There has been an invalid server response.
You have attempted to make an Internet connection, but the Internet browser has received an 
invalid server response.

Try again later, or see your System Administrator.



Internet item not found.
You have attempted to search the Internet for an item that has not been found.

Re-enter a keyword.



Internet transaction has timed out.
You have attempted to transact with an Internet site, but the transaction has timed out.

Try again later.



Micrografx Designer is not installed.
You are trying to run Micrografx Designer, and it is not installed.

Click OK, and install Micrografx Designer, or select another task.



Micrografx Picture Publisher is not installed.
You are trying to run Micrografx Picture Publisher, and it is not installed.

Click OK, and install Micrografx Picture Publisher, or select another task.



"%1" already exists.
You are trying to create a layer name that already exists.

Click Yes to overwrite, No to assign a different layer name.



Not enough disk space. Please delete files or use a different drive.
You have tried to save a file or carry out an action that requires more space than is available on 
disk.

Select another drive, insert a different diskette, or delete any unnecessary files and directories from 
the current drive or diskette.



Not enough memory.
You have carried out an action that requires more memory than is available. This error message 
may occur while you are trying to open a linked chart file.

Close one or more open files and programs and try again.



Not enough memory to run (program name). Quit one or more Windows applications and 
then try again.
You have tried to open a program that requires more memory than is available.

Close one or more open files and programs and try again.



%d replacements were made.
Search and replace found (number) items and replaced them.



OLE Initialization Failed. Make sure that the OLE libraries are the correct version.
OLE initialization failed.

Make sure that the OLE libraries are the correct version.



Out of memory.
You have carried out an action that requires more memory than is available. This error message 
may occur while you are trying to open a linked chart file.

Close one or more open files and programs and try again.



%d replacement was made.
Search and replace found 1 item and replaced it.



Please enter a number.
You have clicked OK without entering a number in a field requiring a number.

Enter a number in the field, and click OK.



Please enter a number between %1 and %2.
You have entered a value outside of this range.

Enter a correct value.



Please select a date style.
You have typed data that requires a date style.

Select a data style.



Save changes in field '(fieldname)'?
You have clicked OK without clicking Add in the Field Setup dialog box.

Click Yes if you want to save the changes.



Save changes to (filename)?
You have attemped to close the file without saving your changes.

Click Yes if you want to save the changes.



This chart may contain FlowCharter 7 data which will be lost when saving to a previous 
FlowCharter file format. Do you wish to continue?
You were trying to save to a previous version of FlowCharter. If you continue, you may lose data.

Click Yes if you want to save to a previous version, No ends the save task. Press the Help button for 
more information.



Selected layer has objects on it.

Delete the layer?
You have selected to delete a layer that has objects on it.
Click Yes if you want to delete the layer with the objects. Click No if you do not want to delete the 
layer.



Spell check completed for selected objects. Would you like to check the remainder of the
chart?
When you requested the spell check, you had one or more objects selected. 

Click Yes to check the remainder of the chart.



Spell check completed in chart.
FlowCharter 7 has checked spelling in the entire chart.

Click OK to close the dialog box and return to your chart.



Text not found in data fields.
A find or replace request has been completed.

The text you entered in the Find what box was not found in data fields. Click OK to close the 
message box.



Text not found in notes.
A find or replace request has been completed.

The text you entered in the Find what box was not found in notes. Click OK to close the message 
box.



Text not found in shapes or lines.
A find or replace request has been completed.

The text you entered in the Find what box was not found in shapes or lines. Click OK to close the 
message box.



Text not found.
A find or replace request has been completed without finding the text you specified.

Click OK to close the message box.



The document must contain an object to import data.
You are trying to import data from a document that does not contain an object.

Select another document.



The file (filename) does not exist.
Would you like to create it?
FlowCharter cannot find the file (filename) you specified.

Click Yes to create the file.



The filename %1 is invalid.
The filename (filename) is invalid.



The filename is too long.
You have entered a file name with more than 254 characters.

Enter a shorter file name.



The name you have selected is already in use. Please enter another.
You are trying to save to a file that has been opened by another user.

Choose another file name.



The ordinal number suffix (i.e., '1st' , '2nd', etc.) for this word appears to be incorrect.
The spell checker has detected text that has the incorrect ordinal number suffix.

Click Ignore for the program to accept theordinal number suffx you have in the text, click Add to add
the ordinal number suffix, or change the suffix.



The preferred spelling for this word is without periods.
The spell checker has detected periods for text that has a preferred spelling without periods.

Click Ignore for the program to accept the text with periods in the chart, click Add to add the text 
with periods to the spelling dictionary, or change the text.



The selected data to paste in the Worksheet is too large. Continue?
You have selected a paste area that is too large, and some of your data may be lost.

Compare the fields to see if you are importing more rows or columns than the worksheet has. Select
an equal number of rows and columns, and continue.



The selected paper size does not match page settings. Do you want page settings to be 
changed to match?
The paper size you selected is too small to display the chart in the page settings you are using.

Click Yes if you want page settings to be changed to match the paper size.



There was no usable text. Please make a different selection and try again.
You have pasted or dragged text data that does not contain any actual text characters. They may be
a bitmap, a picture, or an OLE object instead of text.

Make another selection that does contain actual text characters, or change the selection to contain 
text.



The worksheet must be visible to import data. Go to the View menu and select 
Worksheet.
You are trying to import data, and the Worksheet is not opern.

On the View menu, click Worksheet. You also must have created data fields.



This chart contains data linked from other charts. Would you like to update the data 
now?
You are opening a chart that has linked data.

Click Yes to read the other charts and update the data. Click No to work with this chart without 
updating the data.



This chart has more shape types than are supported in the AF3 file format. Some data 
may be lost.
You are opening a chart that has more shape types than those supported by FlowCharter 7. If you 
open the chart, you may lose some data.

Click Yes to open the chart. Click No if you do not want to open the chart.



This chart does not appear to be a valid EasyFlow version 6. 0 - 8. 0 file. This chart will 
be skipped.
You have tried to import a chart that was not created in EasyFlow versions 6.0 through 8.0. A 
FlowCharter 7 file will not be generated for the chart.

Check to see that the chart is a valid EasyFlow chart. If it was created in an earlier version of 
EasyFlow, first convert it in EasyFlow to version 6.x, 7.x, or 8.x. Next, try importing it again into 
FlowCharter 7.



This chart has been set up to run with multiple entities. Selecting a start shape will 
remove all existing entities. You can add additional entities through the Entitiy Manager.
You have attempted to select a start shape of a chart that has been set up to run with multiple 
entities. 

Add additional entities through the Entity Manager or remove all existing entities and select a 
different start entity. 



This file does not appear to be a valid EasyFlow version 6. 0 - 8. 0 file.
You have tried to import a file that was not created in EasyFlow versions 6.0 through 8.0.

Check to see that the file is a valid EasyFlow file. If it was created in an earlier version of EasyFlow, 
first convert it in EasyFlow to version 6.x, 7.x, or 8.x. Next, try importing it again into FlowCharter 7.



This file is in use. Cannot drop into current chart.
You are trying to drop a file that has been opened by another user into a chart.

Choose another file name.



This file was originally saved in an older file format. Would you like to update it to 
FlowCharter 7?
You are trying to save a file that was originally saved in an older file format.

Click Yes to save the file in FlowCharter 7 format.



This operation will remove text and data fields associated with the selected objects. 
Proceed?
You are attempting a task that will result in removing the text and data fields associated with the 
selected objects.

Click Yes to proceed.



This shape does not have any editable points. Please select another shape.
You are trying to edit points for a shape that does not have editable points.

Select another shape, or discontinue the task.



This word appears twice and may be redundant.
The spell checker has detected text that appears to have been accidently repeated.

Click Ignore for the program to accept the repeated word you have in the text or delete the repeated
word.



This word contains a possibly incorrect hyphen.
The spell checker has detected text that appears to have been hyphenated incorrectly.

Click Ignore for the program to accept the hyphenation you have in the text, or change the 
hyphenation.



This word contains a possibly incorrect trailing period.
The spell checker has detected text that has a trailing period and does not need one.

Click Ignore for the program to accept the trailing period you have in the text or delete the repeated
period.



This word contains possibly incorrect punctuation.
The spell checker has detected punctuation that may be unnecessary or misplaced.

Click Ignore for the program to accept the punctuation you have in the text or delete the 
punctuation.



This word is usually preceded by 'a' instead of 'an'
The spell checker has detected text that requires “an” as an article, but has “a”.

Click Ignore for the program to accept the”an” you have in the text or replace it with “a” .



This word is usually preceded by 'an instead of 'a'
The spell checker has detected text that requires “a” as an article, but has “an”.

Click Ignore for the program to accept the”a” you have in the text or replace it with “an” .



This word may contain incorrectly capitalized letters.
The spell checker has detected a capital letter that it does not recognize in this usage.

Click Ignore for the program to accept the capitalization in the chart, click Add to add the text with 
the capitalziation to the spelling dictionary, or change the text.



This word may contain incorrectly leading characters.
The spell checker has detected leading characters in text that it does not recognize in this usage.

Click Ignore for the program to accept the leading characters in the chart text, click Add to add the 
text with this usage of leading characters to the spelling dictionary, or change the text.



This word may contain incorrectly trailing characters.
The spell checker has detected trailing characters in text that it does not recognize in this usage.

Click Ignore for the program to accept the trailing characters in the chart text, click Add to add the 
text with this usage of trailing characters to the spelling dictionary, or change the text.



This word was marked as 'negative' in the user dictionary.
The spell checker has detected no period for text that requires periods.

Click Ignore for the program to accept the text without periods in the chart, click Add to add the text
without periods to the spelling dictionary, or change the text.



Unable to browse. Check that a suitable Internet browser is installed properly.
You have attempted to browse the Internet, but were unable to.

Check your Internet browser or contact your System Administrator.



Unable to execute (filename). Would you like to re-link?
You have attempted to exexcute a llinked file, but were unable to.

Click Yes to re-link.



Unable to logon to Internet session.
You have attempted to log onto the Internet, but were unable to.

Check your Internet browser or contact your System Administrator.



Unable to make this Internet connection.
You have attempted to connect to a remote site on the Internet, but were unable to.

The remote site may be unavailable at this time. Try again later.



Unable to open (number). A suitable Internet browser may not exist or be installed 
properly. Would you like to re-link?
You have attemped to open an Internet browser which may not exist or may not be installed 
properly.

To re-link, click Yes.



Unable to open download cache file on this machine.
You have attempted to open a cache file that has been downloaded on this machine, but were 
unable to.

Check that the file is not corrupted.



Unable to resolve Internet name.
You have attempted to provide an Internet name that the Internet browser is unable to resolve.

Check the name again before proceeding.



URL is not valid.
You have attempted to visit a site for which the URL is not valid.

Check your spelling of the URL or check for    updated URL information before trying again.



You are making permanent changes to the chart's field setup. This operation could cause
some entered field data to be lost and cannot be undone. Do you wish to continue?
You have made possibly destructive changes to the chart's field table, which could cause some of 
the data to be lost. An example of this is changing a "date" field to "currency."

If you want to undo the changes, click No in this dialog box, and then click Cancel in the Setup Fields
dialog box.



You cannot link a chart to itself.
The chart you have selected in the Link dialog box is the current chart. 

Select a different chart.



You cannot group and link a chart to itself.
The chart you have selected to group and link in the Link dialog box is the current chart.

Select a different chart.



You cannot move object(s) to a locked layer. To unlock this layer, select Layer Manager . 
from the Layers command on the Arrange menu.
You have tried to move an object or objects to a locked layer.

Use the Layer Manager to unlock the layer.



You cannot delete the only unlocked and visible layer.
You have selected to delete a layer that is the only unlocked and visible layer of the layers in your 
chart.

Either change the selected layer’s attributes to locked and invisible or select another layer to be 
unlocked and visible.



You do not have any Data Fields set up yet.

Would you like to set up now?
You have selected a feature that requires data fields to be set up, and you have not set up the data 
fields yet.

Click Yes to open the Setup Fields dialog box to enter your data fields.



Zoom Value Must Be Between 5% and 1600%.
You have entered a value outside of the range.

Enter a number between 5 and 1600.
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A
Active window
Attributes

C
Cancel
Check box
Clear
Click
Clipboard

Command
Compound document
Compound shape
Container program
Control menu box

Control Panel
Copy
Cut

D
Deselect
Dialog box



Dock
Double-click
Drag

E
Embed
Extension

F
Font

G
Grid
Guidelines

H
Handles
Hint line

I
Icon

L
Launch
Link
Living Shapes

M
Menu
Mouse

N
New window
Normal
Note

O
Object
Object application
Object Linking and Embedding (OLE)

P
Page orientation
Page size
Palette
Paper size
Paste

Pixel
Point (noun)
Point (verb)
Pointer
Press



Print area
Proportional

Q
QuickZoom

R
Resize
Redo

S
Scroll
Scroll bars
Select

Shape palette
Shape property

Starting point
Starting shape

T
Text block
Text cursor
Text style
Title bar
Toolbox

Toggle

U
Undo
Update

W
Window
Workspace

Z
Zoom



Active window
The window in which you are working. The active window appears in front of other windows and 
receives the next action. The color of the title bar in the active window distinguishes it from the 
other windows.



Attributes
The characteristics that define the appearance of an object. Shape attributes include its border 
color, width, and style; fill color and pattern; and shadow color and style. Line attributes include its 
color, width, and start and end styles.



Cancel
A button used to close a dialog box without completing the command. The ESC key also can be used 
to close a dialog box.



Check box
A small square box that can be toggled on or off using the mouse. Check boxes frequently are used 
when you can select or deselect one or more options.



Clear
To delete selected objects from a chart using the Clear command on the Edit menu. When you use 
the Clear command, FlowCharter 7 does not place a copy of the objects on the Clipboard.



Click
To quickly press and release the left mouse button.



Clipboard
A temporary storage area for objects that are cut or copied from FlowCharter 7 or another Windows 
program.



Command
A word or phrase, usually found on a menu, that opens a dialog box or carries out an action.



Compound document
A file that contains information from two or more OLE-compatible software programs.



Control menu box
The box, located in the upper left corner of the window, that you click to open the Control menu or 
double-click to close the window.



Control Panel
A Windows accessory for installing printers and fonts, setting up printers and ports, and choosing 
program options.



Copy
To place a copy of selected objects on the Clipboard using the Copy command on the Edit menu.



Cut
To remove selected objects from a chart and place a copy of them on the Clipboard using the Cut 
command on the Edit menu.



Deselect
To move the pointer away from an object and click the left mouse button. The handles on the object 
disappear. Commands, tools, and buttons no longer affect the object.



Dialog box
A window that opens when the program needs information from you before it can carry out an 
action.



Dock
To move the selected area (for example, toolbar or worksheet) to one side of the program window. 
You can place the docking area below the menu bar or to the left, right, or bottom edge of the 
program window. When you drag the docking area to the edge of the program window, that area 
outline "snaps" to the length of the edge. If you drop the docking area after its outline "snaps," it 
docks to that edge of the window.



Double-click
To press and release the left mouse button twice rapidly without moving the mouse.



Drag
To point to an object with the mouse, press and hold the left mouse button, and move the mouse so 
that the object moves with the pointer across the screen.



Embed
To place an object in a file in another program. A graphic image of the object, as well as detailed 
information about its attributes and how to print it, is inserted into the file of the other program. By 
double-clicking the object, you can open its original program and edit it.



Extension
The period and one to three characters at the end of a filename that identify the kind of information 
in the file. For example, the extension for FlowCharter chart files is .flo. The extension for template 
files is .aft and the extension for workspace files is .afw. 



Font
A set of characters, including letters and numbers, that is all one size and style.



Handles
Square boxes that appear on the corners and sides of an object when the object is selected. You use 
the handles to resize the object.



Hint line
A one-line message at the bottom of the FlowCharter 7 window that gives you information about the
tool or button beneath the arrow pointer or the highlighted command.



Icon
A small graphic symbol that represents a program or a file. For example, the chart windows in 
FlowCharter 7 can be minimized to appear as icons in the workspace.



Launch
Running another program by double-clicking on a shape. You can set a shape to run another 
program by selecting the shape, clicking the Link button on the Standard toolbar, and then entering 
the full path in the Link To: Other program or file box.



Link
To connect an object to a file in another program. The file in the other program contains a graphic 
representation of the object and the path to the file that contains it. Changes made to the object in 
its original program also are reflected in the linked object.



Menu
A list of commands organized under a name on the menu bar near the top of the FlowCharter 7 
window. To open a menu, you click the menu name or press ALT and the letter underlined in the 
menu name.



Mouse
A manual device that you move across a flat surface to move the pointer on your screen. A mouse 
can have one or more buttons, which you press to carry out various actions.



Object
An element in a chart window, such as a shape, line, or text block. Objects can be placed in other 
programs using object linking and embedding (OLE).



Object Linking and Embedding (OLE)
The ability to share information among documents created in different programs. You can share 
charts, spreadsheets, text, drawings, sounds, video, and animation among OLE-compatible 
programs.



Palette
A palette is collection of shapes displayed in a Shape palette. You use the shapes in the Shape 
palette to place shapes in charts.



Page orientation
The position of the page on the screen. Portrait (vertical) orientation displays a page taller than it is 
wide. Landscape (horizontal) orientation displays a page wider than it is tall.



Page size
The dimensions of a page on the screen.



Paper size
The physical size of the paper in a printing device.



Paste
To place a copy of the objects on the Clipboard into the active chart window using the Paste 
command on the Edit menu.



Pixel
An individual dot on the screen or printed page. Pixels combine to form an image.



Point (noun)
A type measure equal to about 1/72 of an inch.



Point (verb)
To move the mouse until the pointer on the screen rests on the object you want.



Pointer
A graphic symbol on the screen that follows the movement of the mouse. The pointer is usually an 
arrow, but can change shape depending on the command or button you choose.



Press
To hold down the mouse button.



Print area
The area, as defined either by page size definitions or by the printer, that can be printed.



Resize
To change the size of an object. Dragging a handle into an object makes it smaller; dragging a 
handle away from an object makes it larger.



Scroll
To move through the chart window to see portions of the chart that cannot fit on the screen.



Scroll bars
The bars at the right side and bottom of the FlowCharter 7 window. Each scroll bar contains a scroll 
box and two scroll arrows. Click a scroll bar to move by one screen vertically or horizontally across 
the chart.



Select
To choose an object in the window by clicking it with the mouse. Handles appear on the object to 
indicate it is selected. After an object is selected, it can be edited using commands, tools, and 
buttons.



Shape palette
A collection of shapes displayed in the FlowCharter 7 window. You use the shapes in the Shape 
palette to place shapes in charts.



Starting point
To insert the first entity into a Living FlowChart. If you have multiple entities in a chart and use the 
Starting Point command, all entities will be deleted and a new, single entity will be placed in the 
shape that you choose.



Starting shape
Any shape with an entity in it. When you run the chart, the entity moves out of its starting shape to 
the next shape in the path.



Text cursor
A blinking vertical bar that indicates where to begin entering or editing text.



Text style
An attribute applied to text, such as bold, italic, underline, and strikethrough.



Tile
A method of arranging open chart windows in which the windows are side by side and a portion of 
each window is visible.



Title bar
The bar across the top of a window that contains the name of the window. The title bar also contains
the Control menu box for the window and its minimize and maximize boxes.



Toggle
To alternately change from one state to another, such as on and off.



Toolbox
The vertical bar at the left side of the FlowCharter 7 window. The Toolbox contains tools with which 
to select and resize objects, draw shapes and lines, type text, number shapes, and change the view.



Window
A rectangular area on the screen that displays the FlowCharter 7 program or a chart file. You can 
have several chart windows open at the same time. Each window has its own title bar.



Workspace
The area in FlowCharter 7 that displays the chart windows. You can save the arrangement of the 
windows in a workspace file.



Text block
Text that is independent of a shape, such as a chart title or legend. Text blocks are created using the
Text Tool in the Toolbox.



Proportional
Having the same or a constant ratio. When you resize a shape proportionally, the shape height and 
width maintain a constant ratio relative to each other.



Compound shape
A shape created by combining two or more shapes in FlowCharter 7.



Shape property
Predefined characteristics of a shape, such as its name, size, and connect points. You can change 
shape properties using the Palette menu in the Shape palette.



Container program
An OLE-compatible program that can accept a linked or embedded object from an OLE object 
program.



Object program
An OLE-compatible program that creates objects that can be linked to or embedded in a file in an 
OLE container program.



Zoom
Magnifying or reducing the view of a document. For example, zooming in gives you a closer view 
and zooming out gives you a more distant view.



Grid
A series of horizontal and vertical dots that criss-cross the drawing area. You can snap objects to the
grid for more exact placement.



Guidelines
Horizontal and vertical lines that display but do not print. You use guidelines to align objects. 
Guidelines let you align shapes of different sizes. Guidelines do not appear in the printed chart. 
Objects (shape and text) snap to guidelines.



QuickZoom
The QuickZoom window provides a view-only window of the image. When first opened, this window 
shows a miniature representation of the full image. You use the resizable viewing rectangles to zoom
in and out on the image in the currently active window.



Undo
To reverse the last action or change on a chart.



Redo
Redo restores the most recent edit that has been undone. 



New window
A command that opens a new window for the active chart providing you with two windows for the 
same chart. You can make changes in the second window and then save it as another filename 
without closing the original chart.



Note
You can attach a note to any shape. The note can contain information about a step or process, 
information that will not fit into a shape, or information that you do not want to print as part of the 
chart.



Normal
A command on the View menu that displays objects at their actual sizes. The Normal view is the 
best all-purpose view for creating and changing charts.



Update
When you update a chart, you automatically update linked field data as well as other current 
information such as Date and Time for Master Items.



Living Shapes
Living Shapes are shapes that contain data and code that enables them to perform actions. Every 
shape with a line coming into or going out of it is a Living Shape. 



Switch Tool command
The Switch Tool command switches between the Selector tool and the last Toolbox tool you had 
selected.



Switches between the Selector tool and the last Toolbox tool you had selected.



Insert Link command
The Add Link command links the active shape to another chart or file. This command opens the Link 
dialog box.



Links the active shape to another chart or file by opening the Link dialog box.



Format command
The Format command formats the fill, lines, ends, and effects of an object. This command opens the
Format Object dialog box.



Format the fill, lines, ends, and effects of an object. This command opens the Format Object dialog 
box.



Displays or hides this toolbar.



Adds a horizontal guideline to the chart and adjusts it.



Shows the location of the selected shape(s) as a thick blue line and the mouse pointer location as a 
thin maroon line. Also, you can create guidelines by dragging them off the ruler and into your chart.
The units of measure are shown in the top, left corner of the ruler bar. If the corner shows in, you 
are using inches as the units of measure. If the corner shows cm, you are using centimeters as the 
units of measure.



Shows the location of the selected shape(s) as a thick blue line and the mouse pointer location as a 
thin maroon line. Also, you can create guidelines by dragging them off the ruler and into your chart.
The units of measure are shown in the top, left corner of the ruler bar. If the corner shows in, you 
are using inches as the units of measure. If the corner shows cm, you are using centimeters as the 
units of measure.



Shows information about the selected tool or button. The name of the current shape in the Shape 
palette shows in the box on the right.



Lets you relocate the toolbars. Click anywhere in the gray area around any toolbar and drag it to 
make it a palette, or you can move it to another side of the chart window and attach it to the side.
The toolbar will be a palette when the outline of it is thick. The toolbar will attach to a side of the 
chart window when the outline is thin.



Lets you make a window active by clicking a title bar. Double-click the chart window or program 
window to maximize the window or restore the window to its previous size and location.



Sort command (shortcut menu)
The Sort command opens the Sort Worksheet dialog box that allows you to sort your worksheet 
data.

{button Related Topics,PI(`',`IDH_RT_Sort_Command')}



What is a Worksheet
Worksheet command
View menu



Opens the Sort Worksheet dialog box that allows you to sort your worksheet data.



Sort Worksheet dialog box
The Sort Worksheet dialog box lets you sort the data in your worksheet



Setup Fields command
The Setup Fields command opens the Setup Fields dialog box so that you can enter data fields for 
your chart.

{button Related Topics,PI(`',`IDH_RT_Setup_Fields_Command')}



To set up a data field 



Opens the Setup Fields dialog box so that you can enter data fields for your chart.



Docking Views command
The Docking Views command lets you dock your worksheet.

{button Related Topics,PI(`',`IDH_RT_Docking_View_Command_short')}



To dock the worksheet 



Docks your worksheet.



Hide command
The Hide command hides your worksheet.



Hides your worksheet.



Select command (shortcut)
The Select command selects all objects, or all shapes, or all lines in a chart. It opens the Select 
dialog box.



Selects all objects, or all shapes, or all lines in a chart. It opens the Select dialog box.



Zoom command
The Zoom command zooms in on or out of a part of a chart. It opens the Zoom dialog box.



Zooms in on or out of a part of a chart. It opens the Zoom dialog box.



Format Cells command
The Format Cells command lets you format the number, alignment, border, pattern, and font of the 
spreadsheet cell(s)in your SPC chart. It opens the Format Cells dialog box.



Lets you format the number, alignment, border, pattern, and font of the spreadsheet cell(s)in your 
SPC chart. It opens the Format Cells dialog box.



View Calculation command
The View Calculation command displays or hides the calculation columns for the active spreadsheet,
if available.



Displays or hides the calculation columns for the active spreadsheet, if available.



Insert Titles command
The Insert Titles command lets you insert or hide chart titles and chart axis titles. This command 
opens the Titles dialog box.



Lets you insert or hide chart titles and chart axis titles. Opens the Titles dialog box.



Insert Gridlines command
The Insert Gridlines command lets you insert or hide major and minor gridlines for the category (X), 
value (Y), second value (Y), and series (Z) axis. This command opens the Gridlines dialog box.



Lets you insert or hide major and minor gridlines for the category (X), value (Y), second value (Y), 
and series (Z) axis. Opens the Gridlines dialog box.



Insert Control Lines command
The Insert Control Lines command lets you insert or hide control lines for the selected SPC chart. 
This commands opens the Control Lines dialog box.



Lets you insert or hide control lines for the selected SPC chart. Opens the Control Lines dialog box.



Insert Legend command
The Insert Legend command inserts a legend in your SPC chart.

Note
This legend is not the same as the legend for a FlowCharter chart. A FlowCharter chart’s 

legend displays the totals for the fields in all the shapes in the chart. To work with FlowCharter chart’s 
legend, FlowCharter must be active.    With FlowCharter active, click Legend on the Insert menu to 
activate FlowCharter legends. 



Inserts a legend in your SPC chart.



View in 3D command
The View in 3D command changes your SPC chart to a 3D view.



Changes your SPC chart to a 3D view.



Format Chart command
The Format Chart command lets you change the appearance, base and walls, and backdrop of the 
active SPC chart. It opens the Format Chart dialog box.



Lets you change the appearance, base and walls, and backdrop of the active SPC chart. Opens the 
Format Chart dialog box.



Format 3D View command
The Format 3D View command lets you change the view and lighting of a 3-D SPC chart. It opens the
Format 3D View dialog box.



Lets you change the view and lighting of a 3-D SPC chart. Opens the Format 3D View dialog box.



Format Legend command
The Format Legend command lets you change your SPC chart legend. It opens the Format Legend 
dialog box.



Lets you format your SPC chart legend. Opens the Format Legend dialog box.



Format Title command
The Format Title command lets you change the title of the active chart or chart axis. It opens the 
Format Title dialog box.



Lets you change the title of the active chart or chart axis.Opens the Format Title dialog box.



Format Axis command
The Format Axis command lets you change the active chart axis. It opens the Format Axis dialog 
box.



Lets you change the active chart axis. Opens the Format Axis dialog box.



Column Width command
The Column Width command lets you change the width of active columns and/or the default column
width for the active SPC spreadsheet. It opens the Column Width dialog box.



Lets you change the width of active columns and/or the default column width for the active 
worksheet. Opens the Column Width dialog box.



Column Name command
The Column Name command lets you change the column name in your SPC spreadsheet. It opens 
the Column Header Text dialog box.



Lets you change the column name in your SPC spreadsheet. Opens the Column Header Text dialog 
box.



Row Height command
The Row Height command lets you change the height of active rows and/or the default row height 
for the active SPC spreadsheet. It opens the Row Height dialog box.



Lets you change the height of active rows and/or the default row height for the active SPC 
spreadsheet. Opens the Row Height dialog box.



Page Setup command
The Page Setup command opens the Page Setup dialog that box lets you choose the page size, 
margins, and other options to prepare the chart for printing or viewing.

Note
If you change your page margin, the objects on the page will move as well.

Tip
To fit your chart on the fewest pages, click Portrait if your chart is oriented vertically or 

Landscape if your chart is oriented horizontally.

{button Related Topics,PI(`',`IDH_RT_Page_Setup_Command_short')}



To define the page setup



Opens the Page Setup dialog that box lets you choose the page size, margins, and other options to 
prepare the chart for printing or viewing.



Insert Guideline command
The Insert Guideline command add a guideline to your chart.

{button Related Topics,PI(`',`IDH_RT_Add_Guideline_Command')}



Guidelines command 
View menu 



Adds a guideline to your chart.



Guidelines command
The Guidelines command hides or displays the guidelines.



Hides or displays the guidelines.



Grid command
The Grid command hides or displays the grids.



hides or displays the grids.



Hide Rulers command
The Hide Rulers command hides or displays the rulers.



Hides or displays the rulers.



Standard command
The Standard command hides or displays the Standard toolbar.



Hides or displays the Standard toolbar.



Formatting command
The Formatting command hides or displays the Formatting toolbar.



Hides or displays the Formatting toolbar.



Toolbox command
The Toolbox command hides or displays the Toolbox.



Hides or displays the Toolbox.



Arrange command
The Arrange command hides or displays the Arrange toolbar.



Hides or displays the Arrange toolbar.



Preset Styles command
The Preset Styles command hides or displays the Preset Styles toolbar.



Hides or displays the Preset Styles toolbar.



Data command
The Data command hides or displays the Data toolbar.



Hides or displays the Data toolbar.



Living FlowCharts command
The Living FlowCharts command hides or displays the Living FlowCharts toolbar.



Hides or displays the Living FlowCharts toolbar.



Toolbars command (shortcut)
The Toolbars command hides or shows any of the toolbars.

{button Related Topics,PI(`',`IDH_RT_Toolbars_Command_short')}



Toolbars command 



Hides or shows any of the toolbars.



Customize command (shortcut)
The Customize command lets you customize the program toolbars and the Toolbox.

{button Related Topics,PI(`',`IDH_RT_Customize_Command_short')}



Customize command 



Lets you customize the program toolbars and the Toolbox.



Format command
The Format command lets you change the font and alignment of the selected text. It opens the 
Format Font dialog box.



Lets you change the font and alignment of the selected text.Opens the Format Font dialog box.



Edit Text command
The Edit Text command lets you change the selected text directly.



Lets you change the selected text directly.



Scroll to Object command
The Scroll to Object command displays the object in the chart associated with the selected object in 
the worksheet.



Displays the object in the chart associated with the selected object in the worksheet.



Clear Contents command
The Clear Contents commands clears the contents of the selected cells in your worksheet.



Clears the contents of the selected cells in your worksheet.



Arrange+ command
The Arrange+ command hides or displays the Arrange+ toolbar.



Hides or displays the Arrange+ toolbar.



Cuts the selected objects to the Clipboard.



Copies the selected objects to the Clipboard



Pastes cut or copied objects into the active chart.



Edit command (shortcut menu)
The Edit command lets you reshape shapes, edit connect points, edit text layout, edit text, and edit 
object script.



Lets you reshape shapes, edit connect points, edit text layout, edit text, and edit object script.



Reshape command
The Reshape commands opens the Reshape toolbox to let you reshape the selected shape.



Opens the Reshape toolbox to let you reshape the selected shape.



Connect Points command
The Connect Points command opens the Edit Connect Points toolbox to let you edit the connect 
points for the selected object.



Opens the Edit Connect Points toolbox to let you edit the connect points for the selected object.



Text Layout command
The Text Layout command opens the Edit Text Area Layout toolbox to let you edit the text area for 
the object you selected.



Opens the Edit Text Area Layout toolbox to let you edit the text area for the object you selected.



Text command
The Text command opens the text block to let you edit your text.



Opens the text block to let you edit your text.



Properties command
The Properties command opens the Object Properties dialog box to let you change shape properties 
such as name, behavior, size, and script password.



Opens the Shape Properties dialog box to let you change shape properties such as name, behavior, 
size, and script password.



Selects inches as the measurement unit for your chart.



Selects centimeters as the measurement unit for your chart.



Sorts your worksheet in ascending order.



Sorts your worksheet in descending order.



Lets you select the worksheet element to sort by: object type or specific field name.



Why Should I Use Flowcharts?

The flowchart is the most widely understood form of business graphics. With a flowchart you can 
show and explain a process quickly and clearly. Best of all, because flowcharts are easy to 
understand, they are more likely to be read and remembered than text.

{button Related Topics,PI(`',`IDH_RT_Why_Should_I_Use_Flowcharts')}
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Are There Many Rules in Flowcharting?

No, there are no complicated rules to follow when creating a flowchart. You can design the chart in 
the way that best illustrates the process you want to show.
There are a few general guidelines you can consider when flowcharting. The most important 
guideline is "Keep it simple." You want to keep your flowchart simple so that it will be easy to follow 
and understand.

{button Related Topics,PI(`',`IDH_RT_Are_There_Many_Rules_in_Flowcharting')}



Basic Flowchart Shapes
Choosing Line Styles 
Choosing Arrowhead Styles 
Hints and Guidelines for Effective Flowcharts

Designing Intuitive Charts
Choosing Numbering Schemes 
Choosing Portrait or Landscape Orientation 
Choosing Single-Page or Multiple-Page Charts 



What Shapes Should I Use?

Standardized shapes make it easy to identify key elements in a process, such as decisions, 
connections outside the system, or new elements. However, don’t be too concerned with using the 
"right" shape. Unless your chart is in a specialized discipline, such as data flow, the shapes you use 
depend on your audience.
If your audience is not familiar with flowcharting symbols, use the basic shapes. You also can use 
shapes that are recognized easily, such as computers, cars, and office equipment.

Consistency is a key element in creating a chart that is easy to understand. You can have shapes 
mean whatever you like. If you define the meaning of a shape yourself, however, be sure that you 
use the shape consistently throughout the chart. For example, if you decide a triangle represents a 
budget review, make certain that every budget review is represented by a triangle — and that every
triangle in the chart signifies a budget review.

{button Related Topics,PI(`',`IDH_RT_What_Shapes_Should_I_Use')}



Basic Flowchart Shapes
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Basic Flowchart Shapes

This topic briefly describes the shapes used most often in flowcharting. These shapes should be 
sufficient for your first charts as you begin using flowcharts in your work.

Process
Represents any type of process or activity, 
such as writing a memo, purchasing 
equipment, or interviewing a job 
candidate.

Alterna
te 
Process

Represents an alternate type of process, 
such as external (vs. internal) or static (vs. 
variable). Although popular, this shape is 
not an ISO-standard or ANSI-standard 
shape.

Decisio
n

Indicates a point at which a decision must 
be made. Generally, two flow lines point 
out of the shape—one out of the bottom 
and one out of the side. Each line is 
marked with a decision option, such as 
"Yes" and "No" or "True" and "False." These
lines also can show branch options such as
"Make" versus "Buy."

Input/
Output

Represents the information that goes into 
or comes out of a process. Examples of 
input are orders and inquiries. Examples of
output are reports and products.

Docum
ent

Represents an activity recorded in a 
document, such as a computer file or 
printed report.

Connec
tor

Links a shape to another point in the 
flowchart without using a line. A letter or 
number in the circle links to the 
corresponding letter or number elsewhere 
in the chart. For example, the connector 
may indicate at what point the flow 
continues on another page in the chart. It 
also is used to connect multiple lines at 
one point.

Termin
al

Indicates the start or end of a process. The
beginning terminal shape generally is 
labeled "Start" or "Begin." The ending 
terminal shape is labeled "Stop" or "End."

{button Related Topics,PI(`',`IDH_RT_Basic_Flowchart_Shapes')}
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How Do I Create a Flowchart?
{button Tell me

how . . .,PI(`',`IDH_HT_How_Do_I_Create_a_Flowchart')}

You can create a wide variety of flowcharts. Here we describe how to create a simple flowchart. This 
chart illustrates the process of shipping a product.

Sample Flowchart
Starting the Chart
You begin your chart by drawing a starting terminal shape and labeling it. This shape makes it easy 
for the reader to find the beginning of the process.

Terminal shape
Adding Process Shapes
Next, ask yourself, "What’s the very first thing that happens in this process?" The answer usually is 
some type of activity, which means you draw a process shape (rectangle). In our example, the first 
step in shipping a product is taking the customer’s order for the product.
After you draw the process shape, add text in the shape to describe what the shape represents. (It is
best to keep the text to just a few words so that the flowchart will be easier to understand and 



remember.)
The next step in our example is also an activity—sending the customer’s order to the shipping 
department. Therefore, we use the process shape again. We draw lines with arrows to show the 
order of the steps in the process, or the "process flow." For example, we take the customer’s order 
and then send the order to shipping.

Process shapes
Using a Decision Shape
After the order arrives in shipping, the question arises, "Is the product currently in stock?" Because 
there are two possible answers (Yes or No), this step in the process is shown in a decision shape 
(diamond). A decision shape generally has two lines pointing out of it in different directions. Each 
line is marked with one of the possible answers or outcomes.
In our example, if the answer is "Yes," the process then flows directly to the final activity—shipping 
the product to the customer. This activity is shown in a process shape.

Decision shape
Tip

If you have several decision shapes in your chart, be consistent. Always present "Yes" as the 
choice for the flow from the bottom of the shape or from the side—don’t mix them.
Representing a Document
If the answer is "No," a few more steps are required to complete the process. First, a back-order 
notice is generated and sent to the customer. Because this is a printed notice, we use a document 
shape in the chart.

Document shape
Showing Input and Output
Next, information is gathered about projected orders. Because this step requires input from other 
sources, such as sales people, the input/output shape is used.

Input/Output shape
Using a Connector Shape
After the back-order notice is generated and the sales forecast is considered, additional copies of 
the product are assembled. As expected, this activity is recorded in a process shape. The process 
then links back through the connector shape labeled "A" to the decision shape.

Connector shape
Completing the Process
Finally, after more product has been assembled and is in stock, the flowchart again reaches the final



activity—shipping the product to the customer. The ending terminal shape shows that the process is 
complete.

Terminal shape

{button Related Topics,PI(`',`IDH_RT_How_Do_I_Create_a_Flowchart')}



To create a new chart
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Finding the Sample Charts

FlowCharter includes sample charts that show how some of its features can be used. When we 
discuss a feature or chart attribute that is used in a sample, we will name the chart that uses it so 
that you can open that chart.
The samples are in a subdirectory of the FlowCharter directory.    For example, if you installed 
FlowCharter in the default directory, the sample charts will be located in C:\Program files\Micrografx\
FlowCharter\Samples.

{button Related Topics,PI(`',`IDH_RT_Finding_the_Sample_Charts')}



To open a file 



Choosing Portrait or Landscape Orientation

Most charts can be created with either a portrait (tall) or landscape (wide) orientation. 
With a portrait orientation, the flow is usually from top to bottom. Portrait is often chosen to 

match the orientation of the pages in a report. The following chart illustrates a chart in portrait mode.

With a landscape orientation, the flow is from left to right. Landscape follows the normal left-to-
right pattern of readers and is useful in presentations. Landscape is often chosen to match the 
orientation of the pages in a report. The following graphic illustrates a chart in landscape mode.

Tip
Match your audience’s natural reading patterns as much as possible. Design the chart so that 

the process primarily flows from left to right or top to bottom. Don’t force the audience to scan 
backward or upward for long distances.

{button Related Topics,PI(`',`IDH_RT_Choosing_Portrait_or_Landscape_Orientation')}



Choosing Single-Page or Multiple-Page Charts



Choosing Single-Page or Multiple-Page Charts

A multiple-page chart is a good idea if you want to create a large flowchart, such as a wall chart, but
without a drawing-sized printer, the chart pages must be trimmed and assembled. Therefore, we 
recommend that you create several linked, one-page charts, which are easier to store, duplicate, 
and distribute.
The sample chart Orgdemo.flo illustrates a multiple-page chart that is linked.
In the example below, when you click on the Review shape in the top-level Report Process chart, a 
more detailed chart covering just the Review Process opens.

{button Related Topics,PI(`',`IDH_RT_Choosing_Single_Page_or_Multiple_Page_Charts')}
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Choosing Line Styles
{button Tell me how . . .,PI(`',`IDH_HT_Choosing_Line_Styles')}

The following are general standards for using line styles in flowcharting. However, these standards 
vary widely among industries, companies, and other organizations. Your organization can use these 
standards, or it may have its own.

Solid lines represent physical flows of information and materials. For example, a solid line can 
represent the forwarding of a purchase order.

Dotted lines can indicate temporary or informal flows, such as informal communication among 
departments.

Dashed lines can be used to show electronic transfers of information, such as an electronic-
mail message.

{button Related Topics,PI(`',`IDH_RT_Choosing_Line_Styles')}



To format new lines
To format existing lines
To choose a preset line style



Determining the Way Lines Look
Preset Line Styles
Line Options
Choosing Line Styles that Enhance Your Chart
Connecting Shapes with Lines

Attaching Text to Lines



Choosing Arrowhead Styles
{button Tell me

how . . .,PI(`',`IDH_HT_Choosing_Arrowhead_Styles')}

Arrows indicate a flow or sequence. You use them to clarify the direction of the flow.

One-way flow Two-way flow
Some disciplines, such as information engineering, use specific types of arrows to indicate 
relationships, such as many-to-one and one-to-many.

Many-to-one One-to-many

{button Related Topics,PI(`',`IDH_RT_Choosing_Arrowhead_Styles')}



To choose arrowhead styles



Determining the Way Lines Look
Choosing Line Styles



Choosing Numbering Schemes
{button Tell me

how. . .,PI(`',`IDH_HT_Choosing_Number_Schemes')}

Decimal numbers (1.1, 1.2, 1.3) are useful for numbering shapes in complex charts, such as charts 
that represent multiple branches or systems. Otherwise, integers (1, 2, 3) better illustrate the 
sequence of shapes in a process.

You can add text to the shape number to help explain the chart (Step 1, Step 2).
You may prefer not to number the shapes if the flowchart is easy to understand without them. More 
text will fit in shapes without numbers, and the chart will have a cleaner appearance.
The sample chart Quality.flo illustrates a chart with numbering.

{button Related Topics,PI(`',`IDH_RT_Choosing_Numbering_Schemes')}



Shape Numbers Overview



To renumber shapes automatically
To renumber shapes manually
To show or hide shape numbers
To change the next number for new shapes



Types of Flowcharts

The charts we have used as illustrations up to now have been standard process    flowcharts. A 
standard flowchart illustrates a process using symbols from the American National Standards 
Institute (ANSI). Here are a few other types of flowcharts you can create:

Analysis charts
Block charts
Data flow charts
Deployment flowcharts
Network charts

{button Related Topics,PI(`',`IDH_RT_Types_of_Flowcharts')}



Analysis Charts
Block Charts
Data Flow Charts
Deployment (Functional) Flowcharts
Network Charts



Block Charts
{button Tell me how . . .,PI(`',`IDH_HT_Block_Diagrams')}

Block charts give a brief overview of a process. Using just rectangles and arrows, you can create a 
block chart that breaks a complex process into several large pieces. These large pieces then can be 
detailed in standard flowcharts. Organization charts are a type of block chart. 

The sample chart Orgdemo.flo illustrates a chart that is a block chart.

Tip
Before you begin flowcharting a complex process, it is helpful to create a block chart of the 

entire process. The block chart will serve as the "big picture" while you create the more detailed 
flowcharts. You may choose to keep the block chart as the top level chart, linking each shape to a more
detailed subchart.

{button Related Topics,PI(`',`IDH_RT_Block_Diagrams')}



Analysis Charts
Data Flow Charts
Deployment (Functional) Flowcharts
Network Charts



To create a block CoolSheet



Deployment (Functional) Flowcharts
{button Tell me how . . .,PI(`',`IDH_HT_Deployment_Flowcharts')}

Deployment flowcharts illustrate the flow of information and materials among different 
organizational units. Deployment flowcharts are useful for identifying how time is being used in a 
process; therefore, they are used frequently in quality management and reengineering projects. The
sample chart Wgndploy.flo illustrates a deployment flowchart. One of our demonstration programs 
uses OLE automation to create deployment flowcharts automatically. To run it, double-click on 
Deploy.exe in C:\Program files\Micrografx\Graphics Suite\FlowCharter\Samples in Explorer.

{button Related Topics,PI(`',`IDH_RT_Deployment_Flowcharts')}



Analysis Charts
Block Charts
Data Flow Charts
Network Charts



To create a deployment CoolSheet



Data Flow Charts
{button Tell me how . . .,PI(`',`IDH_HT_Data_Flow_Diagrams')}

Data flow charts use a few strictly defined shapes, lines, and arrows to display the flow of data and 
information. The sample chart Dataflow.flo also illustrates a data flow chart.

{button Related Topics,PI(`',`IDH_RT_Data_Flow_Diagrams')}



Analysis Charts
Block Charts
Deployment (Functional) Flowcharts
Network Charts



To create a block CoolSheet
To create a deployment CoolSheet
To create a CoolSheet
To create a process CoolSheet



Network Charts
{button Tell me how . . .,PI(`',`IDH_HT_Network_Diagrams')}

Network charts illustrate the connections among hardware and software in a system and show how 
the components of the system interact. Shapes in a network chart often resemble the equipment 
they represent, such as a computer terminal. 

The sample chart Network.flo also illustrates a network chart.

{button Related Topics,PI(`',`IDH_RT_Network_Diagrams')}



Analysis Charts
Block Charts
Data Flow Charts
Deployment (Functional) Flowcharts



To create a block CoolSheet
To create a deployment CoolSheet
To create a CoolSheet
To create a process CoolSheet



Analysis Charts
{button Tell me how . . .,PI(`',`IDH_HT_Analysis_Charts')}

A flowchart becomes a powerful analysis tool when data is added to the chart. Analysis charts let 
you achieve the following possibilities:

Accumulate data in a chart
Subtotal data up through chart hierarchies
Print data in reports
Pass data to spreadsheets and databases
Graph data

The sample chart Wgndata1.flo also illustrates an analysis chart.

{button Related Topics,PI(`',`IDH_RT_Analysis_Charts')}



Block Charts
Data Flow Charts
Deployment (Functional) Flowcharts
Network Charts



To create a block CoolSheet
To create a deployment CoolSheet
To create a CoolSheet
To create a process CoolSheet



Hints and Guidelines for Effective Flowcharts

FlowCharter has many features designed to help you create flowcharts that are easy to use and 
understand. Ask yourself two questions before you create a new chart:

Who will be using the chart?
. . . And how will they be using it?

Charts to be used by someone other than the creator should be simple and self-documenting. Take a
few moments now and then to look at your chart with the eyes of a stranger. Does it tell you 
everything you need to know?
The medium also affects design. 

Is the chart going to be printed in black and white? If so, it will most likely be reproduced in a 
vertical (portrait) orientation, and colored backgrounds on shapes will reduce legibility. 

Will it be used as a graphic during a presentation? If so, the audience should be able to read it 
from the back of the room. 

Will it be viewed on a computer monitor? If so, color is an effective tool, but beware of 
resolution problems. 

Will it be used interactively? If so, it should be annotated to tell the user what actions to take, 
such as double-clicking on a shape to link to a subchart.

{button Related Topics,PI(`',`IDH_RT_Hints_and_Guidelines_for_Effective_Flowcharts')}



Using Shapes and Lines Effectively
Using Fonts and Text Effectively
What Shapes Should I Use?
Designing Intuitive Charts



Designing Intuitive Charts
{button Tell me

how . . .,PI(`',`IDH_HT_Designing_Intuitive_Charts')}

Here are a few tips for creating a clear, concise flowchart.
Add a legend or annotation if the audience is unfamiliar with shape or line meanings. This is 

especially important with interactive charts.
Provide prompts for linked or launched shapes.
Indicate beginning and ending points clearly. Provide a separate button on subcharts to make it

easy to return to the top level.
Use subcharts to reduce complexity. When a single chart gets too complicated, move a logical 

subsection to a new chart and replace that section in the original chart with a single shape. You don’t 
need to redraw the shapes in a new chart—just use the group-and-link feature to transfer a group of 
shapes to a new chart and automatically replace them with a new, linked shape.

{button Related Topics,PI(`',`IDH_RT_Designing_Intuitive_Charts')}



Hints and Guidelines for Effective Flowcharts
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To choose line routing type 
To choose line styles for new lines 
To add text to a line 
To choose object effects 

To choose arrowhead styles 
To choose the line crossover 



Using Shapes and Lines Effectively
{button Tell me

how . . .,PI(`',`IDH_HT_Using_ShapesLines_Effectively')}

Keep charts simple and uncluttered.
Use just a few shape types and sizes in a chart. Too many shapes and sizes will make the chart 

difficult to understand.
Align the shapes into columns and rows (using Channel alignment) so it is easier to follow the 

flow.
Avoid crossed lines. If necessary, move shapes to minimize the number of lines that cross over 

each other. Use crossover style and nodes to indicate if crossed lines are connected.
There are over two dozen Shape palettes, containing over 500 shapes. You can create your own 
shapes in other programs and place them in a FlowCharter palette.
If a chart is to be viewed on-screen, use color to define, differentiate, and add interest. If a chart is 
to be printed, avoid using text on a colored background. If you want text on a background, choose 
lighter colors such as yellow, cyan, or light gray. Medium and dark colors can be used for shadow 
effects on printed documents.

Use a shape as background to group several shapes together logically. The sample file Network.flo 
uses several shapes to cluster equipment. Cloud shapes are found in the Net - PC and Network 
Extensions palettes.

{button Related Topics,PI(`',`IDH_RT_Using_Shapes_and_Lines_Effectively')}



Hints and Guidelines for Effective Flowcharts
Using Fonts and Text Effectively
What Shapes Should I Use?



To choose line routing type 
To choose line styles for new lines 
To add text to a line 
To choose object effects 

To choose arrowhead styles 
To choose the line crossover 



Using Fonts and Text Effectively
{button Tell me how . . .,PI(`',`IDH_HT_Using_FontsText')}

Readability is the most important criterion for choosing the font for your chart. Sans serif fonts such 
as Arial are a good choice because they are crisp and easy to read, especially for charts that are 
designed to be viewed on a computer monitor. A larger point size may be necessary for charts that 
will be viewed on computer monitors or in presentations.

{button Related Topics,PI(`',`IDH_RT_Using_Fonts_and_Text_Effectively')}



Hints and Guidelines for Effective Flowcharts
Using Shapes and Lines Effectively
What Shapes Should I Use?

Using Text in Shapes
Using Text for Emphasis



To add text to a shape
To add text to a line 
To fit a shape to text
To choose text styles using the Format menu 
To apply color to existing text



Using Text in Shapes
{button Tell me how . . .,PI(`',`IDH_HT_Using_Text_in_Shapes')}

The greatest difficulty in using text in shapes is getting it to fit. There are several solutions.
Does all the text need to be seen at all times? The Notes feature is designed specifically for 

this need. You can attach a note to any shape.
Is the text providing an additional level of detail? The Link feature lets you attach another chart

to a shape. Double-clicking on the shape opens the more detailed chart, which can contain text, 
shapes, and data.

Does the text need to be inside the shape? The Text feature makes it easy to create text blocks
anywhere on the chart. Or, you can move the text outside the shape using the Shape Properties option
from the Format menu.

Are the shape and its text area large enough? The Fit to Text feature automatically resizes the 
shape to accommodate all of the text.

Are the letters too wide? There are fonts designed to solve this problem. They often have 
"condensed" or "narrow" in their names. Several are included in the ABC Font Collection.

{button Related Topics,PI(`',`IDH_RT_Using_Text_in_Shapes')}



To add text to a shape
To fit a shape to text
To choose text styles using the Format menu 
To apply color to existing text
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Using Text for Emphasis
{button Tell me how . . .,PI(`',`IDH_HT_Using_Text_for_Emphasis')}

You can display (emphasize) titles, headings, and text in several ways. It is more effective to use 
different sizes, weights, and styles of a single font than it is to use a variety of fonts.

Use a larger font size. If most of the text in your chart is 10 points, using 12 points or larger for 
titles and headings will both call attention to them and differentiate them from text used for other 
purposes.

Use bold style. This is the basic, most effective way of emphasizing and differentiating text.
Use italic or underline style. Italic style generally does not work well for titles and headings, but

is useful to differentiate single words within text. Underline style should be used judiciously, because it 
interferes with letters with descenders, such as the j, g, and y in jaggedy.

Use a different typeface. Generally, you should use no more than two typefaces in a chart. 
Differing typefaces have different names, such as Arial and DomCasual BT.

Use a heavier font. Some fonts, which usually contain the words "heavy" or "black" in their 
names, are designed to give emphasis through boldness of stroke. Browse through the font samples in 
the ABC Font Collection. Look for a font that you think stands out but is easy to read.

Use an unusual font. Decorative and novelty fonts are sometimes good attention-getters. They 
often are more difficult to read, so reserve them for short text. For example, try Dom Casual BT 14 
point with the Transport shape from the Process Chart palette to direct the user to the opening shape 
in a chart. Add color for even more effect.

Use graphics to emphasize. You can use shapes from the palettes to create banners. The 
example below is from the Organization Chart palette.

Use color to emphasize titles or differences. For example, actions requiring authorized 
signatures might be displayed in red, while normal activities are displayed in black.

{button Related Topics,PI(`',`IDH_RT_Using_Text_for_Emphasis')}



To add text to a shape
To add text to a line 
To change the way existing text looks
To fit a shape to text
To choose text styles using the Format menu 
To color existing text



Determining the Way Text Looks
Format menu
Formatting toolbar 
Font command

Using Text in Shapes
Using Fonts and Text Effectively
Hints and Guidelines for Effective Flowcharts



Charts Can Be Interactive
{button Tell me how. . .,PI(`',`IDH_HT_Charts_Can_Be_Interactive')}

You have the capability to create an on-line chart that can serve as:
An information kiosk
A visual front-end for a database
A friendly way for sales and warehouse personnel to enter data to be used in a database or 

spreadsheet
A training tool

You can launch video images that use Microsoft Video (AVI files) or sound files.
Because you can launch any EXE file from a shape, you can use a FlowCharter chart as a user-
friendly front-end to programs ranging from in-house programs such as error-tracking systems to 
videos for training purposes.



To link an object to a chart 
To link a shape to a program



OLE Automation
{button Tell me how. . .,PI(`',`IDH_HT_OLE_Automation2')}

Why would you use OLE Automation? Here are some examples of what you can do:
Create hierarchical flowcharts and link them to hierarchical databases. The user can view 

records by clicking through the charts.
Link shapes in process charts to sensors in actual manufacturing process equipment. The 

shape changes color when sensor readings exceed normal range.
Generate an organization chart from a Human Resources database.

{button Related Topics,PI(`',`IDH_RT_OLE_Automation2')}



Object Linking and Embedding (OLE)



To link an object to a chart 



Arrange menu

Click a command below to learn more about it.
Order Changes the order of selected objects.
Layers Provides a submenu of commands that 

opens the Layer Manager, edits all 
layers, adds layers, lets you select a 
layer to move to, moves the layer back
one layer, and moves the layer forward
one layer.

Align Aligns shapes vertically and 
horizontally.

Make Same 
Size

Makes selected shapes same size.

Space 
Evenly

Spaces selected shapes evenly.

Center Centers selected objects or the entire 
chart on a page.

Group Groups the selected objects.
Ungroup Ungroups the selected group of 

objects.
Make New 
Shape

Makes the selected objects into a new 
shape.

Break Apart Breaks apart a new shape that was 
formed with the Make New Shape 
command.

Combine Connects and disconnects closed and 
open objects. Also, forms new shapes 
from different combinations of 
operations that you can do with 
shapes.

Rotate/Flip Rotates or flips the selected object.
Replace 
Shape

Replaces the selected shape(s) with 
the shape in the Shape palette.

Reverse 
Ends

Reverse the ends of the selected line.

Fit to Text Fits the object to the text.

{button Related Topics,PI(`',`IDH_RT_ARRANGEMENU')}



Order command
Layers command
Align command
Make Same Size command
Space Evenly command

Center command
Group command
Combine command
Rotate/Flip command

Reverse Ends command
Replace Shape command
Fit to Text command 



Order command
The Order command moves objects and layers in your chart. You can send objects to the back, bring
objects to the front, send an object one level backward, or bring an object one level forward.

Tip
You can also use the buttons on the Arrange toolbar to specify the ordering.

{button Related Topics,PI(`',`IDH_RT_Order_command')}



To bring an object to the front
To send an object to the back

Bring to Front command
Send to Back command
Bring Forward command
Send Backward command

Arrange toolbar
Arrange menu



Moves objects in your chart. You can send objects to the back, bring objects to the front, send 
objects backward one level at a time, orbring layers forward one level at a time.



Bring to Front command
{button OLE Automation,PI(`',`IDH_OA_Bring_to_Front_command')}
The Bring to Front command on the submenu for the Order command on the Arrange menu to move 
the selected object or objects in front of other objects in the chart.

Tip
You can also use the Bring to Front button on the Arrange toolbar.

Bring to Front button

{button Related Topics,PI(`',`IDH_RT_Bring_to_Front_Command')}



Arrange menu
Send to Back command
Bring to Front button
To bring an object to the front



Moves the selected object or objects in front of other objects in the chart.



ToFront Method



Send to Back command
{button OLE Automation,PI(`',`IDH_OA_Send_to_Back_command')}

The Send to Back command on the submenu for the Order command moves the selected object or 
objects behind other objects in the chart.

Tip
You can also use the Send to Back button on the Arrange toolbar.

Send to Back button

{button Related Topics,PI(`',`IDH_RT_Bring_to_Front_Command')}



Arrange menu
Order command
Bring to Front command
Send to Back button
To send an object to the back



Moves the selected object or objects behind other objects in the chart.



ToBack Method



Send Backward command
The Send Backward command moves the currently selected object one level toward the back. 

Tip
You can also use the Send Backward button on the Arrange toolbar.

Send Backward button

{button Related Topics,PI(`',`IDH_RT_Send_Backward_command')}



Arrange menu
Order command
Send to Back button
To send an object to the back



Moves the currently selected object one level toward the back. 



Bring Forward command
The Bring Forward command moves the currently selected object one level toward the front. 

Tip
You can also use the Bring Forward button on the Arrange toolbar.

Bring Forward button

{button Related Topics,PI(`',`IDH_RT_Bring_Forward_command')}



Arrange menu
Order command
Bring to Front command



Moves the currently selected object one level toward the front. 



Layers command
The Layers command provides a submenu of commands that:

Opens the Layer Manager
Edits all layers
Adds layers
Select a layer to move to objects to
Moves the layer back one layer
Moves the layer forward one layer

Tip
You also can perform the Layers commands using the following buttons on the Arrange+ 

toolbar.

Layer 
Manager 
button

Edit All 
Layers 
button

Add Layer 
button

Move To 
Layer button

Move Back 
One Layer 
button

Move 
Forward One 
Layer button

{button Related Topics,PI(`',`IDH_RT_Layers_command')}



Layer Manger command 
Edit All Layers command 
Add Layer command 
Move To Layer command 

Move Back One Layer command 
Move Forward One Layer command 
Arrange menu 
Arrange+ toolbar 



Provides a submenu of commands that:
Opens the Layer Manager
Edits all layers
Adds layers
Selects the layer to move objects to
Moves the layer back one layer
Moves the layer forward one layer



Layer Manger command
The Layer Manager command opens the Layer Manager that lists the layers defined for the active 
chart and lets you perform layer operations. In Layer Manger, you can change the visible, print, and 
lock properties of layers. Also, Layer Manager lets you select the current layer; add, delete, and 
rename layers; change the order of layers; and specify whether you want to change the current or 
all layers.

Tip
You can also use the Layer Manager button on the Arrange+ toolbar.

Layer Manager button
To display a shortcut menu that opens the Layer Manager click a layer tab with the right mouse

button.

{button Related Topics,PI(`',`IDH_RT_Layer_Manager_command')}



Layers command 
Edit All Layers command 
Add Layer command 
Move To Layer command 

Move Back One Layer command 
Move Forward One Layer command 
Arrange menu 
Arrange+ toolbar 



Opens the Layer Manager that lists the layers defined for the active chart and lets you perform layer
operations.



Edit All Layers command
The Edit All Layers command is used to select, move, and change all objects in the active chart, 
regardless of the layer on which they are located. When changing all layers, you cannot move an 
object on a lower layer in front of an object on a higher layer.

Note
New objects are always placed on the current layer, even when you are changing all layers.

Tips
To switch back to changing just the current layer, clear Edit All Layers.
You also can use the Edit All Layers button on the Arrange+ toolbar.

Edit All Layers button
To display a shortcut menu that lets you edit all layers, click a layer tab with the right mouse 

button.

{button Related Topics,PI(`',`IDH_RT_Edit_All_Layers_command')}



Layers command 
Layer Manger command 
Add Layer command 
Move To Layer command 

Move Back One Layer command 
Move Forward One Layer command 
Arrange menu 
Arrange+ toolbar 



Selects, moves, and changes all objects in the active chart, regardless of the layer on which they are
located.



Add Layer command
The Add Layer command adds a layer to the active chart.

Tip
You can also use the Add Layer button on the Arrange+ toolbar.

Add Layer button
To display a shortcut menu that lets you add layers, click a layer tab with the right mouse 

button.

{button Related Topics,PI(`',`IDH_RT_Add_Layer_command')}



Layers command 
Layer Manger command 
Edit All Layers command 
Move To Layer command 

Move Back One Layer command 
Move Forward One Layer command 
Arrange menu 
Arrange+ toolbar 



Adds a layer to the active chart.



Move To Layer command
The Move To Layer command moves the selected objects to another layer.

Tip
You can also use the Move To Layer button on the Arrange+ toolbar.

Move To Layer button
To display a shortcut menu that lets you move to a layer, click a layer tab with the right mouse 

button.

{button Related Topics,PI(`',`IDH_RT_Move_to_Layer_command')}



Layers command 
Layer Manger command 
Edit All Layers command 
Add Layer command

Move Back One Layer command 
Move Forward One Layer command 
Arrange menu 
Arrange+ toolbar 



Moves the selected object(s) to another layer.



Move To Layer dialog box

The Move To Layer dialog box displays a list of the layers associated with the current chart that you 
can move your selected object(s) to. You also have the option of making the layer you select the 
current layer.

{button Related Topics,PI(`',`IDH_RT_Move_To_Layer_DB')}



Layers command 
Move To Layer command 
Arrange menu 
Arrange+ toolbar 



Lists the layers for your chart. Highlight the one you want to move the selected object(s) to;



Makes the layer you move the selected object(s) to the current layer.



Move Back One Layer command
The Move Back One Layer command moves the active layer back one layer.

Tip
You can also use the Move Back One Layer button on the Arrange+ toolbar.

Move Back One Layer button

{button Related Topics,PI(`',`IDH_RT_Move_Back_One_Layer_command')}



Layers command 
Layer Manger command 
Edit All Layers command 
Add Layer command 

Move To Layer command 
Move Forward One Layer command 
Arrange menu 
Arrange+ toolbar 



Moves the active layer back one layer.



Move Forward One Layer command
The Move Forward One Layer command moves the active layer forward one layer.

Tip
You can also use the Move Forward One Layer button on the Arrange+ toolbar.

Move Forward One Layer button
To display a shortcut menu that lets you edit all layers, click a layer tab with the right mouse 

button.

{button Related Topics,PI(`',`IDH_RT_Move_Forward_One_Layer_command')}



Layers command 
Layer Manger command 
Edit All Layers command 
Add Layer command 

Move To Layer command 
Move Back One Layer command 
Arrange menu 
Arrange+ toolbar 



Moves the active layer forward one layer.



Align command
The Align command on the Arrange menu aligns the selected shapes horizontally based on their left 
edges, right edges, or centers, or vertically based on their top edges, bottom edges, or middles. 
When you click this command, a submenu opens to allow you to make your choice.

Tip
You can also use the Align Left, Align Right, Align Center, Align Top, Align Bottom, or Align 

Middle buttons on the Arrange toolbar.

Align Left 
button

Align Right 
button

Align Center 
button

Align Top 
button

Align Bottom 
button

Align Middle 
button

{button Related Topics,PI(`',`IDH_RT_Align_Command')}



Align, Left command 
Align, Center command
Align, Right command 
Align, Page Center command 

Align, Top command 
Align, Middle command 
Align, Bottom command 
Align, Page Middle command 

Arrange menu
Arrange toolbar 
Align buttons
To align objects



Aligns the selected shapes horizontally based on their left edges, right edges, or centers, or 
vertically based on their top edges, bottom edges, or middles. Opens a submenu to allow you to 
make your choice.



Align, Left command
The Align, Left command aligns the selected object or objects vertically based on their left edges.

Tip
You can also use the Align, Left button on the Arrange toolbar.

Align, Left button

{button Related Topics,PI(`',`IDH_RT_Align_Left_command')}



Align command 
Align, Center command 
Align, Right command 
Align, Page Center command 

Align, Top command 
Align, Middle command 
Align, Bottom command 
Align, Page Middle command 

Align command 
Arrange menu
Arrange toolbar 
To align objects



Aligna the selected object or objects vertically based on their left edges.



Align, Center command
The Align, Center command aligns the selected object or objects vertically based on their centers.

Tip
You can also use the Align Center button on the Arrange toolbar.

Align Center button

{button Related Topics,PI(`',`IDH_RT_Align_Center_command')}



Align command 
Align, Left command 
Align, Right command 
Align, Page Center command 

Align, Top command 
Align, Middle command 
Align, Bottom command 
Align, Page Middle command 

Arrange menu
Arrange toolbar 
Align buttons
To align objects



Align the selected object or objects vertically based on their centers.



Align, Right command
The Align, Right command aligns the selected object or objects vertically based on their right edges.

Tip
You can also use the Align Right button on the Arrange toolbar.

Align, Right button

{button Related Topics,PI(`',`IDH_RT_Align_Right_command')}



Align command 
Align, Left command 
Align, Center command 
Align, Page Center command 

Align, Top command 
Align, Middle command 
Align, Bottom command 
Align, Page Middle command 

Arrange menu
Arrange toolbar 
Align buttons
To align objects



Aligns the selected object or objects vertically based on their right edges.



Align, Page Center command
The Align, Page Center command centers the selected object or objects on the page while keeping 
its current left or right alignment. 

{button Related Topics,PI(`',`IDH_RT_Align_PageCenter_command')}



Align command 
Align, Left command 
Align, Center command 
Align, Right command 

Align, Top command 
Align, Middle command 
Align, Bottom command 
Align, Page Middle command 

Arrange menu
Arrange toolbar 
Align buttons
To align objects



Centers the selected object or objects on the page while keeping its current left or right alignment



Align, Top command
The Align, Top command aligns the selected object or objects horizontally based on their top edges.

Tip
You can also use the Align Top button on the Arrange toolbar.

Align, Top button

{button Related Topics,PI(`',`IDH_RT_Align_Top_command')}



Align command 
Align, Left command 
Align, Center command 
Align, Right command 
Align, Page Center command 

Align, Middle command 
Align, Bottom command 
Align, Page Middle command 
Arrange menu

Arrange toolbar 
Align buttons
To align objects



Aligns the selected object or objects horizontally based on their top edges.



Align, Middle command
The Align, Middle command aligns the selected object or objects horizontally based on their centers.

Tip
You can also use the Align Middle button on the Arrange toolbar.

Align, Middle button

{button Related Topics,PI(`',`IDH_RT_Align_Middle_command')}



Align command 
Align, Left command 
Align, Center command 
Align, Right command 
Align, Page Center command 

Align, Top command 
Align, Bottom command 
Align, Page Middle command 
Arrange menu

Arrange toolbar 
Align buttons
To align objects



Aligns the selected object or objects horizontally based on their centers.



Align, Bottom command
The Align, Bottom command aligns the selected object or objects horizontally based on their bottom
edges.

Tip
You can also use the Align Bottom button on the Arrange toolbar.

Align, Bottom button

{button Related Topics,PI(`',`IDH_RT_Align_Bottom_command')}



Align command 
Align, Left command 
Align, Center command 
Align, Right command 
Align, Page Center command 

Align, Top command 
Align, Middle command 
Align, Page Middle command 
Arrange menu

Arrange toolbar 
Align buttons
To align objects



Aligns the selected object or objects horizontally based on their bottom edges.



Align, Page Middle command
The Align, Page Middle command aligns the selected object(s) in the middle of the page while 
keeping its current top or bottom alignment. 

{button Related Topics,PI(`',`IDH_RT_Align_PageMiddle_command')}



Align command 
Align, Left command 
Align, Center command 
Align, Right command 
Align, Page Center command 

Align, Top command 
Align, Middle command 
Align, Bottom command 
Arrange menu

Arrange toolbar 
Align buttons
To align objects



Aligns the selected object(s) in the middle of the page while keeping its current top or bottom 
alignment



Make Same Size command
The Make Same Size command on the Arrange menu makes the selected shapes the same size 
based on their width, their height, height and width, or fit to text. 
When you click this command, a submenu opens to allow you to make your choice.

Tip
The Make Same Size command defaults the scaling to the largest object selected.
You can also use the Make Same Size Width, Make Same Size Height, Make Same Size Both 

buttons, and Make Same Size Fit to Text on the Arrange toolbar.

Make Same Size 
Width button

Make Same Size 
Height button

Make Same Size 
Both button

Make Same Size 
Fit to Text button

{button Related Topics,PI(`',`IDH_RT_Make_Same_Size_Command')}



Make Same Size, Width command 
Make Same Size, Height command 
Make Same Size, Both command 
Make Same Size, Fit To Text command 

Make Same Size buttons
To make objects the same size
Arrange menu



Makes the selected shapes the same size based on their width, their height, both, or fit to text. 
Opens a submenu to allow you to make your choice.



Make Same Size, Width command
The Make Same Size, Width command makes the selected object(s) the same size based on their 
width.

Tip
The Make Same Size, Wdith command defaults the scaling to the largest object selected.
You can also use the Make Same Size, Width button on the Arrange toolbar.

Make Same Size, Width button

{button Related Topics,PI(`',`IDH_RT_Make_SameSizeWidth_Command')}



Make Same Size command 
Make Same Size, Height command 
Make Same Size, Both command 
Make Same Size, Fit To Text command 

To make objects the same size
Arrange menu



Makes the selected shapes the same size based on their width, their height, both, or fit to text. 



Make Same Size, Height command
The Make Same Size, Height command makes the selected object(s) the same size based on their 
height.

Tip
The Make Same Size, Height command defaults the scaling to the largest object selected.
You can also use the Make Same Size, Height button on the Arrange toolbar.

Make Same Size, Height button

{button Related Topics,PI(`',`IDH_RT_Make_SameSizeHeight_Command')}



Make Same Size command 
Make Same Size, Width command 
Make Same Size, Both command 
Make Same Size, Fit To Text command 

To make objects the same size
Arrange menu



Makes the selected shapes the same size based on their width, their height, both, or fit to text. 



Make Same Size, Both command
The Make Same Size, Both command makes the selected object or objects the same size based on 
their width and height.

Tip
The Make Same Size, Both command defaults the scaling to the largest object selected.
You can also use the Make Same Size, Both button on the Arrange toolbar.

Make Same Size, Both button

{button Related Topics,PI(`',`IDH_RT_Make_SameSizeBoth_Command')}



Make Same Size command 
Make Same Size, Width command 
Make Same Size, Height command 
Make Same Size, Fit To Text command 

To make objects the same size
Arrange menu



Makes the selected object(s) the same size based on their width and height.



Make Same Size, Fit To Text command
The Make Same Size, Fit To Text command makes the selected object or objects the same size based
on their text.

Tip
The Make Same Size, Fit To Text command defaults the scaling to the largest object selected.
You can also use the Make Same Size, Fit To Text button on the Arrange toolbar.

Make Same Size, Fit To Text button

{button Related Topics,PI(`',`IDH_RT_Make_SameSizeFittoText_Command')}



Make Same Size command 
Make Same Size, Width command 
Make Same Size, Height command 
Make Same Size, Both command 

To make objects the same size
Arrange menu



Makes the selected object(s) the same size based on their text.



Space Evenly command
The Space Evenly command on the Arrange menu spaces the selected shapes evenly across or 
down based on their edges or centers. 
When you click this command, a submenu opens to allow you to make your choice.

Tip
You can also use the Space Evenly Across Centers, Space Evenly Down Centers, Space Evenly 

Across Edges, and Space Evenly Down Edges buttons on the Arrange toolbar.

Space 
Evenly 
Across 
Centers 
button

Space 
Evenly 
Down 
Centers 
button

Space 
Evenly 
Across 
Edges 
button

Space 
Evenly 
Down 
Edges 
button

{button Related Topics,PI(`',`IDH_RT_Space_Evenly_Command')}



Space Evenly, Across Centers command 
Space Evenly, Down Centers command 
Space Evenly, Across Edges command 
Space Evenly, Down Edges command 

Arrange menu
Space Evenly buttons
To space objects evenly



Spaces the selected shapes evenly across or down based on their edges or centers. Opens a 
submenu to allow you to make your choice.



Space Evenly, Across Centers command
The Space Evenly, Across Centers command spaces the selected object or objects evenly based on 
their centers.

Tip
You can also use the Space Evenly, Across Centers button on the Arrange toolbar.

Space Evenly, Across Centers button

{button Related Topics,PI(`',`IDH_RT_Space_Evenly_Across_Centers_command')}



Space Evenly command 
Space Evenly, Down Centers command 
Space Evenly, Across Edges command 
Space Evenly, Down Edges command 

Arrange menu
Space Evenly buttons
To space objects evenly



Spaces the selected object or objects evenly based on their centers.



Space Evenly, Down Centers command
The Space Evenly, Down Centers command spaces the selected object or objects evenly based on 
their centers.

Tip
You can also use the Space Evenly, Down Centers button on the Arrange toolbar.

Space Evenly, Down Centers button

{button Related Topics,PI(`',`IDH_RT_Space_Evenly_Down_Centers_command')}



Space Evenly command 
Space Evenly, Across Centers command 
Space Evenly, Across Edges command 
Space Evenly, Down Edges command 

Arrange menu
Space Evenly buttons
To space objects evenly



Spaces the selected object or objects evenly based on their centers.



Space Evenly, Across Edges command
The Space Evenly, Across Edges command spaces the selected object or objects evenly based on 
their edges.

Tip
You can also use the Space Evenly, Across Edges button on the Arrange toolbar.

Space Evenly, Across Edges button

{button Related Topics,PI(`',`IDH_RT_Space_Evenly_Across_Edges_command')}



Space Evenly command 
Space Evenly, Across Centers command 
Space Evenly, Down Centers command 
Space Evenly, Down Edges command 

Arrange menu
Space Evenly buttons
To space objects evenly



Spaces the selected object or objects evenly based on their edges.



Space Evenly, Down Edges command
The Space Evenly, Across Edges command spaces the selected object or objects evenly based on 
their edges.

Tip
You can also use the Space Evenly, Down Edges button on the Arrange toolbar.

Space Evenly, Down Edges button

{button Related Topics,PI(`',`IDH_RT_Space_Evenly_Down_Edges_command')}



Space Evenly command 
Space Evenly, Across Centers command 
Space Evenly, Down Centers command 
Space Evenly, Across Edges command 

Arrange menu
Space Evenly buttons
To space objects evenly



Spaces the selected object or objects evenly based on their edges.



Center command
The Center command centers objects on the current chart. Selecting the Center command opens a 
submenu letting you either center all objects on the chart or selected objects on the chart.

{button Related Topics,PI(`',`IDH_RT_Center_command')}



To center all objects on charts 
To center selected objects on charts 
Entire Chart command 
Selected Objects command 

Arrange menu 



Centers objects on the current chart. Selecting the Center command opens a submenu letting you 
either center all objects on the chart or selected objects on the chart.



Entire Chart command
The Entire Chart command centers all objects on the current chart.

{button Related Topics,PI(`',`IDH_RT_Entire_Chart_command')}



To center all objects on charts 
To center selected objects on charts 
Center command 
Selected Objects command 

Arrange menu 



Centers all objects on the current chart.



To center all objects on charts
1 On the Arrange menu, click Center.
2 Click Entire Chart.

{button Related Topics,PI(`',`IDH_RT_To_center_all_objects_on_charts')}



To center selected objects on charts 
Center command 
Entire Chart command 
Selected Objects command 
Arrange menu



Selected Objects command
The Selected Objects command centers selected objects on the chart.

{button Related Topics,PI(`',`IDH_RT_Selected_Objects_command')}



To center all objects on charts 
To center selected objects on charts 
Center command 
Entire Chart command 
Arrange menu 



Centers selected objects on the chart.



To center selected objects on charts
1 On the Toolbox, click the Selector tool.

Selector tool
2 Select the objects you want to center.
3 On the Arrange menu, click Center.
4 Click Selected Objects.

{button Related Topics,PI(`',`IDH_RT_To_center_selected_objects_on_charts')}



To center all objects on charts 
Center command 
Entire Chart command 
Selected Objects command 
Arrange menu 



Group command
The Group command groups the selected objects into a single object.

You can also use the Group button on the Arrange toolbar.

Group button

{button Related Topics,PI(`',`IDH_RT_Group_command')}



To group objects 
To ungroup objects 
Ungroup command 
Arrange menu 



To group objects
1 On the Toolbox, click the Selector tool.

Selector tool
2 Select the objects you want to group.
3 On the Arrange menu, click Group.

{button Related Topics,PI(`',`IDH_RT_To_group_objects')}



To ungroup objects 
Group command 
Ungroup command 
Arrange menu 



Groups the selected objects.



Ungroup command
The Ungroup command ungroups previously grouped objects.

You can also use the Ungroup button on the Arrange toolbar.

Ungroup button

{button Related Topics,PI(`',`IDH_RT_Ungroup_command')}



To group objects 
To ungroup objects 
Group command 
Arrange menu 



To ungroup objects
1 On the Toolbox, click the Selector tool.

Selector tool
2 Select the object you want to ungroup.
3 On the Arrange menu, click Ungroup.

{button Related Topics,PI(`',`IDH_RT_To_ungroup_objects')}



To group objects 
Group command 
Ungroup command 
Arrange menu 



Ungroups previously grouped objects.



Make New Shape command
The Make New Shape command creates a new shape from the selected objects.

Tip
You can use the Break Apart command to separate the shape back into its original individual 

objects.

{button Related Topics,PI(`',`IDH_RT_Make_New_Shape_command')}



To make a new shape 
Break Apart command 
Arrange menu 



Creates a new shape from the selected objects.



To make a new shape
1 On the Toolbox, click the Selector tool.

Selector tool
2 Select each object that you want to be part of the shape.
3 On the Arrange menu, click Make New Shape.
Tip

You can add the new shape to a Shape palette.

{button Related Topics,PI(`',`IDH_RT_To_make_a_new_shape')}



Make New Shape command 
To break apart a shape 
To add a drawn object to a Shape palette 
Arrange menu 



Break Apart command
The Break Apart command breaks apart a new shape that was formed with the Make New Shape 
command.

{button Related Topics,PI(`',`IDH_RT_BreakApart_command')}



To break apart a shape 
Make New Shape command 
Arrange menu 



Breaks apart a new shape that was formed with the Make New Shape command.



To break apart a shape
1 On the Toolbox, click the Selector tool.

Selector tool
2 Select the object that you want to break apart into their individual shapes.
3 On the Arrange menu, click Break Apart.
Note

You can break apart only those shapes that were created using the Make New Shape 
command.

{button Related Topics,PI(`',`IDH_RT_To_break_apart_a_shape')}



To make a new shape 
Break Apart command 
Make New Shape command 
Arrange menu 



Combine command
The Combine command opens a submenu of commands that perform the following tasks:

Connect the selected, closed objects
Connect the selected open objects and close them
Disconnect the selected, connected objects
Create a new shape by joining the selected objects together
Create a new shape from the outline of the selected shapes
Create a new shape by trimming the bottom shape with the top one
Create a new shape from the intersection of the selected objects
Createa series of new shapes by fragmenting the selected, overlapping shapes
Create a new shape by punching the bottom shape with the top one
Slice the selected, closed shape with the selected open shape 

Tip
All of the Combine submenu commands can be accessed from the following related buttons on 

the Arrange+ toolbar:

Connec
t 
Closed 
button

Connec
t Open 
button

Discon
nect 
button

Join 
button

Outline
button

Trim 
button

Punch 
button

Interse
ct 
button

Fragme
nt 
button

Slice 
button

{button Related Topics,PI(`',`IDH_RT_Combine_command')}



Connect Closed command 
Connect Open command 
Disconnect command 
Join command 

Outline command 
Trim command 
Intersect command 
Fragment command 

Punch command 
Slice command 
Arrange menu 



Connects and disconnects closed and open objects. Also, forms new shapes from different 
combinations of operations that you can do with shapes.



Connect Closed command
The Connect Closed command connects the selected, closed objects.

Tip
You can also use the Connect Closed button on the Arrange+ toolbar.

Connect Closed button

{button Related Topics,PI(`',`IDH_RT_Combine_Connect_Closed_command')}



To connect closed objects 
Combine command 
Arrange menu 



Connects the selected, closed objects.



Connect Open command
The Connect Open command connects the objects and closes them.

Tip
You can also use the Connect Open button on the Arrange+ toolbar.

Connect Open button

{button Related Topics,PI(`',`IDH_RT_Combine_Connect_Open_command')}



To connect open objects 
Combine command 
Arrange menu 



Connects the objects and closes them.



Disconnect command
The Disconnect command disconnects the selected connected object.

Tip
You can also use the Disconnect button on the Arrange+ toolbar.

Disconnect button

{button Related Topics,PI(`',`IDH_RT_Combine_Disconnect_command')}



To disconnect objects 
Combine command 
Arrange menu 



Disconnects the selected connected object.



Join command
The Join command creates a new shape by joining the selected objects together.

Tip
You can also use the Join button on the Arrange+ toolbar.

Join button

{button Related Topics,PI(`',`IDH_RT_Combine_Join_command')}



To join objects 
Combine command 
Arrange menu 



Creates a new shape by joining the selected objects together.



Outline command
The Outline command creates a new shape from the outline of the selected shapes.

Tip
You can also use the Outline button on the Arrange+ toolbar.

Outline button

{button Related Topics,PI(`',`IDH_RT_Combine_Outline_command')}



To outline objects 
Combine command 
Arrange menu 



Creates a new shape from the outline of the selected shapes.



Trim command
The Trim command creates a new shape by trimming the bottom shape with the top one.

Tip
You can also use the Trim button on the Arrange+ toolbar.

Trim button

{button Related Topics,PI(`',`IDH_RT_Combine_Trim_command')}



To trim objects 
Combine command 
Arrange menu 



Creates a new shape by trimming the bottom shape with the top one.



Intersect command
The Intersect command creates new shape from the intersection of the selected objects.

Tip
You can also use the Intersect button on the Arrange+ toolbar.

Intersect button

{button Related Topics,PI(`',`IDH_RT_Combine_Intersect_command')}



To intersect objects 
Combine command 
Arrange menu 



Creates new shape from the intersection of the selected objects.



Fragment command
The Fragment command creates a series of new shapes by fragmenting the selected, overlapping 
shapes. The Fragment command makes new shapes out of the overlapping areas and trims the 
remaining areas into new shapes as well.

Tip
You can also use the Fragment button on the Arrange+ toolbar.

Fragment button

{button Related Topics,PI(`',`IDH_RT_Combine_Fragment_command')}



To fragment objects 
Combining Objects 
Combine command 
Arrange menu 



Createa series of new shapes by fragmenting the selected, overlapping shapes



Punch command
The Punch command creates a new shape by punching the bottom shape with the top one.

Tip
You can also use the Punch button on the Arrange+ toolbar.

Punch button

{button Related Topics,PI(`',`IDH_RT_Combine_Punch_command')}



To punch objects 
Combine command 
Arrange menu 



Creates a new shape by punching the bottom shape with the top one.



Slice command
Slicing an object slices the selected, closed shape with the selected open shape. Slicing opens a 
closed object and creates two endpoints where the slice occurs.

Tip
The Slice command is not available when you have only a single, closed object selected.
You can also use the Slice button on the Arrange+ toolbar.

Slice button

{button Related Topics,PI(`',`IDH_RT_Combine_Slice_command')}



To slice objects 
Combine command 
Arrange menu 



Slices the selected closed shape with the selected open shape.



Rotate/Flip command
With this commands, you can rotate or flip selected objects using the submenu that opens.

Tip
You can also use the following Rotate/Flip buttons on the Arrange toolbar.

Rotate 
Right 
button

Rotate Left
button

Flip 
Horizontal 
button
Flip 
Vertical 
button

{button Related Topics,PI(`',`IDH_RT_RotateFlip_command')}



To rotate an object
Rotate Right command 
Rotate Left command 
Angle command

Flip Horizontal command
Flip Vertical command 
Arrange menu 



Rotates or flips selected objects using the submenu that opens.



Rotate Right command
The Rotate Right command on the Arrange menu rotates the selected object or objects 90 degrees 
to the right.

Tip
You can also use the Rotate Right button on the Arrange toolbar.

Rotate Right button

{button Related Topics,PI(`',`IDH_RT_Rotate_Right_Command')}



To rotate an object
Rotate/Flip command 
Rotate Left command 
Angle command

Flip Horizontal command 
Flip Vertical command 
Arrange menu 



Rotates the selected object or objects 90 degrees to the right.



Rotate Left command
The Rotate Left command on the Arrange menu rotates the selected object or objects 90 degrees to 
the left.

Tip
You can also use the Rotate Left button on the Arrange toolbar.

Rotate Left button

{button Related Topics,PI(`',`IDH_RT_Rotate_Left_Command')}



To rotate an object
Rotate/Flip command 
Rotate Right command 
Angle command

Flip Horizontal command 
Flip Vertical command 
Arrange menu 



Rotates the selected object or objects 90 degrees to the left.



Angle command
The Angle command selects the angle and direction for the object you want to rotate.

{button Related Topics,PI(`',`IDH_RT_Angle_command')}



To select the angle and direction for rotating an object
To rotate an object
Rotate/Flip command 
Arrange menu 



Selects the angle and direction for the object you want to rotate.



To select the angle and direction for rotating an object
1 On the Arrange menu, click Rotate/Flip.
2 Click Angle.
3 Type the angle you want to rotate your angle by.
4 Select either clockwise or counter-clockwise for the direction of the angle to rotate.
5 Click Close.

{button Related Topics,PI(`',`IDH_RT_To_select_angledirection_for_rotating_object')}



To rotate an object
Rotate/Flip command 
Angle command
Arrange menu 



Rotate by Angle dialog box
The Rotate by Angle dialog box allows you to enter the angle for rotating the selected object. You 
can also select the direction of rotation, counter-clockwise or clockwise. 



Enters the angle you want to rotate your object by.



Selects clockwise for the angle of rotation.



Selects counter-clockwise for the angle of rotation.



Flip Horizontal command
The Flip Horizontal command on the Arrange menu flips the selected object or objects horizontally.

Tip
You can also use the Flip Horizontal button on the Arrange toolbar.

Flip Horizontal button

{button Related Topics,PI(`',`IDH_RT_Flip_Horizontal_Command')}



To rotate an object
Rotate/Flip command 
Rotate Right command 
Rotate Left command 

Angle command
Flip Vertical command 
Arrange menu 



Flip Horizontal flips the selected object or objects horizontally.



Flip Vertical command
The Flip Vertical command on the Arrange menu flips the selected object or objects vertically.

Tip
You can also use the Flip Vertical button on the Arrange toolbar.

Flip Vertical button

{button Related Topics,PI(`',`IDH_RT_Flip_Vertical_Command')}



To rotate an object
Rotate/Flip command 
Rotate Right command 
Rotate Left command 

Angle command
Flip Horizontal command
Arrange menu 



Flips the selected object or objects vertically.



Replace Shape command
The Replace Shape command the selected shape(s) with the shape in the Shape palette.

Tip
You can also use the Replace Shape button on the Arrange toolbar.

Replace Shape button

{button Related Topics,PI(`',`IDH_RT_Replace_Shape_command')}



To replace shapes
Arrange menu 
Arrange toolbar 



Replaces the selected shape(s) with the shape in the Shape palette.



Reverse Ends command
The Reverse Ends command reverses the ends of the selected line. This can change the direction of 
the flow for that line.

Tip
You can also use the Reverse Ends button on the Arrange toolbar.

Reverse Ends button

{button Related Topics,PI(`',`IDH_RT_Reverse_Ends_command')}



Arrange menu 
Arrange toolbar 



Reverses the ends of the selected line.



Fit to Text command
The Fit To Text command on the Arrange menu resizes the selected object or objects based on their 
text.

Tip
You can also use the Fit To Text button on the Arrange toolbar.

Fit To Text button

{button Related Topics,PI(`',`IDH_RT_Fit_To_Text_Command')}



To fit a shape to text 
Arrange menu 
Arrange toolbar 



Resizes the selected object or objects based on their text.



Drawing Basics
{button Tell me how . . .,PI(`',`IDH_HT_Drawing_Basics')}

An object is the basic element of a drawing. Before drawing an object, you must choose the type of 
object. An object can be a shape or a line, or a group of shapes and lines.
To choose an object to draw, click the Draw tool to choose an object.

Draw tool
After you choose an object with the Draw tool, the pointer changes to a cross-pointer. The pointer 
also shows a small icon of the shape you chose. The name of the shape is shown on the status bar. 
While the pointer is displayed, you can draw as many objects of the shape as you want.
To switch from the Draw pointer to the Selector tool, do one of the following:

Click the Selector tool on the Toolbox toolbar.

Selector tool
{bmc bullet.bmp Click a shape on the Shape palette.

Click the Finished button.
Click the right mouse button, and click the Switch Tool command.

{button Related Topics,PI(`',`IDH_RT_Drawing_Basics')}



To draw a jointed line
To draw a curved line 
To draw a square 
To draw a rectangle

To draw a polygon 
To draw a circle 
To draw a square with rounded corners 
To draw an irregular polygon 

To draw an irregular polygon with smoothed corners 
To draw an ellipse 



Working with Objects
Snapping to the Grid
Drawing Lines 
Determing the Way Lines Look
Drawing Shapes



To cancel a drawing action
To cancel a drawing action before it is complete, press ESC.

{button Related Topics,PI(`',`IDH_RT_To_cancel_a_drawing_action')}



Drawing Basics
Snapping to the Grid



Snapping to the Grid
{button Tell me how...,PI(`',`IDH_HT_Snapping_to_the_Grid')}

The Snap to Grid feature causes objects to snap to the nearest grid unit when you perform actions 
such as drawing or moving. Snap to Grid makes it easy to position and align objects. You can turn 
the Snap to Grid on and off by clicking the Tools menu, Options, and then the Snap to Grid check 
box.

Tip
You can turn the grid on and off with the Grid command (Ctrl+G) or click the View menu, and 

then Grid.

{button Related Topics,PI(`',`IDH_RT_Snapping_to_the_Grid')}



To automatically snap to grids



Drawing Basics



Drawing Lines
{button Tell me how...,PI(`',`IDH_HT_Drawing_Lines')}

The Draw tool on the Toolbox toolbar lets you draw the following types of lines.
Tool Line Type Action

Jointed Line Draws shapes 
made of 
connected line 
segments.

Curved Line Draws shapes 
made of curved 
lines.

Notes
After you draw a curved line or jointed line, the drawing is a shape.
To change the attributes of a Curved Line or Jointed Line shape, use the Format menu options 

for shapes, not lines.

{button Related Topics,PI(`',`IDH_RT_Drawing_Lines')}



To draw a jointed line
To draw a curved line



Drawing Basics
Snapping to theGrid
Drawing Connector Lines
Drawn Lines vs Connector Lines
Drawing Shapes



To draw a jointed line
1 Click the Draw tool, and click Jointed Line.

Draw tool
2 Point where you want to begin the jointed line segment.
3 Click and drag to draw a segment of the jointed line.
4 Release the mouse button.
5 Repeat steps 3 and 4 to add more jointed line segments.
6 Click Finished, or press Esc when you finish.

Notes
After you draw a jointed line, the line acts like a shape. It cannot be connected with other 

shapes like a connector line can. To connect lines to shapes, use Connector Lines tool.
To change the attributes of a jointed line shape, use the Format menu options for shapes, not 

lines.
Jointed lines are open unless the last point is the same as the first; then the object 

automatically closes.

{button Related Topics,PI(`',`IDH_RT_To_draw_a_jointed_line')}



Drawing Lines
Drawing Basics
Drawing Connector Lines
Drawn Lines vs Connector Lines
Drawing Shapes



To draw a curved line
1 Click the Draw tool, and click Curved Line.

Draw tool
2 Point where you want to begin the curved line segment.
3 Click and drag to draw a segment of the curved line.
4 Release the mouse button.
5 Repeat steps 3 and 4 to add more curved line segments.
6 Click Finished, or press Esc when you finish.

Notes
After you draw a curved line, the drawing is a shape.
To change the attributes of a Curved Line shape, use the Format menu options for shapes, not 

lines.

{button Related Topics,PI(`',`IDH_RT_To_draw_a_curvedline')}



Drawing Lines
Drawing Basics
Drawing Connector Lines
Drawn Lines vs Connector Lines

Drawing Shapes



Drawn Lines vs Connector Lines
{button Tell me

how . . .,PI(`',`IDH_HT_Drawn_Lines_VS_Connector_Lines')}

You should use Connector Lines when you want a line to remain connected to an object even if you 
move the object. Charts and diagrams are drawings where Connector Lines are useful. Connector 
Lines, however, can only touch an object at connector points.
If you want to draw lines that touch objects at precise locations, you should use Lines rather than 
Connector Lines. Lines do not remain connected when an object is moved, but you can place the 
line on the object at any position.

{button Related Topics,PI(`',`IDH_RT_Lines_vs_Connector_Lines')}



To draw a curved line 
To draw a jointed line 
To draw a connector cause and effect line 
To draw a connector curved line 

To draw a connector direct line 
To draw a connector org chart line 
To draw a connector right angle line 
To draw an unconnected line 



Drawing Lines
Drawing Basics
Drawing Connector Lines
Drawing Shapes



Drawing Shapes
{button Tell me how...,PI(`',`IDH_HT_Drawing_Shapes')}

The Draw tool on the Toolbox lets you draw various shapes.

Draw tool
Shapes are closed objects.

Shape Action

Square Draws a square.
Rounded Square Draws a square with rounded 

corners.
Rectangle Draws a rectangle.
Rounded Rectangle Draws a rectangle with 

rounded corners.
Circle Draws a circle.
Ellipse Draws an ellipse.
Polygon Draws an irregular polygon.
Smoothed Polygon Draws an irregular polygon 

with smoothed corners.

{button Related Topics,PI(`',`IDH_RT_Drawing_Shapes')}



To draw a square
To draw a rectangle
To draw a polygon
To draw a circle

To draw a square with rounded corners
To draw an irregular polygon
To draw an irregular polygon with smoothed corners
To draw an ellipse



Snapping to the Grid
Drawing Lines
Drawing Basics

Drawing Connector Lines
Drawn Lines vs Connector Lines 



To draw a rectangle
1 Click the Draw tool, and then click Rectangle.

Draw tool
2 Click where you want to begin the rectangle, and drag the pointer to the opposite corner.
3 Release the mouse button when you finish the rectangle.

{button Related Topics,PI(`',`IDH_RT_To_draw_a_rectangle')}



Drawing Shapes
Drawing Lines
Drawing Connector Lines



To draw a polygon
1 Click the Draw tool, and then click Polygon.

Draw tool
2 Point where you want to begin the polygon.
3 Click and drag to draw the first side of the polygon. Release the mouse button when you have 

the first side drawn as you want it.
4 Click again and drag the pointer where you want to place the next point. 
5 Repeat step 4 to place more points, if you want.
6 Click Finished or press ESC when you finish.

{button Related Topics,PI(`',`IDH_RT_To_draw_a_polygon')}



Drawing Shapes
Drawing Lines
Drawing Connector Lines



To draw a rectangle with rounded corners
1 Click the Draw tool, and then click Rounded Rectangle.

Draw tool
2 Click where you want to begin the rounded rectangle, and drag the pointer to the opposite 

corner.
3 Release the mouse button when you finish the rounded rectangle.

{button Related Topics,PI(`',`IDH_RT_To_draw_a_rounded_rectangle')}



Drawing Shapes
Drawing Lines
Drawing Connector Lines



To draw a square
1 Click the Draw tool, and then click Square.

Draw tool
2 Click where you want to begin the square, and drag the pointer to the opposite corner.
3 Release the mouse button when you finish the square.

{button Related Topics,PI(`',`IDH_RT_To_draw_a_square')}



Drawing Shapes
Drawing Lines
Drawing Connector Lines



To draw a square with rounded corners
1 Click the Draw tool, and then click Rounded Square.

Draw tool
2 Click where you want to begin the rounded square, and drag the pointer to the opposite corner.
3 Release the mouse button when you finish the rounded square.

{button Related Topics,PI(`',`IDH_RT_To_draw_a_square_with_rounded_corners')}



Drawing Shapes
Drawing Lines
Drawing Connector Lines



To draw an irregular polygon
1 Click the Draw tool, and then click Polygon.

Draw tool
2 Point where you want to begin the polygon.
3 Click and drag to draw the first side of the polygon. Release the mouse button when you have 

the first side drawn as you want it.
4 Click again and drag the pointer where you want to place the next point. 
5 Repeat step 4 to place more points, if you want.
6 Click the left mouse button away from the polygon or press ESC when you finish.

{button Related Topics,PI(`',`IDH_RT_To_draw_an_irregular_polygon')}



Drawing Shapes
Drawing Lines
Drawing Connector Lines



To draw an irregular polygon with smoothed corners
1 Click the Draw tool, and then click Smoothed Polygon.

Draw tool
2 Point where you want to begin the smoothed polygon.
3 Click and drag to draw the first side of the polygon. Release the mouse button when you have 

the first side drawn as you want it.
4 Click and drag the pointer where you want to place the next point. 
5 Repeat step 4 to place more points, if you want.
6 Click the left mouse button away from the polygon or press Esc when you finish.

{button Related Topics,PI(`',`IDH_RT_To_draw_an_irregular_polygon_with_smoothed_corners')}



Drawing Shapes
Drawing Lines
Drawing Connector Lines



To draw a circle
1 Click the Draw tool, and then click Circle.

Draw tool
2 Click where you want to begin the circle and drag the pointer.
3 Release the mouse button when the circle is the size you want.
4 Click Finished.

{button Related Topics,PI(`',`IDH_RT_To_draw_a_circle')}



Drawing Shapes
Drawing Lines
Drawing Connector Lines



To draw an ellipse
1 Click the Draw tool, and then click Ellipse.

Draw tool
2 Click where you want to begin the ellipse and drag the pointer.
3 Release the mouse button when the ellipse is the size you want.
4 Click Finished or press Esc when you finish.

{button Related Topics,PI(`',`IDH_RT_To_draw_an_ellipse')}



Drawing Shapes
Drawing Lines
Drawing Connector Lines



To draw a closed freehand object
1 Click the Draw tool, and then click Curved Line or Jointed Line.

Draw tool Curved 
Line

Jointed 
Line

2 Click where you want to begin the line and drag the pointer.
3 Release the mouse button when the line is the size you want.
4 Click and drag the pointer where you want to place the next point. 
5 Repeat step 4 until you have closed the object.
6 Click Finished or press Esc when you finish.

{button Related Topics,PI(`',`IDH_RT_To_draw_a_closed_freehand_object')}



Drawing Shapes
Drawing Lines
Drawing Connector Lines



To draw connected curved lines
1 Click the Draw tool, and then click Curved Line.

Draw tool Curved 
Line

2 Click where you want to begin the line and drag the pointer.
3 Release the mouse button when the line is the size you want.
4 Click and drag the pointer where you want to place the next point. 
5 Repeat step 4 until you have closed the object.
6 Click Finished or press Esc when you finish.

{button Related Topics,PI(`',`IDH_RT_To_draw_connected_curves')}



Drawing Shapes
Drawing Lines
Drawing Connector Lines



Draws a square.



Draws a square with rounded corners.



Draws a rectangle.



Draws a rectangle with rounded corners.



Draws a circle.



Draws an ellipse.



Draws an irregular polygon.



Draws an irregular polygon with smoothed corners.



Draws shapes made of connected line segments.



Draws shapes made of curved lines.



Using Layers
{button Tell me how...,PI(`',`IDH_HT_Using_Layers')}

The Layers command on the Arrange menu has the following submenu commands:
Layer Manger command
Edit All Layers command
Add Layer command
Move to Layer command
Move Back One Layer command
Move Forward One Layer command

These commands let you open the Layer Manager, add layers, edit layers, move selected objects to 
another layer, and move just one layer at a time (backward or forward).
The Layers command also lets you switch between changing the current layer and changing all 
layers. Changing all layers lets you select, move, and change all objects in the active chart, 
regardless of the layer on which they are located. When changing all layers, you cannot move an 
object on a lower layer in front of an object on a higher layer.
At the bottom of each chart window is a layer tab bar that shows a tab for each layer defined for 
that chart. The tabs show the names of the layers and the order in which the layers are arranged. 
The current layer is indicated by a white tab. When a layer is hidden or locked, the name on that tab
is gray.
Scroll arrows appear at the left of the layer tab bar when the tab bar contains more tabs than can be
shown at once.

Note
New objects are always placed on the current layer, even when you are changing all layers.

{button Related Topics,PI(`',`IDH_RT_Using_Layers')}



To change the current layer
To add a layer to the active chart
To change all layers
To delete a layer

To rename a layer
To change the order of a layer
To move an object to a different layer
To move an object back one layer

To move an object forward one layer
To show or hide a layer
To make a layer printable or non-printable
To lock or unlock a layer



Benefits of Layers
Layer Manager



Benefits of Layers
{button Tell me how . . .,PI(`',`IDH_HT_Benefits_of_Layers')}

You have the ability to organize your charts in layers. This lets you place some objects on one layer, 
others on another layer, and so forth, just as you might with several overhead transparencies.
Layers help you do the following:

Manage complex charts with many overlapping objects.
Categorize objects that logically belong together by layer.
View certain objects in your drawing while hiding others.
Easily select and change objects.
Protect objects from accidental changes.
Trace from a template on another layer.
Print certain objects only.

Each chart has one layer by default. The default name of each layer is Layer1, Layer2, and so forth. 
Layer1 is the back layer. The number of layers you can use is virtually unlimited 32,767.

You can do the following with layers:
Rename the layers.
Add and delete layers.
Change the order of layers.
Display or hide selected layers.
Specify layers as printable or non-printable.
Lock layers (so that objects cannot be moved or changed).
Move objects from one layer to another.
Change all the layers at once, or change one layer at a time.

{button Related Topics,PI(`',`IDH_RT_Benefits_of_Layers')}



To add a layer to the active chart 
To change all layers 
To change the current layer 
To change the order of a layer 

To delete a layer 
To lock or unlock a layer 
To make a layer printable or nonprintable 
To rename a layer 

To move an object back one layer 
To move an object forward one layer 
To move an object to a different layer 

To show or hide a layer 



Using Layers
Layer Manager



Layer Manager
{button Tell me how...,PI(`',`IDH_HT_Layer_Manager')}

Layer Manager lists the layers defined for the active chart and lets you perform layer operations. In 
Layer Manger, you can change the visible, print, and lock properties of layers. Also, Layer Manager 
lets you select the current layer; add, delete, and rename layers; change the order of layers; and 
specify whether you want to change the current or all layers.

Note
Layer Manager will not close if you have selected a hidden, locked layer as the current layer. To

close Layer Manager, you must change the current layer to a layer that is not hidden or locked.

{button Related Topics,PI(`',`IDH_RT_Layer_Manager')}



To change the current layer
To add a layer to the active chart
To change all layers
To delete a layer

To rename a layer
To change the order of a layer
To show or hide a layer

To make a layer printable or non-printable
To lock or unlock a layer



Using Layers
Benefits of Layers



To change the current layer
On the layer tab bar at the bottom of the chart window, click the tab of the layer you want to 

make the current layer. You may need to scroll the layer tab bar to locate the tab.
Note

When a layer is hidden or locked, the name of the layer on the tab is unavailable. You cannot 
make a hidden or locked layer the current layer.

{button Related Topics,PI(`',`IDH_RT_To_change_the_current_layer')}



Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



To add a layer to the active chart
Point to Layers on the Arrange menu, and then click Add Layer.

The new layer is added in front of the current layer and becomes the new current layer.

Tips
You also can use the Add Layer button on the Arrange+ toolbar.

Add Layer button
To display a shortcut menu that lets you add a layer, click a layer tab with the right mouse 

button.

{button Related Topics,PI(`',`IDH_RT_To_add_a_layer_to_the_active_chart')}



Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



To change all layers
Point to Layers on the Arrange menu, and then select Edit All Layers.

Edit All Layers lets you select, move, and change all objects in the active chart, regardless of the 
layer on which they are located. When changing all layers, you cannot move an object on a lower 
layer in front of an object on a higher layer.

Note
New objects are always placed on the current layer, even when you are changing all layers.

Tips
To switch back to changing just the current layer, clear Edit All Layers.
You also can use the Edit All Layers button on the Arrange+ toolbar.

Edit All Layers button
To display a shortcut menu that lets you edit all layers, click a layer tab with the right mouse 

button.

{button Related Topics,PI(`',`IDH_RT_To_change_all_layers')}



Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



To delete a layer
1 On the Arrange menu, point to Layers, and then click Layer Manager.
2 Click the name of the layer you want to delete.
3 Click Delete.

Note
When you delete a layer, all objects on the layer are deleted.

Tips
You also can use the Layer Manager button on the Arrange+ toolbar.

Layer Manager button
To display a shortcut menu that lets you delete a layer, click the layer tab with the right mouse 

button for the layer you want to delete.

{button Related Topics,PI(`',`IDH_RT_To_delete_a_layer')}



Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



To rename a layer
1 On the Arrange menu, point to Layers, and then click Layer Manager.
2 Click the name of the layer you want to rename.
3 Click Rename.
4 Type the new name.
5 Click OK.
6 Click OK.

Tips
You also can use the Layer Manager button on the Arrange+ toolbar.

Layer Manager button
To display a shortcut menu that lets you rename a layer, click the layer tab with the right 

mouse button for the layer you want to rename.

{button Related Topics,PI(`',`IDH_RT_To_rename_a_layer')}



Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



To change the order of a layer

{button Show me how . . .,PI(`',`IDH_AVI_tochangelayerorder0018')}
1 On the Arrange menu, point to Layers, and then click Layer Manager.
2 Click the name of the layer you want to reorder.
3 Click Move Up or Move Down as necessary to position the layer in the list where you want it.
4 Click OK.

Tip
To display a shortcut menu that lets you change the order of the layers, click the layer tab with

the right mouse button for the layer you want to change the order of.

{button Related Topics,PI(`',`IDH_RT_To_change_the_order_of_a_layer')}
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Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



To move an object to a different layer 
1 Select the object.
2 On the Arrange menu, point to Layers, and then click Move To Layer.
3 Click the layer to which you want to move the object.
4 Click OK.

Tips
When you move objects to another layer, you are given the option of making that layer the 

current layer.
You can also use the Move To Layer button on the Arrange+ toolbar.

Move to Layer button
To display a shortcut menu that lets you move a selected object to another layer, click the 

layer tab with the right mouse button for the layer with that selected object.

{button Related Topics,PI(`',`IDH_RT_To_move_an_object_to_a_different_layer')}



Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



To move an object back one layer
1 Select the object.
2 On the Arrange menu, point to Layers, and then click Move Back One Layer.

Tips
You can also press Ctrl+F9 to move the selected object back one layer.
You can also use the Move Back One Layer button on the Arrange+ toolbar.

Move Back One Layer button

{button Related Topics,PI(`',`IDH_RT_To_move_an_object_back_one_layer')}



Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



To move an object forward one layer
1 Select the object.
2 On the Arrange menu, point to Layers, and then click Move Forward One Layer.

Tips
You can also press Ctrl+F10 to move the selected object forward one layer.
You can also use the Move Forward One Layer button on the Arrange+ toolbar.

Move Forward One Layer button

{button Related Topics,PI(`',`IDH_RT_To_move_an_object_forward_one_layer')}



Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



To show or hide a layer
1 On the Arrange menu, point to Layer, and then click Layer Manager.
2 To hide a layer, clear the box under the bulb icon for the layer. To show a layer, select the box 

under the bulb icon for the layer.
3 Click OK.

Note
The current layer cannot be hidden. If you hide the current layer, the Layer Manager does not 

close until you make the layer visible or change the current layer to a visible layer.
Tips

To speed up the redraw of complicated drawings, hide the layers that you are not currently 
working with.

To display a shortcut menu that lets you show or hide a layer, click the    layer tab with the right
mouse button of the layer you want to show or hide.

Hiding a layer does not affect its print property.
You also can use the Layer Manager button on the Arrange+ toolbar.

Layer Manager button

{button Related Topics,PI(`',`IDH_RT_To_show_or_hide_a_layer')}



Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



To make a layer printable or nonprintable
1 On the Arrange menu, point to Layers, and then click Layer Manger.
2 To make a layer non-printable, clear the box under the printer icon for the layer.

To make a layer printable, select the box under the printer icon for the layer.
3 Click OK.

Note
Hidden layers are printed unless they are also non-printable. 

Tips
To display a shortcut menu that lets you make a layer printable or non-printable, click the layer

tab with the right mouse button of the layer you want to make printable or non-printable.
You also can use the Layer Manager button on the Arrange+ toolbar.

Layer Manager button

{button Related Topics,PI(`',`IDH_RT_To_make_a_layer_printable_or_nonprintable')}



Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



To lock or unlock a layer
1 On the Arrange menu, point to Layers, and then click Layer Manager.
2 To lock a layer, select the box under the lock icon for the layer.

To unlock a layer, clear the box under the lock icon for the layer.
3 Click OK.
When a layer is locked, it can be displayed or hidden, but it cannot be changed, reordered, or 
deleted.

Note
The current layer cannot be locked. If you lock the current layer, the Layer Manager does not 

close until you unlock the layer or change the current layer to an unlocked layer.
Tips

To display a shortcut menu that lets you lock or unlock a layer, click the layer tab with the right
mouse button of the layer you want to lock or unlock.

You also can use the Layer Manager button on the Arrange+ toolbar.

Layer Manager button

{button Related Topics,PI(`',`IDH_RT_To_lock_or_unlock_a_layer')}



Using Layers
Layer Manager
Arrange menu
Arrange+ toolbar



Layers dialog box
The Layers dialog box lists the layers defined for the active chart and lets you perform operations 
for each layer and all layers.
You can:

Select whether a layer is hidden or visible
Select whether a layer is printable
Select whether is layer is locked
Edit all layers at the same time
Add a layer
Delete a layer
Rename a layer
Move a layer up
Move a layer down

{button Related Topics,PI(`',`IDH_RT_Layers_dialog_box')}



Using Layers
Benefits of Layers
Layer Manager 
Arrange menu 

Layers command 
Layer Manger command 



Lists all available layers in your chart. The current layer is highlighted.



Makes the the layer to be visible or hidden.



Makes the layer be printable or not.



Makes the layer locked or unlocked.



Lets you add a layer to your chart.



Lets you delete a layer from your chart.



Lets you rename a layer in your chart.



Lets you change the order of layers by moving a layer up in your chart. You can only move a layer 
one layer at a time.



Lets you change the order of layers by moving a layer down your chart. You can only move a layer 
one layer at a time.



Lets you make the same changes to all layers in your chart.



Name Layer dialog box
The Name Layer dialog box displays the name of the layer you have selected or added. You can 
change this name by typing in a new one in the box under the text Type the name for this layer:

{button Related Topics,PI(`',`IDH_RT_Name_Layer_dialog_box')}



To add a layer to the active chart 
To rename a layer 



Displays the name of the layer you selected or added. To rename a layer, type over the displayed 
layer name.



What Is a Living FlowChart?
{button Tell me

how . . .,PI(`',`IDH_HT_What_Is_a_Living_FlowChart')}

A Living FlowChart is a chart that runs like a program. A Living FlowChart actually walks you through
the steps in the process, letting you make the decisions as you go. 
In its simplest form, a Living FlowChart "walks" a user through your chart. After drawing a flowchart 
on the screen, you can instruct FlowCharter to "run" the flowchart.    It then takes you through each 
shape that you have drawn on the page, via a series of dialog boxes, using the text in each shape 
and on each line to describe to the person "running" the chart what to do. This type of chart requires
only that you draw a chart.
At its most complex, a Living FlowChart can be quite elaborate, limited only by your imagination and
your ability to write customized script for special operations.    For example, Living FlowCharts can 
add simulation or animation to flowcharts. These complex Living FlowCharts can be used for 
simulation and prototyping.
No matter what you decide to use Living FlowCharts for, the end result is a "Living FlowChart" that 
users can interact with in a dynamic and real-time manner.
You can use Living FlowCharts for the following procedures:

Creating interactive questionnaires
Simulating business processes
Creating tutorials and advanced instructional aids that use dialogs
Prototyping
Creating interactive decision support trees

{button Related Topics,PI(`',`IDH_RT_What_Is_a_Living_FlowChart')}



To run a Living FlowChart
To run part of a flowchart 
To insert a starting point in a flowchart 



How Does a Living FlowChart Work?
Designing Living FlowCharts
Living FlowCharts Toolbar
Using the Shape Action Wizard

Troubleshooting Living FlowCharts
Living FlowChart Rules and Limitations
Living FlowChart Sample Files



Living FlowCharts Toolbar

The Living FlowCharts toolbar contains the following functions.

Opens the Shape Action Wizard and helps you define actions for a shape.

Selects the starting shape for your flowchart.

Shows or hides the Entity Manager window.

Opens the Script Editor, enabling you to edit the script for an object.

Opens the Living FlowCharts options dialog box.

Runs a Living FlowChart.

Stops a running Living FlowChart.

Pauses a running Living FlowChart.

Goes through a flowchart step-by-step.

{button Related Topics,PI(`',`IDH_RT_Living_FlowCharts_Toolbar')}



What Is a Living FlowChart?
How Does a Living FlowChart Work?
Designing Living FlowCharts
Using the Shape Action Wizard
Troubleshooting Living FlowCharts



Troubleshooting Living FlowCharts

What is the problem?
A shape that is automatically processed is not choosing the correct path.
Run the Shape Action Wizard on that shape again, but this time select dialog box behavior, 

display data fields, and leave everything else the same.    Now rerun the flowchart and you can see 
what is happening at that previously automatic shape.

I'm running a chart that accumulates data and the data is not accumulating correctly.
Open the Worksheet (click Worksheet on the Tools menu). The data in each entity in your chart 

appears in the worksheet.

I can't get the chart to return to one shape after it goes through several other shapes.
A Living FlowChart cannot run in the opposite direction of its arrows. To run backwards, you 

must provide a second line out of the shape with an arrow indicating the returning direction.

{button Related Topics,PI(`',`IDH_RT_Troubleshooting_Living_FlowCharts')}
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To select an action type for a shape
1 Click a shape on a flowchart.
2 On the Tools menu, click Shape Action Wizard.
3 Click Next.
4 On the Action Type page, click either Display a dialog box or Automatically choose a path. 
5 Click Next to continue.

Note
Display a dialog box is the default choice and is automatically selected.

{button Related Topics,PI(`',`IDH_RT_To_select_an_action_type_for_a_shape')}



Action Types
Living FlowChart Dialog Boxes 
Automatically Choosing a Path 

To automatically process a shape 
To create a dialog box 



To verify path names
1 Click the    shape where the path names originate.
2 On the Tools menu, click Shape Action Wizard.
3 Move through the wizard until you reach the Verify Path Names page.
4 Make sure the check box next to each path name you want to use is selected. Clear the check 

boxes next to path names you do not want to use.

Note
You also can change the order in which path names appear in a dialog box. 

 How?     

{button Related Topics,PI(`',`IDH_RT_To_verify_path_names')}



Verifying Path Names
To display buttons for each path 
To change the order of buttons in a dialog box 
To change the name of a path 



Living FlowChart Dialog Boxes
{button Tell me

how . . .,PI(`',`IDH_HT_Living_FlowChart_Dialog_Boxes')}

The dialog boxes in Living FlowCharts have two main functions:

Showing information to the user
Any text in the shape automatically appears in the dialog box. In addition, you can set up data fields
that give a user information and use text in buttons to show a user the available paths through the 
rest of the chart.

Getting information from the user
You can set up a dialog box with data fields and enable a user to enter information into the fields. 
This information can determine what choices or path the user sees next. The information can also 
be accumulated with other information and determine the result of the users actions.

{button Related Topics,PI(`',`IDH_RT_Living_FlowChart_Dialog_Boxes')}



To create a dialog box 
To change the appearance of a dialog box 
To select a dialog box layout 



What Is a Living FlowChart? 
Dialog Box Appearance 
Using the Shape Action Wizard 

Designing Living FlowCharts 
Living FlowChart Default Behavior 
Using Dialog Box Layouts



Changing the Standard Dialog Box
{button Tell me

how . . .,PI(`',`IDH_HT_Changing_the_Standard_Dialog_Box')}

You change the body text of the dialog box by typing different text in the shape. You can change 
other elements of the standard dialog box with the Shape Action Wizard. You can:

Change the text in the title bar
Remove the Stop button 
Remove the Shape image
Show data to the user or let the user enter data
Let the user choose his path
Change the labels on the buttons 
Change the order of the buttons 
Remove buttons that represent the paths
Change the layout of the dialog box.

If you want to show data or get data from the user, you must have already set up the data fields in 
the chart. You can display as many or as few data fields as you want in your dialog box. You choose 
the fields you want to display when you run the Shape Action Wizard.

{button Related Topics,PI(`',`IDH_RT_Changing_the_Standard_Dialog_Box')}



To change the appearance of a dialog box



Living FlowChart Dialog Boxes
Dialog Box Appearance 
Using Dialog Box Layouts 
Using the Shape Action Wizard 



To create a dialog box
1 Click a shape on a flowchart.
2 On the Tools menu, click Shape Action Wizard.
3 Click Next.
4 On the Action Type page, click Display a dialog box, then click Next.
5 On the Dialog Box Options page, choose the options that define how the box will look to a user, 

then click Next.
6 On the Path Selection Method page, click Let the user choose the path, then click Next.
7 On the Verify Path Names page, make any changes necessary to the labels for each path, then 

click Next.
8 On the Select Layout page, choose a layout for the buttons and text, then click Next.
9 Click Finish.

{button Related Topics,PI(`',`IDH_RT_To_create_a_dialog_box')}



To change the appearance of a dialog box 
To select a dialog box layout 
To select an action type for a shape 
Living FlowChart Dialog Boxes

Using Dialog Box Layouts
Designing Living FlowCharts 
Action Types 
Living FlowChart Default Behavior 



Using Dialog Box Layouts
{button Tell me

how . . .,PI(`',`IDH_HT_Using_Dialog_Box_Layouts')}

The Shape Action Wizard in Living FlowCharts enables you to arrange a dialog box's buttons and text
in a number of different ways. Using the Select Layout page of the wizard, you can select different 
layouts or positions of the elements in a dialog box. As you choose different layouts from a list, a 
small picture of each layout shows you how the dialog box looks. If you want to see exactly how the 
box will look with your information, a Test button displays a picture of your finished dialog box.

{button Related Topics,PI(`',`IDH_RT_Using_Dialog_Box_Layouts')}



To select a dialog box layout 
To create a dialog box 



Living FlowChart Dialog Boxes
Using the Shape Action Wizard 



To select a dialog box layout
1 Click a shape on your flowchart.
2 On the Tools menu, click Shape Action Wizard.
3 Click Next to go through each page of the wizard until you reach the Select Layout page.
4 Select one of the layouts in the list box. To see what the layout will look like in the finished dialog 

box, click Test.
5 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_select_a_dialog_box_layout')}



To create a dialog box 
Using Dialog Box Layouts
Living FlowChart Dialog Boxes
Using the Shape Action Wizard 



Dialog Box Appearance
{button Tell me how . . .,PI(`',`IDH_HT_Dialog_Box_Appearance')}

When you set up a shape to display dialog boxes for a user, you need to define what the dialog 
boxes will look like. The Dialog Box Appearance wizard page enables you to select several different 
options that determine exactly how the dialog box that the user sees will look.

Dialog Box Title
These two options control what text appears in the title bar of the dialog box for a specific shape.
Chart Name The title bar displays the file name of your chart. For example, if you create a chart 

that shows how to process subscriptions and name the chart "Subscrip", then "Subscrip" appears
in the title bar of the dialog box.

Custom The title bar displays whatever you type in the text box next to this option. For example, if you 
click the Custom option button and type "Subscription Processing Step One" in the text box, then 
"Subscription Processing Step One" will appear in the title bar of the dialog box for this shape when the
user runs the chart.
Notes

Chart Name is the default. Unless you click the Custom option button and type a title in the 
text box, the name of the chart always appears in the title for the dialog box.

If you click the Custom option button but do not type any text in the text box, the chart name 
appears as the dialog box title.
Shape Image
You can hide or show the image of the active shape. This is useful if you want the user to see a 
special image or a meaningful shape. If you want the user to focus on the text in the dialog box, you
can hide the shape.
Data Fields
If you have set up any data fields for the chart, you can select this check box to enable the user to 
see data, add data, or change data for a shape. If you have not set up data fields for the chart, this 
option is not available.
Stop Button
You can show or hide the Stop button.    You may want to hide the Stop button to prevent the user 
from stopping the chart.    You may also want to hide it because it resembles another path name too 
closely, and you want to prevent the user from accidentally clicking it.
You should not remove the Stop button from all dialog boxes. A circular path can occur when all 
shapes are connected in a loop. In a chart like this, an entity can travel in the chart forever because 
there is no way for it to reach the end of the path. When an entity never reaches the end of a path, 
it does not reach the ending shape, the shape that provides a Done button. (The Done button also 
lets the user stop the chart.)

{button Related Topics,PI(`',`IDH_RT_Dialog_Box_Appearance')}



To change the appearance of a dialog box 
To use the chart name as a title for a dialog box
To use a custom name as a title for a dialog box



Living FlowChart Dialog Boxes 
Living FlowChart Default Behavior



To change the appearance of a dialog box
1 Click the shape that uses the dialog box you want to change.
2 On the Tools menu, click Shape Action Wizard.
3 On the Introduction page, click Next.
4 On the Action Type page, click Display a dialog box, then click Next.
5 On the Dialog Box Options page, click one of the option buttons to select a title.
6 Select or clear the check boxes to display or hide the shape image, display or hide a Stop button 

and display data fields.
7 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_change_the_appearance_of_a_dialog_box')}



To use a custom name as a title for a dialog box
To use the chart name as a title for a dialog box
To display the shape image in the dialog box 

To create a dialog box 
To display data fields in a dialog box 
To display a stop button in a dialog box 

Dialog Box Appearance
Changing the Standard Dialog Box 
Using the Shape Action Wizard 



To use the chart name as a title for a dialog box
1 Open the Shape Action Wizard.
2 Go to the Dialog Box Options page.
3 Click the Chart Name option button.
4 Click Next to continue.

Note
The Dialog Box Options page is available only if you have selected Display a dialog box on the 

Action Type page of the wizard.

{button Related Topics,PI(`',`IDH_RT_To_use_the_chart_name_as_a_title')}



To use a custom name as a title for a dialog box
To change the appearance of a dialog box 
Dialog Box Appearance 
Living FlowChart Dialog Boxes
Using Dialog Box Layouts



To use a custom name as a title for a dialog box
1 Open the Shape Action Wizard.
2 Go to the Dialog Box Options page.
3 Click the Custom option button and enter a name in the text box.
4 Click Next to continue.

Note
The Dialog Box Options page is available only if you have selected Display a dialog box on the 

Action Type page of the wizard.

{button Related Topics,PI(`',`IDH_RT_To_use_a_custom_name_as_a_title')}



To use the chart name as a title for a dialog box
To change the appearance of a dialog box 
Dialog Box Appearance 
Living FlowChart Dialog Boxes
Using Dialog Box Layouts



To display the shape image in a dialog box
1 Open the Shape Action Wizard.
2 Click Next.
3 On the Action Type page, click Display a dialog box, then click Next.
4 On the Dialog Box Options page, select the Shape Image check box.
5 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_display_the_shape_image_in_a_dialog_box')}



To change the appearance of a dialog box 
Dialog Box Appearance
Living FlowChart Dialog Boxes
Using Dialog Box Layouts



To display data fields in a dialog box
1 Open the Shape Action Wizard.
2 Click Next.
3 On the Action Type page, click Display a dialog box, then click Next.
4 On the Dialog Box Options page, select the Data Fields check box.
5 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_display_data_fields_in_a_dialog_box')}



To change the appearance of a dialog box 
Dialog Box Appearance
Living FlowChart Dialog Boxes
Using Data Fields 
Using Data in a Living FlowChart 



To display a stop button in a dialog box
1 Open the Shape Action Wizard.
2 Click Next.
3 On the Action Type page, click Display a dialog box, then click Next.
4 On the Dialog Box Options page, select the Stop Button check box.
5 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_display_a_stop_button_in_a_dialog_box')}



To hide a stop button
To change the appearance of a dialog box 

Dialog Box Appearance
Living FlowChart Dialog Boxes



To hide a stop button
1 Open the Shape Action Wizard.
2 Click Next.
3 On the Action Type page, click Display a dialog box, then click Next.
4 On the Dialog Box Options page, clear the Stop Button check box.
5 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_hide_a_stop_button')}



To display a stop button in a dialog box 
To change the appearance of a dialog box 

Dialog Box Appearance
Living FlowChart Dialog Boxes



To automatically process a shape
1 Click a shape on a flowchart.
2 On the Tools menu, click Shape Action Wizard.
3 Click Next.
4 On the Action Type page, click Automatically advance.
5 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_automatically_process_a_shape')}



Automatically Choosing a Path
Action Types 
To select an action type for a shape 



To perform data field operations on a shape
1 Select the shape on which you want to perform data field operations.
2 On the Tools menu, click Shape Action Wizard.
3 Click Next.
4 On the Action Type page, select Automatically advance.
5 On the Automatic Options page, select Yes to confirm that you want to perform data field 

operations.
6 Select a method of path selection.
7 Click Next to move to the Data Field Operations page.

{button Related Topics,PI(`',`IDH_RT_To_perform_data_field_operations_on_a_shape')}



Automatically Choosing a Path 
Using Data Fields 
Performing Math Operations
Using Data in a Living FlowChart 

Expression Functions 
Using Expressions
Understanding Path Selection 



To change the order of buttons in a dialog box
1 Click a shape on a flowchart.
2 On the Tools menu, click Shape Action Wizard.
3 Move through the wizard until you reach the Verify Path Names page.
4 Select a path name and use the arrows to move it up or down in the list.

Up arrow Down arrow

Note
The Dialog Box Options page is available only if you have selected Display a dialog box on the 

Action Type page of the wizard.

{button Related Topics,PI(`',`IDH_RT_To_change_the_order_of_buttons_in_a_dialog_box')}



Verifying Path Names 
Using the Shape Action Wizard 
Letting the User Choose the Path 
Designing Living FlowCharts
 
To verify path names
To change the name of a path 
To display buttons for each path 
To hide a path button 



To change the name of a path
1 Click the shape on a flowchart.
2 On the Tools menu, click Shape Action Wizard.
3 Click Next until the Verify Path Names page appears.
4 Select the path button name you want to change.
5 Click the Change Label button.

Change Label button
6 Type the new name for the button.
7 Press Enter.
8 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_change_the_name_of_a_path')}



Verifying Path Names 
Using the Shape Action Wizard 
Letting the User Choose the Path 
Designing Living FlowCharts
 
To verify path names
To change the order of buttons in a dialog box 
To display buttons for each path 
To hide a path button



To change Living FlowChart options
1 On the Format menu, click Chart Properties.
2 Click the Living FlowCharts tab.

{button Related Topics,PI(`',`IDH_RT_To_change_Living_FlowChart_options')}



To create a password for a Living FlowChart
To change a Living FlowChart's password 
To show entity feedback on a chart 
To run a flowchart when the file opens 

To set the speed of a Living FlowChart 
Chart Properties command
Format menu



To create a password for a Living FlowChart
1 On the Format menu, click Chart Properties.
2 Click the Living FlowCharts tab.
3 Click Password.
4 Type the password in the New Password text box. You can use as many as 16 alphabetic or 

numeric characters in any combination.
5 Type the new password again in the Verify Password text box.
6 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_create_a_password_for_a_Living_FlowChart')}



To change a Living FlowChart's password
To change Living FlowChart options 
Chart Properties command
Format menu



To change a Living FlowChart's password
1 On the Format menu, click Chart Properties.
2 Click the Living FlowCharts tab.
3 Click Password.
4 Type your old password in the Old Password text box.
5 Type the new password in the New Password text box. You can use as many as 16 alphabetic or 

numeric characters in any combination.
6 Type the new password again in the Verify Password text box.
7 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_change_a_Living_FlowChart_password')}



To create a password for a Living FlowChart
To change Living FlowChart options 
Chart Properties command
Format menu



To show entity feedback on a chart
1 On the Format menu, click Chart Properties.
2 Click the Living FlowCharts tab.
3 Select the Show Entity Feedback check box.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_show_entity_feedback_on_a_chart')}



Entity Manager
Entity Manager command
Showing Entity Feedback
Format menu

To create a new entity
To change Living FlowChart options 
Chart Properties command



To run a flowchart when the file opens
1 On the Format menu, click Chart Properties.
2 Click the Living FlowCharts tab.
3 Select the Run Chart on Open check box.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_run_a_flowchart_when_the_file_opens')}



To set the speed of a Living FlowChart
To change Living FlowChart options 
To run a Living FlowChart

What Is a Living FlowChart?
Chart Properties command
Format menu



To set the speed of a Living FlowChart
1 On the Format menu, click Chart Properties.
2 Click the Living FlowCharts tab.
3 Use the slider to define how fast (in tenths of a second) the chart will run. You can set the speed 

in tenths of a second.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_set_the_speed_of_a_Living_FlowChart')}



To run a flowchart when the file opens
To run a Living FlowChart
To change Living FlowChart options 

What Is a Living FlowChart?
Chart Properties command
Format menu



To run a Living FlowChart
1 Open the chart you want to run.
2 On the Insert menu, click Starting Point.
3 Select the shape that will be the starting shape for the flowchart. You will normally select the first

shape on your chart, but you can use any shape that has lines coming out of it.
4 On the Tools menu, click Run Flowchart.

Tip
You also can click the Run button on the Living FlowCharts toolbar to run an open chart.

Run button

{button Related Topics,PI(`',`IDH_RT_To_run_a_Living_FlowChart')}



To run a flowchart when the file opens
To stop a running flowchart
To pause a running flowchart

Run FlowChart command 
Starting Shape 
Living FlowCharts Toolbar
What Is a Living FlowChart? 



To stop a running flowchart
On the Run menu, click Stop.

Tip
You also can stop a running flowchart by clicking the Stop button on the Living FlowCharts 

toolbar or by pressing the Esc key.

Stop button

{button Related Topics,PI(`',`IDH_RT_To_stop_a_running_flowchart')}



To run a Living FlowChart
To run a flowchart when the file opens
To pause a running flowchart
To step through a Living FlowChart
Living FlowCharts Toolbar



To pause a running flowchart
On the Run menu, click Pause.

Tip
You also can pause a running flowchart by clicking the Pause button on the Living FlowCharts 

toolbar.

Pause button

{button Related Topics,PI(`',`IDH_RT_To_pause_a_running_flowchart')}



To run a Living FlowChart
To run a flowchart when the file opens
To stop a running flowchart
To step through a Living FlowChart
Living FlowCharts Toolbar



To step through a Living FlowChart
On the Run menu, click Step.

Tip
You also can step through a flowchart by clicking the Step button on the Living FlowCharts 

toolbar.

Step button

{button Related Topics,PI(`',`IDH_RT_To_step_through_a_Living_FlowChart')}



To run a Living FlowChart
To run a flowchart when the file opens
To stop a running flowchart
To pause a running flowchart
Living FlowCharts Toolbar



Understanding Living FlowChart Events
{button Tell me

how . . .,PI(`',`IDH_HT_Understanding_Living_FlowChart_Events')}

Living FlowCharts are event-driven. An event is caused by an object as a result of something you do.
For example, clicking the mouse on a button causes a click event. Typing a character in a text box 
causes a change event. In the code created by the Shape Action Wizard, a button object causes a 
click event when it receives a mouse click message. In the same way, a text box causes a change 
event when it receives keyboard messages that change the contents of the field.

Three Levels of Event Procedures
FlowCharter now has three levels of event procedures: the object level, the chart level, and the 
application level (OCX).    When an event occurs, the first event procedure that runs is the object’s 
event procedure. The second is the chart’s event procedure. The third is the application event 
procedure.
All object events have equivalent chart events. For example, an object has an OnClick event. The 
chart has an event called OnObjectClick that occurs when any object in the chart is clicked. 
Not all events are available for all levels. Some events do not occur to objects, but only to charts. 
For example, when the user closes the chart, there is no object equivalent.    In this case, the chart’s 
OnClose event procedure runs, then the application level event procedure runs.
There are two kinds of events, depending on whether the event procedure is executed before or 
after the event’s standard behavior: Subclass events and Notify events.

Subclass Events
Subclass event procedures execute before the flowchart performs its standard behavior. Subclass 
event procedures will always have a "Handled" parameter. Some subclass events also have an 
"Allow" parameter. Subclass events are not called by Automation calls. 

Notify Events
Notify event procedures execute after the flowchart performs its standard behavior. Notify event 
procedures are identified by the use of NOTIFY in the event’s name. Unlike Subclass events, 
Notification events are called by automation calls. 

{button Related Topics,PI(`',`IDH_RT_Understanding_Living_FlowChart_Events')}



To create a script using the script editor
To change the script for an object 
To change the script for a chart    



Understanding Subclass Events 
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Using the Shape Action Wizard 
Using Entities 
Living FlowChart Rules and Limitations 



Understanding Subclass Events

Subclass events are events that run the event procedure before carrying out the standard behavior, 
thus allowing you to intervene in the standard behavior. You can recognize Subclass events by the 
presence of a Handled parameter.
When a subclass event occurs, three steps happen, in this order: 
1 FlowCharter runs the event’s procedure, if any.
2 FlowCharter notifies the next level of event procedures.
3 FlowCharter carries out the event’s standard behavior.
All three of these steps happen only if you do not stop the event process. You can stop the event 
process of a subclass event in two ways: you can stop its standard behavior from occurring and you 
can stop FlowCharter from notifying the next event level.
When an event occurs, FlowCharter calls the event procedure for the object to which the event 
occurred. For example, shapes have OnClick event procedures. When you click a shape, a click 
event occurs, and the shape’s OnClick procedure runs. FlowCharter then notifies the chart that an 
object click event has occurred, then notifies the application interface that a click event has 
occurred.
If the event was a chart event, FlowCharter calls the chart’s event procedure.    For example, charts 
have an OnClose procedure. When a user closes the chart, the OnClose procedure runs. Last, 
FlowCharter closes the chart.

Stopping the standard behavior of a subclass event
You can stop the standard behavior of a subclass event.    You may want to prevent a behavior like a 
deletion when you want to protect an object from being deleted.    In the event procedure, you could 
display a dialog box advising the user that this object cannot be deleted.
To prevent a standard behavior, use the Allow parameter and set it to FALSE. Put this line of script 
into the event procedure for the object.    For example, to prevent a shape from being deleted, put 
this line of script into the shape’s OnDelete procedure:

Allow.Value=FALSE
To permit the standard behavior of an event set the Allow parameter to TRUE. This line is usually not
necessary because the default value is TRUE.    You would only need to do this if you had set the 
value to FALSE elsewhere.

Allow.Value    = TRUE

{button Related Topics,PI(`',`IDH_RT_Understanding_Subclass_Events')}
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Understanding Notify Events

Notify events are events that carry out their standard behaviors first, before they run the event 
procedure. When a notify event occurs, three things happen, in this order:
1 FlowCharter carries out the event’s standard behavior.
2 FlowCharter runs the event’s procedure, if any.
3 FlowCharter notifies the next level of event procedures.
For example, you can have a shape that is always the same height and width. This example shows 
an object event procedure that occurs after the user has resized an object. The event is a notify 
event and occurs when the resizing is finished. The event passes the new height and width to the 
object event.

Sub Object_OnSizeFinished((Newheight, NewWidth)
Width = NewHeight
EndSub

Event handlers are not recursive.    That is, although the above example changes the size of the 
object, these changes do not cause the OnSizeFinished event to be called again.

Preventing Further Event Notification
To prevent the further notification of events to the other levels (chart and application), use the 
Handled parameter.
You may want to stop the event notification process because you have prevented the standard 
behavior, like a deletion. Since the shape cannot be deleted, you don’t want to pass on the deletion 
event to the chart and application levels.
To prevent further notification, use the Handled parameter and set it to TRUE. Put this line of script 
into the event procedure for the object.    For example, to prevent further notification of a deletion, 
put this line of script into the shape’s OnDelete procedure:

Handled.Value=TRUE
To permit further notification of an event, set the Handled parameter to FALSE. This line is usually 
not necessary because the default value is FALSE.    You would only need to do this if you had set the
value to TRUE elsewhere.

Handled.Value=FALSE

{button Related Topics,PI(`',`IDH_RT_Understanding_Notify_Events')}
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Showing Entity Feedback
{button Tell me

how . . .,PI(`',`IDH_HT_Showing_Entity_Feedback')}

You can set up a Living FlowChart to show how each entity in the chart is progressing through the 
chart. The entity in this sense "feeds back" information to the user. A simple use for entity feedback 
is to keep track of an entity's path through a chart.

{button Related Topics,PI(`',`IDH_RT_Showing_Entity_Feedback')}
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To turn feedback on or off
1 On the Format menu, click Chart Properties.
2 Click the Living FlowCharts tab.
3 To turn feedback on select the Show Entity Feedback check box. To turn feedback off, clear the 

check box.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_turn_feedback_on_or_off')}
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Run Flowchart command
Selecting this command from the Tools menu starts a Living FlowChart running.

{button Related Topics,PI(`',`IDH_RT_Run_command')}
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Starting Shape
{button Tell me how . . .,PI(`',`IDH_HT_Starting_Shape')}

The starting shape is the shape in which the entity begins its journey through the chart. As you run 
the chart, the entity travels through the chart. The entity's job is to show you where you are in the 
chart and to collect information as it goes. When the entity reaches the end of a path, a Done button
displays in the dialog box. 

{button Related Topics,PI(`',`IDH_RT_Starting_Shape')}
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Ending Shape

The ending shape is the shape at the end of a path. When the entity reaches this shape, a Done 
button appears in the dialog box. 

{button Related Topics,PI(`',`IDH_RT_Ending_Shape')}
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To display buttons for each path
1 Select a shape.
2 On the Tools menu, click Shape Action Wizard.
3 On the Action Type page, click Display a dialog box then click Next.
4 On the Path Selection Method page, make sure that Let the user choose the path is selected.
5 On the Verify Path Names page, select the check boxes next to each path name you want 

displayed as a button.
6 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_display_buttons_for_each_path')}
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To hide a path button
1 Select the shape where the path you want to hide originates.
2 On the Tools menu, click Shape Action Wizard.
3 Move through the wizard until you reach the Verify Path Names page.
4 On the Verify Path Names page, clear the check box next to the path name you want to hide.
5 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_hide_a_path')}
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To create custom buttons
1 Select the shape that will use the buttons.
2 On the Tools menu, click Shape Action Wizard.
3 On the Action Type page, click Display a dialog box then click Next.
4 On the Path Selection Method page, make sure that Let the user choose the path is selected.
5 On the Verify Path Names page, double-click the button name you want to change.
6 Type the name you want to use for the button and press Enter.
6 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_create_custom_buttons')}
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To enter data for a shape
1 Select the shape for which you want to enter data.
2 On the View menu, click Field Viewer.
3 Type the data in the boxes next to the fields you want to use. Press Enter to move from one field 

to the next. (The format that each field requires is shown at the bottom of the Field Viewer.)
4 Click Close.

Tips
To enter data for another shape, click another shape on the chart. (You do not need to close the

Field Viewer.)
To enter data for a field that has not been defined in your chart, click Setup in the Field Viewer.
You can leave fields blank. Blank fields will not show on the chart. Additional fields move up to 

properly space the data on the chart.
To view all of the data in your chart (not just one shape), click Worksheet on the View menu.

{button Related Topics,PI(`',`IDH_RT_To_enter_data_for_a_shape')}
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Using the Shape Action Wizard
{button Tell me how . . .,PI(`',`IDH_HT_Shape_Action_Wizard')}

When you want change a shape's action or create new actions for a shape, you run the Shape Action
Wizard. These actions then govern the way a shape behaves and interacts with the rest of the Living
FlowChart.
The Shape Action Wizard lets you change not only the dialog box appearance, but also many other 
parts of the shape actions. Using the Shape Action Wizard, you can accomplish the following tasks:

Exchange data with the user
Perform math operations on data
Select the user's next path based on data
Change the text that appears in the title bar of a dialog box 
Add or remove a picture of the shape
Add or remove a stop button in a dialog box 
Change the labels on the buttons that represent paths
Change the order of the buttons 
Show or hide buttons 
Change a dialog box layout.

Running the Shape Action Wizard creates customized code for any shape. The wizard writes a script 
for the selected shape based on the options you choose. If you want to perform some action that is 
not possible through the Shape Action Wizard, you can modify the script or write your own code for 
a shape.

Caution
If you make a change to your script then run the Shape Action Wizard again, your script 

changes are lost. The script generated by the Shape Action Wizard overwrites the script you changed.
Note

If you rerun the Shape Action Wizard, your previous Shape Action Wizard selections will be the 
default selections.

{button Related Topics,PI(`',`IDH_RT_Shape_Action_Wizard')}
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Shape Action Wizard command

The Shape Action Wizard command on the Tools menu opens the Shape Action Wizard. You use the 
wizard to program shapes in Living FlowCharts.

{button Related Topics,PI(`',`IDH_RT_Shape_Action_Wizard_command')}
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To open the Shape Action Wizard
On the Tools menu, click Shape Action Wizard.

Tip
You also can click the Shape Action Wizard button on the Living FlowCharts toolbar to open the 

wizard.

Shape Action Wizard button

{button Related Topics,PI(`',`IDH_RT_To_open_the_Shape_Action_Wizard')}
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Using the Worksheet in Living FlowCharts
{button Tell me

how . . .,PI(`',`IDH_HT_Using_the_Worksheet_in_Living_FlowCharts
')}

You can use the worksheet to view, enter, or sort data for a Living FlowChart. The worksheet lists 
every object in your chart that can contain data. 
To view the worksheet, click the View menu and click Worksheet. Each object has a row on the 
worksheet.    Each data field has a column on the worksheet.
Click your right mouse button with your pointer over the worksheet to display its shortcut menu. 
This menu lists commands that apply to the worksheet and to data fields.

{button Related Topics,PI(`',`IDH_RT_Using_the_Worksheet_in_Living_FlowCharts')}
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Understanding Data Accumulation
{button Tell me

how . . .,PI(`',`IDH_HT_Understanding_Data_Accumulation')}

FlowCharter lets you work with six data types: text, duration, date, currency, percent, and number. 
You can combine, or accumulate, some types of data. Each data type has a set of accumulation 
methods. 

Entities Accumulate Data
As an entity runs along a path in a chart, data on the path accumulates into the entity. You can 
watch the data accumulate into the entity by opening the Worksheet. To do so, click View and then 
click Worksheet.
When an entity encounters a shape with no accumulation method, it takes that shape's data. This 
behavior is very useful in creating Living FlowCharts where you want to maintain some state 
information, or remember the answer to a particular question.

Note
Not all data types accumulate, and not all data types have all accumulation methods. For 

example, a Text field does not accumulate. A Date field does not have the Sum or Range accumulation 
methods.

If the data accumulation is done before the data field operations, then the accumulated data 
will not take into account the result of the operations.
Tips

When displayed in the Legend, the accumulation method's result reflects all the objects (lines 
and shapes) in the chart. When displayed in an entity of a Living FlowChart, this number reflects the 
lines and shapes in the entity's path.

If you are having a problem with a chart that uses accumulated data, click Worksheet on the 
Tools menu to view the data in each entity.

{button Related Topics,PI(`',`IDH_RT_Understanding_Data_Accumulation')}
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Using Text Data

If you want to use Text data, use the No Accumulation method.    Even though text doesn't 
accumulate, the entity does carry text through the chart. The entity carries the last text it finds for a
field. That is, each time it finds text for a field, it replaces any text it had for the field with the latest 
text it finds in that field.
If you plan to collect textual data, set up a field for each piece of data you are collecting.    This is 
important to do if you are creating a survey chart. 
For example, if you are collecting name- and address-type information, each piece of information 
should have its own field: First Name, Last Name, Address, City, State, Zip, and Country are all fields
that you would want to consider.

{button Related Topics,PI(`',`IDH_RT_Using_Text_Data')}
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Using Numeric Data

If you want to collect numeric data from the user, decide how you want to use the data in the chart 
as you are setting up the numeric data field.    

Costs are typically set up as Currency with a Sum accumulation method. 
Dates are typically set up with an accumulation method of ??    
To measure how long a process takes, set up a Duration data field and choose an appropriate 

level of detail for the duration (weeks, hours, minutes, or seconds). 
Keep in mind that some numbers, like a membership number or a Social Security number, should 
not be accumulated.    In fact, consider setting up such a field as a text field.

Tip
Duration field values are in milliseconds. That way you can add an hours data field and a 

minutes data field together and get a correct answer.

{button Related Topics,PI(`',`IDH_RT_Using_Numeric_Data')}
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Accumulation Methods

An accumulation method is a way to combine, or accumulate, data of some types. For example, you 
can combine the cost of a process.    The method you use to combine the data is to add it or "Sum" 
it. Thus the accumulation method is Sum. The legend shows the accumulated data for the chart: the
sum of the data for the Cost field.    
Not all data types accumulate, and not all data types have all accumulation methods. For example, 
a Text field does not accumulate. A Date field does not have the Sum or Range accumulation 
methods..
Accumulation 
Method

Description

Sum Sum of the data in the shapes.
Mean Average of the data in the shapes.
Median Middle value of the range of the data in the shapes.
Min Minimum value of the data in the shapes.
Max Maximum value of the data in the shapes.
Range Difference between the highest value and the lowest value 

in the data.
In addition, there are two accumulation methods that yield special information:    Object Count and 
Filled Count. These counts are available for all data field types. 
These two counts are accumulation methods for fields.    You can put any kind of data in these fields,
but the data itself does not accumulate.
Accumulation 
Method

Description

Object Count Number of objects that have the field (regardless of 
whether the fields contain any data). This number is the 
number of objects (shapes and lines) in the chart.

Filled Count Number of objects with data in this field. 

{button Related Topics,PI(`',`IDH_RT_Accumulation_Methods')}
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Using Entities
{button Tell me how . . .,PI(`',`IDH_HT_Using_Entities')}

An entity is an object that flows through a Living FlowChart. An entity has various properties that 
can be changed, such as name, size, shape, fill color, and line color. Entities accumulate the fields of
objects they pass through. These objects can be either shapes or paths.
Entities actually have data field values just like shapes and lines do. 
When an entity encounters an object with no accumulation method (its data field value is set to No 
Accumulation) the entity adopts whatever value the object contains. This feature is very useful for 
creating Living FlowCharts where you want to maintain some state information, or remember the 
answer to a particular question.
If you stop an entity, you cannot run it again, except to start it over again.

Notes
Entities are executed sequentially.
Entities move to the next step when all entities have finished on shape action.
Entities are cleared each time you run the chart.
You can use the worksheet to view any data in an entity.

{button Related Topics,PI(`',`IDH_RT_Using_Entities')}
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Entity Manager
{button Tell me how . . .,PI(`',`IDH_HT_Entity_Manager')}

The Entity Manager is window that appears when you select Entity Manager from the View menu. It 
contains the following buttons.

Adds an entity to the Entity Manger window.

Deletes an entity from the Entity Manger window.

Runs the selected entity.

Stops the selected entity when it is running.

Pauses the selected entity when it is running.

Starts an entity at a specific shape.

{button Related Topics,PI(`',`IDH_RT_Entity_Manager')}
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Entity Manager command
The Entity Manager command on the View menu opens the Entity Manager. You use the Entity 
Manager to add and delete entities on Living FlowCharts. Using the Entity Manager you also can run,
pause, or stop an entity, choose the starting shape for an entity, and change an entity's properties.

Note
You also can display the Entity Manager by clicking 

 on the Living FlowCharts toolbar.

{button Related Topics,PI(`',`IDH_RT_Entity_Manager_command')}
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To open the entity manager
On the View menu, click Entity Manager.

{button Related Topics,PI(`',`IDH_RT_To_open_the_entity_manager')}



To create a new entity
To delete an entity
To start an entity

To stop an entity
To pause an entity



To run one entity
1 On the View menu, click Entity Manager.
2 Click the name of the entity you want to run.
3 Click the Start Entity button.

Start Entity button

{button Related Topics,PI(`',`IDH_RT_To_run_one_entity')}
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To run all entities
On the Tools menu, click Run Flowchart.

Notes
Entities are executed sequentially. Each entity performs its operations once during each Living 

FlowChart cycle. Although the entities usually are handled in the order in which they appear in the 
Entity Manager, the order is not guaranteed.

Entities move to the next step when all entities have finished one shape action.

{button Related Topics,PI(`',`IDH_RT_To_run_all_entities')}
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To move an entity to a different starting shape
1 On the View menu, click Entity Manager.
2 Select the entity you want to move.
3 Click the Starting Shape button.

Starting Shape button
4 Click the shape where you want the entity to start. 

{button Related Topics,PI(`',`IDH_RT_To_move_an_entity_to_a_different_starting_shape')}
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To select a starting shape for an entity
1 On the View menu, click Entity Manager.
2 Select an entity.
3 Click the Starting Shape button.

Starting Shape button
4 Click the shape where you want the entity to start. 

{button Related Topics,PI(`',`IDH_RT_To_select_a_starting_shape_for_an_entity')}
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To create a new entity
1 On the View menu, click Entity Manager.
2 Click the Add Entity button.

Add Entity button

{button Related Topics,PI(`',`IDH_RT_To_create_a_new_entity')}
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To delete an entity
1 On the View menu, click Entity Manager.
2 Click the entity that you want to delete.
3 Click the Delete Entity button.

Delete Entity button
Note

You also can delete an entity by selecting the entity and clicking Delete.

{button Related Topics,PI(`',`IDH_RT_To_delete_an_entity')}
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Pause Entity button
You use this button in the Entity Manager window to temporarily stop a specific entity's path through
a Living FlowChart that is running. This enables you to examine the lines and shapes around the 
entity to determine if you need to make any changes.

Note
You can run an entity one step at a time only if the shape action is automatic. If the shape 

displays a dialog box, nothing happens.

{button Related Topics,PI(`',`IDH_RT_Pause_Entity_button')}
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To pause an entity
1 On the View menu, click Entity Manager.
2 Click the entity that you want to stop running.
3 Click the Pause Entity button.

Pause Entity button
Note

You can run an entity one step at a time only if the shape action is automatic. If the shape 
displays a dialog box, nothing happens.

{button Related Topics,PI(`',`IDH_RT_To_pause_an_entity')}
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Stop Entity button
You use this button in the Entity Manager window to stop a specific entity's from completing its path 
through a Living FlowChart.

{button Related Topics,PI(`',`IDH_RT_Stop_Entity_button')}
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To stop an entity
1 On the View menu, click Entity Manager.
2 Click the entity that you want to stop running.
3 Click the Stop Entity button.

Stop Entity button

{button Related Topics,PI(`',`IDH_RT_To_stop_an_entity')}
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To start an entity
1 On the View menu, click Entity Manager.
2 Click the name of the entity you want to start.
3 Click the Start Entity button.

Start Entity button

{button Related Topics,PI(`',`IDH_RT_To_start_an_entity')}
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To add an entity to a shape
1 On the View menu, click Entity Manager.
2 Select an existing entity or create a new entity.  How?      

3 Click the Starting Shape button.

Starting Shape button
4 Click the shape where you want to add the entity. 

{button Related Topics,PI(`',`IDH_RT_To_add_an_entity_to_a_shape')}
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To change the name of an entity
1 On the View menu, click Entity Manager.
2 Double-click the name of the entity you want to change.
3 In the Name box, type the new name for the entity.
4 Click OK.

Note
You also can change an entity's name by clicking the entity once, then clicking it again. Type 

the new name, then click once to finish.

{button Related Topics,PI(`',`IDH_RT_To_change_the_name_of_an_entity')}
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To select a symbol for an entity
1 On the View menu, click Entity Manager.
2 Double-click the name of the entity you want to change.
3 In the Symbol box, click the symbol you want to use.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_select_a_symbol_for_an_entity')}
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To select a line color for an entity
1 On the View menu, click Entity Manager.
2 Double-click the name of the entity you want to change.
3 In the Line Color box, click the color you want to use.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_select_a_line_color_for_an_entity')}
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To select a fill color for an entity
1 On the View menu, click Entity Manager.
2 Double-click the name of the entity you want to change.
3 In the Fill Color box, click the color you want to use.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_select_a_fill_color_for_an_entity')}
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To change the size of an entity
1 On the View menu, click Entity Manager.
2 Double-click the name of the entity you want to change.
3 Click either the Small, Medium, or Large option button.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_change_the_size_of_an_entity')}
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To view the data in an entity
On the View menu, click Worksheet.

The worksheet displays each entity's data. 

{button Related Topics,PI(`',`IDH_RT_To_view_the_data_in_an_entity')}
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To run part of a flowchart
1 On the View menu, click Entity Manager.
2 Select an existing entity or create a new entity  How?      and select it.

3 Click the Starting Shape button.

Starting Shape button
4 Click the shape where you want the flowchart to begin running. 

{button Related Topics,PI(`',`IDH_RT_To_run_part_of_a_flowchart')}
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To insert a starting point in a flowchart
1 On the Insert menu, click Starting Point.
2 Click the shape where you want the chart to start running.

{button Related Topics,PI(`',`IDH_RT_To_insert_a_starting_point_in_a_flowchart')}
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Starting Point command

Use the Starting Point command on the Insert menu to place a starting point in a Living FlowChart. 
The starting point is an entity that you place in a shape in the flowchart. When you run the chart, 
the sequence of chart operations will begin at the point where you place the entity (the starting 
point) and run from that point to the end of the chart.
The Starting Point command is useful when you want to run only a part of a Living FlowChart.

Note
If you have multiple entities in a chart and use the Starting Point command, all entities will be 

deleted and a new, single entity will be placed in the shape that you choose.

{button Related Topics,PI(`',`IDH_RT_Starting_Point_command')}
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Living FlowChart Sample Files

FlowCharter includes sample charts that show how you can use its Living FlowCharts feature. When 
we discuss a feature or chart attribute that is used in a sample, we will name the chart that uses it 
so that you can open that chart.
The samples are in a subdirectory of the FlowCharter directory.    For example, if you installed 
FlowCharter in the default directory, the sample charts will be located in C:\Program files\Micrografx\
FlowCharter\Samples\Living FlowCharts.

{button Related Topics,PI(`',`IDH_RT_Living_FlowChart_Sample_Files')}
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Living FlowChart Rules and Limitations

Future versions of    FlowCharter may not be compatible with the Living FlowCharts you create with 
this version of    FlowCharter.    To ensure that users with future versions of FlowCharter can run your 
Living FlowCharts, follow these guidelines:

Document the version of    FlowCharter that you use to create your chart or object, within the 
chart or object.

Provide a readme file with your Living FlowChart. In it, note the version of    FlowCharter that 
users need to run the chart. 

When new versions of    FlowCharter are released, create updated versions of the chart or 
object and make them available to your users, in case they wish to upgrade to the new version of    
FlowCharter.

{button Related Topics,PI(`',`IDH_RT_Living_FlowChart_Rules_and_Limitations')}
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To connect a Living FlowChart shape to a Web site
1 Add a new shape to your chart.
2 Define actions for the shape using the Shape Action Wizard.
3 On the Tools menu, click Edit Object Script.
4 Delete all the script between the first line(the one that starts with (Sub) and the last line(End 

Sub).
5 Type the following code after the first line:

Shape.LinkedChartName = http://www.websitename
Shape.link

6 Add an entity to the shape.  How?     
7 Run the flow chart.

{button Related Topics,PI(`',`IDH_RT_To_connect_a_Living_FlowChart_shape_to_a_Web_site')}
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Action Types
{button Tell me how . . .,PI(`',`IDH_HT_Action_Types')}

You can set up a shape to display a dialog box, so you can prompt the user for information, show 
data in fields, have the user enter data in the fields, and let the user choose the next path out of a 
shape.
You can set up a shape to evaluate and/or change data and decide where to go next.
There are two types of shape actions;    Display a dialog box and Automatically choose a path.
In both shape action types you can select the next path based on the shape's data (shape-based 
path selection) or select the next path based on the path meeting conditions you specify (path-
based path selection).

{button Related Topics,PI(`',`IDH_RT_Action_Types')}
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Understanding Path Selection

A path is a line or series of lines that originate at one shape and terminate at another. The "value" of
a path is the accumulated value of all the lines in a path. You can select a path for the user by using 
the Shape Action Wizard. You can do this with either action type, a dialog box shape, or an 
automatically advancing shape. There are three ways to select paths:

Automatically based on shape data
The chart checks the data in the shape and chooses the next path to take, based on the data 
conditions you specify.

Automatically based on path data
The chart checks the data on the lines leading out of this shape. It chooses the next path by comparing
all the paths to the conditions you specify. The path that meets all conditions is chosen.

Let the user choose the path
Choose this option when you want to provide a button in the dialog box for each path, and let 

the user choose the path by clicking a button.

{button Related Topics,PI(`',`IDH_RT_Path_Selection')}
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To select a path based on shape attributes using a dialog box action type
1 Click a shape on a flowchart.
2 On the Tools menu, click Shape Action Wizard.
3 Click Next.
4 On the Action Type page, choose Display a dialog box, then click Next.
5 On the Dialog Box Options page, choose the options that you want, then click Next.
6 On the Path Selection Method page, click Automatically choose the path.
7 Click Based on Shape Data.
8 Click Next to continue.

{button Related 
Topics,PI(`',`IDH_RT_To_select_a_path_based_on_shape_attributes_using_a_dialog_box_action_type')}
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Path-Based Path Selection
{button Tell me

how . . .,PI(`',`IDH_HT_Path_Based_Path_Selection')}

Use path-based path selection when the information a user enters in the shape is more important 
than the destination. This method is typically used in a decision tree chart.
When a shape selects a path based on path data, the shape checks the value of every available 
path and compares the path values to conditions you specify. 
The shape evaluates the first condition and identifies all of the paths that meet it. (In this way, each 
condition creates a subset of paths.) Then, the shape takes the next condition in the list and applies 
it to the subset of paths from the first condition. This process continues until all conditions have 
been evaluated.
The shape selects the path that meets all of the conditions. If more than one path meets all 
conditions, the shape selects a path arbitrarily. If no paths meet all conditions, the entity stops in 
the shape.
When you use this method of path selection with a dialog box, the dialog box will not have a button 
for each path. (The dialog box displays buttons for each path only when you let the user choose the 
path.) Instead, the dialog box will contain a single Next button. When the user clicks it, the shape 
selects the path and advances the user through the chart accordingly.
A path’s value is the accumulation of the data along the entire path, from the shape where the 
entity started to the ending shape. The value of a path accumulates from the beginning to the 
current shape.    This value is added to the projected ending value for the path.    If you have multiple
branches of multiple paths, each is considered a distinct path and will be evaluated as such.

Requirements
You must have data fields set up.
The data must already be in the chart when the end user runs your chart
You must set up conditions for the path. A path must meet all conditions before it is selected. If

more than one path meets the conditions, the chart selects a path arbitrarily. If no path meets all 
conditions, the chart stops at the shape.

{button Related Topics,PI(`',`IDH_RT_Path_Based_Path_Selection')}
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To select a path based on path attributes using a dialog box action type
1 Click a shape on a flowchart.
2 On the Tools menu, click Shape Action Wizard.
3 Click Next.
4 On the Action Type page, choose Automatically advance, then click Next.
5 On the Dialog Box Options page, choose the options that you want, then click Next.
6 On the Path Selection Method page, click Automatically choose the path.
7 Click Based on Path Data.
8 Click Next to continue.

{button Related 
Topics,PI(`',`IDH_RT_To_select_a_path_based_on_path_attributes_using_a_dialog_box_action_type')}
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Path-Based Path Conditions
{button Tell me

how . . .,PI(`',`IDH_HT_Path_Based_Path_Conditions')}

To use path based path selection, you set up conditions, or tests, which determine where the entity
goes when it leaves the shape. In the Shape Action Wizard, you fill in a form for each condition you 
want the shape to evaluate. In other words, you specify all the conditions the paths must meet to be
selected.
A path-based path condition consists of three parts: Data Field, Method, and Value. You can specify 
one or more conditions.
Remember that the shape evaluates the conditions in the order they appear in a list. 
 Condition 
Part

What to choose What your options are

Data Field Choose the field you want to 
compare

Any field that is set up in the chart.

Method Choose the method of 
comparison you want to use.
Use random distribution if you 
want to randomly select any 
path leaving the shape.

Is Smallest (This method requires 
no value.)
Is Largest (This method requires no 
value.)
Is Equal To (You must specify a 
value if you use this method.)
Is Greater Than    (You must specify 
a value if you use this method.)
Is Less Than (You must specify a 
value if you use this method.)
Randomly Distributed (This method 
requires no value.)

Value Enter the value to use for the 
comparison. 
Some methods do not require 
values.    

Constant Value
Shape’s Data
Accumulated Data

Note
A path must meet all conditions before it is selected.

{button Related Topics,PI(`',`IDH_RT_Path_Based_Path_Conditions')}
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To add a path-based path condition
1 Click the Add button. A condition is added to the end of the list.

Add button
2 Triple-click in the Data Field field and choose the field for the first condition.
3 Click four times in the Method field and choose the method of comparison you want to use.
4 Double-click in the Value field.
5 Either enter the data you want to compare, or choose from one of options in the list.
Note
You can compare the path data to:

data in the shape from any of its fields
accumulated data of any field (the data is accumulated up to, but not including the shape for 

which you are creating an action), 
a value you enter
a constant value. 

{button Related Topics,PI(`',`IDH_RT_To_add_a_path_based_path_condition')}
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To delete a path-based path condition
1 Click on the condition you want to delete.
2 Click the Delete button.

{button Related Topics,PI(`',`IDH_RT_To_delete_a_path_based_path_condition')}
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To rearrange conditions
1 Click a condition you want to move in the list.
2 Click the Up Arrow to move the condition up in the list.

Up Arrow
3 Click the Down Arrow to move the condition down in the list.

Down Arrow

{button Related Topics,PI(`',`IDH_RT_To_rearrange_conditions')}
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Shape-Based Path Selection
{button Tell me

how . . .,PI(`',`IDH_HT_Shape_Based_Path_Selection')}
When you run a chart using shape-based path selection, the chart checks the data in the shape and 
chooses the next path to take, based on the data conditions specified in the shape. Use this method 
when you want to use the data in the shape to decide where to send the user next.
Data in the shape can come from various sources: 

You can get data from the user via the dialog box shape action for this shape.
You can set the chart up with pre-defined data already in the shape, or you can import data 

from a database, Excel file, or text file.
You can evaluate the accumulated data instead of the shape’s data. The accumulated data 

does not include any data in the shape. It includes all data accumulated along the entity’s path up to 
but not including the current shape.

When you use this method of path selection with a dialog box, the dialog box will not have a button 
for each path. (You only get buttons for each path when you let the user choose the path.) Instead, 
the dialog box will contain a single Next button. When the user clicks it, the shape selects the path 
and advances the user through the chart accordingly.

Requirements
This method of path selection is only available if:

You have data fields set up.
The shape contains data—it can already be in the chart or the user can enter the data.
You must set up conditions to determine how the shape will behave. The conditions will be 

evaluated in the order they are listed in the dialog box. The first path that meets a condition will be 
selected.
Notes

You can specify conditions based on the shape's actual data, or based on the value as it has 
accumulated while you have been running the chart. 

You can specify multiple conditions for each path. 

{button Related Topics,PI(`',`IDH_RT_Shape_Based_Path_Selection')}
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Shape-Based Path Conditions
{button Tell me

how . . .,PI(`',`IDH_HT_Shape_Based_Path_Conditions')}

To use shape based path selection, you set up conditions, or tests, which determine how to select 
the next path. In the Shape Action Wizard, you fill in a form for each condition you want to evaluate. 
A shape-based path condition consists of four parts: Path, Data Field, Condition, and Value.
Simply put, the condition reads:

Take <Path> when <Data Field> <Condition> <Value>
FlowCharter evaluates the conditions in order, from top to bottom. The first path that meets a 
condition is the one selected.
You can have more than one condition for a path. You can set up as many conditions as you need 
regardless of how many paths you have.
Condition Part What to choose What your options are
Path Choose the path to take if 

the condition is met.
The Path field lists all of the paths out
of the selected shape.

Data Field Choose the field containing 
the data you want to test.

The Data Field field lists all of the 
data fields in the chart.

Condition Choose the condition you 
want to apply to the data.

Is Equal To (You must specify a value 
if you use this condition.)
Is Greater Than    (You must specify a 
value if you use this condition.)
Is Less Than (You must specify a 
value if you use this condition.)
Always (This condition requires no 
value.)
Never (This condition requires no 
value.)

Value Enter the value to compare 
to the data in the field. You 
can enter a value, or you 
can compare the data to 
data in another field in the 
chart, or to accumulated 
data.

A constant value
Data in another field
Accumulated data field

Notes
When you set up the conditions, make sure you account for all possible data.    If you miss a 

range of data and the user enters data within that range, the chart will stop execution.

{button Related Topics,PI(`',`IDH_RT_Shape_Based_Path_Conditions')}
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To add a shape-based path condition
1 Click the Add button. A condition is added to the end of the list.

Add button
2 Triple-click in the Path field and choose the path for the new condition.
3 Triple-click in the Data Field field and choose the field that has the data you want to evaluate.
4 Triple-click in the Condition field and choose the condition you want to use to evaluate the 
data.
5 Double-click in the Value field.
6 Either enter the data you want to compare with the data in the Data Field field, or choose one 
of the Data Fields or Accumulated Data Fields to use for the comparison.

{button Related Topics,PI(`',`IDH_RT_To_add_a_shape_based_path_condition')}
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To delete a shape-based path condition
1 Click on the condition you want to delete.
2 Click the Delete button.

{button Related Topics,PI(`',`IDH_RT_To_delete_a_shape_based_path_condition')}
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Letting the User Choose the Path
{button Tell me

how . . .,PI(`',`IDH_HT_Letting_the_User_Choose_the_Path')}

This method of path selection is only available in a dialog box shape action type. It lets the user 
choose which path a Living FlowChart takes by clicking on one of a set of buttons that you set up in 
a dialog box.
Use this method:

When you want to know which option a user would choose
When there is no data that you can use to select the path for a user. This is another way of 

collecting information from the user. 

{button Related Topics,PI(`',`IDH_RT_Letting_the_User_Choose_the_Path')}
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To let the user choose a path
1 Click a shape on a flowchart.
2 On the Tools menu, click Shape Action Wizard.
3 Click Next.
4 On the Action Type page, choose Display a dialog box, then click Next.
5 On the Dialog Box Options page, choose the options that you want, then click Next.
6 On the Path Selection Method page, click Let the user choose the path.
7 Click Next to continue.

{button Related Topics,PI(`',`IDH_RT_To_let_the_user_choose_a_path')}
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Verifying Path Names
{button Tell me how . . .,PI(`',`IDH_HT_Verify_Path_Names')}

This page lets you:
Change the labels on the buttons in the dialog box (rename the paths)
Reorder the buttons on the dialog box
Choose which path buttons are visible

{button Related Topics,PI(`',`IDH_RT_Verify_Path_Names')}
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Using VBScript
{button Tell me how . . .,PI(`',`IDH_HT_Using_VBScript')}

Visual Basic Scripting Edition (VBScript) is a subset of Visual Basic for Applications, which is itself a 
subset of Visual Basic. As a result, if you know Visual Basic or Visual Basic for Applications, you can 
use much of your Visual Basic knowledge to work successfully in VBScript. 
Although knowing Visual Basic or VBA give you a big head start in learning VBScript, you need to 
what you cannot do in VBScript that you are used to doing in Visual Basic.
One main difference between VBScript and Visual Basic is that Visual Basic has a design-time 
environment. When you run Visual Basic, you get an interactive shell where you can design forms 
and write script. A VBScript file is a plain text file. Even though VBScript is an interpreted language 
like its parent, you must create VBScript code manually. However, the FlowCharter 7 Script Editor 
offers you a basic editing environment that makes it easier to work with your script.
The other primary difference between VBScript and Visual Basic is the language itself. You cannot 
use exactly the same code in VBScript that you used in Visual Basic. Many of the commands, 
keywords, and data types supported in Visual Basic are not supported in VBScript.

VBScript Limitations
VBScript does not have a debugger like Visual Basic.
VBScript cannot read or write files or make system calls.
VBScript does not have a forms editor.
You don't compile a VBScript program into an EXE file. Scripts are distributed as text files.
VB Script does not support default methods or properties.

{button Related Topics,PI(`',`IDH_RT_Using_VBScript')}
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To copy a script
1 On the Tools menu, click Edit Object Script.
2 Select the script you want to copy.
3 On the Script Editor's Edit menu, click Copy.
4 Close the Script Editor.
5 Click the shape that you want to copy the script to.
6 On the Tools menu, click Edit Object Script.
7 Place the cursor where you want the copied script to appear.
8 On the Script Editor's Edit menu, click Paste.
9 Close the Script Editor.

{button Related Topics,PI(`',`IDH_RT_To_copy_a_script')}
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To create a script using the script editor
1 Select the shape you want to use with your script.
2 On the Tools menu, click Edit Object Script.
3 Type the script you want to use.
4 On the Script Editor's File menu, click Close. Clicking Close (or the X in the upper right corner of 

the Script Editor) automatically saves the script.

{button Related Topics,PI(`',`IDH_RT_To_create_a_script_using_the_script_editor')}
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To change the script for an object
1 Click the shape or line for which you want to change the script.
2 On the Tools menu click Edit Object Script.
3 Make the changes.
4 On the File menu, click Close. Clicking Close (or clicking the X in the upper right corner of the 

window) automatically saves the changes you make.

Note
Changes you make to the code using the Script Editor are not reflected in the Shape Action 

Wizard.    If you make changes using the Shape Action Wizard, the changes you made in the code are 
lost.

{button Related Topics,PI(`',`IDH_RT_To_change_the_script_for_an_object')}
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Edit Object Script command
Use the Edit Object Script command on the Tools menu to add to or change the script that controls 
the actions of a specific object or shape. Editing an object directly enables you to specify actions for 
a shape that you cannot add with the Shape Action Wizard.

Note
You must have an object selected before you can edit its script. If you do not select an object, 

the Edit Object Script command does not appear on the Tools menu. The Edit Chart Script command 
appears instead.

{button Related Topics,PI(`',`IDH_RT_Edit_Object_Script_command')}
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Edit Chart Script command
Use the Edit Chart Script command on the Tools menu to add to or change the script for the current 
chart. Editing the chart's script directly enables you to specify special commands or actions for a 
chart.

Note
The Edit Chart Script command does not appear if you have an object selected. If you select an

object, the Edit Object Script command appears instead. To use the Edit Chart Script command, make 
sure no object is selected on your chart.

{button Related Topics,PI(`',`IDH_RT_Edit_Chart_Script_command')}
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To change the script for a chart
1 Make sure no shapes or lines are selected.
2 On the Tools menu click Edit Chart Script. If Edit Object Script appears on the menu, it means a 

shape or line is currently selected.
3 Make the changes.
4 On the File menu, click Close. Clicking Close (or clicking the X in the upper right corner of the 

window) automatically saves the changes you make.

{button Related Topics,PI(`',`IDH_RT_To_change_the_script_for_a_chart')}
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Using Expressions
{button Tell me how . . .,PI(`',`IDH_HT_Using_Expressions')}

An expression is a statement that yields a result by evaluating or comparing values. Expressions are
used when you set up a shape to automatically process data based on the attributes of a path.    An 
expression can contain any combination of variables, functions, operators, numbers, character 
strings, and constants.
Expressions can be as simple as an arithmetic expression, such as (1 + 1), that produces a numeric 
result (2). Or they can perform complex operations on data, such as the following:

ObjectFields.Item("Weeks", 1) + 10 / CurrentFields.Item("Weeks", 1)
Depending on the result you want, you can combine identifiers, operators, and values in a variety of
ways. You use expressions to combine strings of text, add or multiply numeric values, call functions, 
refer to objects and their values, and perform many other operations.
When you create an expression you must enter the names as they appear in script.    You can either 
type in your expression in the Expression Builder box, or use the Insert Data Field button and Insert 
Function button to build the expression. We recommend that you first use the buttons to build the 
expression, then modify it afterwards, if necessary.
When you use the buttons, notice that the data fields are inserted as they would appear in the 
script. Script is the required format for the expression. You can use any data field or accumulated 
data field in an expression. Even text fields are available in this list. You can use expressions to 
concatenate strings from text fields together.

Note
You can use Boolean operators in expressions, but you must type them in the expression itself.

{button Related Topics,PI(`',`IDH_RT_Using_Expressions')}
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Expression Functions

The following functions are available in the Expression Builder.    Operations are not limited to these 
functions however. You may use any function that is available in VB Script. For example, you can 
have truth evaluations, but you must enter those manually.    The Expression Builder does not 
support truth evaluations but VB Script does. To see a complete description of each function, click its
name.
    Function     Description

Add Function Used to sum two numbers.
Subtract Function Used to find the difference between two numbers or to indicate

the negative value of a numeric expression.
Multiply Function Used to multiply two numbers.
Integer Divide 
Function

Used to divide two numbers and return an integer result.

Floating Point 
Divide Function

Used to divide two numbers and return a floating-point result.

Modulus Function Used to divide two numbers and return only the remainder.
Power Function Used to raise a number to the power of an exponent.
Absolute Value 
Function

Returns the absolute value of a number.

Integer Function Returns the integer portion of a number.
Log Function Returns the natural logarithm of a number.
Exp Function Returns e (the base of natural logarithms) raised to a power.
Random Function Returns a random number.
Sign Function Returns an integer indicating the sign of a number.
Square Root 
Function

Returns the square root of a number.

Arctangent 
Function

Returns the arctangent of a number.

Cosine Function Returns the cosine of an angle.
Sine Function Returns the sine of an angle.
Tangent Function Returns the tangent of an angle.

{button Related Topics,PI(`',`IDH_RT_Expression_Functions')}
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Add Function

Description Used to sum two numbers.
Syntax result = expression1+expression2

The + operator syntax has these parts:
Part Description
result Any numeric variable.
expression1 Any expression.
expression2 Any expression.

Remarks Although you can also use the + operator to concatenate two character strings, you 
should use the & operator for concatenation to eliminate ambiguity and provide self-
documenting code. When you use the + operator, you may not be able to determine 
whether addition or string concatenation will occur. 
The underlying subtype of the expressions determines the behavior of the + operator 
in the following way:
If Then
Both expressions 
are numeric

Add.

Both expressions 
are strings

Concatenat
e.

One expression is 
numeric and the 
other is a string

Add.

If one or both expressions are Null expressions, result is Null. If both expressions are 
Empty, result is an Integer subtype. However, if only one expression is Empty, the 
other expression is returned unchanged as result.

{button Related Topics,PI(`',`IDH_RT_Add_Function')}
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Subtract Function
Description Used to find the difference between two numbers or to indicate the negative value of 

a numeric expression.
Syntax 1 result = number1-number2
Syntax 2 -number

The - operator syntax has these parts:
Part Description
result Any numeric variable.
number Any numeric expression.
number1 Any numeric expression. 
number2 Any numeric expression. 

Remarks In Syntax 1, the - operator is the arithmetic subtraction operator used to find the 
difference between two numbers. In Syntax 2, the - operator is used as the unary 
negation operator to indicate the negative value of an expression.
If one or both expressions are Null expressions, result is Null. If an expression is 
Empty, it is treated as if it were 0.

{button Related Topics,PI(`',`IDH_RT_Subtract_Function')}
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Multiply Function
Description Used to multiply two numbers.
Syntax result = number1*number2. The * operator syntax has these parts:

Part Description
result Any numeric variable.
number1 Any numeric expression.
number2 Any numeric expression. 

Remarks If one or both expressions are Null expressions, result is Null. If an expression is 
Empty, it is treated as if it were 0.

{button Related Topics,PI(`',`IDH_RT_Multiply Function')}
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Integer Divide Function
Description Used to divide two numbers and return an integer result.
Syntax result = number1\number2. The \ operator syntax has these parts:

Part Description
result Any numeric variable.
number1 Any numeric expression.
number2 Any numeric expression. 

Remarks Before division is performed, numeric expressions are rounded to Byte, Integer, or 
Long subtype expressions. If any expression is Null, result is also Null. Any 
expression that is Empty is treated as 0.

{button Related Topics,PI(`',`IDH_RT_Integer_Divide_Function')}
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Floating Point Divide Function
Description Used to divide two numbers and return a floating-point result.
Syntax result = number1/number2 

The / operator syntax has these parts:
Part Description
result Any numeric variable.
number1 Any numeric expression.
number2 Any numeric expression. 

Remarks If one or both expressions are Null expressions, result is Null. Any expression that is 
Empty is treated as 0.

{button Related Topics,PI(`',`IDH_RT_Floating_Point_Divide_Function')}
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Modulus Function
Description Used to divide two numbers and return only the remainder.
Syntax result = number1 Mod number2. The Mod operator syntax has these parts:

Part Description
result Any numeric variable.
Number1 Any numeric expression.
number2 Any numeric expression. 

Remarks The modulus, or remainder, operator divides number1 by number2 (rounding floating-
point numbers to integers) and returns only the remainder as result. For example, in 
the following expression, A (which is result) equals 5.
A = 19 Mod 6.7
If any expression is Null, result is also Null. Any expression that is Empty is treated 
as 0.

{button Related Topics,PI(`',`IDH_RT_Modulus_Function')}
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Power Function
Description Used to raise a number to the power of an exponent.
Syntax result = number^exponent. The ^ operator syntax has these parts:

Part Description
result Any numeric variable.
number Any numeric expression.
exponent Any numeric expression.

Remarks Number can be negative only if exponent is an integer value. When more than one 
exponentiation is performed in a single expression, the ^ operator is evaluated as it 
is encountered from left to right.
If either number or exponent is a Null expression, result is also Null.

{button Related Topics,PI(`',`IDH_RT_Power_Function')}
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Absolute Value Function
Description Returns the absolute value of a number.
Syntax Abs(number). The number argument can be any valid numeric expression. If number 

contains Null, Null is returned; if it is an uninitialized variable, zero is returned.
Remarks The absolute value of a number is its unsigned magnitude. For example, ABS(-1) and 

ABS(1) both return 1.

{button Related Topics,PI(`',`IDH_RT_Absolute_Value_Function')}
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Integer Function
Description Returns the integer portion of a number.
Syntax Int(number)

The number argument can be any valid numeric expression. If number contains Null, 
Null is returned.

Remarks Int removes the fractional part of a number and returns the resulting integer value. If 
the number is negative, Int returns the first negative integer less than or equal to the
number. For example, Int converts -8.4 to -9.

{button Related Topics,PI(`',`IDH_RT_Integer_Function')}
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Log Function
Description Returns the natural logarithm of a number.
Syntax Log(number). The number argument can be any valid numeric expression greater 

than 0.
Remarks The natural logarithm is the logarithm to the base e. The constant e is approximately 

2.718282. You can calculate base-n logarithms for any number x by dividing the 
natural logarithm of x by the natural logarithm of n as follows:
Logn(x) = Log(x) / Log(n)
The following example illustrates a custom Function that calculates base-10 
logarithms:
Function Log10(X)
Log10 = Log(X) / Log(10)
End Function

{button Related Topics,PI(`',`IDH_RT_Log_Function')}
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Exp Function
Description Returns e (the base of natural logarithms) raised to a power.
Syntax Exp(number). The number argument can be any valid numeric expression.
Remarks If the value of number exceeds 709.782712893, an error occurs. The constant "e" is 

approximately 2.718282.
Note The Exp function complements the action of the Log function and is sometimes 

referred to as the antilogarithm.

{button Related Topics,PI(`',`IDH_RT_Exp_Function')}
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Random Function
Description Returns a random number.
Syntax Rnd[(number)]. The number argument can be any valid numeric expression.
Remarks The Rnd function returns a value less than 1 but greater than or equal to 0. The value

of number determines how Rnd generates a random number:
If number is          Rnd generates  
Less than zero The same number every time, using number as the seed.
Greater than zeroThe next random number in the sequence.
Equal to zero The most recently generated number.
Not supplied The next random number in the sequence.
For any given initial seed, the same number sequence is generated because each 
successive call to the Rnd function uses the previous number as a seed for the next 
number in the sequence. Before calling Rnd, use the Randomize statement without 
an argument to initialize the random-number generator with a seed based on the 
system timer. 
To produce random integers in a given range, use this formula:
Int((upperbound - lowerbound + 1) * Rnd + lowerbound)
Here, upperbound is the highest number in the range, and lowerbound is the lowest 
number in the range.

{button Related Topics,PI(`',`IDH_RT_Random_Function')}
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Sign Function
Description Returns an integer indicating the sign of a number.
Syntax Sgn(number). The number argument can be any valid numeric expression.
Return Values

If number is Sgn returns
Greater than zero 1
Equal to zero 0
Less than zero -1

Remarks The sign of the number argument determines the return value of the Sgn function.

{button Related Topics,PI(`',`IDH_RT_Sign_Function')}
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Square Root Function
Description Returns the square root of a number.
Syntax Sqr(number). The number argument can be any valid numeric expression greater 

than or equal to 0.

{button Related Topics,PI(`',`IDH_RT_Square_Root_Function')}
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Arctangent Function
Description Returns the arctangent of a number.
Syntax Atn(number). The number argument can be any valid numeric expression.
Remarks The Atn function takes the ratio of two sides of a right triangle (number) and returns 

the corresponding angle in radians. The ratio is the length of the side opposite the 
angle divided by the length of the side adjacent to the angle.
The range of the result is -pi/2 to pi/2 radians.
To convert degrees to radians, multiply degrees by pi/180. To convert radians to 
degrees, multiply radians by 180/pi.

Note Atn is the inverse trigonometric function of Tan, which takes an angle as its 
argument and returns the ratio of two sides of a right triangle. Do not confuse Atn 
with the cotangent, which is the simple inverse of a tangent (1/tangent).

{button Related Topics,PI(`',`IDH_RT_Arctangent_Function')}
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Cosine Function
Description Returns the cosine of an angle.
Syntax Cos(number). The number argument can be any valid numeric expression that 

expresses an angle in radians.
Remarks The Cos function takes an angle and returns the ratio of two sides of a right triangle. 

The ratio is the length of the side adjacent to the angle divided by the length of the 
hypotenuse. The result lies in the range -1 to 1. To convert degrees to radians, 
multiply degrees by pi/180. To convert radians to degrees, multiply radians by 180/pi.

{button Related Topics,PI(`',`IDH_RT_Cosine_Function')}
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Sine Function
Description Returns the sine of an angle.
Syntax Sin(number). The number argument can be any valid numeric expression that 

expresses an angle in radians.
Remarks The Sin function takes an angle and returns the ratio of two sides of a right triangle. 

The ratio is the length of the side opposite the angle divided by the length of the 
hypotenuse. The result lies in the range -1 to 1.
To convert degrees to radians, multiply degrees by pi/180. To convert radians to 
degrees, multiply radians by 180/pi.

{button Related Topics,PI(`',`IDH_RT_Sine_Function')}
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Tangent Function
Description Returns the tangent of an angle.
Syntax Tan(number). The number argument can be any valid numeric expression that 

expresses an angle in radians.
Remarks Tan takes an angle and returns the ratio of two sides of a right triangle. The ratio is 

the length of the side opposite the angle divided by the length of the side adjacent to 
the angle.
To convert degrees to radians, multiply degrees by pi/180. To convert radians to 
degrees, multiply radians by 180/pi.

{button Related Topics,PI(`',`IDH_RT_Tangent_Function')}



Expression Functions
Using Expressions



Performing Math Operations
{button Tell me

how . . .,PI(`',`IDH_HT_Performing_Math_Operations')}

If you are using an automatically advancing shape action, you can perform math operations on the 
data in the chart. The results of these operations can be passed on as the chart continues to run. 
You can use this feature for a wide variety of reasons.    A couple of examples might be:

Estimating a price based on the chart user's choices
Determining the number of employees needed during a shift, based on current traffic 

conditions
Resetting a value to a default value when the chart meets a condition. (You use an operation to

reset the value. You must design the chart to check for the condition before sending the entity through 
the shape containing this operation.)
Planning for Math Operations

Make sure you have all the fields set up that you will need.    You may need one field that will 
only be used to contain the result of an operation.

When you design your chart, keep in mind that you cannot operate on data and display the 
result to the user within the same shape action.    You will need one shape for the operation and a 
second shape to display the result.

The operations are evaluated in order, from top to bottom.

{button Related Topics,PI(`',`IDH_RT_Performing_Math_Operations')}



To perform math operations
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To perform math operations
1 On the Tools menu, click Shape Action Wizard.
2 Click Next.
3 In the Action Type page, click Automatically choose a path.
4 In the Automatic Options page, choose Yes. Select either Based on Shape Data or Based on Path 

Data. 
5 Click Next.
6 In the Data Field field, triple click to display the list of data fields.
7 Click the data field to which you want to assign the result of the expression.
8 Either use the Insert Data Field button and Insert Function button to build the expression or type 

your expression in the Expression Builder box. 
9 Click Next to continue through the rest of the Shape Action Wizard.

{button Related Topics,PI(`',`IDH_RT_To_perform_math_operations')}
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How Does a Living FlowChart Work?

Any set of shapes connected by lines can be a Living FlowChart. Even a simple set of shapes can be 
run as a Living FlowChart.

Starting and Ending Shapes
The first time you run a chart, you may choose the starting shape. The starting shape represents 
the first step in a process. When you choose the starting shape, FlowCharter places an entity in the
starting shape. 
The starting shape is the shape in which the entity begins its journey through the chart. As you run 
the chart, the entity travels through the chart. The entity's job is to show you where you are in the 
chart and to collect information as it goes. When the entity reaches the end of a path, a Done button
displays in the dialog box. 
The ending shape is the shape at the end of a path. When the entity reaches this shape, a Done 
button appears in the dialog box. 
Lines Are Paths
In a Living FlowChart, a line, or a set of lines, represents a path.      Just as you take a set of streets to
drive to work, an entity takes a set of lines to reach the end of the chart. In each case, you have 
completed a path.
Shapes Contain Actions
When you run a Living FlowChart, you begin to walk through the chart. (The entity actually takes 
this journey for you.) Each time the entity reaches a shape in the Living FlowChart, something 
happens: a dialog box displays or the shape does something automatically. What a shape does is 
called a shape action. Notice that we call it a shape action.    The actions are associated with 
shapes only, not lines or text.
Each shape in a Living FlowChart contains an action.    The action determines what happens when 
you run the chart. When you draw and chart then run it, the chart runs using the default shape 
action. The default action is to display a dialog box for each shape when the Living FlowChart runs.
In other words, each shape in the chart has an action, whether you specifically create one (using the
Shape Action Wizard) or not. If you do nothing, the shape's action is to display a standard dialog 
box. 
The power of a Living FlowChart lies in the shape action.

{button Related Topics,PI(`',`IDH_RT_How_Does_a_Living_FlowChart_Work')}
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Living FlowChart Default Behavior
{button Tell me

how . . .,PI(`',`IDH_HT_Living_FlowChart_Default_Behavior')}

By default, a Living FlowChart displays a standard dialog box for every shape. This standard dialog 
box contains:

The text in the shape
A picture of the shape
The name of the chart in the title bar
A Stop button 
Buttons for every line leaving the shape. 

The labels on the buttons come from the text in the path, either the text on the line or the text in 
the next shape.    The standard dialog box includes a Stop button so the user can stop the chart from
any dialog box along the path.
You can change these default settings in one of two ways:

Run the Shape Action Wizard
Change the script

{button Related Topics,PI(`',`IDH_RT_Living_FlowChart_Default_Behavior')}
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Designing Living FlowCharts
{button Tell me

how . . .,PI(`',`IDH_HT_Designing_Living_FlowCharts')}

Before you start using the Shape Action Wizard and adding features to your Living FlowChart, it's a 
good idea to take some time and make some basic design decisions.

Know your audience. As the chart designer, you typically want someone else to run it. Who are 
they?    How much do they know about the subject of the chart?

Make sure you have a clear idea of what you want to accomplish with the Living FlowChart. A 
chart’s objective affects its layout and design. What is the final outcome of running your chart?

Start by creating a complete flowchart with shapes, lines, and text. A neat, fully labeled chart 
will be easier to work with than a confused, sparsely labeled chart.

Run the flowchart (click Tools then Run Flowchart) after you draw it, and before you start to 
customize the shape actions. This helps you find problems early in the chart’s design that could be 
difficult to find later.

Run the chart after you create each new shape action. This way, you can isolate each new part 
of the chart for testing, making it much easier to find problems.

If you want your user to enter data or view data, set up the necessary data fields. (Click Insert 
then Data Field.)

Before you set up a shape that uses automatic behavior, set up the shape to use dialog box 
behavior with automatic path selection until you have your conditions correct. Use data field entry to 
simulate the results of any data field operations that would take place at this shape.

Determine whether your chart could be improved by using one of the accumulation methods to
gather data from several shapes or lines and displaying the results in a shape.

Remember that you can't manipulate data at the same time you collect data. You need two 
consecutive shapes to do that.

{button Related Topics,PI(`',`IDH_RT_Designing_Living_FlowCharts')}
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Automatically Choosing a Path
{button Tell me

how . . .,PI(`',`IDH_HT_Automatically_Choosing_a_Path')}

This type of shape action lets you send entities through the shape without displaying a dialog box. 
Choose this type of shape action when:

You don't need to exchange information with the user.
You want to skip the shape, and just accumulate its data.
You want to change the shape's data using mathematical expressions.
You want to perform a math operation on accumulated data.

When you automatically advance the entity, you:
Do not display a dialog box for the shape.
Choose the next path for the entity. (If only one line leaves the shape, the path selection 

options are not available because the one line is automatically chosen.)
(Optionally) perform math operations on data.

Note
To automatically choose a path, you must have data fields set up in your chart.

Tips
If you want to automatically advance entities through a shape and you do not have data fields, 

consider removing the shape from your chart.
If you do have data fields set up and the only reason you want to automatically advance the 

entity is to accumulate that data, consider moving the data to the path and deleting the shape.

{button Related Topics,PI(`',`IDH_RT_Automatically_Choosing_a_Path')}
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VBA Features Not Included in VBScript

The following Visual Basic for Applications features are not included in the Visual Basic Scripting 
Edition.
Category Omitted Feature/Keyword

Array Handling Array function
Option Base
Private, Public
Declaring arrays with lower bound <> 0

Collection Add, Count, Item, Remove
Access to collections using ! character (e.g., MyCollection!
Foo)

Conditional 
Compilation

#Const
#If...Then...#Else

Constants/Literals Const
All intrinsic constants
Type-declaration characters (e.g., 256&)

Control Flow DoEvents
For Each...Next
GoSub ... Return, GoTo
On Error GoTo
On ... GoSub, On ... GoTo
Line numbers, Line labels
With ... End With

Conversion CCur, CVar, CVDate
Format
Str, Val 

Data Types All intrinsic data types except Variant
Type ... End Type

Date/Time Date statement, Time statement
Timer 

DDE LinkExecute, LinkPoke, LinkRequest, LinkSend 

Debugging Debug.Print
End, Stop 

Declaration Declare (for declaring DLLs)
Property Get, Property Let, Property Set
Public, Private, Static
ParamArray, Optional
New 

Error Handling Erl
Error
On Error ... Resume
Resume, Resume Next 

File Input/Output All



Financial All financial functions

Object Manipulation CreateObject
GetObject
TypeOf

Objects Clipboard
Collection

Operators Like

Options Deftype
Option Base
Option Compare
Option Private Module

Strings Fixed-length strings
LSet, Rset
Mid Statement
StrConv 

Using Objects TypeName
Collection access using !

{button Related Topics,PI(`',`IDH_RT_VBA_Features_Not_In_VBScript')}
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Introduction page

This page is the first page displayed when you run the Shape Action Wizard. You run the Shape 
Action Wizard any time you want to change a shape's action. These actions then govern the way a 
shape behaves and interacts with the rest of the Living FlowChart.
The Shape Action Wizard lets you change several parts of the shape action, not just the dialog box. 
You can also set up the shape to automatically select the next path for the user, and perform math 
operations on data. 
Running the Shape Action Wizard creates customized code for any shape. The wizard writes a script 
for the selected shape based on the options you choose. If you want to perform some action that is 
not possible through the Shape Action Wizard, you can modify the script or write your own code for 
a shape.



Action Type page

This page enables you to set up a shape to perform in one of two ways:

Display a dialog box
Select this option to show the user a dialog box. The user can enter information in the dialog box, 
view information, or use the box to make a decision that advances the user to the next shape. This 
option is the default selection.

Automatically advance
This option sets the shape to perform calculations on data fields, evaluate that data, then decide 
how to advance to the next shape or path on the chart.



Displays a dialog box that enables the user to decide how to advance from this shape.



Sets up the shape to automatically perform calculations on data fields, evaluate that data, then 
advance based on the results of the evaluation.



Dialog Box Options page

The Dialog Box Options page enables you to select several different options that determine exactly 
how the dialog box that the user sees will look.

Chart Name option button
Selecting this option button uses the file name of your chart as the text for the title bar of the dialog
box. This is the default choice for this option.

Custom option button
When you select this option button the title bar of the dialog box will display whatever you type in 
the text box next to this option. If you click the Custom option button but do not type any text in the
text box, the chart name appears as the dialog box title.

Shape Image check box
Selecting this check box displays a picture of the shape on the left side of the dialog box. This box is 
selected by default.

Stop Button check box
Selecting this check box places a Stop button in the dialog box for a shape. The Stop button enables
a user to stop running the chart at the shape. This gives the user more control over your chart. This 
box is selected by default.

Data Viewing/Entering buttons
If you want your user to see data or enter data for the shape, click the Yes button. If you do not want
the user to see or enter data for this shape, click the No button. If you have not set up data fields for
the chart, this option is not available.



Uses the file name of your chart as the text for the title bar of the dialog box.



Sets the title bar of the user’s dialog box to display whatever you type in the text box next to this 
option.



Displays a picture of the shape on the left side of the dialog box.



Enables a user to view, add, or change data for a shape.



Places a Stop button in the dialog box for a shape, enabling the user to stop running a chart.



Path Selection Method page

This page of the Shape Action Wizard enables you to determine how a user will move from this 
shape to the next shape. You can choose one of three options:

Let the user choose the path
The dialog box will contain a button for each path leading out of the shape. The user chooses a path 
by clicking one of the buttons. This option is the default selection.

Automatically choose the path
The dialog box contains one Next button. The chart automatically moves to the next shape based 
either on data in the current shape or data on paths leading out of the shape.

Based on Shape Data
By setting up conditions based on the data in this shape, you determine which path a user takes out
of this shape.

Based on Path Data
The data on each path leading out of this shape is evaluated against criteria you specify. Only the 
path or paths that meet all of the criteria are selected.



Lets the user choose the path out of a shape by clicking a button in the dialog box.



Causes the chart to automatically move to the next shape based either on data in the current shape
or data on paths leading out of the shape.



Automatically determines which path a user takes out of the current shape based on the data in this
shape.



Automatically evaluates the data on each path leading out of this shape against specified criteria. 
Only the path or paths that meet all of the criteria are selected.



Verify Path Names page

If you are letting the user choose the path out of a shape, this page lets you:
Change the labels on the buttons in the dialog box (rename the paths)
Reorder the buttons on the dialog box
Choose which path buttons are visible

Button Label list
This box lists each button in the dialog box and the text that appears on each button. The buttons 
are listed in the order in which they will appear in the dialog box. You can hide any button by 
clearing the check box next to it. All of the path names are selected by default.

Rename Path button
Click this button to change the name of one of the buttons.

Rename Path button
Move Up One Level button
Click this button to change the order in which the button labels appear by moving the selected label 
up one level.

Move Up One Level button
Move Down One Level button
Click this button to change the order in which the button labels appear by moving the selected label 
down one level.

Move Down One Level button



Lists each button in the dialog box and the text that appears on each button. The buttons are listed 
in the order in which they will appear in the dialog box.



Changes the name or the listed order of the selected button.



Select Layout page

The page enables you to determine how the buttons and other elements are arranged in the dialog 
box.

Layout list box
This box lists all of the available options for arranging this dialog box. As you select an option, the 
picture on the right side of the page changes to show you what the layout will look like.

Test button
Click this button to see how the dialog box for this shape will look when you are finished.



Lists all of the available options for arranging this dialog box. The picture on the right shows the 
layout of each option on the list.



Shows how the dialog box for this shape will look when you finish designing it.



Select Data Fields page

This page enables you to add or remove data fields for this shape. You also can define whether an 
entity that passes through the shape uses the data in the shape or uses data accumulated from 
more than one shape. Finally, you can use this page to determine whether the user can change the 
data in the shape or only look at it.

Shape option button
Select this option button to use the shape's data in calculations. This option is the default selection.

Accumulated option button
Select this option button to use accumulated data in calculations.

Modify option button
Select this option to enable a user to change, add to, or remove the information in the data fields. 
This option is the default selection.

View Only option button
Select this option to prevent a user from modifying the information in the data fields.

Available Fields list box
This box lists all of the data fields that have been set up for your chart.

Used Fields list box
This box lists the data fields that will appear in the dialog box for this shape. The order in which the 
fields are listed in the box determines the order in which they appear in the shape's dialog box.

Move Up One Level button
Click this button to move one of the fields in the Used Fields box up one place on the list.

Move Up One Level button
Move Down One Level button
Click this button to move one of the fields in the Used Fields box down one place on the list.

Move Down One Level button
Add button
Click this button to add a selected field in the Available Fields box to the Used Fields list.

Add All button
Click this button to add all of the fields in the Available Fields box to the Used Fields list.

Remove button
Click this button to remove a selected field from the Used Fields list box.

Remove All button
Click this button to remove all of the fields from the Used Fields list box.



Uses the shape's data in calculations.



Uses accumulated data in calculations.



Enables a user to change, add to, or remove the information in the data fields.



Prevents a user from modifying the information in the data fields.



Lists all of the data fields that are set up for this chart.



Lists the data fields that will appear in the dialog box for this shape in the order in which they will 
appear.



Moves a selected field in the Used Fields box up one place on the list.



Moves a selected field in the Used Fields box down one place on the list.



Adds a selected field in the Available Fields box to the Used Fields list.



Adds all of the fields in the Available Fields box to the Used Fields list.



Removes a selected field from the Used Fields list box.



Removes all of the fields from the Used Fields list box.



Shape Based Selection page

This page enables you to set up data conditions that determine how the shape will behave. The path
taken out of this shape is determined by data entered by a user or by data that has been 
accumulated by this shape and other shapes. The conditions are evaluated in the order they are 
listed in the dialog box. The first path that meets a condition is selected.

Notes
You must have data fields set up.
The shape must contain data—it can already be in the chart or the user can enter the data.

New Path button
Click this button to add a new path and its conditions to the Conditions list box.

New Path button
Delete Path button
Click this button to delete a path and its conditions from the Conditions list box.

Delete Path button
Move Up One Level button
Clicking this button moves the selected path up one place on the list, causing it to be evaluated 
before the path conditions below it.

Move Up One Level button
Move Down One Level button
Clicking this button moves the selected path down one place on the list, causing it to be evaluated 
after the path conditions above it.

Move Down One Level button
Path list
This column in the list box displays each path out of the shape. A path can be on the list more than 
once, depending on the conditions defined for it.

Data Field list
This column displays the data field defined for a listed path. Conditions are placed on a data field to 
define a path.

Condition list
This column displays the condition defined for a listed path. You can choose a condition from the 
drop-down list box by double-clicking on the field then clicking the arrow.

Value list
This column displays the value of the data field that is used by the condition. You can choose a value
from the drop-down list box by double-clicking on the field then clicking the arrow. The value can be 
a number that the user enter, the value of the shape, or an accumulated value.



Adds a new path and its conditions to the Conditions list box.



Deletes a path and its conditions from the Conditions list box.



Moves the selected path up one place on the list, causing it to be evaluated before the path 
conditions below it.



Moves the selected path down one place on the list, causing it to be evaluated after the path 
conditions above it.



Displays each path out of the shape. A path can be on the list more than once, depending on the 
conditions defined for it.



Displays the data field defined for a listed path. Conditions are placed on a data field to define a 
path.



Displays the condition defined for a listed path. You can choose a condition from the drop-down list 
box by double-clicking on the field then clicking the arrow.



Displays the value of the data field that is used by the condition. You can choose a value from the 
drop-down list box by double-clicking on the field then clicking the arrow. The value can be a 
number that the user enter, the value of the shape, or an accumulated value.



Path Based Selection page

This page enables you to specify criteria that determines what shape the user or entity moves to 
after the current shape. In path-based selection, the chart checks the data on the lines leading out 
of a shape. The next path is chosen by comparing the paths to the criteria you specify in this shape. 
Each condition set up narrows the set of possible paths that can be chosen.

Notes
To be selected, a path must meet all criteria defined on this page, in the order the criteria is 

listed.
If no path meets all criteria, the chart will stop running at this shape.

New Data Field button
Click this button to add a new data field to the Criteria list box.

New Data Field button
Delete Data Field button
Click this button to delete a data field from the Criteria list box.

Delete Data Field button
Move Up One Level button
Clicking this button moves the selected data field up one place on the list, causing it to be evaluated
before the data fields below it.

Move Up One Level button
Move Down One Level button
Clicking this button moves the selected data field down one place on the list, causing it to be 
evaluated after the data fields above it.

Move Down One Level button
Data Field list
This column displays the data fields used in the criteria. Conditions are placed on a data field to 
define a path.

Method list
This column displays the condition used to define how the data field interacts with a value. You can 
choose a condition from the drop-down list box by double-clicking on the field then clicking the 
arrow.

Value list
This column displays the value of the data field that is used by the condition. You can choose a value
from the drop-down list box by double-clicking on the field then clicking the arrow. The value can be 
a number that the user enter, the value of the shape, or an accumulated value.



Adds a new data field to the Criteria list box.



Deletes a data field from the Criteria list box.



Moves the selected data field up one place on the list, causing it to be evaluated before the data 
fields below it.



Moves the selected data field down one place on the list, causing it to be evaluated after the data 
fields above it.



Displays the data fields used in the criteria. Conditions are placed on a data field to define a path.



Displays the condition used to define how the data field interacts with a value. You can choose a 
condition from the drop-down list box by double-clicking on the field then clicking the arrow.



Displays the value of the data field that is used by the condition. You can choose a value from the 
drop-down list box by double-clicking on the field then clicking the arrow. The value can be a 
number that the user enter, the value of the shape, or an accumulated value.



Automatic Options page

On this page can define how the chart uses a shape when it processes it automatically (without any 
action by a user).

Do you want to perform math operations?
Select Yes to set up custom math operations that the shape performs using the shape's or path's 
data. Select No if you do not need to modify any data. The default option selection is No.

Based on Shape Data option
Select this option to set up conditions based on the shape's data or accumulated data. These 
conditions determine what paths are taken out of the shape. This option is the default selection.

Based on Path Data option
Select this option to define criteria that a path will need to meet to be selected as a path out of this 
shape.



Selecting Yes lets you modify data fields by setting up custom math operations that the shape 
performs using the shape's or path's data. Selecting No disables the math operations option.



Sets up conditions based on the shape's data or accumulated data. These conditions determine 
what paths are taken out of the shape.



Defines criteria that a path will need to meet to be selected as a path out of this shape.



Data Field Operations page

This page enables you to modify selected data fields by creating customized expressions to use with
data in the fields. These expressions make it possible for you to make a shape perform special 
functions that enable your Living FlowChart to do almost any task.

New Data Field button
Click this button to add a new data field to the Operations list box.

New Data Field button
Delete Data Field button
Click this button to delete a data field from the Operations list box.

Delete Data Field button
Move Up One Level button
Clicking this button moves the selected data field and its expression up one place on the list, 
causing it to be evaluated before the data fields below it.

Move Up One Level button
Move Down One Level button
Clicking this button moves the selected data field and its expression down one place on the list, 
causing it to be evaluated after the data fields above it.

Move Down One Level button
Data Field list
This column displays the data field used in an operation. An expression is then created to use for 
this data field.

Expression list
This column lists the expressions attached to each listed data field.

Expression Builder
You use this box to create an expression. You can use the Insert Data Field and Insert Operation 
buttons to create the expression. Or you can create an expression by typing the expression in the 
box.

Insert Data Field button
Click the button to display a list of the available data fields you can use in the operations.

Insert Operation button
Click this button to display a list of operations that you can insert in expressions. These operations 
are used with the data fields and any information you enter to create the expression



Adds a new data field to the Operations list box.



Deletes a data field from the Operations list box.



Moves the selected data field and its expression up one place on the list, causing it to be evaluated 
before the data fields below it.



Moves the selected data field and its expression down one place on the list, causing it to be 
evaluated after the data fields above it.



Displays the data field used in an operation. An expression is then created to use for this data field.



Lists the expressions attached to each listed data field.



Displays an expression as it is created. You can use the Insert Data Field and Insert Operation 
buttons to create the expression. Or you can create an expression by typing the expression in the 
box.



Displays a list of the available data fields you can use in the operations.



Displays a list of operations that you can insert in expressions. These operations are used with the 
data fields and any information you enter to create the expression.



Finished page

Clicking the Finished button on this page converts the choices you made on the previous pages to a 
script. This script runs whenever an entity reaches this shape. Remember that any script that was 
already written for this shape is replaced when you click the Finish button.
The choices you made as you ran the Shape Action Wizard are not saved until you click the Finished 
button. Clicking the Cancel button erases all of the changes you made when you ran the Shape 
Action Wizard this time.



Understanding Living Shapes
{button Tell me

how . . .,PI(`',`IDH_HT_Understanding_Living_Shapes')}

Living Shapes contain data and code that enables them to perform actions. Every shape with a line 
coming into or going out of it is a Living Shape. 
You can drag these shapes to the palette and store them in the Media Manager then use them in 
any other flowchart. This makes it easy to use a shape and its actions in another chart without 
having to run the Shape Action Wizard or write the same code more than once.

{button Related Topics,PI(`',`IDH_RT_Understanding_Living_Shapes')}



To display a Living Shapes palette
To add a drawn object to a Shape palette 



Living Shapes - Living FlowChart Palette 
Living Shapes - Button Palette 
What Is a Living FlowChart? 



Using Data in a Living FlowChart
{button Tell me

how . . .,PI(`',`IDH_HT_Using_Data_Fields_in_a_Living_FlowChart')}
A Living FlowChart lets you use data in new and powerful ways. Instead of just displaying data, the 
chart can gather data, calculate data, act on the results of the calculation, and display the results in 
different ways. With a Living FlowChart you can:

Create a chart that acts as a custom calculator, designed for your specific needs.
Display data to the user.
Do math operations on data and display the result to the user.
Create a chart with built-in data and that lets the user make choices and identifies the best 

solution based on those choices.
Create a chart with built-in formulas that operate on data that the user provides. The chart 

then displays the result of the operation, thus allowing the user to make informed choices.
Design a chart that collects data from the user and stores it.

You can access two versions of the data:
The data in a shape or line.    
The accumulated data.

{button Related Topics,PI(`',`IDH_RT_Using_Data_Fields_in_a_Living_FlowChart')}



To display data fields in a dialog box 
To enter data for a shape 
To perform data field operations on a shape 
To view the data in an entity 



Automatically Choosing a Path 
Understanding Data Accumulation 
Using Expressions
Expression Functions 



Using the Script Editor
{button Tell me how . . .,PI(`',`IDH_HT_Using_the_Script_Editor')}

When you run the Shape Action Wizard, even if you only create standard dialog boxes, the wizard 
creates a Visual Basic Script. It is this script that tells FlowCharter what each shape does. The script 
is generated as soon as, but not before, you click Finish on the last page of the wizard.
You can use the Script Editor to make changes or additions to the script that the Shape Action 
Wizard creates. You also can create an entirely new, original script, from scratch, using the Script 
Editor. In most cases, you will probably run the Shape Action Wizard then open the Script Editor and 
make changes or additions to the existing script. 

Caution
If you rerun the Shape Action Wizard, you overwrite any manual changes you have 
made to the script!

You can use the Script Editor to create or edit two different types of scripts: object scripts and chart 
scripts. These two types have different uses.

Object Scripts
A shape action is driven by the shape’s (object’s) script. The script determines all the behaviors of 
that object. Script written for one object has no effect on any other object. You can work with object 
script by selecting the object (the shape) you want to edit script for, then selecting Edit Object Script
from the Tools menu. Once you make your changes and leave the Script Editor, the actions of an 
object are changed.
Remember that the script for a shape remains attached to that shape. If you copy the shape into 
another chart, the script goes with it.

Chart Scripts
A chart script governs the behavior of the entire Living FlowChart. You bring up the chart script by 
selecting Edit Chart Script from the Tools menu. 
When the chart script is active, all the events in the procedures drop-down list become chart events.
Any additions or changes you make apply to the entire chart, independent of any object scripts.

{button Related Topics,PI(`',`IDH_RT_Using_the_Script_Editor')}



To create a script using the script editor 
To copy a script 
To change the script for a chart
To change the script for an object 



Script Editor window 
Edit Chart Script command 
Edit Object Script command 

Troubleshooting Living FlowCharts 
Understanding Living FlowChart Events 
Using VBScript 



Script Editor window
{button Tell me how . . .,PI(`',`IDH_HT_Script_Editor_window')}

The Script Editor has two menus that make it easier to work with the script. It has a box that shows 
you which object (identified by a unique number) in your chart you are working with. And it has a 
drop-down list box that lists every event. These parts of the editor are described below.

Object
This box displays the unique number of the object that the script applies to.

Proc
Event procedures are subroutines that are called automatically by FlowCharter as a result of some 
action taken by the user, by FlowCharter, or by the computer. This drop-down list box lists all 
available events. The list of events is different for objects and for charts. The list changes to reflect 
the type of script you are creating.
When you select one of the event procedures from the list box, the program places the object's 
number and the name of the procedure in the Script Editor window. This gives you a bit of a head 
start on your coding.

File
Save As Lets you save script as a text file. 

Reset Lets you discard any changes you make to script.
Print Prints the script.
Print Setup Selects a printer and printer options.
Close Closes the Script Editor and automatically saves any changes you make to script.
Edit
Undo Reverses the last change you made to a script.

Cut Cuts the selected part of a script to the Clipboard.
Copy Copies the selected part of a script to the Clipboard.
Paste Pastes the contents of the Clipboard into the script.
Find Opens the Find window and lets you search for specific parts of a script. 
Replace Replaces specific text with other text.
Go To Opens a window that lets you specify a line number in the script, then moves the cursor to that 
line in the script.

{button Related Topics,PI(`',`IDH_RT_Script_Editor_window')}



To change the script for a chart 
To change the script for an object 
To create a script using the script editor 
To copy a script 



Using the Script Editor 
Edit Chart Script command 
Edit Object Script command 
Understanding Living FlowChart Events 
Using VBScript 



Living Shapes - Button Palette
{button Tell me

how . . .,PI(`',`IDH_HT_Living_Shapes_Button_Palette')}

This palette contains buttons that you can place in a Living FlowChart. Some of the buttons are 
programmed with functions that help run the flowchart. Other buttons can be programmed by a 
chart designer. The shapes in this palette are listed below. Click on a button to find out more about 
it.

Run buttons

Information buttons

Print button

Show/Hide Layer buttons

User-defined buttons

{button Related Topics,PI(`',`IDH_RT_Living_Shapes_Button_Palette')}



To display a Living Shapes palette 



Living Shapes - Living FlowChart Palette 
Understanding Living Shapes 
Shape Palettes Overview 
Run Buttons 

Information Buttons 
Print Button 
Show/Hide Layer Buttons 
User-Defined Buttons 



User-Defined Buttons

This button will perform a task you specify when double-clicked in your chart. See the OLE 
Automation section of the help file for more information on how to program your button.

{button Related Topics,PI(`',`IDH_RT_User_Defined_Buttons')}



Living Shapes - Button Palette 
Run Buttons 
Information Buttons 
Print Button 
Show/Hide Layer Buttons 



Run Buttons

Double-click these buttons in your chart to run your Living FlowChart.

{button Related Topics,PI(`',`IDH_RT_Run_Buttons')}



Living Shapes - Button Palette 
User-Defined Buttons 
Information Buttons 
Print Button 
Show/Hide Layer Buttons



Information Buttons

Use this button as a repository for important information. The information is displayed whenever you
double-click on the button.

{button Related Topics,PI(`',`IDH_RT_Information_Buttons')}



Living Shapes - Button Palette 
User-Defined Buttons 
Run Buttons 
Print Button 
Show/Hide Layer Buttons



Print Button

Double-click on this shape in your chart to print the chart.

{button Related Topics,PI(`',`IDH_RT_Print_Button')}



Living Shapes - Button Palette 
User-Defined Buttons 
Run Buttons 
Information Buttons 
Show/Hide Layer Buttons



Show/Hide Layer Buttons

Use these buttons to show or hide informational layers in your chart.    After the button is in the 
chart, you can right-click on the button to change which layer will be shown or hidden.

{button Related Topics,PI(`',`IDH_RT_Show_Hide_Layer_Buttons')}



Living Shapes - Button Palette 
User-Defined Buttons 
Run Buttons 
Information Buttons 
Print Button 



Living Shapes - Living FlowChart Palette
{button Tell me

how . . .,PI(`',`IDH_HT_Living_Shapes_Living_FlowChart_Palette')}

This palette contains customized shapes you can use in a Living FlowChart. These shapes are 
programmed to perform certain functions in a Living FlowChart. Using them makes it easier to 
design a clear, efficient chart quickly. The shapes in this palette are listed below. Click on a shape to 
find out more about it.

Start

Finish

Status Report

Source

Sink

Queue

Pool

{button Related Topics,PI(`',`IDH_RT_Living_Shapes_Living_FlowChart_Palette')}



To display a Living Shapes palette



Living Shapes - Button Palette 
Understanding Living Shapes 
Shape Palettes Overview 
Start Shape
Finish Shape

Status Report Shape
Source Shape
Sink Shape
Queue Shape
Pool Shape



To display a Living Shapes palette
1 Click the Shape Palettes button to open it, if necessary.

Shape Palettes button.
2 On the Shape palette, click Options.
3 Click Subject.
4 If one of the Living Shapes palettes is not displayed, click Expand All.
5 Double-click either the Living FlowChart palette or the Buttons palette.
6 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_display_a_Living_Shapes_palette')}



Living Shapes - Living FlowChart Palette
Living Shapes - Button Palette



Start Shape

Use this shape as a starting point for your Living FlowChart. An entity will automatically be placed in
this shape when you put it in your chart 

{button Related Topics,PI(`',`IDH_RT_Start_Shape')}



Living Shapes - Living FlowChart Palette
Finish Shape
Status Report Shape
Source Shape

Sink Shape
Queue Shape
Pool Shape
Living Shapes - Button Palette 



Finish Shape

This shape can be used to end your Living FlowChart. Any entity entering this shape will be stopped.

{button Related Topics,PI(`',`IDH_RT_Finish_Shape')}



Living Shapes - Living FlowChart Palette
Start Shape
Status Report Shape
Source Shape

Sink Shape
Queue Shape
Pool Shape
Living Shapes - Button Palette 



Status Report Shape

When an entity enters this shape it displays a dialog showing the current status of all the 
accumulated data fields.

{button Related Topics,PI(`',`IDH_RT_Status_Report_Shape')}



Living Shapes - Living FlowChart Palette
Start Shape
Finish Shape
Source Shape

Sink Shape
Queue Shape
Pool Shape
Living Shapes - Button Palette 



Source Shape

The source generates entities at the frequency you specify.    It keeps a count of all the entities it has
generated during each run of a Living FlowChart. It will also clean up any entities created in previous
runs every time you run your chart. Double-click the shape in your chart to set the entity frequency.

{button Related Topics,PI(`',`IDH_RT_Source_Shape')}



Living Shapes - Living FlowChart Palette
Start Shape
Finish Shape
Status Report Shape

Sink Shape
Queue Shape
Pool Shape
Living Shapes - Button Palette 



Sink Shape

The sink removes any entities that enter it from the chart.    It maintains a count of all entities it has 
removed.

{button Related Topics,PI(`',`IDH_RT_Sink_Shape')}



Living Shapes - Living FlowChart Palette
Start Shape
Finish Shape
Status Report Shape

Source Shape
Queue Shape
Pool Shape
Living Shapes - Button Palette 



Queue Shape

The queue delays any entities that enter it by an amount you specify.    You can also specify the 
maximum number of entities it can hold.    Double-click on the queue in your chart to change it's 
settings.

{button Related Topics,PI(`',`IDH_RT_Queue_Shape')}



Living Shapes - Living FlowChart Palette
Start Shape
Finish Shape
Status Report Shape

Source Shape
Sink Shape
Pool Shape
Living Shapes - Button Palette 



Pool Shape

The pool is a specialized queue.    It accepts and keeps entities until the number of entities reaches 
its overflow amount.    It then allows entities to leave. It allows no more entities than its maximum 
capacity.    If any entity is in the pool longer than the amount specified in the pool's delay, the entity 
will leave regardless of how many entities are in the pool.
Double-click on the pool in your chart to change its settings.

{button Related Topics,PI(`',`IDH_RT_Pool_Shape')}



Living Shapes - Living FlowChart Palette
Start Shape
Finish Shape
Status Report Shape

Source Shape
Sink Shape
Queue Shape
Living Shapes - Button Palette 



Run Chart dialog box

This dialog box gives you two ways to choose a starting shape for your chart.

Choose a starting shape for me
When you select this option, FlowCharter chooses the starting shape and begins running the chart 
from that shape. The program usually chooses the first shape (either at the top or on the left) in the 
chart. If it cannot identify the first shape, it makes a guess. This guess might not be the place where 
you want the chart to begin. Based on what shape the program chooses, consider selecting a shape 
manually or redesigning part of your chart.

Let me choose the starting shape
When you select this option and click OK, your mouse pointer changes to look like the pointer below.

Starting Shape Pointer
You can then move the pointer to the shape you want to choose as the starting shape. When you 
click the shape you want, the chart begins running from that shape.

Note
Although you can choose any shape as your starting shape, not every shape is a good starting 

point for running a Living FlowChart. If you happen to choose a shape that is at the end of a line or 
path, your chart won’t really go anywhere when it runs. Only those shapes that have lines connected 
to them make good starting points for a chart.

{button Related Topics,PI(`',`IDH_RT_Run_Chart_dialog_box')}



Starting Shape 
To insert a starting point in a flowchart 
To run a Living FlowChart 
To select a starting shape for an entity 



Stops a running Living FlowChart.



Pauses a running Living FlowChart. Clicking this again restarts the chart.



Runs through a Living FlowChart step by step.



Using CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Using_CoolSheets')}

CoolSheets are templates designed for several frequently used business charts and structured 
graphics. CoolSheets make layout and design fast and easy. They provide a grid or placeholders in 
which objects can be placed, sized, and aligned automatically. You also get graphic tabs for easy 
page formatting.
You can use CoolSheets to create organization charts, comparison charts, process charts, business 
forms, and many other types of flowcharts. Each CoolSheet contains a specially designed grid. Click 
on the icons below to find out more about each CoolSheet.

Pyramid CoolSheets

Basic CoolSheets

Block CoolSheets

Cascade CoolSheets

Process CoolSheets

Deployment CoolSheets

Comparison CoolSheets

Timeline CoolSheets

Circle-Spoke CoolSheets

Target CoolSheets

DrawBar CoolSheets

Checklist CoolSheets

{button Related Topics,PI(`',`IDH_RT_Using_CoolSheets')}





To create a CoolSheet
To create a block CoolSheet
To create a cascade CoolSheet
To create a deployment CoolSheet

To create a basic CoolSheet
To create a process CoolSheet
To create a pyramid CoolSheet
To change a CoolSheet



CoolSheets command
Block CoolSheet
Cascade CoolSheet
Deployment CoolSheet

Basic CoolSheet
Process CoolSheet
Pyramid CoolSheet
Statistical Process Control Charts



Block CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Block_CoolSheet')}

Block CoolSheets help you create a chart that illustrates a graphical matrix or gives a brief overview
of a process. This type of chart is often used to create a chart that breaks a complex process into 
several large pieces. These large pieces then can be detailed in standard flowcharts. 
For example, the blocks could represent a company's products and services arranged in columns 
and rows. Arrows can indicate transitions between blocks in the chart. Organization charts are a 
type of block chart.

Tip
Before you begin flowcharting a complex process, it is helpful to create a block chart of the 

entire process. This block chart serves as the "big picture" while you create the more detailed 
flowcharts. You may choose to keep the block chart as the top level chart, linking each shape to a more
detailed subchart.

{button Related Topics,PI(`',`IDH_RT_Block_CoolSheet')}



To create a block CoolSheet



Using CoolSheets
CoolSheets command



Cascade CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Cascade_CoolSheet')}

You can use a Cascade CoolSheet to illustrate items in a sequence, such as steps in a process. 
Cascade charts are more interesting visually than linear flowcharts. They also can contain more 
information since they allow for shape overlap.

{button Related Topics,PI(`',`IDH_RT_Cascade_CoolSheet')}



To create a cascade CoolSheet



CoolSheets command
Using CoolSheets



Pyramid CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Pyramid_CoolSheets')}

You can use a Pyramid CoolSheet to create charts that show hierarchical lists, such as those 
illustrating business values and goals or customer requirements. The top of the pyramid typically 
represents the most important or highest-level item or concept.

{button Related Topics,PI(`',`IDH_RT_Pyramid_CoolSheets')}



To create a pyramid CoolSheet



To add levels to a pyramid CoolSheet 
To delete levels from a pyramid CoolSheet 
To unlock pyramid CoolSheet levels 
To unlock pyramid CoolSheet levels 

To split a pyramid level 
CoolSheets command
Using CoolSheets



Basic CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Basic_CoolSheets')}

You can use a Basic CoolSheet to create a grid of squares on your chart. The grid enables you to 
place objects in precise positions on the chart or align them with each other.

{button Related Topics,PI(`',`IDH_RT_Basic_CoolSheets')}



To create a Basic CoolSheet



CoolSheets command
Using CoolSheets



Process CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Process_CoolSheets')}

The Process CoolSheets help you create a specialized type of flowchart. This type of flowchart shows
the details of a process so that it can be readily understood. By understanding how a process flows, 
your quality team can make changes to improve the flow.
FlowCharter 7 makes it easy for you to draw process charts of many styles, using blocks, specialized
symbols, or pictures to depict the operations (that is, the steps) involved in the process. Process 
charts can be used to depict the flow of anything -- from manufacturing activities to paper chases. 
Virtually every task that is performed and every activity that occurs can be documented in a process
chart. 

{button Related Topics,PI(`',`IDH_RT_Process_CoolSheets')}



To create a process CoolSheet



CoolSheets command
Using CoolSheets



Deployment CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Deployment_CoolSheets')}

The Deployment CoolSheets help you create a chart that is used to illustrate the flow of information 
and materials among different organizational units. Deployment flowcharts are useful for identifying 
how time is being used in a process; therefore, they are used frequently in quality management and 
reengineering projects. 

{button Related Topics,PI(`',`IDH_RT_Deployment_CoolSheets')}



To create a deployment CoolSheet



CoolSheets command
Using CoolSheets



Comparison CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Comparison_CoolSheets')}

The Comparison CoolSheets help you create charts that compare items in columns and rows, such 
as products and features.    These charts can represent yes/no relationships (using check marks or 
thumbs up/down) or multiple-value relationships (using filled bullets).    For example, a chart that 
compares various product features may use full, half-full, and empty bullets to represent ratings of 
good, satisfactory, and poor, respectively.

{button Related Topics,PI(`',`IDH_RT_Comparison_CoolSheets')}



To create a comparison CoolSheet



CoolSheets command
Using CoolSheets



Timeline CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Timeline_CoolSheets')}

The Timeline CoolSheets help you create charts that illustrate schedules for tasks, projects, and 
procedures.    Unlike with project management software, you don't need to learn complex 
methodologies.    You can create timelines merely by drawing.

{button Related Topics,PI(`',`IDH_RT_Timeline_CoolSheets')}



To create a timeline CoolSheet



CoolSheets command
Using CoolSheets



Circle-Spoke CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Circle_Spoke_CoolSheets')}

The Circle-Spoke CoolSheets help you create charts that show items in a circular arrangement, 
connected to a center shape.    Spoke charts are useful for illustrating business principles, the key 
benefits of a product, or a product line.

{button Related Topics,PI(`',`IDH_RT_Circle_Spoke_CoolSheets')}



To create a circle-spoke CoolSheet



CoolSheets command
Using CoolSheets



Target CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Target_CoolSheets')}

The Target CoolSheets create a chart that shows how various factors are rated, with each ring 
representing a rating level.    You can use target charts to show concentric rings of focus, such as 
with increasingly focused customer groups and business objectives.

{button Related Topics,PI(`',`IDH_RT_Target_CoolSheets')}



To create a target CoolSheet



CoolSheets command
Using CoolSheets



DrawBar CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_DrawBar_CoolSheets')}

The DrawBar CoolSheets help create bar charts that show rough orders of magnitude or conceptual 
quantitative relationships (for example, something is smaller than or larger than something else). 
These charts, which often are used in market and business planning, are useful for for illustrating 
general relationships rather than precise numbers.

{button Related Topics,PI(`',`IDH_RT_DrawBar_CoolSheets')}



To create a drawbar CoolSheet



CoolSheets command
Using CoolSheets



Checklist CoolSheets
{button Tell me how . . .,PI(`',`IDH_HT_Checklist_CoolSheets')}

The Checklist CoolSheets help you create single or multiple-column visual checklists. You can list 
items and check off those that are completed or of most importance.

{button Related Topics,PI(`',`IDH_RT_Checklist_CoolSheets')}



To create a checklist CoolSheet



CoolSheets command
Using CoolSheets



CoolSheets command
Use the CoolSheets command on the Insert menu to create a CoolSheets template for your chart. 
You can create several CoolSheets, including:

Block CoolSheets
Cascade CoolSheets
Deployment CoolSheets
Basic CoolSheets
Process CoolSheets
Pyramid CoolSheets
Comparison CoolSheets
Timeline CoolSheets
Circle-Spoke CoolSheets
Target CoolSheets
DrawBar CoolSheets
Checklist CoolSheets

{button Related Topics,PI(`',`IDH_RT_CoolSheets_Command')}



Using CoolSheets
To create a CoolSheet
To change a CoolSheet



To create a CoolSheet
1 On the Insert menu, click CoolSheets.
2 Click the type of CoolSheets you want to create.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.

{button Related Topics,PI(`',`IDH_RT_To_create_a_CoolSheet')}



To create a pyramid CoolSheet
To create a basic CoolSheet
To create a block CoolSheet
To create a cascade CoolSheet

To create a process CoolSheet
To create a deployment CoolSheet
To create a comparison CoolSheet
To create a timeline CoolSheet

To create a circle-spoke CoolSheet
To create a target CoolSheet
To create a drawbar CoolSheet
To create a checklist CoolSheet

To change a CoolSheet
Using CoolSheets



To create a block CoolSheet
1 On the Insert menu, click CoolSheet.
2 Click the Block icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.

{button Related Topics,PI(`',`IDH_RT_create_a_block_CoolSheet')}



Block CoolSheets
To change a CoolSheet



To create a cascade CoolSheet
1 On the Insert menu, click CoolSheets.
2 Click the Cascade icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.

{button Related Topics,PI(`',`IDH_RT_create_a_cascade_CoolSheet')}



Cascade CoolSheets
To change a CoolSheet



To create a deployment CoolSheet
1 On the Insert menu, click CoolSheet.
2 Click the Deployment icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.

{button Related Topics,PI(`',`IDH_RT_create_a_deployment_CoolSheet')}



Deployment CoolSheets
To change a CoolSheet



To create a basic CoolSheet
1 On the Insert menu, click CoolSheet.
2 Click the Basic icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.

{button Related Topics,PI(`',`IDH_RT_create_a_Basic_CoolSheet')}



Basic CoolSheets
To change a CoolSheet



To create a process CoolSheet
1 On the Insert menu, click CoolSheet.
2 Click the Process icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.

{button Related Topics,PI(`',`IDH_RT_create_a_process_CoolSheet')}



Process CoolSheets
To change a CoolSheet



To create a pyramid CoolSheet
1 On the Insert menu, click CoolSheet.
2 Click the Pyramid icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.

{button Related Topics,PI(`',`IDH_RT_create_a_pyramid_CoolSheet')}



Pyramid CoolSheets
To add levels to a pyramid CoolSheet
To delete levels from a pyramid CoolSheet
To unlock pyramid CoolSheet levels 

To split a pyramid level 
To change a CoolSheet



To create a comparison CoolSheet
1 On the Insert menu, click CoolSheet.
2 Click the Comparison icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.



Comparison CoolSheets
To change a CoolSheet



To create a timeline CoolSheet
1 On the Insert menu, click CoolSheet.
2 Click the Timeline icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.



Timeline CoolSheets
To change a CoolSheet



To create a circle-spoke CoolSheet
1 On the Insert menu, click CoolSheet.
2 Click the Circle-Spoke icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.



Circle-Spoke CoolSheets
To change a CoolSheet



To create a target CoolSheet
1 On the Insert menu, click CoolSheet.
2 Click the Target icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.



Target CoolSheets
To change a CoolSheet



To create a drawbar CoolSheet
1 On the Insert menu, click CoolSheet.
2 Click the DrawBar icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.



DrawBar CoolSheets
To change a CoolSheet



To create a checklist CoolSheet
1 On the Insert menu, click CoolSheet.
2 Click the Checklist icon.
3 Click OK.
4 Follow the instructions in the CoolSheets wizard.



Checklist CoolSheets
To change a CoolSheet



To change a CoolSheet
1 Click anywhere on the CoolSheet to select it.
2 Click the right mouse button.
3 From the menu that appears, click Edit CoolSheet.
4 Make any changes you want.
5 Click Finished.
6 Click anywhere outside the CoolSheet to continue working.

{button Related Topics,PI(`',`IDH_RT_To_change_a_CoolSheet')}



To resize a CoolSheet
To move a CoolSheet
To add CoolSheet rows or columns
To create a CoolSheet
Using CoolSheets



To resize a CoolSheet
1 Click anywhere on the CoolSheet to select it.
2 Point to a handle. The pointer changes to a two-headed arrow.
3 Press and hold the left mouse button, and drag the handle until the CoolSheet is the size you 

want.
4 Release the mouse button.

Tips
To change the width and height of the CoolSheet proportionally, use the corner handles. To 

change either the width or height, use the middle handles.
To disable proportional resizing, press and hold Shift while you drag a handle.

{button Related Topics,PI(`',`IDH_RT_To_resize_a_CoolSheet')}



To move a CoolSheet
To create a CoolSheet
Using CoolSheets



To move a CoolSheet
1 Click anywhere on the CoolSheet to select it.
2 Press and hold the left mouse button, and drag the CoolSheet to the position you want. A dotted 

rectangle surrounds the CoolSheet and follows the movement of the pointer.
3 Release the mouse button.

Tip
You can also move the CoolSheet with the keyboard and the mouse, combined.    

How?

{button Related Topics,PI(`',`IDH_RT_To_move_a_CoolSheet')}



To resize a CoolSheet
To create a CoolSheet
Using CoolSheets



To move a CoolSheet using the keyboard and the mouse
1 Select the CoolSheet by clicking on it.
2 Hold the left mouse button down and use the keyboard's arrow keys to move the CoolSheet.
3 When the CoolSheet is where you want it to be, release the mouse button.



To add CoolSheet rows or columns
1 Click anywhere on the CoolSheet to select it.
2 Click the right mouse button.
3 From the menu that appears, click Edit CoolSheet.
4 Click the Insert Cell button on the CoolSheets toolbar.

Insert Cell
button

5 Click Row or Column.
6 Click Finished.

{button Related Topics,PI(`',`IDH_RT_To_add_CoolSheet_rows_or_columns')}



To resize a CoolSheet
To move a CoolSheet
To delete CoolSheet rows or columns
To create a CoolSheet
Using CoolSheets



To delete CoolSheet rows or columns
1 Click anywhere on the CoolSheet to select it.
2 Click the right mouse button.
3 Click Edit CoolSheet.
4 Click the Delete Cell button on the CoolSheets toolbar.

Delete Cell
button

5 Click Row or Column.
6 Click Finished.

{button Related Topics,PI(`',`IDH_RT_To_delete_CoolSheet_rows_or_columns')}



To resize a CoolSheet
To move a CoolSheet
To add CoolSheet rows or columns
To create a CoolSheet
Using CoolSheets



To add levels to a pyramid CoolSheet
1 Click anywhere on the CoolSheet to select it.
2 Click the right mouse button.
3 Click Edit CoolSheet.
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5 Click Finished.

{button Related Topics,PI(`',`IDH_RT_To_add_levels_to_a_pyramid_CoolSheet')}



To resize a CoolSheet
To delete levels from a pyramid CoolSheet
Pyramid CoolSheets

To move a CoolSheet
Using CoolSheets



To delete levels from a pyramid CoolSheet
1 Click anywhere on the CoolSheet to select it.
2 Click the right mouse button.
3 From the menu that appears, click Edit CoolSheet.
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5 Click Finished.

{button Related Topics,PI(`',`IDH_RT_To_delete_levels_from_a_pyramid_CoolSheet')}



Pyramid CoolSheets
To add levels to a pyramid CoolSheet
To resize a CoolSheet

To move a CoolSheet
Using CoolSheets



To unlock CoolSheet rows or columns
1 Click anywhere on the CoolSheet to select it.
2 Click the right mouse button.
3 Click Edit CoolSheet.
4 Click either the Unlock Columns or Unlock Rows button on the CoolSheets toolbar.

Unlock Columns 
button

Unlock Rows 
button

5 Click Finished.

{button Related Topics,PI(`',`IDH_RT_To_lock_or_unlock_CoolSheet_tabs')}



To resize a CoolSheet
To move a CoolSheet
To delete CoolSheet rows or columns 
To create a CoolSheet 
Using CoolSheets



To unlock pyramid CoolSheet levels
1 Click anywhere on the CoolSheet to select it.
2 Click the right mouse button.
3 Click Edit CoolSheet.
4 Click the Unlock Levels button on the CoolSheets toolbar.

Unlock 
Levels 
button

5 Click Finished.

{button Related Topics,PI(`',`IDH_RT_To_unlock_Pyramid_CoolSheet_levels')}



To add levels to a pyramid CoolSheet
To delete levels from a pyramid CoolSheet 
To split a pyramid level 
To resize a CoolSheet

To move a CoolSheet
To create a CoolSheet 
Using CoolSheets



To split a pyramid level
1 Click anywhere on the CoolSheet to select it.
2 Click the right mouse button.
3 Click Edit CoolSheet.
4 Click the Split Level button on the CoolSheets toolbar.

Split Level 
button

5 Click Finished.

{button Related Topics,PI(`',`IDH_RT_To_split_Pyramid_CoolSheet_levels')}



To add levels to a pyramid CoolSheet 
To delete levels from a pyramid CoolSheet 
To unlock pyramid CoolSheet levels 
To resize a CoolSheet

To move a CoolSheet
To create a CoolSheet
Using CoolSheets



To add or delete circles from a circle-spoke CoolSheet
1 Click anywhere on the CoolSheet to select it.
2 Click the right mouse button.
3 Click Edit CoolSheet.
4 Click the Insert Circle or Delete Circle button on the CoolSheets toolbar.

Insert Circle 
button

Delete Circle 
button

5 Click Finished.

{button Related Topics,PI(`',`IDH_RT_To_add_delete_circles_from_circlespoke_CoolSheet')}



To create a circle-spoke CoolSheet>procedur
To resize a CoolSheet>procedur
To move a CoolSheet>procedur
To create a CoolSheet>procedur
Using CoolSheets



To add or delete rings from a target CoolSheet
1 Click anywhere on the CoolSheet to select it.
2 Click the right mouse button.
3 Click Edit CoolSheet.
4 Click the Insert Ring or Delete Ring button on the CoolSheets toolbar.

Insert Ring 
button

Delete Ring 
button

5 Click Finished.

{button Related Topics,PI(`',`IDH_RT_To_add_delete_rings_from_target_CoolSheet')}



To create a target CoolSheet
To unlock a ring in a target CoolSheet 
To resize a CoolSheet
To move a CoolSheet

To create a CoolSheet 
Using CoolSheets



To unlock a ring in a target CoolSheet
1 Click anywhere on the CoolSheet to select it.
2 Click the right mouse button.
3 Click Edit CoolSheet.
4 Click the Insert Ring or Delete Ring button on the CoolSheets toolbar.

Insert Ring 
button

Delete Ring 
button

5 Click Finished.

{button Related Topics,PI(`',`IDH_RT_To_unlock_rings_in_target_CoolSheet')}



To create a target CoolSheet 
To unlock a ring in a target CoolSheetIDH_To_unlock_a_ring_in_a_target_CoolSheet  
To resize a CoolSheet
To move a CoolSheet

To create a CoolSheet 
Using CoolSheets



CoolSheets toolbar

The CoolSheets toolbar gives you a quick way to make changes to a CoolSheet. You can use the 
toolbar to add or delete rows, columns, or levels and to lock or unlock CoolSheet tabs. 
The CoolSheets toolbar appears when you when you click Edit CoolSheet from the right mouse 
button menu. The toolbar that displays varies depending on the CoolSheet you selected. The 
CoolSheet toolbars contains the following buttons:

Inserts cells (rows or columns) to a 
CoolSheet.

Deletes cells (rows or columns) from a 
CoolSheet.

Unlocks columns in a CoolSheet.

Unlocks rows in a CoolSheet.

Inserts levels into a pyramid CoolSheet.

Deletes levels from a pyramid CoolSheet.

Unlocks levels from a pyramid CoolSheet.

Splits levels in a pyramic CoolSheet.

Inserts circles into a Circle-Spoke 
CoolSheet.

Delete circles from a Circle-Spoke 
CoolSheet.

Inserts rings into a target CoolSheet.

Deletes rings into a target CoolSheet.

Unlocks rings into a target CoolSheet.

Saves changes to the CoolSheet.

{button Related Topics,PI(`',`IDH_RT_CoolSheets_Toolbar')}



To change a CoolSheet
To resize a CoolSheet
To add CoolSheet rows or columns
To delete CoolSheet rows or columns

To add levels to a pyramid CoolSheet
To delete levels from a pyramid CoolSheet
To create a CoolSheet
Using CoolSheets



Inserts cells (rows or columns) to a CoolSheet.



Deletes cells (rows or columns) from a CoolSheet.



Unlocks columns in a CoolSheet.



Unlocks rows in a CoolSheet.



Inserts levels into a pyramid CoolSheet.



Deletes levels from a pyramid CoolSheet.



Unlocks levels from a pyramid CoolSheet.



Splits levels in a pyramic CoolSheet.



Inserts circles into a Circle-Spoke CoolSheet.



Delete circles from a Circle-Spoke CoolSheet.



Inserts rings into a target CoolSheet.



Deletes rings into a target CoolSheet.



Unlocks rings into a target CoolSheet.



Saves changes to the CoolSheet.



The CoolSheets Toolbar 
The CoolSheets toolbar gives you a quick way to make changes to a CoolSheet. You can use the 
toolbar to add or delete rows, columns, or levels and to lock or unlock CoolSheet levels. 
The CoolSheets toolbar appears when you when you click Edit CoolSheets from the right mouse 
button menu.



Insert CoolSheet dialog box

CoolSheets are templates designed for several frequently used business charts and structured 
graphics. CoolSheets make layout and design fast and easy. They provide a grid or placeholders in 
which objects can be placed, sized, and aligned automatically. You also get graphic tabs for easy 
page formatting.
You can use CoolSheets to create organization charts, comparison charts, process charts, business 
forms, and many other types of flowcharts. Each CoolSheet contains a specially designed grid.

{button Related Topics,PI(`',`IDH_RT_Insert_CoolSheet_dialogbox')}



CoolSheets command
Block CoolSheet
Cascade CoolSheet
Deployment CoolSheet

Basic CoolSheet
Process CoolSheet
Pyramid CoolSheet
Statistical Process Control Charts



Format menu 

Click a command below to learn more about it.
Fill Specifies the background color, fill 

pattern, and pattern color for shapes.
Line Changes the color, weight, and style of 

lines.
Ends Changes the color, size, and arrowhead

type of lines.
Effects Changes the color, style, and depth of 

the effect for an object.
Font Defines the font, size, style (bold, italic,

underline, strikethrough), color of text, 
and whether or not it can be opaque.

Text Alignment Defines the horizontal or vertical 
alignment of text and the text-to-page 
orientation (horizontal or vertical).

Object 
Properties

Displays and defines object information
and behavior.

Chart 
Properties

Specifies master items, data fields, link
and note indicators, and Living 
FlowCharts.

Shape 
Numbering

Hides or displays shape numbers, sets 
the next shape number, automatically 
renumber the shapes, or makes the 
Renumber tool active.

{button Related Topics,PI(`',`IDH_RT_FORMATMENU')}



Fill command
Line command
Ends command
Effects command

Font command
Text Alignment command
Object Properties command
Chart Properties command

Shape Numbering command



Chart Properties command
The Chart Properties command lets you change master items; data field options; link, note, and 
node indicators; and Living FlowCharts options.

Note
The changes you make with this command affect all objects on the chart.

{button Related Topics,PI(`',`IDH_RT_Chart_Command_FC')}



To define master items
To move master items 
To format fields 
To choose indicators for shapes

To set options for Living FlowCharts
Format menu



Changes master items; data field options; link, note, and node indicators; and Living FlowCharts 
options.



Font command
The Font command defines the font, size, style (bold, italic, underline, strikethrough), color of text, 
and whether or not it is opaque.

Tips
If you are creating text, either by typing when a line or shape is selected or by selecting the 

Text Tool and clicking to begin a new text block, the title bar of the dialog box includes "Editor," and the
format you define is applied to any new text you create.

If you have selected text, the title bar of the dialog box includes "Selected Object(s)," and the 
format you define is applied to the selected text and any new text you create.

If you have not selected text, the title bar of the dialog box includes "Chart Default," and the 
format you define is applied to any new text you create.

You also can use the buttons on the Formatting toolbar to specify formats.

{button Related Topics,PI(`',`IDH_RT_Font_Command')}



Format menu
Formatting toolbar 
Determining the Way Text Looks
To choose text styles using the Format menu 



Defines the font, size, style (bold, italic, underline, strikethrough), color of text, and whether or not it
can be opaque.



Text Alignment command
The Text Alignment command defines the horizontal or vertical alignment of text and the text-to-
page orientation (horizontal or vertical).

Tips
If you are creating text, either by typing when a line or shape is selected or by selecting the 

Text tool and clicking to begin a new text block, the title bar of the dialog box includes "Editor," and the
format you define is applied to any new text you create.

If you have selected text, the title bar of the dialog box includes "Selected Object(s)," and the 
format you define is applied to the selected text and any new text you create.

If you have not selected any text, the title bar of the dialog box includes "Chart Default," and 
the format you define is applied to any new text you create.

You also can use the buttons on the Formatting toolbar to specify formats.

{button Related Topics,PI(`',`IDH_RT_Alignment_Command')}



Format menu
Formatting toolbar 
Determining the Way Text Looks
To choose text styles using the Format menu 



Defines the horizontal or vertical alignment of text and the text-to-page orientation (horizontal or 
vertical).



Fill command
The Fill command specifies the background color, fill pattern, and pattern color for shapes.
When you choose this command, the Fill tab of the Format Object dialog box opens.

Tip
You also can use the buttons on the Formatting toolbar to fill shapes and make filled lines.

{button Related Topics,PI(`',`IDH_RT_Fill_Command')}



Format menu
Formatting toolbar 
Determining the Way Shapes Look



Specifies the background color, fill pattern, and pattern color for shapes.



Object Properties command
The Object Properties displays and defines properties of objects. It opens the Object Properties 
dialog box. The Object Properties dialog box shows a picture of the shape, the shape number 
location, and the text area, along with the tools and buttons used to change the properties.
You can change the name of the shape, change its connect points and its number and text area, and
choose other shape property options.

Note
The properties you define are applied only to the selected shape.

{button Related Topics,PI(`',`IDH_RT_Shape_Information_Command')}



Format menu
Determining the Way Shapes Look



Shows the properties of the selected shape and lets you redefine them.
You can change the name of the shape, change its connect points and its number and text area, and
choose other shape property options.



Shape Numbering command
The Shape Numbering command changes the numbering of any selected shapes and new shapes.

Note
The numbering applies to any selected shape(s) in the chart and new shapes.

{button Related Topics,PI(`',`IDH_RT_Shape_Numbering_Command')}



Display Shape Numbers command
Set Next Shape Number command
Renumber tool command
Format menu

Determining the Way Shapes Look



Changes the numbering of the current shape and new shapes.



Display Shape Numbers command
The Display Shape Numbers command hides or displays shape numbers.

{button Related Topics,PI(`',`IDH_RT_Display_Shape_Numbers')}



To hide and display shape numbers
Shape Numbering command
Set Next Shape Number command
Renumber tool command

Format menu



To hide and display shape numbers
1 On the Format menu, click Shape Numbering .
2 Click Display Shape Numbers command.

{button Related Topics,PI(`',`IDH_RT_To_hide_and_display_shape_numbers')}



Shape Numbering command
Display Shape Numbers command
Set Next Shape Number command
Renumber tool command

Format menu



Hides or displays shape numbers.



Set Next Shape Number command
The Set Next Shape Number command lets you to specify whether or not you want the show 
number or renumber option to apply to all shapes, selected shapes, or new shapes.

Note
The numbering applies to the selected shape(s) in the chart and new shapes.

{button Related Topics,PI(`',`IDH_RT_Renumber_command')}



Shape Numbering command
Display Shape Numbers command
To set the next shape number
Set Next Shape Number command

Renumber tool command
Format menu



Specifies whether or not you want the show number or renumber option to apply to all shapes, 
selected shapes, or new shapes.



To set the next shape number
1 On the Format menu, click Shape Numbering.
2 Type the next number and any text you want to appear beside the number in the Next Number 

box.
3 Click OK.

Notes
The number and text you define appear in the next shape you place in the chart. The number 

automatically increases with each new shape.
This feature only affects shapes that are numbered with the Shape Numbering feature. If you 

type a number in the shape, the number cannot be changed via this method.

{button Related Topics,PI(`',`IDH_RT_To_renumber_shapes')}



Shape Numbering command
Display Shape Numbers command
Auto Renumber command
Renumber tool command

Format menu



Auto Renumber command
The Auto Renumber command automatically renumbers the shapes in the active chart.

{button Related Topics,PI(`',`IDH_RT_Auto_Renumber_command')}



Shape Numbering command
Display Shape Numbers command
Set Next Shape Number command
Renumber tool command
Format menu



Automatically renumbers the shapes in the active chart.



To automatically renumber shapes
1 Select the shapes you want to renumber.
2 On the Format menu, click Shape Numbering.
3 Click Auto Renumber.

Note
This feature only affects shapes that are numbered with the Shape Numbering feature. If you 

type a number in the shape, the number cannot be renumbered via this method.

{button Related Topics,PI(`',`IDH_RT_To_automatically_renumber_shapes')}



Shape Numbering command
Display Shape Numbers command
Set Next Shape Number command
Renumber tool command
Format menu



Renumber tool command
The Renumber tool command makes the Renumber tool active so that you can renumber shapes.

{button Related Topics,PI(`',`IDH_RT_Renumber_tool_command')}



To make the Renumber tool active
Shape Numbering command
Display Shape Numbers command
Set Next Shape Number command
Format menu



To make the Renumber tool active
1 On the Format menu, click Shape Numbers.
2 Click Renumber tool on the submenu.

Tip
You also can use the Renumber tool on the Toolbox to renumber shapes.

{button Related Topics,PI(`',`IDH_RT_To_make_the_Renumber_tool_active')}



Shape Numbering command
Display Shape Numbers command
Set Next Shape Number command
Renumber tool command
Format menu



Makes the Renumber tool active so that you can renumber shapes.



Line command
The Line command ets you change the color, weight, and style of lines.

Tip
You also can use the buttons on the Formatting toolbar to specify formats.

{button Related Topics,PI(`',`IDH_RT_Line_Command')}



Format menu
Formatting toolbar 
Determining the Way Lines Look
To choose line styles using the Format menu 



Changes the color, weight, and style of lines.



Ends command
The Ends command changes the color, size, and arrowhead type of lines.

Tip
You also can use the buttons on the Formatting toolbar to specify formats.

{button Related Topics,PI(`',`IDH_RT_Ends_Command')}



Format menu
Formatting toolbar 
Determining the Way Lines Look
To choose line styles using the Format menu 



Changes the color, size, and arrowhead type of lines.



Effects command
The Effects command changes attributes of effects of the object. After you select if the object is to 
have an effect (shadow or 3D), you can change the color, style, and depth of the effect.

Tip
Use the Apply button to make your changes and view the results without closing the dialog 

box.

{button Related Topics,PI(`',`IDH_RT_Effect_Command')}



Format menu
To choose object effects
Formatting toolbar 



To choose object effects
1 To change the effects for existing objects as well as future objects, select the objects you want to 

change.
2 On the Formatting menu, click Effects.
3 Click the Effects tab.
4 To change the effect, click the radio button for the effect you want: None, Shadow, or 3D.
5 To change the effect color, click the down arrow, and click a color on the color palette.
6 To change the effect depth, click the up or down arrow by the Depth box and select the depth 

you want.
7 To change the effect style, click the style you want. Move the scroll bar to find additional styles.

Note
You have to apply shadows to lines separately.

Tip
You also can use the buttons on the Formatting toolbar to specify effects.

{button Related Topics,PI(`',`IDH_RT_To_choose_object_effects')}



Effects command
Format menu
Formatting toolbar 



Changes the color, style, and depth of the effect for an object.



Chart Properties dialog box - Master Items tab
The Chart Properties dialog box - Master Items tab specifies which master items you want to appear 
and to select other master items options. The current master item displays in the associated 
information area.

{button Related Topics,PI(`',`IDH_RT_DB_Format_Chart_MasterItems')}



Chart Properties command
Format menu
To define master items
To move master items 



Chart Properties dialog box - Indicators tab

The Chart Properties dialog box - Indicators tab specifies the indicators for shapes with links or 
notes.

Tips
Link and Note indicators can be no longer than three characters.
The font and text style options affect only the Note and Link indicators and only if the 

indicators are text.
If you select Show Nodes On Lines, but you have no connecting lines, no nodes will appear.    

(Lines that overlap have crossovers instead of nodes.) Nodes appear at end points and where lines 
connect. They help you distinguish between connecting lines and lines that overlap. Nodes are 
represented by small solid circles on lines. You can click a node and drag it to resize or reposition the 
line.

{button Related Topics,PI(`',`IDH_RT_DB_Format_Chart_Indicators')}



Chart Properties command
Format menu
Indicators 
To choose indicators for shapes



Shows and lets you specify which master items are to be displayed. Click the box to select or 
deselect a master item. 
When you click a name in the list, additional options related to the master item will appear on the 
right.



Unchecks all check boxes.



Displays the master item chart name.



Associates text with the page number master item.



Selects the format for the date master item.



Updates date and time master items.



Enters text for Text1 master item.



Enters text for Text2 master item.



Enters path name for file containing the logo master item.



Displays master items on all the pages in the chart.



Displays master items on only the first page in the chart; 



Shows the current placement for the data field and lists available options for you to choose from.



Specifies whether or not you want field names displayed on the chart.



Specifies and allows you to change the number of hours per day for duration fields.



Specifies and allows you to change the number of days per week for duration fields.



Shows the current data fields text font and lets you select another font.



Shows the current data fields text style and lets you select another style.



Shows the current data fields text size and lets you select another size.



Specifies and allows you to change the color for data fields.



Specifies and allows you to change whether or not data fields should be opaque.



Specifies up to three characters to be used as a link indicator.



Specifies whether you want shapes with links to have a shadow, icon indicator, or text indicator.



Specifies up to three characters to be used as a note indicator.



Specifies whether or not you want shapes with notes to display a shadow.



Shows or hides the nodes on line.



Shows the current note and indicator text font and lets you select another font.



Shows the current note and indicator text style and lets you select another style.



Shows the current note and indicator text size and lets you select another size.



Shows the current note and indicator text color and lets you select another color.



Chart Properties dialog box - Living FlowCharts tab
The Chart Properties dialog box - Living FlowCharts tab selects options for working with Living 
FlowCharts. You can hide or display the entity feedback or whether or not to automatically run the 
Living FlowChart after opening it. You can also set the delay for running the Living FlowChart. The 
Password button lets you set up or change the password for the flowchart.

{button Related Topics,PI(`',`IDH_RT_Format_Chart_Living_Flowcharts')}



To set options for Living FlowCharts
Chart Properties command
Format menu!



To set options for Living FlowCharts
1 On the Format menu, click Object Propertie.
2 Click the Living FlowCharts tab.
3 Click the Password button to select or change the password for the Living FlowChart.
4 Leave the Old Password box blank if this is a new password. If you are changing your password, 

type your password in this box.
5 Type your new password into the New Password box.
6 Type your new password into the Verify Password box to ensure you typed what you intended.
7 Click OK.
8 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_set_options_for_Living_Flowcharts')}



What is a Living FlowChart?!
Format menu!



Displays the entity feedback. To not display the feedback, clear the check box.



Runs the Living FlowChart after you open the chart. To manually run the chart after opening, clear 
the check box.



Sets the delay for running the Living FlowChart.



Creates or changes the password for the active Living FlowChart.



Format Font dialog box - Font tab

The Format Font dialog box - Font tab defines the font, size, special effects (bold, italic, underline, 
strikethrough), color, and if you want your text opaque.

Tip
You also can use the buttons on the Formatting toolbar to specify fonts.

{button Related Topics,PI(`',`IDH_RT_DB_Format_Text_Font')}



Format menu!
Determining the Way Text Looks!
To choose text styles using the Format menu! 



Format Font dialog box - Alignment tab

The Format Font dialog box - Alignment tab specifies the horizontal and vertical alignment of text.

Tip
You also can use the buttons on the Formatting toolbar to specify alignment.

{button Related Topics,PI(`',`IDH_RT_DB_Format_Text_Alignment')}



Format menu!
Determining the Way Text Looks!
To choose text styles using the Format menu! 



Shows the current text effects (bold, italic, underline, strikethrough) for you to change. You may 
apply more than one text effect.



Shows the current text effects (bold, italic, underline, strikethrough) for you to change. You may 
apply more than one text effect.



Shows the current text effects (bold, italic, underline, strikethrough) for you to change. You may 
apply more than one text effect.



Shows the current text effects (bold, italic, underline, strikethrough) for you to change. You may 
apply more than one text effect.



Shows the current color and lists available colors for you to choose from.



Indicates whether the shape color will show through the text (not checked) or the text will appear on
a white background (checked).



Provides a preview of the way the text will appear.



Shows the horizontal position of the text (Left, Center, or Right).



Shows the horizontal position of the text (Left, Center, or Right).



Shows the horizontal position of the text (Left, Center, or Right).



Shows the vertical position of the text (Top, Middle, or Bottom).



Shows the vertical position of the text (Top, Middle, or Bottom).



Shows the vertical position of the text (Top, Middle, or Bottom).



Lets you apply vertical orientation for text.



Lets you apply horizontal orientation for text.



Shows the current font and font size and the list of available fonts and sizes.



Format Object dialog box - Fill tab

The Format Object dialog box - Fill tab specifies the background color, fill pattern, and pattern color 
for shapes.

Tips
The Color box determines the background color of the shape.
If you select None for the Color, no pattern will display because the entire shape becomes 

transparent. In fact, if you select None and your shape has a shadow, you will be able to see its 
shadow through the shape.

If you select None for the Pattern, the shape is again transparent (even if you have a color 
applied in the Color box).

If you do not want a transparent shape, make sure Pattern is not None and Color is not None.
Use the Apply button to make your changes and view the results without closing the dialog 

box.

{button Related Topics,PI(`',`IDH_RT_DB_Format_Object_Fill')}



Format menu
Determining the Way Shapes Look



Shows the current fill style and provides other styles you can select.



Shows the current fill foreground color and provides a color palette for other colors you can select.



Shows the current fill pattern color and provides a color palette for other colors you can select.



Provides a sample of pattern styles you can select for your object.



Provides a preview of your changes.



Provides a color palette for you to select the start color of your fill when you select a gradient 
pattern style.



Provides a color palette for you to select the end color of your fill when you select a gradient pattern
style.



Provides a sample of gradient styles you can select for your object.



Format Object dialog box - Effects tab

The Format Object dialog box - Effects tab changes the color, style, and depth of the effect for an 
object.

{button Related Topics,PI(`',`IDH_RT_DB_Format_Object_Effects')}



Format menu
Determining the Way Shapes Look



Shows the current object effect and provides other effects you can select.



Shows the current object color and provides a color palette for other colors you can select.



Shows the object's depth (if shadow or 3D are selected) and lets you enter a value to change the 
depth.



Provides a sample of effect styles you can select for your object.



Provides a preview of your object with your changes.



Format Object dialog box - Line tab

The Format Object dialog box - Line tab changes the type, color, weight, and style of lines.

{button Related Topics,PI(`',`IDH_RT_DB_Format_Line')}



Format menu
Determining the Way Lines Look
To choose line styles using the Format menu 



Format Object dialog box - Ends tab

The Format Object dialog box - Ends tab changes the type and size for line ends and crossovers.

{button Related Topics,PI(`',`IDH_RT_DB_Format_Ends')}



Format menu
Determining the Way Lines Look
To choose line styles using the Format menu 



Shows the current line and lists available types for you to choose from.



Shows the current color and lists available colors for you to choose from.



Shows the current line weight and lists available weights for you to choose from.



Shows the current style and lists available styles (solid, dotted, dashed) for you to choose from.



Provides preview of the way the selected line will appear.



Shows the current arrowhead type and lists available types for you to choose from.



Shows the current arrowhead size and lists available sizes for you to choose from.



Shows the current color and lists available colors for you to choose from.



Shows the current arrowhead type and lists available types for you to choose from.



Shows the current arrowhead size and lists available sizes for you to choose from.



Shows the current color and lists available colors for you to choose from.



Shows the current crossover type for the chart and lists available crossovers for you to choose from.



Shows the current crossover jump size for the chart and lists available sizes for you to choose from.



Provides preview of the way the selected ends and crossovers will appear.



Applies the changes, but does not close the dialog box.



Object Properties dialog box - Properties tab

This dialog box lets you change the name of the shape and choose object properties behavior, such 
as:

Resizing the object proportionally
Using the default style of the shape when dropping the shape into a new chart
Rotating the text when you rotate the shape
Changing the default size of the shape

{button Related Topics,PI(`',`IDH_RT_ObjectProperties_db_Properties')}



To change the properties for new objects
To change the properties of an existing object
Object Properties command 
Format menu 



Object Properties dialog box - Living FlowCharts tab

This dialog box lets you apply a script password for the object, if applicable.

{button Related Topics,PI(`',`IDH_RT_ObjectProperties_db_LivingFlowCharts')}



Object Properties
To change a Living FlowChart's password 
Object Properties command 
Format menu 



Displays the current shape name. You can apply a unique name to the selected shape.



Sets the default behavior to resizing the object proportionally.



Sets the default style of the shape when dropping the shape into a new chart.



Sets the default behavior to rotating text when you rotate the shape.



Sets the default width of the shape.



Sets the default height of the shape.



Displays the object ID the program assigned to the selected object.



Lets you apply a script password for the object, if applicable.



Importing Data into your Chart
{button Tell me

how . . .,PI(`',`IDH_HT_Importing_Data_into_your_Chart')}

One of the options you have for providing data for the shapes in your chart is by importing data into 
a worksheet. The process for importing data into an active chart is:

Set up your data fields
Open the worksheet
Open and follow the Data Import wizard

The following guidelines help you import your data more efficiently:
Note the number of shapes as you will be importing one row of data for every shape.
Note the number of fields and their names so that you can match up the fields when you are 

setting up the import.
Know what kind of data you need, as the Data Import wizard provides you with different file 

formats: Excel files, database files, and text files.
Look at the data you are importing to be sure it is in the basic format of the chart you want to 

import to. For example, is your text file tab-delimited? If not, the entire text file could import as one 
large field.

{button Related Topics,PI(`',`IDH_RT_Importing_Data_into_your_Chart')}



Using Data Fields 
What is a Worksheet? 



To set up a data field 
To enter data in a worksheet 
To enter data in the Field Viewer 
To import data from a database 

To import all data from Excel 
To import selected data from Excel 
To import data from a text file 



Data Import wizard
{button Tell me how . . .,PI(`',`IDH_HT_Importing_Databases')}

When you are confident that your active chart and data file you are importing are compatible, to 
import your data, open the Data Import wizard in one of the following ways:

Click Import Data on the Tools menu
Click the Import Data button

Import Data button
With the Data Import wizard, you can:

Import all of the data in a file into your worksheet or specify the data you want to import.
Select the source of your data (an Excel file, from databases, or from a tab-delimited text file)
Query a database to specify the data you want to import, if you want to specify the data to 

import
Map the selected data fields to those in your worksheet
Place data directly into your active worksheet rows based on the data fields you selected

To provide you with more control over the data that you can bring in, the Data Import wizard has a 
SQL query builder so that you can query a database file for selected fields. Also, with its field 
mapping functionality, you can customize which imported data field goes to which of your active 
worksheet data fields.

Note
You can access the Data Import wizard only if you are in an active worksheet.
The Data Import wizard lets you use data in other databases. The databases from which you 

can import are:
dBASE files
Excel files
FoxPro files
MS Access
Paradox files
Text files
To import one of the supported database, you must have installed the proper database driver 

for that particular database. You install the database driver with the Control Panel command in your 
system Start Up Settings options.

{button Related Topics,PI(`',`IDH_RT_Data_Import_wizard')}



Importing Data into your Chart
What is a Worksheet?
Selecting Database Source
Troubleshooting: Importing Data
Tools Menu



To import data from a database
To import all data from Excel 
To import selected data from Excel 

To import data from a text file 
To set up database as an ODBC data source
To build a query



Troubleshooting: Importing Data
I can't map the fields because no fields are listed in the Import Fields box.
I can't display the Worksheet.
I can't open a database.
All of my data from Excel is imported, and I only wanted some of the data imported.
All of my data from my text file is imported, and I only wanted some of the data imported.
I want to import data, but there is an error message saying data fields are not set up.
No fields show up in my query builder.



What is a Worksheet?
{button Tell me how . . .,PI(`',`IDH_HT_What_Is_Worksheet')}

The worksheet displays the data for your chart even if you entered the data with the Field Viewer or 
imported the data.    The advantage of entering your data directly in the worksheet is that you can 
quickly view and compare the data for all shapes perhaps eliminating some errors in data entry.
The structure of the worksheet is:

Every shape has a corresponding row
Each data field has a corresponding column heading

The worksheet has many features for data entry, display, and modification. For example, ;you can:
Hide the worksheet
Dock (float) the worksheet
Change row or column sizes
Cut, copy, and paste data field information

Notes
Shapes must be present before you can access the Worksheet command.
Data fields must be set up before you can enter data.

Tip
You do not have to close your worksheet to return to the chart. You can display both.

{button Related Topics,PI(`',`IDH_RT_Worksheet_concepts')}



Using Data Fields 
Importing Data into your Chart
Worksheet command
View menu



To enter data in a worksheet 
To change data in a worksheet 
To set up a data field



To enter data in a worksheet
1 Click the Selector tool.

Selector tool
2 Point to the cell in the worksheet that you want to enter data in.
3 Type the data in the cell.
Tip

You can also enter data using the Field Viewer.

{button Related Topics,PI(`',`IDH_RT_To_enter_data_in_a_worksheet')}



To enter data in the Field Viewer 
To set up a data field 
What is a Worksheet
Worksheet command
View menu



To change data in a worksheet
1 Click the Selector tool.

Selector tool
2 Point to the cell in the worksheet that you want to change the data in.
3 Type your changes.
Tip

You can also make changes to data using the Field Viewer.

{button Related Topics,PI(`',`IDH_RT_To_change_data_in_a_worksheet')}



To enter data in the Field Viewer 
To set up a data field 
What is a Worksheet
Worksheet command
View menu



To sort worksheets
1 Place your cursor in your worksheet.
2 Click the right mouse button.
3 Select what object/field to sort by.
4 Select whether to sort in ascending or descending order.
5 Click OK.

{button Related Topics,PI(`',`IDH_RT_To_sort_worksheets')}



What is a Worksheet
Worksheet command
View menu



To change column sizes in your worksheet
1 Click the column you want to resize.
2 Move your cursor along the edge of the column to resize until a double-ended arrow displays.
3 Hold down the left mouse button, and move the arrow until the column is the desired width.

{button Related Topics,PI(`',`IDH_RT_To_change_column_sizes')}



To change row sizes in your worksheet 
What is a Worksheet
Worksheet command
View menu



To change row sizes in your worksheet
1 Click the row you want to resize.
2 Move your cursor along the edge of the row to resize until a double-ended arrow displays.
3 Hold down the left mouse button, and move the arrow until the row is the desired height.

{button Related Topics,PI(`',`IDH_RT_To_change_row_sizes')}



To change column sizes in your worksheet 
What is a Worksheet
Worksheet command
View menu



To hide the worksheet
On the View menu, click Worksheet while in the active worksheet.

or
You can also click the right mouse button while in the active worksheet, and then click Hide.

{button Related Topics,PI(`',`IDH_RT_To_hide_the_worksheet')}



To dock the worksheet 
What is a Worksheet
Worksheet command
View menu



To dock the worksheet
In the active worksheet, click the right mouse button, and click Docking View.

{button Related Topics,PI(`',`IDH_RT_To_dock_the_worksheet')}



To hide the worksheet 
What is a Worksheet
Worksheet command
View menu



Worksheet command
The Worksheet lets you view and change data. You can show or hide the worksheet. You can enter 
data by typing in the worksheet or by using the Field Viewer command. 

Tips
You can change the data by typing over data directly in the worksheet, in the Field Viewer 

dialog box, or on the chart.
To import external data, use the Import Data command or the Import Data button on the Data 

toolbar.

Import Data button

{button Related Topics,PI(`',`IDH_RT_worksheet_command')}



To import data from a database
To set up database as an ODBC data source
To import all data from Excel
To import selected data from Excel
To import data from a text file



Selecting Database Sources
{button Tell me

how . . .,PI(`',`IDH_HT_Selecting_Database_Source')}

To import data, you need to select the database source that has your data. You select the data 
format using the Data Import wizard. The Data Import wizard lists three data formats for your 
selection:

Excel (worksheet with .xls extension)
Database (ODBC data source)
Text (file with .txt extension)

Note
Your ODBC database source is one that you must have set up before importing data. If you do 

not have one set up, the procedure for setting up a database source includes a shortcut that allows 
you to set one up. 
Tip

With Excel files, you can import all data or you can select which data fields you want to import.

{button Related Topics,PI(`',`IDH_RT_Selecting_Database_Source')}



Using Data Fields 
Importing Data into your Chart
Data Import wizard 
What is an ODBC Source? 



To import data from a database
To set up database as an ODBC data source
To import all data from Excel
To import selected data from Excel
To import data from a text file



What is an ODBC Source?
{button Tell me

how . . .,PI(`',`IDH_HT_What_is_an_ODBC_source')}

An Open Database Connectivity (ODBC) data source includes the data you wants to access and the 
information needed to access that data. ODBC is the driver manager and a set of ODBC drivers that 
allow the program access to data using SQL as a standard language. ODBC is needed for the Data 
Import wizard to allow importing data from external databases and to allow custom searches 
(queries) of the database so that you can select specific fields to import.
Examples of data sources are:

A SQL Server database, the server on which it resides, and the network used to access that 
server.

A directory containing a set of dBASE files you want to access.
The Data Import wizard supports the following external databases:

dBASE
Excel
FoxPro
MS Acess 7.0 Database 
Paradox
Text

{button Related Topics,PI(`',`IDH_RT_What_is_an_ODBC_source')}



Using Data Fields 
Importing Data into your Chart
Data Import wizard 
What is an ODBC Source? 



To set up database as an ODBC data source 



How Do I Query a Database?
{button Tell me how . . .,PI(`',`IDH_HT_How_Query_Database')}

A query is a customized search of a database for specific database fields that meet specific 
requirements. A query is customized in that you select which database fields you want to find. 
After you indicate the database source, the Data Imoprt wizard lists the fields in that database. The 
process for querying a database with the Data Import wizard is basically pointing to those fields you 
want to import.    This process is called building a query by the Data Import wizard.
After building your query, you can use the Data Import wizard to tell the program which of the fields 
in your chart to place the data field you are importing. This is called field mapping.

{button Related Topics,PI(`',`IDH_RT_How_Query_Database')}



What is SQL? 
What is a Query Builder? 
What is Field Mapping? 



To build a query 
To execute the last query 
To use an external SQL query 



What is a Query Builder?
{button Tell me

how . . .,PI(`',`IDH_HT_What_Is_a_Query_Builder')}

The SQL Query Builder in the Data Import wizard has two functions:
List the fields in your database file for you to make your selection
Display the fields you have chosen that will make up your query

When you are using the SQL Query Builder in the Data Import wizard, you will point to the fields you 
want to use, and then verify in the SQL Query box that the fields you indicated are in the query.

{button Related Topics,PI(`',`IDH_RT_What_Is_a_Query_Builder')}



What is SQL? 
How Do I Query a Database? 



To build a query 
To use an external SQL query 
To execute the last query 



What is SQL?

Structured Query Language (SQL) is a language the program uses to retrieve, update, and manage 
data. This program uses the information you provide in the Data Import wizard’s SQL Query Builder 
to write a command, or SQL statement, that will actually perform the query of the database. 

{button Related Topics,PI(`',`IDH_RT_What_Is_SQL')}



How Do I Query a Database? 
What is a Query Builder? 



What is Field Mapping?
{button Tell me how . . .,PI(`',`IDH_HT_What_Is_Field_Mapping')}

Field Mapping with the Data Import wizard lets you map the data field you are importing to the data 
field in your chart. The Data Import wizard’s Field Mapping page lists the Import Fields and 
Application Fields. By selecting the Import Field and then the Application field, the two fields are 
mapped.

Tips
You can import the data from a field to more than one field.
You can ignore mapping data.

{button Related Topics,PI(`',`IDH_RT_What_Is_Field_Mapping')}



Importing Data into your Chart 



To map fields 



To import selected data from Excel
1 Use the Data Import wizard to import selected data from Excel.
2 Click Excel file, and click Next.
3 Enter the file name in the Enter the data file name box, and click Next.
4 Select the data you want to import.
5 Click Finish.

Tips
If your chart does not contain as many shapes and lines as rows of data you want to import, 

some data will not be imported.
In the Data Import wizard - Finished page, you may only select consecutive rows of data.

{button Related Topics,PI(`',`IDH_RT_To_import_selected_data_from_Excel')}



To import all data from Excel 
To import data from a database 
To import data from a text file 
Importing Data into your Chart 



To import all data from Excel
1 Use the Data Import wizard to import all data from Excel.
2 In the Data Import wizard - Data Import Type page, click Excel File, and click Next.
3 Enter the file name in the Enter the data file name box, and click Next.
4 Select the data you want to import.
5 Click Finish.

Tips
If your chart does not contain as many shapes and lines as rows of data you want to import, 

some data will not be imported.
In the Data Import wizard - Finished page, you may only select consecutive rows of data.

{button Related Topics,PI(`',`IDH_RT_To_import_all_data_from_Excel')}



To import selected data from Excel 
To import data from a database 
To import data from a text file 
Importing Data into your Chart 



To import data from a text file
1 Use the Data Import wizard to import all data from a text file.
2 In the Data Import wizard - Data Import Type page, click Text File, and click Next.
3 Enter the file name in the Enter the data file name box, and click Next.
4 Select the data you want to import.
5 Click Finish.

Tips
If your chart does not contain as many shapes and lines as rows of data you want to import, 

some data will not be imported.
In the Data Import wizard - Finished page, you may only select consecutive rows of data.

{button Related Topics,PI(`',`IDH_RT_To_import_data_from_text_file')}



To import all data from Excel 
To import selected data from Excel 
To import data from a database 
Importing Data into your Chart 



Data Import wizard - Open File page

The Data Import wizard Open File page lets you open your database file. If the file you want to open 
does not open after you enter the file name in the Enter the data file name box, clicking the Browse 
button displays a list of files.

{button Related Topics,PI(`',`IDH_RT_Open_File_Dialog_Box_DataImportWizard')}



To open a file in Data Import wizard 
Importing Data into your Chart 
Selecting Database Source 



To open a file in Data Import wizard
In the Data Import wizard    - Open File page, enter the file name in the Enter the data file name

box, and click Next.
Note

If the file you want to open does not open after you enter the file name in the Enter the data 
file name box, clicking the Browse button displays a list of files.

{button Related Topics,PI(`',`IDH_RT_To_open_a_file_in_DataImportwizard')}



To import all data from Excel 
To import selected data from Excel 
To import data from a database 
To import data from a text file 
Importing Data into your Chart 



To import data from a database
1 Create one shape for each row you want to import.
2 Set up the fields for the data you want to import.

 
3 On the Tools menu, click Import Data, and then click Next.
4 Click Database, and click Next.
5 Click the database you want to import from, and click Next.
6 Click Query Builder.
7 In the Fields box, hold down the Ctrl key, click each field you want to import, and then click 
OK.
8 Click Next.
9 Click on an Import Field, then click the Application Field where you want to put the data, and 
then click OK.
10 Repeat Step (9) for each Import Field you want to import.

11 Click Next.
12 Select the data you want to import.

13 Click Finish.
Tips

In the SQL Query Builder page, you can select more than one field by holding the Ctrl key.
If the name of the database you want to use does not appear in the Data Source list, you need 

to set it up as a data source.
If your chart does not contain as many shapes and lines as rows of data you want to import, 

some data will not be imported.
In the Data Import wizard - Finished page, you may only select consecutive rows of data.

{button Related Topics,PI(`',`IDH_RT_import_data')}



Data Import wizard
To set up database as an ODBC data source
To build a query
To map fields

Worksheet command
Import Data command
Troubleshooting: Importing Data



To set up database as an ODBC data source
1 Click  
2 Click Add.
3 From the Installed ODBC Drivers list, select the name of the driver that the data source will use.
4 Click OK. A dialog box is displayed.
5 Enter information about the data source, such as its name, version number, or location.

{button Related Topics,PI(`',`IDH_RT_Setting_up_Database')}



The 32bit ODBC utility is missing from your Windows Control Panel. You may not have any ODBC 
drivers installed. ODBC drivers are typically installed when you install database programs or 
spreadsheet programs. If you have such a program on your system and want to import data from it 
into FlowCharter, try running the prorgram's setup utility. Look for an installation option that lets you
install its ODBC driver. Refer to the program's documentation for details.



Data Import wizard
To import data from a database
Worksheet command
Import Data command

Troubleshooting: Importing Data



Data Import wizard - Introduction page
The Data Import wizard Introduction page is the first page you see after:

Clicking Import Data button

Import Data button
Clicking Import Data command
Clicking Data Import wizard command

From this page, you continue with the Data Import wizard. Before you continue, you should have done 
the following:

Created a shape for every row of data you plan to import into the chart
Set up one field for each column of data you plan to import
Set up your database as a database source
Display the worksheet, and click the cell when you want the data to start

If you haven't done one or more of these tasks, click Cancel to leave the Data Import wizard.
Click Related Topics if you need help with any of these tasks.

{button Related Topics,PI(`',`IDH_RT_Data_Introduction_db')}



Data Import wizard
Worksheet command
Import Data command
View Menu

Troubleshooting: Importing Data



Data Import wizard - Data Import Type page
Use the Data Import wizard Import Type page to select the source for your data.

You can select an Excel file, a database source, or a text file.    You can also execute the last query.
If you want to import an entire Excel file, click Excel File. If you want to import an entire text file, click 
Text File.
If you want to import selected parts of an Excel file or a text file, click Database. (You must have the 
Microsoft Excel ODBC driver installed in order to do this.)

{button Related Topics,PI(`',`IDH_RT_Data_Import_Type')}



Data Import wizard
Worksheet command
Import Data command
View Menu

Troubleshooting: Importing Data



Imports an entire Excel file.



Imports a database if your data was created in an ODBC-enabled program. These programs include 
Excel, dBase, FoxPro, Paradox, and Access. To use this option, you must have the ODBC driver for 
the program installed on your PC.



Imports a text tile if your data is in a text file format.



Executes your previous query.



Data Import wizard - Data Source page
The Data Import wizard Data Source page selects the database file.    This page lists the database 
sources:

Excel file
Database
Text file

Notes
The database you select must be ODBC-compliant.
You must have set up the database from the Control Panel before you can import from it.

{button Related Topics,PI(`',`IDH_RT_Data_Sources')}



Data Import wizard
To set up database as an ODBC data source
Troubleshooting: Importing Data



Lists the database sources that you can use. You must have set up your database as an ODBC 
source. 



Data Import wizard - SQL Query page
The Data Import wizard SQL Query page accesses the Query Builder and then enter the query.

You can do the following in this box:
Type in a SQL query
Paste a query from the Clipboard
Automatically enter a query using the Query Builder button

A query appears in this box if you have executed a query previously. You may delete it by pressing 
the Delete key or you may modify it or reuse it. If you click Query Builder and build a new query, it 
will replace the one in the box.

{button Related Topics,PI(`',`IDH_RT_SQL_query_db')}



Data Import wizard
To build a query
Troubleshooting: Importing Data



Builds a query for retrieving data. The Query Builder lets you select data you want to import.



Shows the query that will be used to select the data. You can either enter a SQL query in it or use 
the Query Builder to insert automatically.



To build a query
1 Use the Data Import wizard to select a database.
2 In the Data Import wizard - SQL Query page, click Query Builder.
3 Click the table that has the fields you want to import, if necessary.
4 Hold down the Ctrl key, and click the fields you want to import.
5 Click OK.

{button Related Topics,PI(`',`IDH_RT_Building_Query')}



Data Import wizard
What is a Query Builder? 
What is SQL? 
Troubleshooting: Importing Data



SQL Query Builder page
The SQL Query Builder page lists the fields in the database you selected. Based on your selections, 
the Query Builder writes a query in SQL and inserts it in the query box.

{button Related Topics,PI(`',`IDH_RT_SQL_Query_Builder')}



Data Import wizard
To build a query
Troubleshooting: Importing Data



Lists the tables of your database. Click each table to get its list of fields. Often a database has only 
one tables.



Lists the fields in each table.



Lists your query selections.



To use an external SQL query
1 In the Data Import wizard - SQL Query page, click Query Builder.
2 Click the table that has the fields you want to import, if necessary.
3 Hold down the Ctrl key, and click the fields you want to import.
4 Click OK.

{button Related Topics,PI(`',`IDH_RT_to_use_external_query')}



To execute the last query 
What is a Query Builder? 
What is SQL? 
Importing Data into your Chart 



To execute the last query
1 In the Data Import wizard - Data Import Type page, click Execute Last Query.
2 Click the rows of data you want to import, if necessary.
3 Click Finished.

{button Related Topics,PI(`',`IDH_RT_to_execute_last_query')}



To use an external SQL query 
What is a Query Builder? 
What is SQL? 
Importing Data into your Chart 



Data Import wizard - Field Mapping page
The Data Import wizard Field Mapping page to map the import fields with the fields in your chart.

{button Related Topics,PI(`',`IDH_RT_Data_Field_Mapping')}



Data Import wizard
To map fields
Troubleshooting: Importing Data



Lists the fields you selected to import from your database.



Lists the fields in your chart.



To map fields
1 Use the Data Import wizard - Field Mapping page to map fields.
2 In the Import Fields box, click the field to map.
3 In the Application Fields box, click the field that you want the import information placed. A line 

between the two fields displays when the mapping for those fields is made.
4 Repeat Step 2 until all fields you want mapped are mapped.
5 Click Next.

Tips
You can connect an Import field to more than one Application field by holding down the Ctrl 

key and clicking additional Application fields. The lines between the Import Fields and Application 
Fields display the extra connection.

If the order is already the way you want, click Finish.
To ignore previous mapping, click Ignore Mapping.

{button Related Topics,PI(`',`IDH_RT_Mapping_Data_Fields')}



What is Field Mapping? 
Data Import wizard
Troubleshooting: Importing Data



CIgnores previous mapping.



To select specific data to import
1 In the Data Import wizard - Finished page, point to the data you want and drag the cursor to 

show the range.
2 Click Finish.

Note
If you select more data than there is room for in your worksheet, you will get an error message.

If you click Yes to proceed, the program will import the beginning portion of the data you selected, 
onlyto what will fill your worksheet.

{button Related Topics,PI(`',`IDH_RT_select_specific_data_to_import')}



Using Data Fields 
Data Import wizard 
Importing Data into your Chart 



Data Import wizard - Finished page
The Data Import wizard - Finished page lets you select the data you want to import (if you are 
selecting specifi data), indicate that you are finished with the importing data process and want to 
return to the program with the data, or return to previous wizard pages to change some of your 
selection.

{button Related Topics,PI(`',`IDH_RT_Data_import_wizard_finished_page')}



To select specific data to import 
Importing Data into your Chart 
Data Import wizard 



To create a histogram
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click Histogram, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
Histogram charts can have only two columns.

{button Related Topics,PI(`',`IDH_RT_Creating_a_histogram')}



To import data into your chart
To set up charts
To make a chart 3-D

Histograms
Statistical Process Control Charts (SPC Charts) 



To create a Pareto chart
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click Pareto, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
Pareto charts can have only two columns.

Tip
If you have several categories with small numbers of defects, consider grouping them in a 

category called Other.

{button Related Topics,PI(`',`IDH_RT_Creating_a_pareto')}



To import data into your chart
To set up charts
To make a chart 3-D

Pareto charts 
Statistical Process Control Charts (SPC Charts) 



Applies the changes to your chart or worksheet. Use the Apply button when you want to view the 
results of your changes and leave the dialog box open so you can make more changes.



Displays information about the dialog box.



To create a pie chart
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click Pareto, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
Pie charts can have only two columns.

{button Related Topics,PI(`',`IDH_RT_Creating_a_pie_chart')}



To import data into your chart
To set up charts
To make a chart 3-D
Pie charts

Statistical Process Control Charts (SPC Charts) 



To create an SPC chart
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click the type of chart you want to create, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
Moving Range, Histogram, Pareto, C, and Pie charts can have only two columns.
Run charts must have at least two columns and can have no more than 128 columns.
X Avg, R charts must have at least three columns and can have no more than 26 columns.
P, NP, and U charts can only have three columns.
Scatter charts must have at least three columns and can have no more than 128 columns.

{button Related Topics,PI(`',`IDH_RT_Creating_an_SPC_chart')}



To import data into your chart
Statistical Process Control Charts (SPC Charts) 



To create a scatter chart
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click Scatter chart, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
Scatter charts must have at least three columns and can have no more than 128 columns.

{button Related Topics,PI(`',`IDH_RT_Creating_a_scatter_diagram')}



To import data into your chart
Scatter charts
Statistical Process Control Charts (SPC Charts) 



To create a control chart
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click the type of control chart you want, and click Finish. (Use the More 

button to display information about each chart type.)
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
C charts can have only two columns.
P, NP, and U charts can only have three columns.

{button Related Topics,PI(`',`IDH_RT_Creating_control_charts')}



To import data into your chart
To set up charts
To make a chart 3-D
Control charts

Statistical Process Control Charts (SPC Charts) 



To create a run chart
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click Run chart, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
Run charts must have at least two columns and can have a maximum of 128 columns.

{button Related Topics,PI(`',`IDH_RT_Creating_a_run_chart')}



To import data into your chart
To set up charts
To make a chart 3-D
Run charts

Statistical Process Control Charts (SPC Charts) 



To create an XAvg, R control chart
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click XAvg, R control chart, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
X Avg, R control charts must have at least three columns and can have no more than 26 

columns.

{button Related Topics,PI(`',`IDH_RT_Creating_XAvg_R_control_charts')}



To import data into your chart
To set up charts
To make a chart 3-D
XAvg, R control charts

Statistical Process Control Charts (SPC Charts) 



To create Moving Range charts
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click Moving Range chart, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that you are in DataAnalyzer, that you have an active chart, and that you 

want to create a new chart.
Moving Range charts can have only two columns.

{button Related Topics,PI(`',`IDH_RT_Creating_Moving_Range_charts')}



To import data into your chart
To set up charts
To make a chart 3-D
Moving Range charts

Statistical Process Control Charts (SPC Charts) 



To create P control charts
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click P control chart, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
P control charts can only have three columns.

{button Related Topics,PI(`',`IDH_RT_Creating_P_control_charts')}



To import data into your chart
To set up charts
To make a chart 3-D
P control charts

Statistical Process Control Charts (SPC Charts) 



To create NP control charts
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click NP control chart, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
NP control charts can only have three columns.

{button Related Topics,PI(`',`IDH_RT_Creating_NP_control_charts')}



To import data into your chart
To set up charts
To make a chart 3-D
NP control charts

Statistical Process Control Charts (SPC Charts) 



To create C control charts
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click C control chart, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
C control charts can have only two columns.

{button Related Topics,PI(`',`IDH_RT_Creating_C_control_charts')}



To import data into your chart
To set up charts
To make a chart 3-D
C control charts

Statistical Process Control Charts (SPC Charts) 



To create U control charts
1 On the Insert menu, click SPC chart, and click Next.
2 In the Chart Type list box, click U control chart, and click Finish.
3 On the worksheet, enter the label for each category.
4 Enter the value for each category.
5 Click Chart.

Notes
These steps assume that DataAnalyzer is not active, that you have a chart displayed, and that 

you want to create an SPC chart.
U control charts can only have three columns.

{button Related Topics,PI(`',`IDH_RT_Creating_U_control_charts')}



To import data into your chart
To set up charts
To make a chart 3-D
U control charts

Statistical Process Control Charts (SPC Charts) 



Insert menu

Click a command below to learn more about it.
Link Changes a link for selected objects.
Data Field Creates or arranges a data field.
Legend Hides or shows a chart legend.
Starting 
Point

Selects a starting shape for a Living 
FlowChart.

CoolSheet Inserts a CoolSheet into a chart.
Guideline Adds a guideline to the chart and adjusts 

them.
SPC Chart Inserts a Statistical Process Control chart into 

a flowchart.
Object Inserts a drawing, image, or other object into 

a chart.

{button Related Topics,PI(`',`IDH_RT_InsertMenu')}



Link command 
Data Field command 
Legend command 
Starting Point command 

CoolSheets command 
Guideline command 
SPC Chart command 
Object command (Insert menu) 



Link command
The Link command opens a list of objects linked to the active chart.
Use this command to update the object with changes made in the source file, open the source file, 
change the source file or item, or break the link to the source file.

Note
You can only change the links of linked objects. For example, you cannot break a link of an 

inserted object.

{button Related Topics,PI(`',`IDH_RT_Link_Command')}



To clear links
To group and link objects
To open linked charts
To clear links

To link a shape to another chart
To open linked charts



Legend command
The Legend command in the Insert menu inserts a special shape, the "Legend," which reports the 
totals of the fields. The reported totals reflect the current state of the fields on the chart and update 
automatically when any field changes. As with other shapes the "totals" in this shape will be shown 
in the same font and style as other data.

Note
This legend is not the same as the legend for an SPC chart. To display or hide an SPC chart’s 

legend, activate the SPC chart by double-clicking on it. On the Insert menu, click Legend. An SPC 
chart’s legend identifies the different elements of the SPC chart.

{button Related Topics,PI(`',`IDH_RT_Legend_Command')}



To display or hide a chart legend
Insert menu



To display or hide a chart legend
1 On the Insert menu, click Legend. If the legend was hidden it is now displayed.    If it was shown, 

it is now hidden.
2 Move the shape to where you want it. Move the legend just like any other shape.

Notes
You can select, retype, and style the legend title.
You can replace and style the legend shape.
This legend is not the same as the legend for an SPC chart. To display or hide an SPC chart’s 

legend, activate the SPC chart by double-clicking on it. On the Insert menu, click Legend. An SPC 
chart’s legend identifies the different elements of the SPC chart.

{button Related Topics,PI(`',`IDH_RT_To_display_or_hide_a_FlowCharter_chart_legend')}



Legend Command
Insert menu



SPC Chart command
The SPC Chart command on the Insert menu creates and inserts a SPC (Statistical Process Control) 
data chart.
When you choose this command, the Chart wizard opens to help you choose a SPC chart type.

{button Related Topics,PI(`',`IDH_RT_SPC_Chart_Command')}



Statistical Process Control Charts (SPC Charts)
To create an SPC chart



Selects a starting shape for a Living FlowChart.



Guideline command
The Guideline command on the Insert menu lets you add horizontal or vertical guidelines to a chart. 
Guidelines let you align shapes of different sizes to achieve an attractive, organized appearance for 
the chart. Guidelines do not appear in the printed chart.

{button Related Topics,PI(`',`IDH_RT_Guideline_Command')}



Working with guidelines
To create a guideline
Showing and hiding guidelines
Aligning shapes to guidelines



Object command (Insert menu)
{button OLE

Automation,PI(`',`IDH_OA_InsertObjectFromFile_Method')}
The Object command on the Insert menu lets you insert a new or existing object into a chart from an
OLE-compatible program on your system.
If you insert from an existing file, you can link the object to the source file. You also have the option 
to display the inserted object as an icon instead of a full graphic.

{button Related Topics,PI(`',`IDH_RT_Object_Command')}



To insert a new object in a chart
To insert an object from a file



Changes the link for selected objects.



Attaches fields to shapes so that you can associate data with the shape. Before you can attach fields
to a shape, you must set up the fields. The table of fields includes field names, field type, field 
format, an accumulation method (formula), and an option to show or hide the field descriptions in 
the chart. 



Reports the totals of the fields. The reported totals reflect the current state of the fields on the chart 
and update automatically when any field changes. As with other shapes the "totals" in this shape 
will be shown in the same font and style as other data. The Legend command is in the Insert menu.



Creates and inserts a SPC (Statistical Process Control) data chart. When you choose this command, 
the ABC Chart Wizard opens to help you choose an SPC chart type.



Inserts CoolSheets into a chart.



Adds horizontal or vertical guidelines to a chart. Guidelines let you align shapes of different sizes to 
achieve an attractive, organized appearance for the chart. Guidelines do not appear in the printed 
chart.



Adds horizontal guidelines to a chart.



Adds vertical guidelines to a chart.



Inserts a new or existing object into a chart from an OLE-compatible program on your system.



Insert Object dialog box

The Insert Object dialog box lets you choose an object to insert into your chart. You may create a 
new object or choose an existing one.

{button Related Topics,PI(`',`IDH_RT_Insert_Object_Dialog_Box')}



To insert a new object in a chart
To insert an object from a file
Object command (Insert menu)
Edit menu



Inserts a new object into your chart.
You select an object type from the list of OLE-compatible programs shown in the Object Type list. 
When you click OK, a new, empty object is inserted in the program window, and the object program 
opens for you to fill in the empty object. The object appears in both the object’s program and this 
program at the same time.



Describes what happens when you select the selected object type.



Inserts an existing object into your chart.
You open an existing OLE-compatible file that contains the object you want to insert in FlowCharter. 
The object is embedded into your chart.



# IDH_CSH_Object_Type_Insert_ObjectLists the available types of objects you can insert into your 
chart.



Shows the object as an icon rather than the object itself in your chart. 





Getting Started

{button Show Lessons,JI(`',`IDH_Tutorials')}

FlowCharter tutorials contain several "mini" tutorials that you can work through at your own pace. 
Each tutorial takes less than five minutes to complete.
Before starting the tutorials, you should know how to open menus, choose commands, and select 
objects using a mouse. Each tutorial lets you practice with an existing FlowCharter file, so you 
should know how to open and close files in FlowCharter. 
You can follow the tutorials from first to last, or you can skip to the ones that interest you the most. 
None of the tutorials assume that you have worked through any of the other tutorials. 
The tutorial files are on the CD-ROM in a directory called TUTORIAL.    The files are not automatically 
installed on your PC. You can either use the tutorial files from the CD-ROM, or copy them all to a 
directory on your PC.
If you installed FlowCharter 7 from your network, contact your system administrator to find out 
where the tutorial files are.

Tips
 Use the Browse buttons, 

 and 
--at the top of this window--to advance to the next or previous lesson.

 When you finish each tutorial, do not save changes to it. Just click Close on the File menu, then
click No in the dialog box.



Lessons
Using Help 
Working with Shapes 
Working with Lines 
Creating a Simple Flowchart 
Viewing a Chart 
Attaching Notes and Numbering Shapes 
Entering and Editing Text 
Setting Up a Table for Data 
Enhancing Shapes 
Using Color in a Chart 
Changing the Display Order of Objects 
Customizing the Shape Palette 
Defining Shape Properties 
Creating an Organization Chart 
Creating a Cause-and-Effect Chart 



Using Help

The Help system is the best way to find answers to your FlowCharter questions. The hint line, the 
ToolTips, and the context-sensitive help let you find out quickly how to use FlowCharter features.    
For more information, you can read about FlowCharter concepts and procedures in the Help system.

Tips
The hint line appears in the status bar, at the bottom of the window. The text in the hint line 

changes when the pointer is located over most program elements. 
ToolTips appear when you pause the pointer over a button or tool. ToolTips are on by default, 

but you can turn them off. To do so, click the View menu, click Toolbars, and clear the Show ToolTips 
check box.

In this tutorial, you find help on the window elements using the hint line and ToolTips, and you find 
help on the Open command by several different methods: using context-sensitive help (F1), using 
the table of contents, using the Index, and using the Find tab.

What do you want to 
do?

What kind of Help to 
use

What to do

Find a quick answer to a 
specific question

Index tab In the Index, type a key 
word.

Learn about a 
FlowCharter feature or 
concept

Contents tab In the Contents, double-
click a book you want to 
read, then double-click a 
page you want to read.

Find out what an item is 
in the program

ToolTip
(and if that doesn’t tell 
you enough)

Rest your cursor over the 
item for a moment.    Its 
name will display.

F1
(and if THAT doesn’t tell 
you enough)

Press F1 and read the 
brief description of the 
item.

Index tab Type the name of the item.
There will often be more 
information about it in the 
Help system.

Find out even more 
information (when 
you’ve tried everything 
else and still can’t find 
the information you 
need)

Find tab Use the Find tab when you
can’t find what you’re 
looking for anywhere else.

Getting help for a tool
1 On the File menu, click New.
2 Click Blank Page.
3 Move your pointer over to the Toolbox.
4 Rest the pointer over a tool. The name of the tool appears in a "ToolTip."

The text in the status bar describes the function of the tool or button under the pointer.
5 Move the pointer over the toolbars, and the Shape Palette (press F9 if it is not displayed).



6 On the View menu, click Toolbars.
7 Click Show ToolTips to turn this feature on and off.

{button < Back,JI(`>Larget',`IDH_Using_On_line_Help');cw(`proctut')}          {button Next 
>,JI(`',`IDH_Using_F1_for_Context_Sensitive_Help')}          



Getting help for a command
1 Click the Tools menu.
2 Press the DOWN ARROW key until the Spelling command is highlighted. (Do not click on it.)
3 Press F1. Information about the Spelling command displays.

Tip
You can click the Help button 

 on the Standard toolbar, then click a command on a menu or a button on the toolbar to display a help
message for the command or button.

{button < Back,JI(`',`IDH_Using_the_Hint_Line_and_Bubble_Help')}          {button Next 
>,JI(`',`IDH_Searching_for_a_help_topic')}          



Searching for help on a specific topic
Searching for a help topic is like using a book’s index. Use the Index tab when you want information 
about something specific, like a specific task or program element. For example, to find help for 
importing data into an SPC chart, base your search on the word "data."
1 Click the Help Topics button at the top of this window. (Move the Help Topics dialog box to the 

left, so you can see both this window and the dialog box.)
2 Click the Index tab.
3 Type Data. The search list shows entries beginning with "Data."

Normally, you would double-click a subentry to display information about it. (We want you to 
continue working through the tutorial though, so please continue the tutorial and experiment 
with the index later.)

4 Click the  button to close the Help Topics dialog box and return to this tutorial.

Tip
You can also use the Find tab to search for a word or phrase located in any help topic.

{button < Back,JI(`',`IDH_Using_F1_for_Context_Sensitive_Help')}          {button Next 
>,JI(`',`IDH_Using_the_Subject_Index')}          



Find Tab
If this is the first time you have ever clicked on the Find tab, a wizard will come up.    When you are 
finished answering the questions, the Find tab will display its contents.
The Find tab is a list of every single word and phrase appearing in the Help system. 
To use the Find tab
1 In the top field, type a word or several words that you want to find. As you type, notice that the 

words in the middle box change.
2 In the middle box, double-click on a matching word to narrow the search.
3 In the bottom box, a list of topic titles displays. Double-click the topic title you want to read.



Using the help contents
You can use the help contents like the table of contents of a book. Use the Contents tab when you 
want to find related information grouped together. 
For example, when you want to find out what you can do with text in FlowCharter, you can look in 
the book called "Working with Text."
1 Click the Help Topics button at the top of this window. (Move the Help Topics dialog box to the 

left, so you can see both this window and the dialog box.)
2 Click the Contents tab.
3 Scroll down and double-click the “Working with Text” book. Here you see a list of topics that tell 

you about using text in FlowCharter.
Normally, you would double-click a page to read about something. Now, we just want you to look 
at the list of topics in the Contents. (We don't want you to close the tutorial just yet.)
Topics that start with the word "To" are procedures. They tell you how to do something.    
Procedures display in yellow windows on the right side of the screen.    They stay on top of other 
windows so that you can use the program and read the procedure at the same time.
Topics that start with a verb form ending with "ing" tell you about something that you can do, but
do not contain steps.    They often have a "Tell me how . . ." button to get you to a topic which 
does, however.
Topics starting with nouns or noun phrases describe a concept or program element.
Most topics have a Related Topics button. When you click one, a short menu displays with a list of
related help topics that may interest you.

4 Click  to close the Help Topics dialog box and return to this tutorial.

{button < Back,JI(`',`IDH_Searching_for_a_help_topic')}                    {button Next 
>,JI(`',`IDH_The_OLE_Automation_Button')}          



 The OLE Automation Button - For Developers Only

The OLE Automation button, , displays information related to the current topic for 
people writing OLE Automation programs in Visual Basic or C++.

To run another tutorial, click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Using_the_Subject_Index')} 



Creating a Simple Flowchart
FlowCharter makes it easy to create flowcharts. You can draw shapes and lines and enter text 
quickly and effortlessly.
In this tutorial, you place shapes in a chart, connect shapes with a line, and enter text in shapes. 



To create a simple flowchart - Page 1 of 3
You use the Shape tool to place shapes.
You select the shape you want to place from the Shape Palette .
To select a shape which is already placed on the chart, you use the Selector tool.

1 On the File menu, click New. 
2 Click Blank Page. FlowCharter opens a blank chart window.
3 Click the View Shape Palettes button to open the Shape palette if it isn't already open.

View Shape Palettes button
4 Click the top left shape (the Process shape) in the Standard Shape palette.
5 Click the Shape tool at the left of the chart.

Shape tool
6 Click in the chart window. A new shape is drawn automatically.
7 Point inside the shape, press and hold the left mouse button, and drag the pointer away from 
the shape. When you let go of the mouse button, another shape is drawn, connected to the first shape 
by a line. 
8 Move the pointer away from the second shape and click the left mouse button. Another shape is 

drawn, but it is not connected to the second shape.
{button Illustration,PI(`',`IDH_POP_Example1')}

{button < Back,JI(`>LargeT',`IDH_Creating_a_Simple_Flowchart');CW(`Proctut')}                    {button 
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To create a simple flowchart - Page 2 of 3
You use the Line tool to draw lines that connect shapes. Several line types and line styles are 
available.
1 Click the Connector Line tool.

Connector Line tool
2 Move the pointer to the center of the second shape, and click the left mouse button.
3 Slowly move the pointer outside of shape 2. 

As you move the pointer, the green connect points display. As the pointer crosses the edge of 
the shape, the green connect points no longer display, and the connect point that will be the actual 
point of contact becomes a blinking, circular outline. The line snaps to the active connect point nearest
where the pointer crosses the edge. If you prefer a different point, move the pointer back into the 
shape and out again.
4 Move the pointer to the third shape. 

As you move the pointer across the edge of the shape, the green connect points are displayed 
again. The line snaps to the blinking connect point nearest where the pointer crosses the edget. 
Click the left mouse button when the line is where you want it. The second and third shapes are 
connected.
{button Illustration,PI(`',`IDH_POP_Example2')}

Tips
After you place shapes, you can type text in them to describe what the shapes represent in the

flowchart.

{button < Back,JI(`',`IDH_To_create_a_simple_flowchart_Page_1_of_3')}          {button Next 
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To create a simple flowchart - Page 3 of 3
You use the Selector tool to select an object (a shape, line, or text) so that you can do something to 
it.
1 Click the Selector tool.

Selector tool
2 Point to the first shape and click the left mouse button to select it.
3 Type the following: This is step 1. 

The text appears inside a dotted box in the shape. The box represents the shape’s text area. 
The text wraps at the edges of the box and scrolls upward as you type.
4 Click the second shape to select it.
5 Type the following: This is step 2.
6 Click on the third shape to select it.
7 Type the following: This is step 3.
8 To deselect the text, move the pointer to a blank area in the chart window and click the left 

mouse button.    Both the text and the shape are deselected.
{button Illustration,PI(`',`IDH_POP_Example3')}

Tip
To deselect the text without deselecting the shape, press Esc. When you press Esc after 

entering text in a shape, you are returned to the previous mode. In this task, the Selector tool was 
active, so we are returned to Select mode.

This is the last lesson using this chart. 
On the File menu, click Close.    Click No in the dialog box.

To run another tutorial
Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_To_create_a_simple_flowchart_Page_2_of_3')}          





 
Viewing a Chart

Viewing your work is often as important as creating it. FlowCharter offers several ways for you to 
view different portions of your charts: scroll bars, the Zoom tool, the QuickZoom window, and auto-
scrolling (dragging a shape off the screen).
This tutorial shows you how to use the View tool to see different parts of your chart and how to 
move within the chart.



Viewing objects in a chart
You’ll find the Zoom tool particularly useful when you want to zoom in on a particular area of your 
chart.
1 On the File menu, click Open.
2 Double-click the file BICYCLE.FLO in the TUTORIAL directory of your CD-ROM. (If you installed 

FlowCharter 7 from your network, contact your system administrator to find out where the 
tutorial files are.) 

3 On the View menu, click Page to view all the objects on the current page. 
4 Click the front tire of the bicycle.

(We are selecting the front tire so that when you zoom back in, it will be in the center of the 
window.)

5 On the View menu, click Normal to view objects at their actual size.
6 Click in a blank area of the chart.
7 Try steps 3 through 5 again, this time skipping step 4 to see what happens.

Tips
You can also press F4 to change to the Page view.
You can also press F3 to change to the Normal view.

{button < Back,JI(`>Larget',`IDH_Viewing_a_Chart');cw(`proctut')}          {button Next 
>,JI(`',`IDH_Zooming_In_and_Out_on_a_Chart')}          



Zooming in and out on a chart
1 Click the Zoom Control tool.

Zoom Control
2 Click Zoom tool.

The pointer changes to a magnifying glass. 
3 Drag the magnifying glass to select the area you want to view.
4 Release the mouse button. 

The chart is redrawn, focusing on the selected area.
5 On the View menu, click Page to view the entire chart.
Tip

You can also press F4 to change to the Page view.

{button < Back,JI(`',`IDH_Viewing_Objects_in_a_Chart')}          {button Next 
>,JI(`',`IDH_Using_the_QuickZoom_Window')}          



Using the QuickZoom window
The QuickZoom window is especially useful when you are working on a large chart and want to get 
to specific places on it, quickly.
1 On the View menu, click QuickZoom. 

A miniature version of your chart displays in a small window.
2 In the QuickZoom window, drag the magnifying glass to select the area you want to view.

Once you have an area selected, you can click around in the QuickZoom window to display a 
different area of the chart.

3 Double-click in the QuickZoom window to show the whole chart.
4 On the View menu, click QuickZoom to close the QuickZoom window. 

Tip
You can also press F6 to close and open the QuickZoom window.

{button < Back,JI(`',`IDH_Zooming_In_and_Out_on_a_Chart')}          {button Next 
>,JI(`',`IDH_Viewing_the_Full_Screen')}          



Viewing the full screen 
You can view the whole chart at once on your screen, without FlowCharter’s program elements. This 
view is especially useful for presentations, since you can hide the program elements, and 
temporarily draw on the chart.
Press the ESC key to exit this next mode at any time.
1 On the View menu, click Full Screen.
2 Press and hold the left mouse button and drag it across the screen. Notice a line is drawn as you 

do so.
3 Now press and hold the right mouse button to draw another, differently colored line.
4 Now press and hold both the left and right mouse buttons simultaneously. You can draw a line in 

a third color.
5 Press Esc to exit the Full Screen view.    Note that the colored lines are not saved with the chart.

{button < Back,JI(`',`IDH_Using_the_QuickZoom_Window')}          {button Next 
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Changing the magnification (Zoom percentage)
You can magnify or shrink the chart by entering a zoom percentage. 
1 In the Standard toolbar, click in the Zoom Control box. (You may have to move the tutorial 

window down, slightly, to see the Zoom Control box.)
2 Click the down arrow to see the zoom levels.
3 Click 25%. The chart is shrunk to 25% of its actual size.
4 Type 125 and press Enter. The chart is displayed at 125% of its actual size.

Chances are, you didn't click on a part of the bicycle before you typed 125 in the Zoom Control 
box. If you didn't, you probably just see a blank screen. That's because it zoomed to the center of
the chart, which is blank when viewed at 25%.

5 Press F4 to view the current page. Use the horizontal scroll bar to move the view back to the 
bicycle.

Tips
The zoom percentage you enter must be between 5% and 1600%.
When you use other methods of zooming, the current view percentage displays in this Zoom 

Control box.    If you find a percentage view that you like, note the number so you can enter it in the 
Zoom Control box later.

{button < Back,JI(`',`IDH_Viewing_the_Full_Screen')}          {button Next 
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Using the Zoom In and Zoom Out buttons
You can magnify or shrink the chart by clicking Zoom Control and then selecting either Zoom In and 
Zoom Out.
1 Click the bicycle seat.
2 Click the Zoom Control tool.

Zoom Control
3 Click Zoom In. The Zoom pointer displays.

Zoom pointer
Each time you click this on the chart with the Zoom In pointer displayed, the chart is 

magnified. It zooms in on whatever you have selected.    If you don’t have anything selected, it zooms 
in on the center of the viewable area.
4 Click the Zoom Control tool.

Zoom Control
5 Click Zoom Out. The Zoom pointer displays.

Zoom pointer
Each time you click this button, the chart is shrunk. It zooms out with whatever you have 

selected in the middle of the screen. If you don’t have anything selected, it zooms in on the center of 
the viewable area.
This is the last lesson using the bicycle chart. 

On the File menu, click Close.    Click No in the dialog box.
To run another tutorial

Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Changing_the_magnification_Zoom_percentage')}          



Working with Shapes
After you place shapes in a chart, it is easy to move and resize them.
This tutorial shows you how to move and resize shapes efficiently. You also learn how to replace one 
shape with another.



Moving a shape
You can move shapes anywhere within a chart. Lines connected to the shapes move with them.
1 On the File menu, click Open.
2 Double-click the file SHAPES.FLO in the TUTORIAL directory of your CD-ROM.    (If you installed 

FlowCharter 7 from your network, contact your system administrator to find out where the 
tutorial files are.) 

3 Click the Selector tool.

Selector tool
4 Point to shape 3 in the chart.
5 Press and hold the left mouse button, and drag shape 3 until it is aligned with shapes 1 and 2.
6 Release the mouse button when you finish.

{button Illustration,PI(`',`IDH_POP_Example4')}
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Resizing a shape
You can easily change the size of shapes in a chart. When you select a shape, eight handles appear 
around it. You use the handles to shrink and enlarge the shape.
1 Click the Selector tool.

Selector tool
2 Point to the first shape and click the left mouse button to select it.
3 Point to a corner handle on shape 1 until the pointer changes to a double-headed arrow.
4 Press and hold the left mouse button, and drag the handle toward the center of the shape.
5 Release the mouse button when shape 1 is approximately the same size as the other shapes.

{button < Back,JI(`',`IDH_Moving_a_Shape')}          {button Next >,JI(`',`IDH_Replacing_a_Shape')}       



Replacing a shape 
FlowCharter lets you easily replace one shape in a chart with another. The shape you choose as a 
replacement automatically attaches to any lines connected to the original shape. 
1 Click the Selector tool. 

Selector tool
2 Select shape 2.
3 Click the Shape tool.

Shape tool
4 Click a different shape in the Shape Palette. (If the Shape palette is not visible, click the View 
Shape Palettes on the Standard toolbar.)

View Shape Palettes
5 On the Arrange menu, click Replace Shape. 

Shape 2 is replaced with the shape you chose in the Shape palette.
{button Illustration,PI(`',`IDH_POP_Example5')}

Tip
You can also click the Replace Shape button on the Arrange toolbar.

Replace Shape button
This is the last lesson using this chart.

On the File menu, click Close. Click No in the dialog box.
To run another tutorial

Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Resizing_a_Shape')} 





Attaching Notes and Numbering Shapes

FlowCharter lets you attach text to shapes to provide more detailed information. You also can 
display and change shape numbers automatically.
This tutorial shows you how easy it is to attach notes and renumber shapes.



Attaching notes to shapes 
You can attach a note to any shape in a chart. The note can contain any text you want to use to 
describe a shape. For process improvement, notes can be used to enter processing rules, business 
issues, and other relevant information.
1 On the File menu, click Open.
2 Double-click the file NOTES.FLO in the TUTORIAL directory of your CD-ROM.    (If you installed 

FlowCharter 7 from your network, contact your system administrator to find out where the 
tutorial files are.) 

3 Click the Selector tool.

Selector tool
4 Press Alt + F6. The Note window opens. 
5 Point to shape 1, and click the left mouse button to select it.
6 Click in the Note window. The blinking text cursor appears. 
7 Type the following: This is a note about shape 1.
8 Click in a blank area of the chart to deselect the Note window. The Note window changes and the 

indicator -N appears next to the shape number in shape 1. The -N is an indicator which means 
that a note is attached to shape 1.

9 Select shape 2.
10 Click in the Note window. 
11 Type the following: This is a note about shape 2.
12 Select shape 1 again. The note you entered for shape 1 appears in the Note window, and a note 

indicator appears in shape 2.
{button Illustration,PI(`',`IDH_POP_Example6')}

13 On the View menu, click Note. The Note window closes.

{button < Back,JI(`>Larget',`IDH_Attaching_Notes_and_Numbering_Shapes');cw(`proctut')}          
{button Next >,JI(`',`IDH_Numbering_Shapes')}          





Numbering shapes
FlowCharter can automatically number shapes you place in a chart. You can renumber the shapes in
any order and specify text you want to appear beside the shape numbers.
1 On the Format menu, click Shape Numbering.
2 Click Display Shape Numbers.
3 On the Format menu, click Set Next Shape Number.
4 In the Next Number box, type: Step 1.10.
5 Click OK. 
6 On the Format menu, click Renumbering tool.
7 With the Renumbering tool pointer, click each shape you want to renumber or number.

The selected shapes are renumbered in consecutive order, starting with 1.10.
{button Illustration,PI(`',`IDH_POP_Example7')}

Note
To turn off numbers of shapes already numbered, you must select each shape before 

deselecting Display Shape Numbers.
Tip

To turn numbering off, click Shape Numbering in the Format menu, and deselect Display Shape
Numbers.

This is the last lesson using this chart.
On the File menu, click Close. Click No in the dialog box.

To run another tutorial
Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Attaching_Notes_to_Shapes')}        





Entering and Editing Text
FlowCharter lets you place text anywhere in a chart. The text can provide detailed information about
the steps and procedures in your chart.
This tutorial shows you how to enter text in a chart and change the typeface, point size, and color of
the text.



Entering text
You can type text exactly where you want it in a chart.
1 On the File menu, click New.
2 Click Blank Page. A blank chart window opens.
2 Click the Text tool.

Text tool
3 Click in the chart window. The blinking text cursor appears.
4 Type the following: This is an example of how text is entered.
5 Press Enter to begin a new line.
6 Type the following: in FlowCharter. The Formatting toolbar shows the font, size, and style 
options used for the text. 
7 Click outside the text area to finish text entry.

{button < Back,JI(`>Larget',`IDH_Entering_and_Editing_Text');cw(`proctut')}          {button Next 
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Changing the typeface, point size, and color
You can change the typeface, point size, and color of text in a chart. This feature lets you emphasize
the text that is most important.
1 Click the Text tool.

Text tool
2 Point in front of the letter “F” in “FlowCharter.”
3 Press and hold the left mouse button, and drag the text cursor across the words “FlowCharter.”
The text is highlighted. Release the mouse button.
4 Click the down arrow at the right of the Font box in the Formatting toolbar. A list of the 
available fonts opens.
5 Select a font in the box, such as Dom Casual.
6 Click the down arrow at the right of the Size box. A list of the available point sizes opens.
7 Select a larger point size, such as 12.
8 Click the down arrow next to the Text Color button and click a color.

Text Color button
9 Press LEFT ARROW to see the text changes. 

{button Illustration,PI(`',`IDH_POP_Example8')}

This is the last lesson using this chart.
On the File menu, click Close.    Click No in the dialog box.

To run another tutorial
Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Entering_Text')}        





Working with Lines
FlowCharter makes it simple to connect shapes with lines. You can use lines to show the direction of 
process flow in your chart.
This tutorial shows you how to connect shapes with lines and change where lines connect to shapes.



Connecting shapes with a line
Connecting two shapes with a line is as easy as clicking inside the two shapes you want to connect.
1 On the File menu, click Open.
2 Double-click the file LINES.FLO in the TUTORIAL directory of your CD-ROM.    (If you installed 

FlowCharter 7 from your network, contact your system administrator to find out where the 
tutorial files are.) 

3 Click the Connector Line tool.

Connector Line tool
4 Click Right Angle Line. 

Right Angle Line
5 Click inside shape 1. 

When you move the mouse inside the shape, the green connect points appear. A line snaps to 
the point that is closest to the mouse pointer. 
6 While inside shape 1, move the mouse pointer so that the line snaps to the connect point you 

want.
7 Without pressing the mouse button, drag the pointer out of shape 1 near the connect point.

The line connects to shape 1 based on where the pointer tip exits the shape.
8 Move the pointer into shape 2.

The connect points on shape 2 appear.
9 Move the pointer until the line is connected to the shape at the connect point that you want.
10 Click to draw the line.

{button Illustration,PI(`',`IDH_POP_Example9')}
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Changing connect points
When you connect two shapes with a line, the line automatically snaps to the connect points closest
to the pointer’s path. After you draw the line, you can easily move the line to different connect 
points.
1 Click the Selector tool.

Selector tool
2 Click the line to select it, if it is not selected.
3 Point to the handle on the line end connected to shape 2.
4 When the line pointer is displayed, press and hold the left mouse button, and drag the handle 
out of the shape to disconnect the line from the shape.

Line Pointer
5 Drag the line back in through another side of the shape. 
6 Release the mouse button.

{button Illustration,PI(`',`IDH_POP_Example10')}
This is the last lesson using this chart. 

On the File menu, click Close.    Click No in the dialog box.
To run another tutorial

Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Connecting_Shapes_with_a_Line')}      





Setting Up a Table for Data
FlowCharter lets you easily set up a table for a chart.
This tutorial shows you how to set up the table and enter data into it. In this example, the table is 
applied to a process chart. The process has three steps, and therefore three shapes. After you set up
the table, you will enter data into the fields of the table.



Setting up the fields - Page 1 of 3
1 On the File menu, click Open.
2 Double-click the file FIELDS.FLO in the TUTORIAL directory of your CD-ROM.      (If you installed 

FlowCharter 7 from your network, contact your system administrator to find out where the 
tutorial files are.) 

3 On the Insert menu, click Data Field. 
4 Click in the Field Name box and type Task.
5 In the Field Type box, click the down arrow.
6 Click Text. 

The Field Type is changed to “Text,” the Field Format is changed to “text,” and the Accumulation 
Method is changed to “No Accumulation.”

7 Click the Add button. 
The Task field is added to the Field list. 
{button Illustration,PI(`',`IDH_POP_Example11')}

{button < Back,JI(`>larget',`IDH_Setting_Up_Data_Fields');cw(`proctut')}          {button Next 
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Setting up the fields - Page 2 of 3
8 Type Manhours in the Field Name box.
9 In the Field Type box, click the down arrow.
10 Click Duration. 

The Field Type is changed to “Duration,” the Field Format is changed to “# w.”, and the 
Accumulation Method is changed to “Sum.”

11 In the Field Format box, click the down arrow.
12 Click “# hours.” 

The Field Format is changed to “# hours.”
13 Click the Add button. 

The Manhours field is added to the Field list.
{button Illustration,PI(`',`IDH_POP_Example12')}

{button < Back,JI(`',`IDH_Setup')}          {button Next 
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Setting up the fields - Page 3 of 3
14 Type Cost in the Field Name box.
15 In the Field Type box, click the down arrow.
16 Click Currency. 

The Field Type changes to “Currency,” the Field Format changes to “$###0.00;($###0.00),” and
the Accumulation Method changes to “Sum.”

17 Click the Add button. The Cost field is added to the Field list.
{button Illustration,PI(`',`IDH_POP_Example13')}

18 Click OK. The dialog box closes.

{button < Back,JI(`',`IDH_Setting_up_the_fields_Page_2_of_3')}          {button Next 
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Setting data fields options
1 On the Format menu, click Chart Properties.
2 Click the Data Fields tab.
3 Change Placement to Inside Middle.
4 Click the Hide Field Names check box.
5 Click the down arrow at the right of the font’s size box, and click 8.
6 Click the Bold check box.

{button Illustration,PI(`',`IDH_POP_Example14')}
7 Click OK. The dialog box closes. If you saved the chart, these settings would be saved with the 

chart.
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Displaying the Data toolbar
1 Place the cursor over the toolbar area at the top of the FlowCharter window.
2 Press the right mouse button. A list of toolbars displays. The toolbars that are displayed have 

checkmarks beside their names.
3 If Data is not checked, click Data. The Data toolbar displays.

{button < Back,JI(`',`IDH_Setting_Data_Fields_Preferences')}          {button Next 
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Entering data into the fields    - Page 1 of 3
To demonstrate the ease and versatility of entering data, this tutorial deliberately uses three 
different methods of selecting boxes.
1 Click the Selector tool.

Selector tool
2 Click shape 1.
3 On the Data toolbar, click the Field Viewer button. The Viewer opens.

Viewer button
4 Type Get screwdriver in the Task box. Press Enter. The text appears in shape 1.
5 Type .1 in the Manhours box. Press Enter. The value appears in shape 1.
6 Type .07 in the Cost box. Press Enter. The value appears in shape 1.

{button Illustration,PI(`',`IDH_POP_Example15')}

{button < Back,JI(`',`IDH_Displaying_the_Data_toolbar')}        {button Next 
>,JI(`',`IDH_Entering_data_into_the_fields_Page_2_of_3')}          





Entering data into the fields    - Page 2 of 3
7 Click shape 2. The boxes in the Viewer are cleared. The shape number appears at the top of the 

Viewer.
8 Click in the Task box and type Install screws. Press Tab.
9 Type .2 in the Manhours box. Press Tab.
10 Type 3.75 in the Cost box. Press Tab.

{button Illustration,PI(`',`IDH_POP_Example16')}
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Entering data into the fields    - Page 3 of 3
11 Select shape 3. The boxes in the Viewer are cleared.
12 Click in the Task box and type Record serial no.
13 Click in the Manhours box, and type .1. 
14 Click in the Cost box, and type .53.
15 Press Tab.

{button Illustration,PI(`',`IDH_POP_Example17')}
16 Click Close to close the Viewer.
This is the last lesson using this chart.

On the File menu, click Close.    Click No in the dialog box.
To run another tutorial

Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Entering_data_into_the_fields_Page_2_of_3')}    





Enhancing Shapes
FlowCharter gives you several ways to enhance the appearance of shapes in a chart. This tutorial 
shows you how to add color, shadows, and fill patterns to shapes. You also learn how to change the 
border style of a shape.



Adding a shadow
You can add shadows to shapes to give your charts depth.
1 On the File menu, click Open.
2 Double-click the file CHGSHAPE.FLO in the TUTORIAL directory of your CD-ROM.    (If you installed 

FlowCharter from your network, contact your system administrator to find out where the tutorial 
files are.) 

3 Click the Selector tool.

Selector tool
4 Point to the shape in the chart, and click the left mouse button to select it.
5 Click the Shadow button in the Formatting toolbar. (You may have to move the tutorial window 
slightly to uncover the button.) A Shadow palette opens.

Shadow button
6 Click a shadow style. The shadow is applied to the selected shape. 

This illustration also shows the floating shadow palette. {button 
Illustration,PI(`',`IDH_POP_Example18')}
Tips

The Shadow palette can be “dragged off” so that it floats. To do this, click on the Shadow 
button to display its palette. With the palette displayed, press the left mouse button and drag the 
palette away from the Shadow button.

You can always click the right mouse button on a shape to display a menu of actions you can 
perform on a shape.

You can also format a shape's shadow using the Format menu.    
 How?
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Adding a fill pattern and color
Fill patterns and fill colors let you add variety and interest to your charts.
1 On the Format menu, click Fill.
2 Click the Fill tab.
3 Click the Pattern radio button.
4 Click the diagonal line pattern. The pattern is applied to the selected shape.
5 Click a color from the color palette for Foreground color. 
6 Click a color from the color palette for Pattern color. The color appears in the shape displayed in 

the Fill tab's sample area.
{button Illustration,PI(`',`IDH_POP_Example19')}

Tip
Color palettes on the toolbar can be “dragged off” so that they float. To do this, click on the 

button to display its palette. With the palette displayed, press the left mouse button and drag the 
palette away from the button.
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Changing the border style
FlowCharter offers several border styles for the outline of shapes.
1 Click the Line Style button in the Formatting toolbar. The Line Style palette opens.

Line Style button
2 Click the first dashed style. The line style is applied to the border of the selected shape. 

{button Illustration,PI(`',`IDH_POP_Example20')}
Tips

The Line Style palette can be “dragged off” so that it floats. To do this, click on the button to 
display its palette. With the palette displayed, press the left mouse button and drag the palette away 
from the button.

These style changes you have made to the shape also affect the next new shapes you place.    
Try putting a new shape on the chart before you close the file. (Remember to click the Shape tool first!)

This is the last lesson using this chart.
On the File menu, click Close.    Click No in the dialog box.

To run another tutorial
Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Adding_a_Fill_Pattern_and_Color')}      





Using Color in a Chart
FlowCharter lets you choose from a variety of colors for shapes, lines, and text. You can use colors to
color-code objects or to enhance your chart’s appearance.
This tutorial shows you how easy it is to change the color of objects and to create your own colors.



Changing the border color of a shape
You can easily change the color of a shape’s border. The border includes the lines around and inside 
a shape.
1 On the File menu, click Open.
2 Double-click the file COLOR.FLO in the TUTORIAL directory of your CD-ROM.    (If you installed 

FlowCharter 7 from your network, contact your system administrator to find out where the 
tutorial files are.) 

3 Click the Selector tool.

Selector tool
4 Point to the first shape in the chart and click the left mouse button to select it.
5 Click the down arrow next to the Line Color button in the Formatting toolbar. 

Line Color button
6 Click the royal blue color. The border turns blue.

{button Illustration,PI(`',`IDH_POP_Example21')}

{button < Back,JI(`>larget',`IDH_Using_Color_in_a_Chart');cw(`proctut')}          {button Next 
>,JI(`',`IDH_Choosing_a_Custom_Color')}          





Creating a custom color
If you want to use a color that does not appear in the palette, FlowCharter lets you create a color 
and add it to the palette.
1 Click the Selector tool.

Selector tool
2 Click the first shape, if it is not already selected.
3 Click the down arrow next to the Fill Color button

Fill Color button
4 Just for fun, let's make a palette out of the color box.

Drag the palette off by holding down the left mouse button and dragging towards the bottom 
of the screen. (When you see a thick outline of the palette appear, you can release the mouse button.)
5 On the palette, click More colors. The Color dialog box opens.
6 Click in the large box of colors. 
7 Drag your mouse around it until the color you want is displayed in the bottom left corner of the 

dialog box (in the small color box labeled “Color|Solid.”) You can also use the lighten/darken 
slider to adjust the color.

8 Click OK. The color is applied to the selected shape.    The color also appears in the Fill Color 
palette, at the bottom. This color will be available from now on in the palette.
{button Illustration,PI(`',`IDH_POP_Example22')}

9 Click the Close button on the Fill Color palette to close it.

Tip
You can create up to 33 custom colors. The 34th color you create will replace the first custom 

color you created.
This is the last lesson using this chart.

On the File menu, click Close.    Click No in the dialog box.
To run another tutorial

Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Changing_the_Border_Color')}    





Changing the Display Order of Objects
As you draw charts, new objects appear on top of previously drawn objects. FlowCharter provides 
two buttons for changing the order of objects. These buttons let you bring objects to the front or 
send them to the back of other objects.
This tutorial shows you how easy it is to move a shape to the front and back of a line.



Bringing an object to the front
You can bring a shape in front of a line so that the line does not appear to cross over the shape. 
1 On the File menu, click Open.
2 Double-click the file REORDER.FLO in the TUTORIAL directory of your CD-ROM.    (If you installed 

FlowCharter 7 from your network, contact your system administrator to find out where the 
tutorial files are.) 

3 Click the Selector tool.

Selector tool
4 Point to shape 1 and click the left mouse button to select it.
5 On the Arrange menu, click Order, and then Bring to Front.

Shape 1 appears in front of the line.
{button Illustration,PI(`',`IDH_POP_Example23')}

Tip
You can also use the Bring to Front button in the Arrange toolbar. 

Bring to Front button

{button < Back,JI(`>larget',`IDH_Changing_the_Display_Order_of_Objects');cw(`proctut')}          
{button Next >,JI(`',`IDH_Sending_an_Object_to_the_Back')}          





Sending an object to the back
You can send a filled shape behind other shapes to frame them.
1 Click the Selector tool.

Selector tool
2 Select the large rectangle in the chart.
3 On the Arrange menu, click Order, and then Send to Back.

The shape appears behind the objects that it was covering.
{button Illustration,PI(`',`IDH_POP_Example24')}

Tip
You can also use the Send to Back button in the Arrange toolbar. 

Send to Back button
This is the last lesson using this chart.

On the File menu, click Close.    Click No in the dialog box.
To run another tutorial

Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Bringing_an_Object_to_the_Front')}    





Customizing the Shape Palette
You can customize the Shape palette by adding, deleting, and rearranging shapes and modifying the
buttons used to choose shapes.
This tutorial shows you how to add a composite shape to the Shape palette and how to change the 
order and size of the shape buttons.



Adding and rearranging shapes - Page 1 of 2
You can easily add a composite shape to the Shape palette and then name the shape. 
1 On the File menu, click Open.
2 Double-click the file PALETTE.FLO in the TUTORIAL directory of your CD-ROM.    (If you installed 

FlowCharter 7 from your network, contact your system administrator to find out where the 
tutorial files are.) 

3 Click the Selector tool.

Selector tool
4 Point above and to the left of the document shapes. Press and hold the left mouse button, and 
drag down and to the right until all three shapes are enclosed. Release the left mouse button to select 
the shapes.

{button Illustration,PI(`',`IDH_POP_Example25')}
5 Open the Shape palette, if it is not open already. (On the View menu, click Shape Palettes.)

{button < Back,JI(`>larget',`IDH_Customizing_the_Shape_Palette');cw(`proctut')}          {button Next 
>,JI(`',`IDH_Adding_and_Rearranging_Shapes_Page_2_of_2')}          





Adding and rearranging shapes - Page 2 of 2
6 Put the cursor over the selected shapes. 
7 When the cursor becomes a four-headed arrow, press the left mouse button and drag the shapes 

over the Shape palette.

Four-headed arrow
8 When the cursor becomes a pointer with a plus sign, drop the shapes onto the Shape palette 
(just release the left mouse button). The group of shapes is added to the Shape palette.

If you drop the shape before the pointer changes, the shape will not be added to the palette.
9 Pause your cursor over the new shape in the Shape palette.    Notice the ToolTip says “UNTITLED.”
10 Double-click the new shape. The Shape Properties dialog box displays.
11 Type Form in the Name box.
12 Click OK. Now when you place your cursor over the shape, the ToolTip says “Form.”
13 Press and hold the left mouse button over the shape in the Shape palette. Drag the shape across 

the Shape palette and drop it anywhere in the second row of the Shape palette.
This is the way you can rearrange shapes within a palette.

{button < Back,JI(`',`IDH_Adding_and_Rearranging_Shapes')}          {button Next 
>,JI(`',`IDH_Resizing_Buttons_in_the_Shape_Palette')}          



Resizing buttons in the Shape palette
The buttons in the Shape palette can be resized. You can make them smaller to reduce the palette’s 
overall size and free some screen space or make them larger to see more shape detail.
1 The Shape palette itself has a menu bar with one menu on it: Options. On the Options menu, 

click Properties. The Properties dialog box opens with the Subject tab displayed.
2 Change the width and height sliders to the size you want. A sample of the size is shown in the 

white preview window. If the Square check box is checked, the buttons will retain a square shape.
3 Click OK.    The thumbnails (the mini-images of the shapes) are resized and displayed in the 

Shape palette.
This is the last lesson using this chart.

On the File menu, click Close.    Click No in the dialog box.
To run another tutorial

Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Adding_and_Rearranging_Shapes_Page_2_of_2')}        



Defining Shape Properties
Each shape has certain characteristics, or “properties.” Shape properties include the size and 
position of the text area and the positions of the shape number and connect points.
This tutorial shows you how to resize the text area and move the shape number and a connect 
point.



Resizing the text area
FlowCharter gives you the flexibility you need to position text in a shape.
1 On the File menu, click Open.
2 Double-click the file PROPS.FLO in the TUTORIAL directory of your CD-ROM.    (If you installed 

FlowCharter 7 from your network, contact your system administrator to find out where the 
tutorial files are.) 

3 Click the Selector tool.

Selector tool
4 Point to shape 1 and click the left mouse button to select it.
5 Click the Edit tool, and click Text Layout.

Edit tool
6 On the Edit Text Area Layout toolbar, click the Text Select tool.

Text Select tool
7 Click the text area in the shape to select it.
8 Point to any of the handles of the text area.
9 Press and hold the left mouse button, and drag the handle to the position you want. Release 
the mouse button.
10 Repeat steps 8 and 9 until the text area is the size you want.
11 Click OK. There is now more room for the text in the shape.

{button < Back,JI(`>larget',`IDH_Defining_Shape_Properties');cw(`proctut')}          {button Next 
>,JI(`',`IDH_Moving_a_Connect_Point')}          



Moving a connect point
Moving a connect point on a shape is as simple as clicking and dragging it to its new location.
1 With the same shape still selected, click the Selector tool.

Selector tool
2 Point to shape 1, and click the left mouse button to select it.
3 Click the Edit tool, and click Connect Points.

Edit tool
4 Click the Select tool on the Edit Connect Points toolbar.
5 Click the connect point (round outline) at the bottom of the shape to select it. The outline is filled 

to indicate it is selected.
6 Point to the selected connect point.
7 Press and hold the left mouse button, and drag the connect point to the lower right corner of the 

shape. (Make sure the connect point is not entirely outside the shape, but is still overlapping the 
shape border.) Release the mouse button. 

8 Click Finished. Lines can be connected to the new connect point.

{button < Back,JI(`',`IDH_Resizing_the_Text_Area')}          {button Next 
>,JI(`',`IDH_Realigning_a_shape_number')}          



Realigning a shape number
You can align your shape numbes so that to be on the right or left of the shape, or in the center of 
the shape.
1 With the same shape still selected, click the Selector tool.

Selector tool
2 Point to shape 1, and click the left mouse button to select it.
3 Click the Edit tool, and click Text Layout.

Edit tool
4 Click Left Align Label, Center Align Label, or Right Align Label on the Edit Text Area Layout 

toolbar.

Left 
Align 
Label

Center 
Align 
Label

Right 
Align 
Label

5 Click Finished. The shape number is realigned within the shape based on your selection.

{button < Back,JI(`',`IDH_Moving_a_Connect_Point')}          {button Next 
>,JI(`',`IDH_Repositioning_a_Line')}          



Repositioning a line
After you move a connect point on a shape, you can move lines to the connect point’s new position.
1 Click the Selector tool.

Selector tool
2 Click the line connecting the two shapes.
3 Point to the handle where the line exits shape 1. The cursor becomes a line pointer:

Line pointer
4 Press and hold the left mouse button, and drag the handle to the lower right corner of the 
shape. You may notice that the line immediately snaps to the connect point, since it is the closest 
connect point to the line end.
5 Release the mouse button after the line snaps to the new connect point.

{button Illustration,PI(`',`IDH_POP_Example30')}
This is the last lesson using this chart.

On the File menu, click Close.    Click No in the dialog box.
To run another tutorial

Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Realigning_a_Shape_Number')}        





Creating an Organization Chart
FlowCharter offers an org-line feature that lets you create organization charts as easily as 
flowcharts.
In this tutorial you create a standard organization chart using process shapes and org lines.



Choosing the Org Chart Line style
1 On the File menu, click New.
2 Click Blank Page. A blank chart window opens.
2 Click the Connector Line tool. 

Connector Line tool
3 Click Org Chart Line.

Org Chart Line button
4 Click the Arrowheads button. (It may be underneath this tutorial window. To move the tutorial 
window, just click on its title bar and drag it where you want it.) The Arrowheads palette opens.

Arrowheads button
5 Click the first style in the menu (no arrow). 

{button < Back,JI(`>larget',`IDH_Creating_an_Organization_Chart');cw(`proctut')}          {button Next 
>,JI(`',`IDH_Placing_the_Top_Shape')}          



Placing the top shape
1 Click the first shape in the Shape palette. (Press F9 if the Shape palette is not open.)
2 Click in the chart window to place the top shape of the organization chart.

{button < Back,JI(`',`IDH_Choosing_the_Org_Line_Style')}          {button Next 
>,JI(`',`IDH_Placing_Connected_Shapes')}          



Placing connected shapes
1 Press and hold the left mouse button, and drag the pointer straight down out of the top shape. 

The blue connecting line should align with the bottom, middle of the shape.
2 Release the mouse button to place the connected shape immediately below the top shape.

{button Illustration,PI(`',`IDH_POP_Example31')}
3 Point again inside the top shape.
4 Press and hold the left mouse button, and drag another shape straight down until it is directly 

over the shape below. Continue pressing the mouse button.
5 Drag the new shape to the right. This shape aligns to the second shape you placed.
6 Release the mouse button to place the new shape to the right of the second shape.

{button Illustration,PI(`',`IDH_POP_Example32')}
7 Repeat steps 3 through 6 to place a connected shape at the left on the row.

{button Illustration,PI(`',`IDH_POP_Example33')}

Tips
The connecting line is drawn from the side of the reference shape as the new shape exits the 

reference shape.
If you do not like where a line connects to a shape, continue pressing the mouse button, drag 

the new shape back to the “reference” shape, and drag it out again.

{button < Back,JI(`',`IDH_Placing_the_Top_Shape')}          {button Next >,JI(`',`IDH_Adding_Text')}         









Adding text
1 Click the Selector tool.

Selector tool
2 Select the top shape and type President. Press Esc.
3 Select the first shape in the second row and type Exec. Vice President. Press Esc.
4 In the other two shapes, type Controller in one and Creative Director in the other. 

{button Illustration,PI(`',`IDH_POP_Example34')}
This is the last lesson using this chart.

On the File menu, click Close.    Click No in the dialog box.
To run another tutorial

Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Placing_Connected_Shapes')}





Creating a Cause-and-Effect Chart
FlowCharter offers a process analysis feature that lets you create Ishikawa or “fishbone” charts for 
gathering, sorting, and relating information. These charts can be used to relate causes and effects 
and to determine their levels of influence. This chart is excellent for documenting team 
“brainstorming” sessions.
In this tutorial you create a cause-and-effect chart by modifying the cause-and-effect template 
(CAUSE.AFT).



Opening the cause-and-effect template
1 On the File menu, click Open.
2 In the Files of type box, click the down arrow and select FlowCharter Template (*.aft). 
3 Double-click the file CAUSE.AFT in the TUTORIAL directory of your CD-ROM.    (If you installed 

FlowCharter 7 from your network, contact your system administrator to find out where the 
tutorial files are.) 

{button < Back,JI(`>larget',`IDH_Creating_a_Cause_and_Effect_Diagram');cw(`cause')}          {button 
Next >,JI(`',`IDH_Replacing_Shape_Labels')}          



Replacing shape labels
1 Click the Selector tool.

Selector tool
2 Click the shape labeled “Effect.”
3 Type Wheel Falls Off.
4 Click the upper left shape labeled “Cause,” and type Design, Components.
5 Click the upper right shape labeled “Cause,” and type Assembly.
6 Click the lower right shape labeled “Cause,” and type Operate, Maintain.
7 Press Esc.
8 Press and hold Shift and click each of the shapes you labeled. The shapes are selected as you 
click them.
9 On the Arrange menu, point to Make Same Size, and click Fit to Text.

{button Illustration,PI(`',`IDH_POP_Example35')}

{button < Back,JI(`',`IDH_Opening_the_Cause_and_Effect_Template')}          {button Next 
>,JI(`',`IDH_Deleting_a_Line')}          





Deleting a line
1 Click the Selector tool.

Selector tool
2 Click the line attached to the lower left shape labeled “Cause.”
3 Press Del. The line, the shape at the end of it, and all dependent lines pointing to it are 
deleted.

{button Illustration,PI(`',`IDH_POP_Example36')}

{button < Back,JI(`',`IDH_Replacing_Shape_Labels')}          {button Next 
>,JI(`',`IDH_Completing_the_Chart')}          





Completing the chart - Page 1 of 3
1 Click the Selector tool, if necessary.

Selector tool
2 Click the upper left “Cause” the line attached to “Design, Components.”
3 Type Hub out of round.
4 Press Esc. The text block is selected.
5 Click the second “Cause” on the left side of the line, and type Excessive shoulder-cotter 
distance.
6 Click the small line connecting the third “Cause” on the left side. Handles appear on either side
of the line.
7 Press Del to delete the line, its label, and all of its dependent lines and labels.
8 Click the line attached to “Excessive shoulder-cotter distance.” Drag the line to where the 

deleted lines used to be.
{button Illustration,PI(`',`IDH_POP_Example37')}

{button < Back,JI(`',`IDH_Deleting_a_Line')}          {button Next 
>,JI(`',`IDH_Completing_the_Chart_Page_2_of_3')}          





Completing the chart - Page 2 of 3
9 Click the line attached to “Cause” on the right side of “Design, Components.”
10 Drag the right handle of the line to stretch the line to the right.
11 Click the word “Cause” on the right side of “Design, Components.”
12 Type Cotter pin.
13 Press Esc.
14 Click the Connector Line tool. 

Connector Line tool
15 Click Cause-and-Effect Line.

Cause-and-Effect Line
16 Click the Arrowheads button, and click the simple arrowhead (second from the top, left).

Arrowheads button
17 Point to the line attached to “Cotter pin.” Press and hold the left mouse button, and drag 
downward to draw a new line.
18 Type Thin.

{button Illustration,PI(`',`IDH_POP_Example38')}

{button < Back,JI(`',`IDH_Completing_the_Chart')}          {button Next 
>,JI(`',`IDH_Completing_the_Chart_Page_3_of_3')}          





Completing the chart - Page 3 of 3
19 Point to another position on the line attached to “Cotter pin.” Press and hold the left mouse 

button, and drag downward to draw a new line.
20 Type Brittle.
21 Press Esc.

{button Illustration,PI(`',`IDH_POP_Example39')}
22 Practice working with the chart.

{button < Back,JI(`',`IDH_Completing_the_Chart_Page_2_of_3')}          {button Next 
>,JI(`',`IDH_Deleting_the_How_to_Hints')}          





Deleting the how-to hints
1 Click the Selector tool.

Selector tool
2 Click the How-to Hints in the upper right corner of the page. The handles appear around the 
box.
3 Press Del.

{button Illustration,PI(`',`IDH_POP_Example40')}
This is the last lesson using this chart.

On the File menu, click Close.    Click No in the dialog box.
To run another tutorial

Click the Help Topics button at the top of this window.

{button < Back,JI(`',`IDH_Completing_the_Chart_Page_3_of_3')}        





Indicators
There are three types of indicators: note indicators, link indicators, and line nodes. 

A note indicator means that a note is attached to a shape. 
A link indicator means that when you double click the shape, something will happen (another 

chart will display, a program will be executed, and so on).    For more information, look up Linking 
Charts under the Contents tab in Help.

Line nodes show where lines connect. (On the other hand, line crossovers indicate where lines 
overlap. A crossover is an attribute of a line. For more information on crossovers, look up Crossovers 
under the Index tab in Help.)

To change an indicator, click the Format menu, click Chart, and click the Indicators tab.



Shape palette
You select the shape you want to place on the chart from the Shape palette. The Shape palette 
displays the shapes that you can place in a chart. If the Shape palette is not open, the Shape tool 
places the last shape you selected. 
When you open FlowCharter for the first time, a set of commonly used symbols appears in the 
Shape palette. The name of the Shape palette appears in the title bar. The available shapes appear 
as buttons in the palette.
The View Shape Palettes on the Standard toolbar opens and closes the Shape palette. You can also 
press F9 to open and close the Shape palette. 
You can leave the palette open all the time, if you want. It "floats" over the chart    and can be 
dragged wherever you want it.
Many additional shapes are available in the Shape palette files included with the program. (See the 
Shape palette chapter for a complete list of available palettes and shapes.)



Line Types
FlowCharter has five line types:

The direct, right angle, and curved line types can be used in any kind of chart.    
The org chart line type is designed to be used for organization charts, family trees, kinship charts, and 
similar chart types.
The cause and effect line type is designed to be used in cause-and-effect chart types (also known as 
fishbone charts or Ishikawa charts).



Line Styles
You can assign several different styles to your lines. To do so, click the Line Styles button on the 
Formatting toolbar and click the style you want.

Lines Style button 
The styles you can choose are:



The Shadow Tab
You can assign shadows to the selected shapes via the Format menu.
1 On the Format menu, click Effects.
2 Click the Effects tab.
3 In the Shadow box, select the shadow or select No Shadow to turn off the shadow.

Note
The offset of a shadow determines the distance between the shadow and the shape. The offset

must be a number from 1 to 5.



Color dialog box

This dialog box lets you create custom colors and to change the default color. You can color text, 
shapes, lines, and borders. You can create up to 33 custom colors.    
After selecting More Colors, you can drag the cross pointer in the large colored box that displays. As 
you drag the pointer, several things happen:

The numbers change in the Hue, Sat, Lum boxes and the Red, Green, Blue boxes.
The selected color appears in the left half of the Color|Solid box. On the left side, the color is 

the exact color you have selected. On the right side, the solid color closest to your selected color 
displays.
Tips

Use the slider to change the amount of white or black in a color.
The type of video driver you have may affect how colors display.

{button Related Topics,PI(`',`IDH_RT_Set_Custom_Color_DB')}



To create a custom color



To create a custom color
1 Click the Text Color, Fill Color, or Line Color button on the Formatting toolbar.

Text 
Color 
button

Fill Color
button

Line 
Color 
button

2 Click More Colors.
3 Click or drag anywhere in the large color window to select a color.
4 Click OK. The color becomes the selected color for the fill, text, or line. It also appears in the color

palette.

Tips
Move the vertical scroll bar on the right to adjust the amount of white and black in your color.
For finer control, you can type the values you want in the text boxes. Values must be between 

0 and 255.
You can create up to 33 custom colors.
When the custom color palette is full, you can still add more colors. When you do, the first 

custom color (in the upper left corner) is removed and your new color is added in the lower right corner
of the palette.

If you are using Windows-standard VGA (16 colors), certain colors appear different when 
drawing lines and typing text, due to the limitation of your display driver.

{button Related Topics,PI(`',`IDH_RT_Changing_ribbon_colors')}



To color existing text 
To color an existing shape 
To color an existing line 
Formatting toolbar



To color an existing line
1 Click the Selector tool.

Selector tool
2 Click the line that you want to apply color to.
3 Click the Line Color button.

Line Color button
4 Click the color you want.

{button Related Topics,PI(`',`IDH_RT_Apply_line_color')}



To create a custom color 
To color existing text 
To color an existing shape 
Formatting toolbar



To color an existing shape
1 Click the Selector tool.

Selector tool
2 Click the shape that you want to apply color to.
3 Click the Fill Color button.

Fill Color button
4 Click the color you want.

{button Related Topics,PI(`',`IDH_RT_Apply_shape_color')}



To create a custom color 
To color existing text 
To color an existing line 

Choosing shape styles that enhance your chart
Formatting toolbar



To color existing text
1 Click the Selector tool.

Selector tool
2 Click the text that you want to apply color to.
3 Click the Text Color button.

Text Color button
4 Click the color you want.

{button Related Topics,PI(`',`IDH_RT_Apply_line_color')}



To create a custom color 
To color an existing shape
To color an existing line
Formatting toolbar



To apply a pattern to an existing shape
1 Click the Selector tool.

Selector tool
2 Click the shape that you want to apply a pattern to.
3 On the Format menu, click Chart Properties.
4 Click the Fill tab, if necessary.
5 Click the Fill Style you want, and click OK.

Tip
Use the Apply button to make your changes and view the results without closing the dialog 

box.

{button Related Topics,PI(`',`IDH_RT_Apply_pattern')}



To change the properties for a selected shape
To color existing text 
To color an existing line 
Choosing shape styles that enhance your chart
Formatting toolbar



Showing and Hiding Guidelines
{button OLE 
Automation,PI(`',`ID
H_OA_Guidelines')}
{button Tell me 
how . . .,JI(`>proc
edur',`IDH_To_sho
w_or_hide_all_gui
delines');CW(`larg
e')}

You can choose to show or hide guidelines in your chart.
When guidelines are hidden, they have no effect on the positioning of objects.
You may want to hide guidelines while moving objects close to (but not on) the guidelines to prevent
the objects from snapping to them. When you show guidelines, all the guidelines you placed appear 
on the screen.
You can:

Add horizontal guidelines
Add vertical guidelines
Remove guidelines

{button Related Topics,PI(`',`IDH_RT_Showing_and_Hiding_Guidelines')}



Aligning shapes to guidelines
Working with guidelines
To align a shape to a guideline
To turn snapping on or off 

To show or hide all guidelines
To create a guideline
To delete a guideline
To duplicate a guideline

To move a guideline



GuidelinesOn Property
AddHorizontalGuideline Method
AddVerticalGuideline Method
ClearGuidelines Method



Working with Guidelines
{button Tell me how . . .,PI(`',`IDH_HT_Working_with_Guidelines')}

You can use guidelines to align objects. When you drag a shape near a guideline, the shape’s sides 
and center snap into alignment with the guideline. Guidelines let you align shapes of different sizes 
and achieve an attractive, organized look. Guidelines do not appear in the printed chart.
Guidelines can be dragged from rulers and placed in a chart. If the Snap To Grid option is selected in
the Options Alignment dialog box, guidelines snap to ruler positions. You may choose either Fine or 
Coarse alignment.

{button Related Topics,PI(`',`IDH_RT_Working_with_Guidelines')}



Aligning shapes to guidelines
Showing and hiding guidelines



To align a shape to a guideline
To turn snapping on or off To show or hide all guidelines
To create a guideline



Aligning Shapes to Guidelines
{button Tell me how . . .,PI(`',`IDH_HT_Aligning_Shapes_to_Guidelines')}

When you drag a shape near a guideline, the sides and center of the shape snap into alignment with
the guideline. Guidelines let you align shapes of different sizes to achieve an attractive, organized 
appearance.
If you drag more than one selected object, the selected object beneath the pointer snaps to the 
guideline.
You can use guidelines to align either edges of shapes or the centers of shapes.

If you drag an edge near the guideline, the edge of the shape snaps into alignment.
If you drag the dashed blue cross in the center of the shape near the guideline, the center of 

the shape snaps into alignment with the guideline.

{button Related Topics,PI(`',`IDH_RT_Aligning_Shapes')}



Showing and hiding guidelines
Working with guidelines
To show or hide all guidelines
To create a guideline

To delete a guideline
To duplicate a guideline
To move a guideline



To align a shape to a guideline
To turn snapping on or off 



To show or hide all guidelines
On the View menu, click Guidelines.

The guidelines are displayed when Guidelines is checked. The guidelines are hidden when 
Guidelines is cleared.

Tip
You also can click the right mouse button in the ruler area, if displayed, and then click 

Guidelines to show or hide guidelines.

{button Related Topics,PI(`',`IDH_RT_To_Show_or_Hide_All_Guidelines')}



Aligning shapes to guidelines
Showing and hiding guidelines
Working with guidelines
To align a shape to a guideline

To create a guideline
To delete a guideline
To duplicate a guideline
To move a guideline



To create a guideline
1 Point to the horizontal or vertical ruler.
2 Press and hold the left mouse button, and drag the pointer into the chart. A light blue horizontal 

or vertical line representing the guideline is attached to the pointer.
3 Release the mouse button when the guideline appears where you want it. The guideline appears 

as a solid-colored line in the chart, extending across the entire width or height of the window.

Tip
You also can click the right mouse button in the ruler area, if displayed, and then click Add 

Guideline to create a guideline.

{button Related Topics,PI(`',`IDH_RT_To_create_a_guideline')}



Aligning shapes to guidelines
Showing and hiding guidelines
Working with guidelines
To align a shape to a guideline

To delete a guideline
To duplicate a guideline
To move a guideline
To show or hide all guidelines



To move a guideline
1 Click the Selector tool.

Selector tool
2 Point to the guideline you want to move.
3 Press and hold the left mouse button, and drag the guideline where you want it. The pointer 

changes to the Guideline pointer over the guideline.
4 Release the mouse button when you are finished.

{button Related Topics,PI(`',`IDH_RT_To_move_a_guideline')}



Aligning shapes to guidelines
Showing and hiding guidelines
Working with guidelines
To align a shape to a guideline

To create a guideline
To delete a guideline
To duplicate a guideline
To show or hide all guidelines



To duplicate a guideline
1 Click the Selector tool.

Selector tool
2 Point to the guideline you want to duplicate. When the guideline is selected, the pointer changes 

to the guideline pointer.

Guideline pointer
3 Press and hold Ctrl.
4 Press and hold the left mouse button. A small plus sign is added to the right of the Guideline 

pointer to indicate you are duplicating a guideline.

Guideline pointer with plus sign
5 Drag the duplicate guideline where you want it.
6 Release Ctrl and the left mouse button.
7 Repeat steps 2 through 6 to create more guidelines.

{button Related Topics,PI(`',`IDH_RT_To_duplicate_a_guideline')}



Aligning shapes to guidelines
Showing and hiding guidelines
Working with guidelines
To align a shape to a guideline

To create a guideline
To delete a guideline
To move a guideline
To show or hide all guidelines



To delete a guideline
1 Click the Selector tool.

Selector tool
2 Point to the guideline you want to delete.
3 Press and hold the left mouse button. The pointer changes to the Guideline pointer over the 

guideline.
4 Drag horizontal guidelines to the horizontal ruler; drag vertical guidelines to the vertical ruler.
5 Release the mouse button when the guideline pointer is positioned over the appropriate ruler.

{button Related Topics,PI(`',`IDH_RT_To_delete_a_guideline')}



Aligning shapes to guidelines
Showing and hiding guidelines
Working with guidelines
To align a shape using channel alignment 

To align a shape to a guideline
To create a guideline
To duplicate a guideline

To move a guideline
To show or hide all guidelines



To align a shape to a guideline
1 On the View menu, click Guidelines if Guidelines is not checked.
2 Click the Selector tool.

Selector tool
3 Select the shape you want to align.
4 Point to the selected shape.
5 Press and hold the left mouse button, and drag the shape near the guideline.
6 Release the mouse button.

Notes
In step 5, if you drag an edge near the guideline, the edge of the shape snaps into alignment.
In step 5, if you drag the dashed blue cross in the center of the shape near the guideline, the 

center of the shape snaps into alignment with the guideline.

{button Related Topics,PI(`',`IDH_RT_To_align_a_shape_to_a_guideline')}



Aligning shapes to guidelines
Showing and hiding guidelines
Working with guidelines
To create a guideline

To delete a guideline
To duplicate a guideline
To move a guideline
To show or hide all guidelines

To turn snapping on or off



Welcome to the World of Living FlowCharts!
This Quick Tour explains an exciting, powerful new way to add action and impact to your 
visual communications.
Now, instead of a picture on a page, your charts can be interactive, exchanging 
information with your chart users. Your charts can move and change as the information in 
them changes.    Regardless of the purpose of your flowchart, the end result is a "Living 
FlowChart" that users can interact with in a dynamic and real-time manner.

{button Next >,JI(`',`IDH_What_Is_a_Living_FlowChart_QT')}          



What Is a Living FlowChart?
A Living FlowChart is a chart that 
runs like a program and interacts 
with its user, gathering and 
displaying information 
automatically. Any set of shapes 
connected by lines can be a 
Living FlowChart. Even a simple 
set of shapes can be run as a 
Living FlowChart.

All you have to do to create a 
Living FlowChart is draw a simple 
flowchart. If you already have 
flowcharts created with a 
previous version of FlowCharter, 
you can run them as Living 
FlowCharts right now!

{button < Back,JI(`',`IDH_Overview_QT')}          {button Next 
>,JI(`',`IDH_How_Does_a_Living_FlowChart_Work_QT')}          



How Does a Living FlowChart Work?
In a Living FlowChart, every 
shape contains an action. A 
line, or a set of lines, represents
a path. Just as you take a set of
streets to drive to work, an 
entity takes a set of lines 
through shapes to reach the 
end of the chart. In each case, 
you have completed a path.

The first time you run a chart, 
you choose the starting 
shape. 
When the user chooses the starting shape, FlowCharter places an entity in that 
shape. As the user runs the chart, the entity travels through the chart. Each time 
the entity reaches a shape in the Living FlowChart, something happens: a dialog box
appears or the shape does something automatically.

{button < Back,JI(`',`IDH_What_Is_a_Living_FlowChart_QT')}          {button Next 
>,JI(`',`IDH_Shape_Actions_Power_Living_FlowCharts_QT')}          



Shape Actions Power Living FlowCharts
The power of a Living FlowChart lies in 
the shape action.

Each shape in the chart has an action, 
whether you specifically create one 
with the Shape Action Wizard or not. 
The shape action determines what 
happens when you run the chart. 

A shape action can display a dialog box
so you can prompt the user for data, 
show data in fields, have the user 
enter data in the fields, and let the 
user choose the next path out of a 
shape. Or, a shape action can evaluate
and/or change data and decide where 
to go next.

{button < Back,JI(`',`IDH_How_Does_a_Living_FlowChart_Work_QT')}          {button Next 
>,JI(`',`IDH_Entities_Travel_the_Paths_QT')}          



Entities Travel the Paths
An entity is an object that moves along the paths of a Living FlowChart. You can think of 
an entity as a messenger or a delivery person that travels a route and collects data along 
the way. Entities have fields just like shapes and lines do. The entity fields are empty until 
you run the chart. As the chart runs, the entity moves through the chart collecting data as
it goes. 

{button < Back,JI(`',`IDH_Shape_Actions_Power_Living_FlowCharts_QT')}          {button Next
>,JI(`',`IDH_The_Shape_Action_Wizard_Customizes_a_Shape_Action_QT')}          



The Shape Action Wizard Customizes a Shape Action
When you want a shape to do 
something other than display the 
standard dialog box, you run the Shape
Action Wizard. The Shape Action 
Wizard lets you change not only the 
dialog box appearance, but also many 
other parts of the shape action. You 
can also set up the shape to 
automatically select the next path for 
the user, and perform math operations 
on data.

{button < Back,JI(`',`IDH_Entities_Travel_the_Paths_QT')}          {button Next 
>,JI(`',`IDH_Dialog_Boxes_Communicate_with_the_User_QT')}          



Dialog Boxes Communicate with the User
The dialog boxes in Living 
FlowCharts communicate with your 
users in two ways:
They show information to the 
user
Any text in the shape automatically 
appears in the dialog box. In 
addition, you can set up fields that 
give information and use text in 
buttons to show the available paths 
through the rest of the chart.
They get information from the 
user
You can set up a dialog box with 
fields and let a user enter data into 
the fields. This data can determine 
the path the entity takes next. The 
data can also be accumulated with 
other data.

{button < Back,JI(`',`IDH_The_Shape_Action_Wizard_Customizes_a_Shape_Action_QT')}       
{button Next >,JI(`',`IDH_Path_Selection_Makes_a_Chart_Interactive_QT')} 



Path Selection Makes a Chart Interactive
You can let your users navigate 
through the chart using buttons in 
dialog boxes, or you can select the 
path for them. To select the path for 
them, you evaluate data in the chart. 
Based on the evaluation, you route the
entity to the appropriate path. There 
are three ways to select a path:
1. Let the user choose the path by 

providing buttons in the dialog box
2. Automatically choose the path by 

evaluating data in the shape
3. Automatically choose the path by 

evaluating data in the path

{button < Back,JI(`',`IDH_Dialog_Boxes_Communicate_with_the_User_QT')}          {button 
Next >,JI(`',`IDH_Let_the_User_Choose_a_Path_QT')}          



Letting the User Choose a Path
The standard dialog box provides buttons that 
represent all of the available paths leaving the 
shape. The user chooses the path by clicking one 
of the buttons. 
Let the user choose the path when you want to 
know which option he would choose or when 
there is no data to select the path for him.

{button < Back,JI(`',`IDH_Path_Selection_Makes_a_Chart_Interactive_QT')}          {button 
Next >,JI(`',`IDH_Automatically_Choose_a_Path_Using_Shape_Data_QT')}          



Automatically Choosing a Path Using Shape Data
To use shape-based path selection, you set up a condition or set of conditions that 
determine how to route the entities from the current shape. When you run the chart and 
the entity reaches the shape, the chart compares the value you specify in the condition to
the data in the shape. If the two values match, the path specified in the condition is the 
one taken.
Use shape-based path selection when you want to evaluate the data in the shape to 
decide where to send the entity next.

{button < Back,JI(`',`IDH_Let_the_User_Choose_a_Path_QT')}          {button Next 
>,JI(`',`IDH_Automatically_Choose_a_Path_Using_Path_Data_QT')}          



Automatically Choosing a Path Using Path Data
When a shape selects a path based on path data, the shape checks the value of every 
available path and compares the path values to conditions you specify. The shape selects 
the path that meets all of the conditions. If more than one path meets all conditions, the 
shape selects a path arbitrarily. If no paths meet all conditions, the entity stops in the 
shape. 
Use path-based path selection when the data a user enters in the shape is more important
than the destination.

{button < Back,JI(`',`IDH_Automatically_Choose_a_Path_Using_Shape_Data_QT')}          
{button Next >,JI(`',`IDH_Living_FlowCharts_Can_Work_Magic_with_Data_QT')}          



Living FlowCharts Can Work Magic with Data
When you add data to a Living FlowChart, you open up a whole new world of possibilities 
for communicating information to your users. Any shape in the chart can display data to 
or collect data from the user, perform math operations on data, or select a path based on 
data.
Data can reside in shapes and on lines. You can design a chart with preset data, or you 
can collect data from the user as the chart runs. You also can track data as it accumulates 
in an entity as the entity moves through the chart.

{button < Back,JI(`',`IDH_Automatically_Choose_a_Path_Using_Path_Data_QT')}          
{button Next >,JI(`',`IDH_FlowCharts_Accumulate_Data_QT')}          



Living FlowCharts Can Accumulate Data
FlowCharter offers six field 
types: text, duration, date, 
currency, percent, and 
number.

Each field type has a set of 
Accumulation Methods, 
which is a fancy term for a 
simple concept. You can 
combine, or accumulate, 
data of some field types. 
For example, you can 
"combine" the cost of a 
process. The method you 
use to combine the data is 
to add it or "Sum" it. Thus 
the accumulation method 
is Sum. 

{button < Back,JI(`',`IDH_Living_FlowCharts_Can_Work_Magic_with_Data_QT')}          
{button Next >,JI(`',`IDH_Math_Operations_Add_Power_to_Data_QT')}          



Math Operations Add Power to Data
You can perform math operations on the data in the chart, and pass on the result as the 
chart continues to run. A math operation is composed of two parts: the name of the data 
field that you want to change, and the expression.

 {button < Back,JI(`',`IDH_FlowCharts_Accumulate_Data_QT')}          {button Next 
>,JI(`',`IDH_Write_Your_Own_Script_for_Power_and_Flexibility_QT')}          



Write Your Own Script for Power and Flexibility
In addition to using the Shape 
Action Wizard to create script, you 
can create script manually. When 
you create script manually, you 
can attach script to any object 
(shape, line, or text block). Script 
written for one object has no 
effect on any other object.

The script for an object remains 
attached to that object. If you 
copy the shape, line, or text into 
another chart, the script goes with
it. This makes it easy to make 
changes and additions to charts. If
an object’s actions are already 
defined in one chart, you can save
time by using them in another 
chart.

{button < Back,JI(`',`IDH_Math_Operations_Add_Power_to_Data_QT')}          {button Next 
>,JI(`',`IDH_Living_Shapes_Add_Action_to_a_Chart_QT')}          



Living Shapes Add Action to a Chart
Living Shapes contain data and script that enables them to perform predefined or user-
defined actions. These shapes make your charts faster, more efficient, and easier to use.
You can drag these shapes from the palette to use them in any flowchart. For example, 
the Printer button is a Living Shape that prints the chart when the user double-clicks it.

The Start button shape is a Living Shape that begins running the chart when the user 
double-clicks it.
You can also drag your own shapes (and their actions) to the palette. This makes it easy to 
use a shape and its actions in another chart without having to run the Shape Action Wizard 
or write the same script more than once.

{button < Back,JI(`',`IDH_Write_Your_Own_Script_for_Power_and_Flexibility_QT')}          
{button Next >,JI(`',`IDH_Running_a_Living_FlowChart_Is_Easy_QT')}          



Running a Living FlowChart Is Easy
When you’re ready to run the Living 
FlowChart you’ve designed, you can start it 
using one of the following methods:
1. Selecting the Run FlowChart command 

from the Tools menu. Using this method 
lets you choose where the chart begins 
running.

2. Clicking the Run button on the Standard 
toolbar. This shortcut also lets you choose 
where the chart begins running.

3. Running the chart automatically, when 
the FlowCharter file opens. This is the 
fastest, easiest way for a user to run a 
chart.

{button < Back,JI(`',`IDH_Living_Shapes_Add_Action_to_a_Chart_QT')}          {button Next 
>,JI(`',`IDH_Now_You_Ready_to_Bring_Life_to_Your_Charts_QT')}          



Now You're Ready to Bring Life to Your Charts!
Now you’ve seen how easy it is to design and run powerful Living FlowCharts.
There are several examples of Living FlowCharts included with FlowCharter. Run one of 
these to see the power of Living FlowCharts in action. The Tutorial chapter of the 
FlowCharter book also has several examples of Living FlowCharts.
Or you can dive right in and start creating your own interactive charts.
Either way, Living FlowCharts give you the power and flexibility to improve 
communications with your customers and employees. 

{button < Back,JI(`',`IDH_Running_a_Living_FlowChart_Is_Easy_QT')}





Welcome to FlowCharter 7

FlowCharter lets you create any business diagram quickly and easily. And after you have 
constructed your charts, you can actually navigate through them, following the processes and 
updating mission-critical data. Just double-click a shape on a high-level chart to explore the detailed 
processes that make up that event.
With intelligent line routing, a variety of alignment options, and hundreds of shapes, creating 
attractive and useful flowcharts is as easy as ABC.
When you need to know something about FlowCharter, refer to the help system.

{button Related Topics,PI(`',`IDH_RT_Welcome_to_ABC_FlowCharter')}



To find topics in help
To search for words in a help file
To get information in a dialog box
To print a help topic



OLE Automation
{button OLE 
Automation,PI(`',`I
DH_OA_OLE_Auto
mation')}
{button Tell me 
how. . .,PI(`',`IDH_
HT_OLE_Automatio
n')}

You can control this version of FlowCharter using OLE Automation. This is an advanced feature that 
requires Visual Basic, knowledge of programming in Visual Basic, and knowledge of FlowCharter. 
Visual Basic requires different automation controls, depending on the version of Visual Basic that 
you are using.    (Visual Basic 4.0 is not backward-compatible with older versions of the automation 
controls, those with VBX file extensions.)
If you are using Visual Basic 4.0, install FLOW.OCX. See To install the OCX event handler for details 
on installing Flow.ocx. 
If you are using Visual Basic 3.0 or earlier, install ABCAUTO.VBX. See To install the VBX event 
handler for details on installing Abcauto.vbx.
Using OLE Automation is described in a help file that comes with FlowCharter. When you installed 
FlowCharter, it installed that help file and its related FlowCharter help file.
This help system is contained in the file Automate.hlp. There are several ways you can access the 
OLE Automation help file:

You can run the file from this help.
You can run it using the Windows Explorer.
You can run it using Excel (which also lets you browse through the language elements and see 

quick descriptions of them).

{button Related Topics,PI(`',`IDH_RT_OLE_Automation')}



To access OLE Automation help from this help
To access OLE Automation help using Excel
To access OLE Automation help using the Explorer
To access OLE Automation help from Visual Basic



To get help on Visual Basic 
Difference Between Writing for External Applications and Internal Scripts



Welcome to OLE_Automation



To access OLE Automation from this help
1 Click the button to the right of the command.

OLE Automation button
2 To return to this help from the OLE Automation help, click the button to the right of the topic 
title.

Flow Equivalent button
Tips

The help for OLE Automation is included in FlowCharter help. To the right of selected buttons, 
commands, dialog boxes, and areas of dialog boxes are buttons labeled OLE Automation. (There is 
one to the right of the title of this help topic. It goes to the Welcome topic of the help for OLE 
Automation.) If you click one of those buttons, help displays for the OLE Automation-related property or
method. Be sure to check the related topics in the OLE Automation method or property to find other 
properties or methods that are related to the FlowCharter area you are working in.

When a property or method has an equivalent FlowCharter command, a button labeled "Flow 
Equivalent" appears to the right of the topic title. You can click the button to go to the FlowCharter 
topic that describes the related command, button, option, or other FlowCharter element.

If no button or a dimmed button appears to the right of a topic, then there is no FlowCharter 
equivalent.

{button 
Related 
Topics,PI(`',`I
DH_RT_Acce
ssing_from_t
his_Help')}

{button OLE 
Automation,
PI(`',`IDH_O
A_OLE_Auto
mationCP')}

OLE Automation
To access OLE Automation help from Visual Basic
To access OLE Automation help using Excel
To access OLE Automation help using the Explorer

To get help on Visual Basic



Welcome to OLE_Automation



To access OLE Automation help using the Explorer
1 Open the Explorer.
2 Locate the directory in which FlowCharter is installed (C:\Program Files\Micrografx\FlowCharter, 

by default).
3 Double-click the file Automate.hlp.

{button Related Topics,PI(`',`IDH_RT_Accessing_Using_File_Manager')}



OLE Automation
To access OLE Automation help from this help
To access OLE Automation help from Visual Basic
To access OLE Automation help using Excel
To get help on Visual Basic



To access OLE Automation help using Excel
1 Run Excel.
2 On the Insert menu, click the Macro command.
3 Choose Module.
4 On the Tools menu, click the References command.
5 Click Browse. Search for the flow70.tlb file where FlowCharter 7 is installed and select it. (For 

example, "C:\Program Files\Micrografx\FlowCharter\Flow70.tlb")
6 Click Micrografx FlowCharter OLE Automation 7.0 so an X appears in the box in front of it.
7 Click OK to close the dialog box.
8 On the View menu, click the Object Browser command.
9 Click the down arrow to the right of the Libraries/Workbooks box. 
10 Click FlowLib to select it.
11 Click the object you want information about in the Objects/Modules box.
12 Click the button with a question mark in it, if you wish. OLE Automation help appears showing the

topic about that object.
or
Click the method or property you want information about in the Methods/Properties box.

Tip
If the button with a question mark in it is gray, then the help file is not installed. You must 

install the help file using the Installation program.

{button Related Topics,PI(`',`IDH_RT_Accessing_Using_Excel_5_0')}



OLE Automation
To access OLE Automation help from this help
To access OLE Automation help from Visual Basic
To access OLE Automation help using the Explorer

To get help on Visual Basic



To get help on Visual Basic
You can get help on Visual Basic by clicking Visual Basic help. 

Note
You must have the Visual Basic directory in your DOS path, or you must copy the Visual Basic 

help file (VB.HLP) to your FlowCharter directory.

{button Related Topics,PI(`',`IDH_RT_Jumping_to_Visual_Basic')}



OLE Automation
To access OLE Automation help from this help
To access OLE Automation help from Visual Basic
To access OLE Automation help using Excel

To access OLE Automation help using the Explorer



To access OLE Automation help from Visual Basic
There are several ways you can access this help from Visual Basic. Each way brings up an 
appropriate topic.

Select Events VBX and press F1.
Highlight a procedure name in the Proc combo box and press F1.
Highlight a property or method from OLE Automation and press F1.

{button Related Topics,PI(`',`IDH_RT_Accessing_from_Visual_Basic')}



OLE Automation
To access OLE Automation help from this help
To access OLE Automation help using Excel
To access OLE Automation help using the Explorer

To get help on Visual Basic



Shortcut Keys
Charts and Windows
New chart Ctrl+N
Open file Ctrl+O
View at actual size F3
View current page F4
Close chart Ctrl+F4 OR Ctrl+W
Save file Ctrl+S
Print chart Ctrl+P
Open/close Note window Alt+F6
Open/close QuickZoom 
window

F6

Open/close Shape palette F9
Split screen Ctrl+Alt+S
Duplicate a guideline (with 
Selector tool)

Ctrl+Drag existing 
guideline 

Shift page to right Alt+Page Up
Shift page to left Alt+Page Down 
Exit program Alt+F4

Changing
Change text F2
Bold text Ctrl+B
Italicize text Ctrl+I
Underline text Ctrl+U
Go to beginning of text block Ctrl+Home
Go to end of text block Ctrl+End
Undo/redo change Ctrl+Z/Ctrl+Y
Cut Ctrl+X (OR Shift+Del)
Copy Ctrl+C (OR Ctrl+Insert)
Paste Ctrl+V (OR 

Shift+Insert)
Duplicate Ctrl+Drag
Clear Delete
Find Ctrl+F
Replace Ctrl+H
Select all Ctrl+A



Check spelling F7
Disable magnetic alignment 
while placing shapes

Shift+Drag

Align shape bottom Ctrl+Shift+8
Align shape center Ctrl+Shift+5
Align shape left Ctrl+Shift+3
Align shape middle Ctrl+Shift+6
Align shape right Ctrl+Shift+7
Align shape top Ctrl+Shift+4
Justify horizontally Ctrl+Shift+9
Justify vertically Ctrl+Shift+0 (Zero)
Fit text to shape F8
Align text right Ctrl+R
Align text center Ctrl+E
Align text left Ctrl+L
Moves objects back one layer Ctrl+F9
Moves objects forward one 
layer

Ctrl+F10

Full-screen View
Leave full-screen view Esc, End, X
Erase chart annotations Delete, Spacebar, E
Go to next chart window Tab, Page Down, N
Go to previous chart window Shift+Tab, Page Up, P

Help
Context-sensitive help topic F1

Use the additional shortcut keys ed next to the menu commands and in the hint line.



To drag an item
1 Select the item you want to drag.
2 Move the cursor over the selected item.
3 Press the left mouse button. 
4 While holding the button down, move the mouse where you want the item.
5 Release the left mouse button.

Note
To "select" a palette, display it by clicking the down-arrow of its button.




